Subject: [mpls-tp] Help me define backtracking

From: Ben Niven-Jenkins <[email-masked]>
Date: Wed, 03 Jun 2009 11:41:11 +0100

Colleagues,

The liaison from the ITU on draft-ietf-mpls-tp-requirements-08 requested
that we provide a definition for the term backtracking in requirement 66 D.

I can't find a good definition for backtracking (or even know what it is) so
can someone provide me with a definition we could use.

Requirement 66 D reads:
   66  MPLS-TP MUST support 1:n protection (including 1:1 protection).

       D.  The action of protection switching MUST NOT cause user data
           to loop.  Backtracking is allowed.

If no one can provide a suggested definition I will just remove the sentence
"Backtracking is allowed".

Thanks
Ben

---

From: Huub van Helvoort <[email-masked]>
Date: Wed, 03 Jun 2009 12:52:31 +0200

Hello Ben,

> can someone provide me with a definition we could use.

I was at that meeting and someone used the word "tromboning" to
describe it, however that is still not clear.
If I understood well tromboning is like this:

Before:
[A]------------>[Z]

after:
[A]------------>[?]---------\
                             |
                 [Z]<--------/

Where I am not sure if [?] can be [Z]

Just my 2c, Huub.

-- 
================================================================
Always remember that you are unique...just like everyone else...

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 3 Jun 2009 12:09:27 +0100

Hi,

Easiest to see this on a ring...

<ascii-art>

  B--C--D
 /       \
A         E
 \       /
  H--G--F
 
</ascii-art>

Consider an LSP ABCDE
Link failure CD
Rapid repair is via tunnel or segment CBAHGFED
Giving a full data path ABCBAHGFEDE

The fact that the data passes through B and A twice (also E) is not to be seen as a loop.
It is "backtracking" and is allowed as part of protection.
Ideally it would be optimised out at a later stage.

(BTW, the situation arises in other topologies as well, but is easiest to show in a ring.)

A
----- Original Message ----- 
From: "Huub van Helvoort" <[email-masked]>
To: "Ben Niven-Jenkins" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, June 03, 2009 11:52 AM
Subject: Re: [mpls-tp] Help me define backtracking

> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>

---

From: Lou Berger <[email-masked]>
Date: Wed, 03 Jun 2009 07:22:57 -0400

how about "Traffic may traverse the same link (once in each direction) 
to support such protection.".

BTW I always liked the term "Hairpin" for such traffic flows.

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Wed, 3 Jun 2009 13:24:23 +0200

-----Original Message-----
From: Sprecher, Nurit (NSN - IL/Hod HaSharon) 
Sent: Wednesday, June 03, 2009 1:55 PM
To: 'ext Ben Niven-Jenkins'
Subject: RE: [mpls-tp] Help me define backtracking

I believe that by backtracking, we refer to the possibility to switch
traffic (back) to the interface from which traffic was received, when
protection is active. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Ben Niven-Jenkins
Sent: Wednesday, June 03, 2009 1:41 PM
To: [email-masked]
Subject: [mpls-tp] Help me define backtracking

Colleagues,

The liaison from the ITU on draft-ietf-mpls-tp-requirements-08 requested
that we provide a definition for the term backtracking in requirement 66
D.

I can't find a good definition for backtracking (or even know what it
is) so
can someone provide me with a definition we could use.

Requirement 66 D reads:

If no one can provide a suggested definition I will just remove the
sentence
"Backtracking is allowed".

Thanks
Ben

---

From: Huub van Helvoort <[email-masked]>
Date: Wed, 03 Jun 2009 14:29:36 +0200

Hi Adrian,

> Giving a full data path ABCBAHGFEDE

This is in ITU-T terms "wrapping" in ring protection.

> Ideally it would be optimised out at a later stage.

If the optimisation would be AHGFE it would be "steering"
specifically for designed for transatlantic ring protection
switching.

Cheers, Huub.

------------
> From: "Huub van Helvoort" <[email-masked] <mailto:[email-masked]>>
> To: "Ben Niven-Jenkins" <[email-masked] 
> <mailto:[email-masked]>>
> Cc: <[email-masked] <mailto:[email-masked]>>

-- 
================================================================
                   http://www.van-helvoort.eu/
================================================================
Always remember that you are unique...just like everyone else...

---

From: hejia 48726 <[email-masked]>
Date: Wed, 03 Jun 2009 21:25:52 +0800

Hi Huub and Adrian,

Yes. I remember this is given as an example of "wrapping" regarding ring protection in Sophia meeting. Any definition of "wrapping" that can help to clarify this? 

B.R.
Jia

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained here in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this email in error, please notify the sender by phone or email
 immediately and delete it!
 *****************************************************************************************

----- 原邮件 -----
发件人: Huub van Helvoort <[email-masked]>
日期: 星期三, 六月 3日, 2009 下午8:30
主题: Re: [mpls-tp] Help me define backtracking
收件人: Adrian Farrel <[email-masked]>
抄送: [email-masked]

> > The fact that the data passes through B and A twice (also E) is 
> not to 
> > be seen as a loop.
> > (BTW, the situation arises in other topologies as well, but is 
> easiest 
> > to show in a ring.)
> >  
> > A
> > From: "Huub van Helvoort" <[email-masked] 
> <mailto:[email-masked]>>> To: "Ben Niven-Jenkins" 
> <[email-masked] 
> >  >> I can't find a good definition for backtracking (or even 
> know what 
> > it is) so

---

From: Loa Andersson <[email-masked]>
Date: Wed, 03 Jun 2009 15:51:14 +0200

Jia,

I remember that statement from Sophia Antipolis also, but I thought it
was the other way around; wrapping is an example of backtracking that is
specific to rings

/Loa

hejia 48726 wrote:
> ----- ??? -----
> ???: Huub van Helvoort <[email-masked]>
> ??: ???, ?? 3?, 2009 ??8:30
> ??: Re: [mpls-tp] Help me define backtracking
> ???: Adrian Farrel <[email-masked]>
> ??: [email-masked]
> 
>> Hi Adrian,
>>
>> You replied:
>>

-- 

Loa Andersson

Sr Strategy and Standards Manager    phone:  +46 10 717 52 13
Ericsson ///                                 +46 767 72 92 13 

                                       email:  [email-masked]
                                               [email-masked]

---

From: "Towne, Jeffrey R (Jeff)" <[email-masked]>
Date: Wed, 3 Jun 2009 09:19:21 -0500

From IEEE 802.17-2004 (Resilient packet ring (RPR) access method):

5.1.23 wrapping: The transmission of a frame on an opposing ringlet in order to route around a fault in a given ringlet.

5.1.19 steering: A protection method in which a source station redirects a unicast frame to the ringlet
retaining connectivity to a destination station, or a multicast/broadcast frame to one or both ringlets retaining connectivity to destination stations.

Jeff Towne [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of hejia 48726
Sent: Wednesday, June 03, 2009 09:26
To: [email-masked]; Adrian Farrel
Cc: [email-masked]
Subject: Re: [mpls-tp] Help me define backtracking

Hi Huub and Adrian,

B.R.
Jia

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained here in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this email in error, please notify the sender by phone or email  immediately and delete it!
 *****************************************************************************************

----- 原邮件 -----
发件人: Huub van Helvoort <[email-masked]>
日期: 星期三, 六月 3日, 2009 下午8:30
主题: Re: [mpls-tp] Help me define backtracking
收件人: Adrian Farrel <[email-masked]>
抄送: [email-masked]

> > Rapid repair is via tunnel or segment CBAHGFED Giving a full data
> > path ABCBAHGFEDE
>
> specifically for designed for transatlantic ring protection switching.
>
> Cheers, Huub.
>
> ------------
> >  > Where I am not sure if [?] can be [Z]  >  > Just my 2c, Huub.
>
> --

---

From: hejia 48726 <[email-masked]>
Date: Wed, 03 Jun 2009 23:03:50 +0800

Exactly, Loa. Perhaps the wording should have been in this way: "wrapping" is given as an example... 

Thanks for pointing out that!

Cheers
Jia

----- 原邮件 -----
发件人: Loa Andersson <[email-masked]>
日期: 星期三, 六月 3日, 2009 下午9:51
主题: Re: [mpls-tp] Help me define backtracking
收件人: hejia 48726 <[email-masked]>
抄送: [email-masked], Adrian Farrel <[email-masked]>, [email-masked]

> > Yes. I remember this is given as an example of "wrapping" 
> regarding ring protection in Sophia meeting. Any definition of 
> "wrapping" that can help to clarify this? 
> > 
> > 
> > B.R.
> > Jia
> > 
> > 
> ******************************************************************************************>  This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained here in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s)
 is prohibited. If you receive this email in error, please notify the sender by phone or email
> *****************************************************************************************> 
> > ----- ??? -----
> >>>  >> The liaison from the ITU on draft-ietf-mpls-tp-
> requirements-
> >> 08 requested