Subject: [mpls-tp] Resolving ITU-T last call comment on draft-mpls-tp-requirements-08 & backtracking

From: Ben Niven-Jenkins <[email-masked]>
Date: Thu, 04 Jun 2009 00:05:13 +0100

ITU Colleagues,

In the ITU liaison sent as part of the WG last call for
draft-ietf-mpls-tp-requirements-08 the following comment was made:

3) Requirement 66 D: The term "backtracking" should be defined, this should
be included in the rosetta draft.

To resolve the comment I propose changing the text "Backtracking is allowed"
to "Traffic may traverse the same link (once in each direction)
to support such protection without being considered to have looped." so the
full requirement would now read:

   66  MPLS-TP MUST support 1:n protection (including 1:1 protection).

       D.  The action of protection switching MUST NOT cause user data
           to loop.  Traffic may traverse the same link (once in each
           direction) to support such protection without being considered to
           have looped.

Would the proposed editorial change resolve the ITU comment?

Thanks
Ben

---

From: Malcolm Betts <[email-masked]>
Date: Thu, 04 Jun 2009 03:16:25 -0400

Ben,

The original request from the ITU was to include the definition of
backtracking in the Rosetta stone draft and did not request a change in the
draft.  I think that your proposed modification address the issue that
caused the comment and is a better solution.  I support the proposed change
with a minor editorial modification:

 D.  The action of protection switching MUST NOT cause user data
     to loop.  Traffic may traverse the same link (once in each
     direction) /delete/ to support such protection/end delete/ without
being considered to
     have looped. /add/ This situation may arise, for example, when a
protection switch is
     activated.

The final version would be:

D.  The action of protection switching MUST NOT cause user data
     to loop.  Traffic may traverse the same link (once in each
     direction) without being considered to have looped. This situation
     may arise, for example, when a protection switch is activated.

Could the people who were at the MPLS-TP interim meeting please indicate if
they have any objections to the resolution proposed above by June 11th.

Regards,

Malcolm Betts

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ben Niven-Jenkins
> Sent: June-03-09 7:05 PM
> To: [email-masked]; [email-masked]
> Subject: [mpls-tp] Resolving ITU-T last call comment on draft-mpls-tp-
> requirements-08 & backtracking
> 
> ITU Colleagues,
> 
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 04 Jun 2009 11:48:14 +0100

Strictly the traffic could safely traverse the link more once in
each direction depending on the number of repaired failures and the
number of layer networks. This was why the less precise
term backtracking was useful.

How about

The action of protection switching MUST NOT cause the user
data to enter an uncontrolled loop. The protection switching
system MAY cause traffic to pass over a given link more
than once, but it must do so in a controlled way such that
uncontrolled loops do not form.

Stewart