Subject: Re: [mpls-tp] Is PW a layer of MPLS-TP?

From: "BUSI ITALO" <[email-masked]>
Date: Mon, 2 Nov 2009 09:57:27 +0100

Lou,

Thanks for your clarifications. See in line marked with [ib]

Italo 

> -----Original Message-----
> From: Lou Berger [mailto:[email-masked]] 
> Sent: Friday, October 30, 2009 4:42 PM
> To: BUSI ITALO
> Cc: [email-masked]; Adrian Farrel; BOCCI Matthew; [email-masked]
> Subject: Re: [mpls-tp] Is PW a layer of MPLS-TP?
> 
> Italo,
> 
> See below.
> 
> On 10/30/2009 11:27 AM, BUSI ITALO wrote:
> > I agree with Stewart.
> > 
> > Within MPLS-TP, PW represents the MPLS-TP service sub-layer 
> while LSP
> > represents the MPLS-TP transport sub-layer. Both are in the scope of
> > MPLS-TP.
> 
> As you know PWs, aren't the only way to provide client services in TP.
> So, I think you need to scope this to only the case when PWs are used
> for client adaptation.
> 

[ib] I was (implicitly) considering only non-Network Layer clients. I
therefore agree that I should have rephrased as PW representing the
MPLS-TP service sub-layer for non-Network Layer clients.

> > 
> > Having both in the scope of MPLS-TP does not preclude to move the PW
> > specific aspects outside the scope of 
> draft-ietf-mpls-tp-survive-fwk and
> > in the scope of a new draft to be developed within the PWE3 WG as
> > discussed during the call on 27 October.
> > 
> 
> I think we heard different things on this call.  I heard that the
> survive-fwk document will provide the overall umbrella (not hook) for
> TP, independent of the mechanism(s) used to provide the survivability.
> The document will also provide the details/hooks for LSP survivability
> mechanisms, and state that PW details would be covered in a separate
> document.  It is this separate document that we agreed would 
> be brought
> forward by PW experts, but this document still needs to conform to the
> overall / mechanism-independent portion of survive-fwk.
> 

[ib] I agree with your statements. I do not think they contradict mine:
in my view they provide more details on the scope of the two drafts.

> Lou
> 
> > Italo
> > 
> >> -----Original Message-----
> >> From: [email-masked] 
> >> [mailto:[email-masked]] On Behalf Of Stewart Bryant
> >> Sent: Wednesday, October 28, 2009 3:20 PM
> >> To: Adrian Farrel
> >> Cc: BOCCI Matthew; [email-masked]
> >> Subject: Re: [mpls-tp] Is PW a layer of MPLS-TP?
> >>
> >> Adrian Farrel wrote:
> >>> Hi,
> >>>
> >>> I am trying this question again with a different subject line.
> >>>
> >>> It would be helpful to have more answers than just Neil's 
> >> (not that I 
> >>> don't value his view, but one person doesn't make consensus!)
> >>>
> >>> My question:
> >>> Hasn't the work on the MPLS-TP Framework draft judged PW to be a 
> >>> client of MPLS-TP?
> >>> That is, PW is not a layer of MPLS-TP, but the client.
> >>> Doesn't that mean that PW survivability is out of scope for the 
> >>> MPLS-TP Survivability I-D?
> >>>
> >>> Thanks,
> >>> Adrian
> >>>
> >>
> >> Adrian
> >>
> >> It seems to me that the best way to describe MPLS-TP is as 
> a service 
> >> sub-layer carried
> >> over a transport sub-layer. This is called up in the latest 
> >> version of 
> >> the -TP fwk, although
> >> perhaps we need to make this clearer in the next version.
> >>
> >> It also seems to me that you have written the MPLS-TP transport 
> >> sub-layer survivability fwk
> >> and that we also need one or more MPLS-TP service 
> sub-layer service 
> >> layer survivability
> >> documents.  Thus we need an MPLS-TP service sub-layer 
> service layer 
> >> survivability fwk
> >> for PW which we can shepherd in PWE3. I am not sure whether 
> >> there also needs
> >> to be an NLTS equivalent document, since although 
> >> survivability is easy 
> >> in an IP
> >> network with dynamic routing protocols, MPLS-TP currently 
> >> only describes 
> >> static
> >> configured network layer services and they have very similar 
> >> properties 
> >> to PWs from
> >> a survivability point of view.
> >>
> >> Each document should include appropriate scoping information.
> >>
> >> Stewart
> >>
> >>
> >>
> >> _______________________________________________
> >> mpls-tp mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/mpls-tp
> >>
> > _______________________________________________
> > mpls-tp mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/mpls-tp
> > 
> > 
> > 
>

---

From: Lou Berger <[email-masked]>
Date: Mon, 02 Nov 2009 10:41:51 -0500

Italo,
	Glad to hear that we're in agreement on this!

Lou