Subject: [mpls-tp] Question about fragmentation in MPLS

From: "[email-masked]" <[email-masked]>
Date: Tue, 10 Nov 2009 13:19:13 -0500

Hello all,

MPLS-TP is being presented as an option for transport, similar to the existing transport protocols like SONET, ATM etc.  The current transport protocols handle fragmentation well.

However, MPLS inherently cannot handle fragmentation. If a large packet has to be fragmented, then it is only the first fragment that has all the labels intact. The second fragment will get lost because it does not carry labels.

In the recent MPLS2009 conference one presenter described using MPLS-TP for storage networks. Jumbo/Large packets are more likely to get fragmented if the transport is MPLS.

I believe, the current solution is to do MPLS MTU discovery and then fragment the packets before sending it into MPLS tunnels. However, I don't think that is a scalable solution. Shouldn't there be mechanisms in MPLS-TP that can handle fragmentation?
Is this issue being addressed?  Am I missing something here?

Thanks
Partha

---

From: "Shahram Davari" <[email-masked]>
Date: Tue, 10 Nov 2009 10:24:34 -0800

Hi Partha,

Why do you think the MTU discovery is not scalable? Also as far as I know SONET does not support any fragmentation, does it?

Regards,
Shahram

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, November 10, 2009 10:19 AM
To: [email-masked]
Subject: [mpls-tp] Question about fragmentation in MPLS

Hello all,

Thanks
Partha

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 10 Nov 2009 16:35:05 -0500

Hi Shahram, If say, MPLS MTU between PE1 and a remote PE PE2 is 1500 and between PE1 and PE3 the MPLS MTU is 1400.  Isn't it difficult to fragment the packets before they enter the MPLS tunnel? Thanks - Partha

From: Shahram Davari [mailto:[email-masked]]
Sent: Tuesday, November 10, 2009 1:25 PM
To: Turaga, Partha; [email-masked]
Subject: RE: Question about fragmentation in MPLS

Hi Partha,

Regards,
Shahram

Thanks
Partha