Subject: [mpls-tp] Regarding MIBs for MPLS-TP

From: Lavanya Srivatsa <[email-masked]>
Date: Tue, 24 Nov 2009 12:37:05 +0530

Hello all,

Based on the identifiers detailed out for MPLS-TP as per the
draft-ietf-mpls-tp-identifiers-00.txt, is there any plan to define new and
separate MIB(s) for MPLS-TP to cater to environments where IP demultiplexing
is not present since the existing MIB objects/tables are all predominantly
IP-based? OR enhance/modify existing IP-based MIB(s) through newer versions?

Any inputs/"discussion notes"/"minutes" related to MIB objects/tables for
MPLS-TP that can be shared would be useful  and appreciated.

Thanks in advance
Lavanya

---

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Wed, 25 Nov 2009 13:36:54 -0600

Hi Lavanya,

Given the extension in MPLS-TP, there might be new and separate management information models, such as MIB(s) if one decides to use SNMP/SMI.

>From the ITU-T side, the plan is: once G.8151 (MPLS-TP NE management requirements) is stable, we will start working on G.8152 (MPLS-TP NE protocol-neutral management information model). Note that protocol-neutral means neutral with respect to management interface protocol. Once G.8152 is stable, it can be used as the base to define protocol-specific management information models, such as SNMP, Netconf, or even CMIP, CORBA, TL1, depends on one's choice.

The advantage of specifying the protocol-neutral info model first is it ensures all the protocol-specific info models are compatible if they are all based on the same protocol-neutral one.

Regards,
Kam
P.S. Please note my new email address, [email-masked]<mailto:[email-masked]>, effective since 1 November 2009.

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lavanya Srivatsa
Sent: Tuesday, November 24, 2009 2:07 AM
To: [email-masked]
Subject: [mpls-tp] Regarding MIBs for MPLS-TP

Hello all,

Based on the identifiers detailed out for MPLS-TP as per the draft-ietf-mpls-tp-identifiers-00.txt, is there any plan to define new and separate MIB(s) for MPLS-TP to cater to environments where IP demultiplexing is not present since the existing MIB objects/tables are all predominantly IP-based? OR enhance/modify existing IP-based MIB(s) through newer versions?

Any inputs/"discussion notes"/"minutes" related to MIB objects/tables for MPLS-TP that can be shared would be useful  and appreciated.

Thanks in advance
Lavanya

---

From: Lavanya Srivatsa <[email-masked]>
Date: Mon, 30 Nov 2009 09:53:08 +0530

Thank you for your inputs Kam.

My 2 c - I think the challenge here would be to define (a set of) MIB(s)
that keeps in mind (and relates to in that sense to) the MPLS-TP management
requirements and is also in line at a certain level atleast with the MPLS
MIBs that already exist so that it does not cause too much of churn!!

Thanks
Lavanya

On Thu, Nov 26, 2009 at 1:06 AM, Lam, Hing-Kam (Kam) <
[email-masked]> wrote:

>  Hi Lavanya,
>
>
>
> Given the extension in MPLS-TP, there might be new and separate management
> information models, such as MIB(s) if one decides to use SNMP/SMI.
>
>
>
> From the ITU-T side, the plan is: once G.8151 (MPLS-TP NE management
> requirements) is stable, we will start working on G.8152 (MPLS-TP NE
> protocol-neutral management information model). Note that protocol-neutral
> means neutral with respect to management interface protocol. Once G.8152 is
> stable, it can be used as the base to define protocol-specific management
> information models, such as SNMP, Netconf, or even CMIP, CORBA, TL1, depends
> on one’s choice.
>
>
>
> The advantage of specifying the protocol-neutral info model first is it
> ensures all the protocol-specific info models are compatible if they are all
> based on the same protocol-neutral one.
>
>
>
> Regards,
>
> Kam
>
> P.S. *Please note my new email address,* [email-masked]*,
> effective since 1 November 2009.*
>
>
>
>
>   ------------------------------
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Lavanya Srivatsa
> *Sent:* Tuesday, November 24, 2009 2:07 AM
> *To:* [email-masked]
> *Subject:* [mpls-tp] Regarding MIBs for MPLS-TP
>
>
>
> Hello all,
>
>
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 30 Nov 2009 15:03:34 +0100

I think that what you call protocol-specific management information
model is called a data model in the IETF. See RFC 3444. In any case a
MIB module is a data model and the data modeling language is SMIv2.
SNMP is the management protocol. 
 
If the data models for MPLS-TP include configuration information I would
suggest that we consider YANG as a DML to be used with NETCONF. YANG is
close to being submitted by the NETMOD WG to the IETF, and the timing
may be appropriate for using it. 
 
Dan

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Lam, Hing-Kam (Kam)
	Sent: Wednesday, November 25, 2009 9:37 PM
	To: Lavanya Srivatsa
	Cc: [email-masked]
	Subject: Re: [mpls-tp] Regarding MIBs for MPLS-TP

	Hi Lavanya,

	Given the extension in MPLS-TP, there might be new and separate
management information models, such as MIB(s) if one decides to use
SNMP/SMI. 

	From the ITU-T side, the plan is: once G.8151 (MPLS-TP NE
management requirements) is stable, we will start working on G.8152
(MPLS-TP NE protocol-neutral management information model). Note that
protocol-neutral means neutral with respect to management interface
protocol. Once G.8152 is stable, it can be used as the base to define
protocol-specific management information models, such as SNMP, Netconf,
or even CMIP, CORBA, TL1, depends on one's choice.

	The advantage of specifying the protocol-neutral info model
first is it ensures all the protocol-specific info models are compatible
if they are all based on the same protocol-neutral one.

	Regards,

	Kam

	P.S. Please note my new email address,
[email-masked] <mailto:[email-masked]> ,
effective since 1 November 2009.

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Lavanya Srivatsa
	Sent: Tuesday, November 24, 2009 2:07 AM
	To: [email-masked]
	Subject: [mpls-tp] Regarding MIBs for MPLS-TP

	Hello all,

	Based on the identifiers detailed out for MPLS-TP as per the
draft-ietf-mpls-tp-identifiers-00.txt, is there any plan to define new
and separate MIB(s) for MPLS-TP to cater to environments where IP
demultiplexing is not present since the existing MIB objects/tables are
all predominantly IP-based? OR enhance/modify existing IP-based MIB(s)
through newer versions?

	Any inputs/"discussion notes"/"minutes" related to MIB
objects/tables for MPLS-TP that can be shared would be useful  and
appreciated.

	Thanks in advance

	Lavanya

---

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Mon, 30 Nov 2009 09:52:20 -0600

Dan,

Yes, "protocol-specific management information model" in ITU-T is "data model" in RFC 3444. Further more, "protocol-neutral management information model" in ITU-T is "information model" in RFC 3444.

I didn't use the term "data model" because in some forums, the term "data model" refers to the part of the model that specifies the entities, data structures, attributes, state, but no operations; and they have the term "operation model" for the part of the model that specifies operations, notifications, and transactions.

Regards,
Kam

________________________________
From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: Monday, November 30, 2009 9:04 AM
To: Lam, Hing-Kam (Kam); Lavanya Srivatsa
Cc: [email-masked]
Subject: RE: [mpls-tp] Regarding MIBs for MPLS-TP

I think that what you call protocol-specific management information model is called a data model in the IETF. See RFC 3444. In any case a MIB module is a data model and the data modeling language is SMIv2.  SNMP is the management protocol.

If the data models for MPLS-TP include configuration information I would suggest that we consider YANG as a DML to be used with NETCONF. YANG is close to being submitted by the NETMOD WG to the IETF, and the timing may be appropriate for using it.

Dan

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lam, Hing-Kam (Kam)
Sent: Wednesday, November 25, 2009 9:37 PM
To: Lavanya Srivatsa
Cc: [email-masked]
Subject: Re: [mpls-tp] Regarding MIBs for MPLS-TP
Hi Lavanya,

Regards,
Kam

Hello all,

Thanks in advance
Lavanya