Subject: [mpls-tp] Erratum for RFC 5586

From: Adrian Farrel <[email-masked]>
Date: Tue, 03 Nov 2009 23:04:41 +0000

All,

Matthew Bocci has reported an Erratum for RFC 5586 that can be viewed at 
http://www.rfc-editor.org/errata_search.php?rfc=5586&eid=1940)

The IANA considerations section (section 10) as published says that the code 
point allocation scheme for the PW Associated Channel Type is...

   0 - 32751 : IETF Review
   32760 - 32767 : Experimental

This leaves an unexplained gap in the code points for 32752 to 32759, and 
also does not explain what happens for values above 32767.

The Erratum fixes the allocation to read:

   0 - 32759 : IETF Review
   32760 - 32767 : Experimental
   32768 - 65535 : IETF Review

This choice is made to keep the Experimental range where it has already been 
defined (so as not to impact any existing implementations) and to cover the 
rest of the codepoints.

IANA have confirmed that they can update the registry to reflect this change 
on the strength of the Erratum without us publishing any further documents.

At this time, I need to hear from the people working in this area (PWE3, 
MPLS, and MPLS-TP) if this change is *not* acceptable.

Please send comments to the mpls-tp list only ([email-masked]) or unicast 
to me.

I will let this comment period run until 20th November.

Thanks,
Adrian

---

From: Nitin Bahadur <[email-masked]>
Date: Wed, 4 Nov 2009 09:10:08 -0800

I doubt that someone is shipping software with the experimental code-points.

Given that, it might be better to move experimental to the end.

If someone is shipping software, then they should raise their hand now.

Nitin

> This choice is made to keep the Experimental range where it 
> has already been defined (so as not to impact any existing 
> implementations) and to cover the rest of the codepoints.

---

From: Adrian Farrel <[email-masked]>
Date: Wed, 04 Nov 2009 17:46:39 +0000

Agree that leaving the experimental allocations in the middle is not 
aesthetically pleasing, but:
- does it hurt?
- moving them would require an RFC not an Erratum

Thanks,
Adrian
----- Original Message ----- 
From: "Nitin Bahadur" <[email-masked]>
To: "'Adrian Farrel'" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, November 04, 2009 5:10 PM
Subject: Re: [mpls-tp] Erratum for RFC 5586

> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>

---

From: "Loa Andersson" <[email-masked]>
Date: Wed, 4 Nov 2009 18:58:07 +0100 (CET)

All,

the values for experimental code points did not change, so it should
be fine.

The only change is that we make clear that all other code points are
for IETF review.

/Loa
>> implementations) and to cover the rest of the codepoints.

Loa Andersson

Sr Strategy and Standards Manager
Ericsson ///
   phone:  +46 10 717 52 13
           +46 767 72 92 13

   email:  [email-masked]
           [email-masked]

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 5 Nov 2009 11:17:11 +0200

Loa, Adrian, Nitin and all,
As of today, only 6 (six!) ACH types from contiguous block of more than 32,000 have been allocated in almost 4 years.
So I would guess that this block would happily suffice for at least the next 100 years, and stop worrying about experimental code points in the middle.

My 2c,
     Sasha

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Loa Andersson
> Sent: Wednesday, November 04, 2009 7:58 PM
> To: Nitin Bahadur
> Cc: 'Adrian Farrel'; [email-masked]