Subject: Re: [mpls-tp] If a PW is a sublayer, why is it different?

From: Maarten Vissers <[email-masked]>
Date: Mon, 02 Nov 2009 08:47:04 +0100

Lou,

These definitions are being included in draft recommendation G.ptneq "Types
and characteristics of Packet Transport Network equipment". Draft 0 is in
TD185/3 (SG15, Dec. 2009). Next draft will be available soon; editors are
including the material agreed during the last SG15 meeting.

Regards,
Maarten

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: vrijdag 30 oktober 2009 12:27
To: Maarten Vissers
Cc: 'Drake, John E'; [email-masked]
Subject: Re: [mpls-tp] If a PW is a sublayer, why is it different?

Maarten,
	By "we use" I assume you mean ITU-T.  Is this correct?  If so,
perhaps you can help out those of us in the IETF who are unfamiliar with
your generic usage of the acronyms/concepts you list below by providing a
reference to the document(s) that include the generic definitions?

Much thanks,
Lou

On 10/29/2009 6:15 PM, Maarten Vissers wrote:
> John,
> 
> Yes of course. Transport networks have a common, technology 
> independent architecture. The terminology I am using is as such not 
> defunct. The MPLS-TP technology does not add anything new. I.e. all 
> elements are already available in other technologies like Ethernet VLAN
and OTN.
> 
> For circuit technologies we use the LO, HO and MS terminology (LO 
> VC/HO VC/MS, LO ODU/HO ODU/OMS). For packet technologies we use the 
> VC, VP and VS terminology (ATM VC/VP, Ethernet VC/VP/VS, MPLS-TP VC/VP).
> 
> NMS can manage all LO and VC layers in a similar manner. Also all HO 
> and VP layers can be managed similarly. And MS and VS layer can be 
> managed similarly.
> 
> Regards,
> Maarten
> 
> -----Original Message-----
> From: Drake, John E [mailto:[email-masked]]
> Sent: donderdag 29 oktober 2009 18:24
> To: Maarten Vissers; 'Adrian Farrel'; 'Luca Martini'
> Cc: [email-masked]
> Subject: RE: [mpls-tp] If a PW is a sublayer, why is it different?
> 
> Maarten,
> 
> Is there any particular reason why you insist upon re-using the 
> terminology of a defunct technology?
> 
> Thanks,
> 
> John
> 
>> -----Original Message-----
>> From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of Maarten Vissers
>> Sent: Thursday, October 29, 2009 9:58 AM
>> To: 'Adrian Farrel'; 'Luca Martini'
>> Cc: [email-masked]
>> Subject: Re: [mpls-tp] If a PW is a sublayer, why is it different?
>>
>> Indeed. 
>>
>> The S-PE node switches MPLS-TP VC signals (and terminates the MPLS-TP 
>> VP signals (if present)).
>> The P node switches MPLS-TP VP signals. 
>> The T-PE node terminates MPLS-TP VC signals (and terminates the 
>> MPLS-TP VP signals (if present)).
>>
>> The S-PE node also bridges Ethernet VC signals (carrying E-Tree and 
>> E-LAN services). Note that in this case the MPLS-TP VC signal, in 
>> which the Ethernet VC signal is carried, is terminated in the S-PE.
>>
>> The functionality of the NNI ports on P and PE nodes and the common 
>> functionality of the UNI-N ports on T-PE nodes is illustrated in C698 
>> (SG15, Sep/Oct 2009) http://www.itu.int/md/T09-SG15-C-0698/en.
>>
>> Regards,
>> Maarten
>>
>> -----Original Message-----
>> From: Adrian Farrel [mailto:[email-masked]]
>> Sent: donderdag 29 oktober 2009 13:44
>> To: Maarten Vissers; 'Luca Martini'
>> Cc: [email-masked]
>> Subject: Re: [mpls-tp] If a PW is a sublayer, why is it different?
>>
>> Right (for whatever meaning "S-PE" has").
>> We seem to agree that there is no functional difference between the 
>> two cases of node C.
>>
>> A
>> ----- Original Message -----
>> From: "Maarten Vissers" <[email-masked]>
>> To: "'Adrian Farrel'" <[email-masked]>; "'Luca Martini'" 
>> <[email-masked]>
>> Cc: <[email-masked]>
>> Sent: Thursday, October 29, 2009 11:59 AM
>> Subject: RE: [mpls-tp] If a PW is a sublayer, why is it different?
>>
>>
>>> Adrian,
>>>
>>>> In the first case, node C is a P-node.
>>>> In the second case, node C is an S-PE.
>>>
>>> I would consider node C a to be a S-PE in both cases.
>>> Rationale is that the LSP in the first case is a segment LSP of a 
>>> MPLS-TP VC and in the second case the same MPLS-TP VC is
>> present but
>>> without the segment.
>>>
>>> Regards,
>>> Maarten
>>>
>>> -----Original Message-----
>>> From: [email-masked] [mailto:[email-masked]] On 
>>> Behalf Of Adrian Farrel
>>> Sent: donderdag 29 oktober 2009 0:53
>>> To: Luca Martini
>>> Cc: [email-masked]
>>> Subject: Re: [mpls-tp] If a PW is a sublayer, why is it different?
>>>
>>> Luca,
>>>
>>> Perhaps I didn't explain my question clearly enough.
>>>
>>> In the data plane of an MPLS-TP network (so it is all one
>> server type
>>> - MPLS-TP), is there any difference in behavior in an S-PE
>> and P node
>>> when switching packets?
>>>
>>> Let me draw a network...
>>>
>>>
>>> A==B==C***D***E
>>>
>>> Consider that I build two LSP tunnels ABC and CDE.
>>> Now suppose I want an LSP (note: not a PW) form A to E. It runs ACE 
>>> using the two tunnels.
>>> At C, when a packet is received, the top label is popped
>> (end of LSP
>>> ABC) and the exposed label is used for forwarding. Then a
>> new label is
>>> imposed (LSP CDE) before the packet is sent onward.
>>>
>>> Now, let me draw another network.
>>>
>>> A==B==C***D***E
>>>
>>> Consider that I build two LSP tunnels ABC and CDE.
>>> Now suppose I want a PW (note: not an LSP) form A to E. It runs ACE 
>>> using the two tunnels.
>>> At C, when a packet is received, the top label is popped
>> (end of LSP
>>> ABC) and the exposed label is used for forwarding. Then a
>> new label is
>>> imposed (LSP CDE) before the packet is sent onward.
>>>
>>> In the first case, node C is a P-node.
>>> In the second case, node C is an S-PE.
>>> There is nothing that precludes or requires node C to be on
>> any domain
>>> boundary.
>>>
>>> What is the difference in the data plane between node C in
>> the first
>>> case and node C in the second case?
>>>
>>> It is important (to me) to limit this question to the data plane. I 
>>> don't care how the LSPs or PWs are set up or what service
>> they are delivering.
>>>
>>> Thanks,
>>> Adrian
>>>
>>> ----- Original Message -----
>>> From: "Luca Martini" <[email-masked]>
>>> To: "Adrian Farrel" <[email-masked]>
>>> Cc: <[email-masked]>
>>> Sent: Wednesday, October 28, 2009 10:31 PM
>>> Subject: Re: [mpls-tp] If a PW is a sublayer, why is it different?
>>>
>>>> Hi Adrian,
>>>>
>>>> An S-PE is very different. A P node has no knowledge of what is in 
>>>> the PW, what specific parameters are incompatible with the 2 PWs.
>>>> block or fake PW OAM, etc...
>>>> An S-PE is an administrative , and control point for the
>> MS-PW. While
>>>> a P Router switches all LSP the same , and does not even
>> have to be a
>>>> MIP.
>>>> Also an S-PE can connect PWs running on completely
>> different server
>>>> networks, without any interworking function at the network layer.
>>>>
>>>> Luca
>>>>
>>>>
>>>>
>>>> Adrian Farrel wrote:
>>>>> So trying to take this a step further...
>>>>>
>>>>> If a PW is "just a label" making it "just a sub-layer" why do we 
>>>>> insist that it is in any way different within the network?
>>>>>
>>>>> How is an S-PE that switches PW segments any different
>> from a P-node
>>>>> that switches LSP segments? True, the S-PE must terminate the LSP 
>>>>> tunnel (pop a label) before finding the PW label on which
>> to switch.
>>>>> But this same function could apply at a P-node that is
>> switching an
>>>>> LSP that was carried in a tunnel.
>>>>>
>>>>
>>>>> If this is the case, shouldn't we *include* PWs in the
>> Survivability
>>>>> Framework:
>>>>> - as automatically the same as LSPs
>>>>> - with some examples to show how the function if achieved.
>>>>>
>>>>> To repeat: How are PWs any different within the network.
>>>>>
>>>>
>>>>> [In answering, please recall that we are talking about MPLS-TP 
>>>>> networks only.]
>>>>>
>>>>> Thanks,
>>>>> Adrian
>>>>>
>>>>> ----- Original Message ----- From: "David Allan I"
>>>>> <[email-masked]>
>>>>> To: "Sprecher, Nurit (NSN - IL/Hod HaSharon)"
>>>>> <[email-masked]>; <[email-masked]>
>>>>> Sent: Wednesday, October 28, 2009 4:41 PM
>>>>> Subject: Re: [mpls-tp] Is PW a layer of MPLS-TP
>>>>>
>>>>>
>>>>>> Hi Nurit:
>>>>>>
>>>>>> I think you misunderstand me. My comment on whether we supported 
>>>>>> clients besides PWs was to illustrate second order consequences, 
>>>>>> not to suggest that OAM was wagging the dog or was involved in 
>>>>>> delineation of layers and sublayers...
>>>>>>
>>>>>> IMO all labels between the link layer preamble and the
>> label with
>>>>>> the S- bit set are either reserved functions or
>> sub-layers of the
>>>>>> MPLS-TP "layer", "sub-layers" AND reserved labels being what was 
>>>>>> known as "levels" in RFC 3031. All sub layers have the
>> potential to
>>>>>> be switched including the PW sub-layer, ergo a PW is a
>> sub-layer of
>>> MPLS-TP...
>>>>>>
>>>>>> I hope I'm clear...
>>>>>>
>>>>>> Cheers
>>>>>> D
>>>>>>
>>>>>> -----Original Message-----
>>>>>> From: Sprecher, Nurit (NSN - IL/Hod HaSharon) 
>>>>>> [mailto:[email-masked]]
>>>>>> Sent: Wednesday, October 28, 2009 12:27 PM
>>>>>> To: David Allan I; [email-masked]
>>>>>> Subject: RE: [mpls-tp] Is PW a layer of MPLS-TP
>>>>>>
>>>>>> Hi Dave,
>>>>>> I am afraid again that relying on OAM to distinnguish
>> between the
>>>>>> clients is a wrong approach.
>>>>>> Best regadrs,
>>>>>> Nurit
>>>>>>
>>>>>> -----Original Message-----
>>>>>> From: [email-masked]
>> [mailto:[email-masked]] On
>>>>>> Behalf Of ext David Allan I
>>>>>> Sent: Wednesday, October 28, 2009 6:02 PM
>>>>>> To: [email-masked]
>>>>>> Subject: [mpls-tp] Is PW a layer of MPLS-TP
>>>>>>
>>>>>> HI Adrian:
>>>>>>
>>>>>> IMO the S-bit is set in the PW label and clear in the
>> encapsulating
>>>>>> sub-layers, hence it is a sub-layer in the G.805 sense
>> of MPLS-TP.
>>>>>>
>>>>>> IMO it does confuse the landscape as OAM discrimination requires 
>>>>>> apriori knowledge of the label type at bottom of stack
>> IF we assume
>>>>>> a BOS can be other than a PW...
>>>>>>
>>>>>> My 2 cents
>>>>>> D
>>>>>>
>>>>>> You wrote>>>>
>>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> I am trying this question again with a different subject line.
>>>>>>
>>>>>>
>>>>>> It would be helpful to have more answers than just
>> Neil's (not that
>>>>>> I don't value his view, but one person doesn't make consensus!)
>>>>>>
>>>>>> My question:
>>>>>>
>>>>>> Hasn't the work on the MPLS-TP Framework draft judged PW to be a 
>>>>>> client of MPLS-TP?
>>>>>> That is, PW is not a layer of MPLS-TP, but the client.
>>>>>>
>>>>>> Doesn't that mean that PW survivability is out of scope for the 
>>>>>> MPLS-TP Survivability I-D?
>>>>>>
>>>>>> Thanks,
>>>>>> Adrian
>>>>>> _______________________________________________
>>>>>> mpls-tp mailing list
>>>>>> [email-masked]
>>>>>> https://www.ietf.org/mailman/listinfo/mpls-tp
>>>>>> _______________________________________________
>>>>>> mpls-tp mailing list
>>>>>> [email-masked]
>>>>>> https://www.ietf.org/mailman/listinfo/mpls-tp
>>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> mpls-tp mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/mpls-tp
>>>>
>>>>
>>>
>>> _______________________________________________
>>> mpls-tp mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/mpls-tp
>>>
>>>
>>
>> _______________________________________________
>> mpls-tp mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/mpls-tp
>> =
> 
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
> 
> 
>

---

From: Lou Berger <[email-masked]>
Date: Mon, 02 Nov 2009 10:40:01 -0500

Maarten,
	If you think this terminology applies to TP, it seems like it would be
a good idea to have the document sent over to this group  either
formally or informally.  Don't you agree, or did I miss something?

Thanks,
Lou

---

From: Maarten Vissers <[email-masked]>
Date: Mon, 02 Nov 2009 21:06:46 +0100

Lou,

I agree with you. I will ask Q.9/15 to send a liaison.

Regards,
Maarten

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: maandag 2 november 2009 16:40
To: Maarten Vissers
Cc: [email-masked]
Subject: Re: [mpls-tp] If a PW is a sublayer, why is it different?

Maarten,
	If you think this terminology applies to TP, it seems like it would
be a good idea to have the document sent over to this group  either formally
or informally.  Don't you agree, or did I miss something?

Thanks,
Lou

On 11/2/2009 2:47 AM, Maarten Vissers wrote:
> Lou,
> 
> These definitions are being included in draft recommendation G.ptneq 
> "Types and characteristics of Packet Transport Network equipment". 
> Draft 0 is in
> TD185/3 (SG15, Dec. 2009). Next draft will be available soon; editors 
> are including the material agreed during the last SG15 meeting.
> 
> Regards,
> Maarten
> 
> perhaps you can help out those of us in the IETF who are unfamiliar 
> with your generic usage of the acronyms/concepts you list below by 
> providing a reference to the document(s) that include the generic
definitions?
>>> The S-PE node switches MPLS-TP VC signals (and terminates the 
>>> functionality of the UNI-N ports on T-PE nodes is illustrated in 
>>> C698 (SG15, Sep/Oct 2009) http://www.itu.int/md/T09-SG15-C-0698/en.
>>>
>>> Regards,
>>> Maarten
>>>