Subject: [mpls-tp] R****** Defect Indication

From: Chris Benson <[email-masked]>
Date: Fri, 13 Nov 2009 17:29:11 -0800 (PST)

Hi folks,

I have found several references in some MPLS-TP drafts to
RDI standing for Remote Defect Indication - most notably
in Section 5.2 of draft-ietf-mpls-tp-oam-framework-02.

Another MPLS-TP draft expands RDI to Reverse Defect Indication
(title of Section 2.2 of draft-boutros-mpls-tp-fault-02 and
elsewhere therein).

At first it seemed to me that the latter was just a typing
affectation that really meant "Remote", but now I am not
so sure. After all, there is a FORWARD Defect Indicator,
that presumably would become "remote", but not "reverse"!

Should draft-boutros-mpls-tp-fault-02 just refer to RDI
as "Remote Defect Indication"?

With thanks in advance, from Chris Benson

---

From: Huub van Helvoort <[email-masked]>
Date: Sat, 14 Nov 2009 05:26:04 +0100

Hello Chris,

> in Section 5.2 of draft-ietf-mpls-tp-oam-framework-02.

This is correct. It is an indication that the remote end
has detected a defect (in the forward direction). It shall
be used only for PM.

> (title of Section 2.2 of draft-boutros-mpls-tp-fault-02 and

This is not correct and should be changed.

> that presumably would become "remote", but not "reverse"!

FDI was introduced in Y.1711, together with BDI backward
defect indication.

> as "Remote Defect Indication"?

Yes.

Regards, Huub.

-- 
================================================================
Always remember that you are unique...just like everyone else...