Subject: Re: [mpls-tp] [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

From: [email-masked]
Date: Mon, 2 Aug 2010 09:43:55 +0800

Jeong-dong,
I don't completely understand your describles. 
in former part, you think the protection locking message is not a reply 
message ,but is
a originator of request message.
while in your last sentence. the Message is not originated by a SEN.
so I can't see this locking message is originator of Locking request 
message or only a reply 
to protection switching Request message arrived at the SEN？
if it is the former, SEN as MIP of a path, it can't actively initiate a 
request messgae.
else if it  is only the reply to protection switching request message. 
IMO, for the following
example：
 
          A------B------C  D------E------F 
            \   LPD1   /        \   LPD3  / 
              \            /            \            / 
               P-----Q----------R-----S 
              /                                   \ 
             /           LPD2                \ 
            /                                        \ 
           G--------------H---------------J 

 when a path G-H-J have failure, end node G firstly initiate a protection 
switching event message to 
 SEN node P, R. if SEN node P,R would relpy to the protection switching 
event, the Reply message(locking
 message) should be sent to the end nodes G or J of LPD2, can't be sent to 
the end nodes D,F of LPD3;

 my understanding to your opinions may be wrong?

  best regards
  liu

"Ryoo, Jeong-dong" <[email-masked]> 
2010-07-30 18:22
请答复 给
"Ryoo, Jeong-dong" <[email-masked]>

收件人
<[email-masked]>, "Taesik Cheung" <[email-masked]>
抄送
<[email-masked]>, <[email-masked]>, <[email-masked]>
主题
RE: Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Liu,
 
What you described in your email is aligned with the operations stated in 
the MPLS-TP mesh protection draft.
The protection locking message is not exactly a reply message, which goes 
to the originator of the request message.
It is certainly destined to other nodes, which share the common facility,
This is an additional function of SEN to provide the shared mesh 
protection.
What I would like to emphasize is that this message is not originated by a 
SEN (a MIP of the path for linear protection) if there is no protection 
switching event message arrived at the SEN,
 
Best regards,
 
Jeong-dong 
==============================================
Jeong-dong Ryoo, Ph.D.
Principal Member of Research Staff
Network Research Department
Electronics and Telecommunications Research Institute (ETRI) 
Phone: +82-42-860-5384, Fax: +82-42-860-6342
Email: [email-masked]
==============================================

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-07-30 PM 6:21:08
To: "Taesik Cheung" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>, "[email-masked]" <[email-masked]>, 
"[email-masked]" <[email-masked]>
Subject: Re: [mpls] a question about 
draft-cheung-mpls-tp-mesh-protection-01

Taesik 
thank you for replying .but I don't agree your opinions 
According to your describles in the draft. I think the protection locking 
message isn't  a response to the protection state change notification 
message sent from a MEP. 
and it is activley generate a Locking Request message for the SEN node. 
for example. the following figure : 
          A------B------C  D------E------F 
            \   LPD1   /        \   LPD3  / 
              \            /            \            / 
               P-----Q----------R-----S 
              /                                   \ 
             /           LPD2                \ 
            /                                        \ 
           G--------------H---------------J 
a. Node G detects the failure, and initiates the linear protection 
      switching for the failed working path G-H-J; 

   b. At the same time, node G generates the protection switching event 
      message saying that a protection switching event happened to node 
      P and R, which are SENs for J->H->G. 

   c. The SEN P compares the protection switching priority of LPD2 with 
      that of LPD1. In this example, as the priority of LPD1 is higher 
      than LPD2, SEN P does not take an action to node A. 
      The SEN R compares the protection switching priority of LPD2 with 
      that of LPD3. In this example, as the priority of LPD3 is lower 
      than LPD2, SEN R sends the protection locking message requesting 
      LoP to node D.(if the Locking message is a response to the 
protection 
      state change , I think the Locking message should send to Node G , 
      not node D. because at the time there is no protection state change 
for LPD2 . 
     Node D can't send any state change request to SEN node R firstly. 
     do you think so?  ) 

   d. Node D takes the protection locking message as an input to the 
      linear protection switching, and follows the linear protection 
      switching procedure to process the end-to-end LoP command 

 maybe my understanding be wrong? 

  best regards 
   liu 

"Taesik Cheung" <[email-masked]> 
?件人:  [email-masked] 
2010-07-30 16:45 

?答? ?
Taesik Cheung <[email-masked]>

收件人
<[email-masked]>, <[email-masked]> 
抄送
[email-masked], [email-masked] 
主?
Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Hi Liu, 
 
Thank you for the comments. 
Please see in-line. 
 
Regards, 
Taesik 

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-07-30 PM 5:06:30
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: a question about draft-cheung-mpls-tp-mesh-protection-01

hi, 
today I reviewed your this draft, I have a few questions for mesh 
protection 
1 in section 3, In my mind, there is a sentence : In both cases, 1:1 or 
1+1 protection may be used. 
  if there use 1+1 protection for each working path. it is no necessary to 
apply mesh protection. 
  beacause the bandwidth resource of protection is equal to the sum of 
bandwidth resource of all 
  protected path. so I think 1+1 protection should not be used in the mesh 
protection. 
  do you think so? 
[Taesik] Yes, if 1+1 protection is used, shared mesh protection is not 
necessary. The sentence is just generic one. Right after the sentence, we 
described that if 1:1 protection is used, the segment PQR can be shared by 
two protection paths. 

2 about the Shared node SEN will send the protection locking message 
requesting 
     LoP to the end node of protected LSP. IMO, as SEN node is MIP of the 
protected 
     LSP , it can't generate unsolicit OAM packet to send other node. so 
how to generate 
   the protection locking message requesting LOP in the SEN node ? 
[Taesik] The protection locking message is a response to the protection 
state change notification message sent from a MEP. It is similar to 
LTM/LTR or Lock Intruct / Lock Report relationship. 

 Maybe i miss something important? 
 thank you 

 best regards 
 liu 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is 
solely property of the sender's organization. This mail communication is 
confidential. Recipients named above are obligated to maintain secrecy and 
are not permitted to disclose the contents of this communication to 
others.
This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed. 
If you have received this email in error please notify the originator of 
the message. Any views expressed in this message are those of the 
individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam 
system.
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is 
solely property of the sender's organization. This mail communication is 
confidential. Recipients named above are obligated to maintain secrecy and 
are not permitted to disclose the contents of this communication to 
others.
This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed. 
If you have received this email in error please notify the originator of 
the message. Any views expressed in this message are those of the 
individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam 
system.

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: "Ryoo, Jeong-dong" <[email-masked]>
Date: Mon, 2 Aug 2010 12:10:30 +0900

Liu,

I think you have correct understanding on the mesh protection draft.

What I wanted to say was that the locking message from a SEN is generated due to the event message arrived at the SEN from an end node of the linear protection domain that suffers a failure,

The locking message is not exactly a reply to the event message as the locking message does not go to the source of the event message, but it can be viewed as a kind of such a message since the locking message cannot be generated without an event message.

Best regards

Jeong-dong

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-08-02 AM 10:43:55
To: "Ryoo, Jeong-dong" <[email-masked]>
Cc: "Taesik Cheung" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Jeong-dong,
I don't completely understand your describles.
in former part, you think the protection locking message is not a reply message ,but is
a originator of request message.
while in your last sentence. the Message is not originated by a SEN.
so I can't see this locking message is originator of Locking request message or only a reply
to protection switching Request message arrived at the SEN？
if it is the former, SEN as MIP of a path, it can't actively initiate a request messgae.
else if it  is only the reply to protection switching request message. IMO, for the following
example：

when a path G-H-J have failure, end node G firstly initiate a protection switching event message to
SEN node P, R. if SEN node P,R would relpy to the protection switching event, the Reply message(locking
message) should be sent to the end nodes G or J of LPD2, can't be sent to the end nodes D,F of LPD3;

best regards
liu

2010-07-30 18:22

?答? ?

收件人

抄送

主?

Liu,

What you described in your email is aligned with the operations stated in the MPLS-TP mesh protection draft.
The protection locking message is not exactly a reply message, which goes to the originator of the request message.
It is certainly destined to other nodes, which share the common facility,
This is an additional function of SEN to provide the shared mesh protection.
What I would like to emphasize is that this message is not originated by a SEN (a MIP of the path for linear protection) if there is no protection switching event message arrived at the SEN,

Best regards,

Jeong-dong

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-07-30 PM 6:21:08
To: "Taesik Cheung" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Taesik
According to your describles in the draft. I think the protection locking message isn't  a response to the protection state change notification message sent from a MEP.

LoP to node D.(if the Locking message is a response to the protection
not node D. because at the time there is no protection state change for LPD2 .

best regards
liu

2010-07-30 16:45

?答? ?

收件人

抄送

主?

Hi Liu,

Regards,
Taesik

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-07-30 PM 5:06:30
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: a question about draft-cheung-mpls-tp-mesh-protection-01

hi,
today I reviewed your this draft, I have a few questions for mesh protection
1 in section 3, In my mind, there is a sentence : In both cases, 1:1 or 1+1 protection may be used.
if there use 1+1 protection for each working path. it is no necessary to apply mesh protection.
beacause the bandwidth resource of protection is equal to the sum of bandwidth resource of all
protected path. so I think 1+1 protection should not be used in the mesh protection.
do you think so?
[Taesik] Yes, if 1+1 protection is used, shared mesh protection is not necessary. The sentence is just generic one. Right after the sentence, we described that if 1:1 protection is used, the segment PQR can be shared by two protection paths.

2 about the Shared node SEN will send the protection locking message requesting
LoP to the end node of protected LSP. IMO, as SEN node is MIP of the protected
LSP , it can't generate unsolicit OAM packet to send other node. so how to generate
the protection locking message requesting LOP in the SEN node ?
[Taesik] The protection locking message is a response to the protection state change notification message sent from a MEP. It is similar to LTM/LTR or Lock Intruct / Lock Report relationship.

best regards
liu

---

From: "Ryoo, Jeong-dong" <[email-masked]>
Date: Mon, 2 Aug 2010 13:44:39 +0900

Liu,

LCK instruction/report are the functions of OAM,

What we are interested in here is "Lockout of Protection (LoP)" in protection switching,

When an end node of linear protection domain receives the protection locking message from a SEN,

it acts in the same way as an LoP command is issued.

Jeong-dong

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-08-02 PM 1:24:07
To: "Ryoo, Jeong-dong" <[email-masked]>
Cc: "Taesik Cheung" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Jeong-dong,
IMO, Lock message mainly include two type of message: one is Lock instuction, another is Lock reporting.
if Lock mesage is similar to Lock instruction, it should be only generated by MEP of LSP to lock LSP path
in the peer MEP. not be generated by SEN(MIP of LSP);
if lock message is similar to Lock reporting, it may  be generated in MIP of LSP when the server layer is lock state.
but this draft is not the situation, why to generate Lock messasge in MIP of LSP.

can this function be added just now?

best regards
liu

2010-08-02 11:10

?答? ?

收件人

<[email-masked]>

抄送

"Taesik Cheung" <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>

主?

Liu,

Best regards

Jeong-dong

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-08-02 AM 10:43:55
To: "Ryoo, Jeong-dong" <[email-masked]>
Cc: "Taesik Cheung" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Jeong-dong,

best regards
liu

2010-07-30 18:22

?答? ?

收件人

抄送

主?

Liu,

Best regards,

Jeong-dong

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-07-30 PM 6:21:08
To: "Taesik Cheung" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Taesik

best regards
liu

2010-07-30 16:45

?答? ?

收件人

抄送

主?

Hi Liu,

Regards,
Taesik

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-07-30 PM 5:06:30
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: a question about draft-cheung-mpls-tp-mesh-protection-01

hi,

best regards
liu

---

From: "Ryoo, Jeong-dong" <[email-masked]>
Date: Mon, 2 Aug 2010 17:59:36 +0900

Liu,

The two messages that are introduced in the draft are specific to the mesh protection.

Therefore, those messages cannot be included in the set of the linear protection protocol messages.

And they are not OAM messages, either.

The encapsulations of those messages are not deternined.

If you have any suggestions, please let us know.

Jeong-dong

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-08-02 PM 3:09:59
To: "Ryoo, Jeong-dong" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Jeong-dong,
I know here Lock message is not Lock instuction/report. but the message should be
encapusalted into APS/PSC or other OAM packet to transported to other nodes.
if the Lock message is in the APS/PSC packet, they should run between the peer MEPs in the
section, lsp and PW . not run between MEP and MIP for a LSP.
if the lock message is in OAM packet, it may be similar to Lock instruct/report to use to
lock of protection. not lock of LSP.

best regards
liu

2010-08-02 12:44

?答? ?

收件人

<[email-masked]>

抄送

[email-masked], [email-masked], [email-masked]

主?

Liu,

Jeong-dong

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-08-02 PM 1:24:07
To: "Ryoo, Jeong-dong" <[email-masked]>
Cc: "Taesik Cheung" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Jeong-dong,

best regards
liu

2010-08-02 11:10

?答? ?

收件人

<[email-masked]>

抄送

主?

Liu,

Best regards

Jeong-dong

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-08-02 AM 10:43:55
To: "Ryoo, Jeong-dong" <[email-masked]>
Cc: "Taesik Cheung" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Jeong-dong,

best regards
liu

2010-07-30 18:22

?答? ?

收件人

抄送

主?

Liu,

Best regards,

Jeong-dong

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-07-30 PM 6:21:08
To: "Taesik Cheung" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [mpls] a question about draft-cheung-mpls-tp-mesh-protection-01

Taesik

best regards
liu

2010-07-30 16:45

?答? ?

收件人

抄送

主?

Hi Liu,

Regards,
Taesik

-----Original Message-----
From: "[email-masked]" <[email-masked]>
From Date: 2010-07-30 PM 5:06:30
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: a question about draft-cheung-mpls-tp-mesh-protection-01

hi,

best regards
liu