Subject: [mpls-tp] MPLS-TP Linear protection switching - server layer indication

From: Selvan <[email-masked]>
Date: Thu, 26 Aug 2010 17:48:10 +0530

Hi,
  In* draft-ietf-mpls-tp-linear-protection-02* draft, 'server layer
indication'  is depicted separately and feeds indication to the 'Local
request logic' (in Figure 1: Protection switching control logic)

I have few queries related to the 'server layer indication' mentioned in the
protection switching draft.

Consider the following example:

                Client Layer
|<-----------------------LSP 100 --------------------->|
*R1---------R2-------------------------R3--------------R4*

             |<-------LSP200---------->|
                Server Layer (With protection mechanism)

LSP 100 starts from R1 and ends at R4

LSP 100 is being carried over LSP200 which spans between R2 --- R3

Now, LSP 200 becomes the server layer for LSP100(client)

*Questions:*

1) When a failure is detected by the Server Layer, will it be indicated to
the client layer ?   (ie) If a failure is detected by R2, will it be
informed to R1 ?

2) If 'yes', *what is the mechanism* by which the server layer failure
information is propagated to the client layer ?
3) Is the 'Holdoff-timer' applicable only for "Server layer alarm
indication" ? Is this timer not applicable for fault being notified from OAM
(or) from control plane ?

Thanks
Selvan

---

From: "Shahram Davari" <[email-masked]>
Date: Thu, 26 Aug 2010 09:37:58 -0700

Hi Selvan,

Please see inline.

Thx
Shahram

From: [email-masked] [mailto:[email-masked]] On Behalf Of Selvan
Sent: Thursday, August 26, 2010 5:18 AM
To: [email-masked]
Subject: [mpls-tp] MPLS-TP Linear protection switching - server layer indication

Hi,
  In draft-ietf-mpls-tp-linear-protection-02 draft, 'server layer indication'  is depicted separately and feeds indication to the 'Local request logic' (in Figure 1: Protection switching control logic)

I have few queries related to the 'server layer indication' mentioned in the protection switching draft.

                Client Layer
|<-----------------------LSP 100 --------------------->|
R1---------R2-------------------------R3--------------R4

Questions:

1) When a failure is detected by the Server Layer, will it be indicated to the client layer ?   (ie) If a failure is detected by R2, will it be informed to R1 ?

SD> Yes to both questions

2) If 'yes', what is the mechanism by which the server layer failure information is propagated to the client layer ?

AIS and RDI
3) Is the 'Holdoff-timer' applicable only for "Server layer alarm indication" ? Is this timer not applicable for fault being notified from OAM (or) from control plane ?

SD> AIS has  the effect of Alarm suppression.

Thanks
Selvan