Subject: [mpls-tp] A couple of questions regarding draft-bfl-mpls-tp-uni-nni-00

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 3 Aug 2010 19:02:26 +0300

Hi all,
A couple of questions regarding draft-bfl-mpls-tp-uni-nni-00.

1. It seems that the only difference between the UNI diagram in RFC 5921 and that in the draft
   is the split into UNI-C and UNI-C. It farther seems that the split has been pretty well obvious
   in 5921. Did I miss something?

2. The NNI diagrams in RFC 5921 and in the draft seem indeed different, In particular, the diagram
   in the draft contains a new entity that has been missing in RFC 5921 - Transport Path CP. 
   However, any explanations regarding this entity seem to be missing both in 5921 
   and in the draft. Again, did I miss something?

Regards,
     Sasha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, August 03, 2010 6:15 PM
To: [email-masked]
Subject: I-D Action:draft-bfl-mpls-tp-uni-nni-00.txt 

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : MPLS Transport Profile User-to-Network and Network-to-Network Interfaces
	Author(s)       : M. Bocci, et al.
	Filename        : draft-bfl-mpls-tp-uni-nni-00.txt
	Pages           : 8
	Date            : 2010-08-03

The framework for MPLS in transport networks [RFC5921] provides
reference models for an MPLS-TP User-to-Network Interface (UNI), and
an MPLS-TP Network-to-Network interface (NNI).  This document updates
those reference models to show detailed reference points for these
interfaces, along with further clarification of the functional
architecture of MPLS-TP at a UNI and NNI.

This document is a product of a joint Internet Engineering Task Force
(IETF) / International Telecommunication Union Telecommunication
Standardization Sector (ITU-T) effort to include an MPLS Transport
Profile within the IETF MPLS and Pseudowire Emulation Edge-to-Edge
(PWE3) architectures to support the capabilities and functionalities
of a packet transport network as defined by the ITU-T.

This Informational Internet-Draft is aimed at achieving IETF
Consensus before publication as an RFC and will be subjet to an IETF
Last Call.

[RFC Editor, please remove this note before publication as an RFC and
insert the correct Streams Boilerplate to indicate that the published
RFC has IETF onsensus.]

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-bfl-mpls-tp-uni-nni-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Tue, 3 Aug 2010 18:35:36 +0200

Hi Sasha, 

> From: Alexander Vainshtein [mailto:[email-masked]] 
> Sent: 03 August 2010 17:02
> To: Bocci, Matthew (Matthew); Dan Frost; LEVRAU, LIEVEN (LIEVEN)
> Cc: [email-masked]
> Subject: A couple of questions regarding draft-bfl-mpls-tp-uni-nni-00
> 
> Hi all,

The main change we made here was to change the span used to indicate the UNI with a reference point for the UNI. This is more inline with convention.

>    and in the draft. Again, did I miss something?

Yes, infact the original diagram in 5921 also ignored the fact that the transport path can be present at the NNI, and only showed the transport service data plane and transport service control plane. When we updated this figure, we felt that both entities should be shown because in the general case, transport service and transport path signaling may be present here. However, both transport service and transport path are defined in 5921.

Regards

Matthew

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> 	Title           : MPLS Transport Profile 
> User-to-Network and Network-to-Network Interfaces
> The framework for MPLS in transport networks [RFC5921] 
> provides reference models for an MPLS-TP User-to-Network 
> Interface (UNI), and an MPLS-TP Network-to-Network interface 
> (NNI).  This document updates those reference models to show 
> detailed reference points for these interfaces, along with 
> further clarification of the functional architecture of 
> MPLS-TP at a UNI and NNI.
> 
> (IETF) / International Telecommunication Union 
> Telecommunication Standardization Sector (ITU-T) effort to 
> include an MPLS Transport Profile within the IETF MPLS and 
> Pseudowire Emulation Edge-to-Edge
> (PWE3) architectures to support the capabilities and 
> functionalities of a packet transport network as defined by the ITU-T.
> 
> Consensus before publication as an RFC and will be subjet to 
> an IETF Last Call.
> 
> [RFC Editor, please remove this note before publication as an 
> RFC and insert the correct Streams Boilerplate to indicate 
> that the published RFC has IETF onsensus.]
> 
> Below is the data which will enable a MIME compliant mail 
> reader implementation to automatically retrieve the ASCII 
> version of the Internet-Draft.
>