Subject: [mpls-tp] Query on draft-ietf-mpls-tp-linear-protection-06.txt

From: Apratim Mukherjee <[email-masked]>
Date: Fri, 18 Mar 2011 00:20:14 -0700

To the authors.

Say a PSC State Machine ( referred to as SM below ) is in state Normal.
Now PSC SM gets SF on Protect as input event, hence goes to Unavailable.
Next PSC SM gets SF on Working , so stays in Unavailable. 
( At this point this LSP group is incapable of carrying client traffic) 

Next PSC SM gets SF Clear on Protect as input event. As per the draft , now the PSC SM  moves to Normal state. 

But should it not be going to PSC Protecting Failure state since client traffic should be using the Protect Path in this state ?

I did see a similar query and reply from Yaacov which seems to suggest that when we move Normal state here , this is something 
Like a temporary transitioning state and the SF on Working should now be provided as input so that the SM can move to the correct 
Protecting Failure State. 

Specifically : 'In essence, as pointed out in the comment in row #80 of the LC comments the state machine dictates that you 
transition through Normal to arrive at the Protecting failure state.' , though the context was a slightly different sequence of 
steps involving SF , FS and Clear . 

Does this mean that in certain cases , we need to store the other pending events to the PSC state machine to be provided as input later ?

In any case , can you please also point me to the location of the LC comments for this draft.

Regards,
Apratim

---

From: "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Sun, 20 Mar 2011 18:42:16 +0100

Hi all,

Since I am not sure that this attachment was delivered to the mailing
list the first time it was sent I am resending.

The attachment contains the LC comments and their resolution after
discussion by the editors of the Linear Protection draft.

Best regards,
Yaacov