Subject: Re: [mpls-tp] [mpls] WG LC draft-lm-pwe3-mpls-tp-gal-in-pw-00.txt

From: Luca Martini <[email-masked]>
Date: Fri, 11 Mar 2011 06:31:37 -0700

Greg ,
Some

On 02/18/11 11:15, Greg Mirsky wrote:
> Dear Luca,
> I see at least two issues:
>
>     * use of GAL for PW, in my view, is another VCCV CC type that has
>       to be negotiated as described in RFC 5085.
>
These are valid points, but this document in question does not define,
not discussed VCCV.
We have since posted a draft that proposes a new VCCV mode , and we
welcome comments regarding that document.
(draft-nadeau-pwe3-vccv-2-01.txt)

>     * use of GAL creates ambiguous situation when PW CW is used. The
>       benefit from extending GAL in PW, as I see, is for PWs that are
>       not required to use PW CW. That might be a good enough reason to
>       update RFC 5586 as proposed in the document but we must address
>       use cases of GAL in PWs that require presence PW CW. If we
>       prohibit or even discourage use of GAL for these PWs that have
>       PW VCCV as native Associated Channel, then architecture of ACh
>       for MPLS-TP PW not simplified as result of adopting the proposal.
>
> Regard
Greg,
The GAL is basically a notifier that the packet following the end of the
MPLS label stack, is explicitly defined as a G-ACH format.
Normally the packet would be decoded as an IP packet , unless the last
label on the stack indicated otherwise.

The GAL can certainly be applied  to a PW OAM packet on a PW that uses
the CW, and this document does not define that , nor restricts it.

The scope of this document is limited to removing an unnecessary
restriction in rfc5586, hence  this comment not applicable to this document.

Thanks.
Luca

> s,
> Greg
>
> On Fri, Feb 18, 2011 at 7:46 AM, Luca Martini <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Greg,
>
>     Sorry, but I do not remember the point you mention.
>     Can you explain again here ?
>     Thanks.
>     Luca
>
>
>     On 02/17/11 23:47, Greg Mirsky wrote:
>     > Dear Authors and All,
>     > prior to the meeting in Bejing and acceptance of this proposal as WG
>     > document Luca and I agreed that use of GAL with PW VCCV presents a
>     > problem.
>     > I was not attending the IETF-79, nor I found discussion of this
>     issue
>     > in the minutes. I think that this issue should be specified,
>     > explained. In my view, this document updates not only RFC 5586
>     > but RFC 5085 too.
>     >
>     > Regards,
>     > Greg
>     >
>     > Comment to draft-lm-pwe3-mpls-tp-gal-in-pw-00.txt
>     >
>     > On Sat, Oct 30, 2010 at 10:14 AM, Luca Martini
>     <[email-masked] <mailto:[email-masked]>
>     > <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>     >
>     >     Greg,
>     >
>     >     You are correct , the proposed update does not propose any
>     changes
>     >     to VCCV.
>     >     However the problem with vccv is not as simple as to ask for
>     a new
>     >     code point from IANA.
>     >     Given the good amount of discussion on this point, we should
>     >     probably have a discussion in Beijing.
>     >
>     >     Luca
>     >
>     >
>     >
>     >     On 10/29/2010 05:07 PM, Greg Mirsky wrote:
>     >>     Dear Authors,
>     >>     I think that proposed update of the Section 4.2. RFC 5586
>     makes it possible
>     >>     to use GAL on MPLS-TP PW that uses Control Word. I consider
>     it to be
>     >>     conflict between PW VCCV CC types because use of GAL is not
>     negotiated
>     >>     through PW VCCV negotiation. To avoid such situation I propose:
>     >>
>     >>        - in Section 5 request IANA to assign new CC Type "MPLS
>     Generic
>     >>        Associated Channel Label"
>     >>        - assign precedence to new CC Type that affects Section
>     7 RFC 5085
>     >>
>     >>     Regards,
>     >>     Greg
>     >>
>     >>
>     >>
>     >>     _______________________________________________
>     >>     mpls mailing list
>     >>     [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     >>     https://www.ietf.org/mailman/listinfo/mpls
>     >
>     >
>     >
>     > _______________________________________________
>     > mpls mailing list
>     > [email-masked] <mailto:[email-masked]>
>     > https://www.ietf.org/mailman/listinfo/mpls
>
>

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 11 Mar 2011 11:14:25 -0800

Dear Luca,
thank you for bringing draft-nadeau-pwe3-vccv-2-01 to my attention. I'll
send my comments to it in a separate e-mail.
I'll have to miss another opportunity to discuss your proposal in a meeting.
Please add my comments below to my earlier expressed WG LC comments:

   - the draft-lm-pwe3-mpls-tp-gal-in-pw-00 depends on any solution that
   addresses applicability of GAL in PW VCCV, e.g. solution proposed in
   draft-nadeau-pwe3-vccv-2-01;
   - the draft-lm-pwe3-mpls-tp-gal-in-pw-00 needs to mention such dependency
   and refer to any existing proposal;
   - I believe that the draft-lm-pwe3-mpls-tp-gal-in-pw-00 can be advanced
   in lock with document that addresses use of GAL in PW VCCV.

Regards,
Greg

---

From: Alexander Vainshtein <[email-masked]>
Date: Fri, 11 Mar 2011 21:21:49 +0200

Greg, Luca,
As I've already stated in my comment on draft-nadeau-pwe3-vccv-2, IMHO it makes draft-lm-pwe3-mpls-tp-gal-in-pw completely useless.

My 2c,
     Sasha

From: [email-masked] [mailto:[email-masked]] On Behalf Of Greg Mirsky
Sent: Friday, March 11, 2011 9:14 PM
To: Luca Martini
Cc: [email-masked]; [email-masked]; pwe3; HUANG Feng F; [email-masked]
Subject: Re: [mpls] WG LC draft-lm-pwe3-mpls-tp-gal-in-pw-00.txt

Dear Luca,
thank you for bringing draft-nadeau-pwe3-vccv-2-01 to my attention. I'll send my comments to it in a separate e-mail.
I'll have to miss another opportunity to discuss your proposal in a meeting. Please add my comments below to my earlier expressed WG LC comments:

 *   the draft-lm-pwe3-mpls-tp-gal-in-pw-00 depends on any solution that addresses applicability of GAL in PW VCCV, e.g. solution proposed in draft-nadeau-pwe3-vccv-2-01;
 *   the draft-lm-pwe3-mpls-tp-gal-in-pw-00 needs to mention such dependency and refer to any existing proposal;
 *   I believe that the draft-lm-pwe3-mpls-tp-gal-in-pw-00 can be advanced in lock with document that addresses use of GAL in PW VCCV.
Regards,
Greg
On Fri, Mar 11, 2011 at 5:31 AM, Luca Martini <[email-masked]<mailto:[email-masked]>> wrote:
Greg ,
Some

Greg,

Thanks.
Luca

> s,
> Greg
>
> On Fri, Feb 18, 2011 at 7:46 AM, Luca Martini <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>
>     Greg,
>
>     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     > <mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>> wrote:
>     >
>     >     Greg,
>     >
>     >>     [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>> <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>
>     > [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>

---

From: venkatesan mahalingam <[email-masked]>
Date: Fri, 11 Mar 2011 15:12:51 -0500

Hi,
AFAIK, ACH can't be used without supporting the CW in HW.

As per RFC-5085, 5.1.1.  In-Band VCCV (Type 1)
CC Type-1 mode of VCCV operation MUST be supported when the control word is
present.

Are we implicitly mandating the CW (ACH) in HW by configuring/negotiating
the CC type-4?
It looks to me that CC type-1 for ACH without GAL and CC type-4 for ACH with
GAL.

IMO, if we support CC type-4, CC type-1 support is implicitly attained.

IMHO, it should be possible to get the MPLS-TP OAM control packets with or
without GAL from HW to CP by negotiating CC type-1 itself.

Some editorial comments for the draft-nadeau-pwe3-vccv-2-01.txt draft,
"
4.1.1.  MPLS VCCV Control Channel (CC) Type 4

   IANA is requested to augment the registry of "MPLS VCCV Control
   Channel Types" with the new type defined below. As defined in
   RFC5058, this new bitfield is to be assigned by IANA using
"
Replace the RFC5058 as RFC5085.

Thanks,
Venkat.

On Fri, Mar 11, 2011 at 2:21 PM, Alexander Vainshtein <
[email-masked]> wrote:

> Greg, Luca,
>
> As I’ve already stated in my comment on draft-nadeau-pwe3-vccv-2, IMHO it
> makes draft-lm-pwe3-mpls-tp-gal-in-pw completely useless.
>
>
>
> My 2c,
>
>      Sasha
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *Greg Mirsky
> *Sent:* Friday, March 11, 2011 9:14 PM
> *To:* Luca Martini
> *Cc:* [email-masked]; [email-masked]; pwe3; HUANG Feng F;
> [email-masked]
> *Subject:* Re: [mpls] WG LC draft-lm-pwe3-mpls-tp-gal-in-pw-00.txt
>
>
>
> Dear Luca,
> I'll have to miss another opportunity to discuss your proposal in a
> meeting. Please add my comments below to my earlier expressed WG LC
> comments:
>
>    - the draft-lm-pwe3-mpls-tp-gal-in-pw-00 needs to mention such
>    dependency and refer to any existing proposal;
> [email-masked]

-- 
Best Regards,
Venkatesan Mahalingam.

---

From: Thomas Nadeau <[email-masked]>
Date: Fri, 11 Mar 2011 15:58:22 -0500

> CC Type-1 mode of VCCV operation MUST be supported when the control word is present.
> 
> Are we implicitly mandating the CW (ACH) in HW by configuring/negotiating the CC type-4?
> It looks to me that CC type-1 for ACH without GAL and CC type-4 for ACH with GAL.

	The IETF's protocols do not mandate how they are to be implemented per se (i.e.:
in HW or not). The draft addresses the operational concerns of configuration/complexity 
by having 1 mode for each of the major operational scenarios: with or without the CW.

> IMHO, it should be possible to get the MPLS-TP OAM control packets with or without GAL from HW to CP by negotiating CC type-1 itself.

	There is no negotiation; VCCV uses a capability advertisement. But more to the point, 
the proposed operation rule here is simple and straight-forward: if you have configured the CW and advertised 
that as per the rules for use of the CW, then Type 1 MUST be used. If not, use Type 4 (if both sides are capable).  

> Replace the RFC5058 as RFC5085.

	Cool, thanks. We will fix this in the next rev.

	--Tom

> 
> Thanks,
> Venkat.
> 
> On Fri, Mar 11, 2011 at 2:21 PM, Alexander Vainshtein <[email-masked]> wrote:
> Greg, Luca,
> 
> As I’ve already stated in my comment on draft-nadeau-pwe3-vccv-2, IMHO it makes draft-lm-pwe3-mpls-tp-gal-in-pw completely useless.
> 
>  
> My 2c,
> 
>      Sasha
> 
>  
> the draft-lm-pwe3-mpls-tp-gal-in-pw-00 depends on any solution that addresses applicability of GAL in PW VCCV, e.g. solution proposed in draft-nadeau-pwe3-vccv-2-01;
> the draft-lm-pwe3-mpls-tp-gal-in-pw-00 needs to mention such dependency and refer to any existing proposal;
> I believe that the draft-lm-pwe3-mpls-tp-gal-in-pw-00 can be advanced in lock with document that addresses use of GAL in PW VCCV.
> Regards,
> Greg
> 
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3

---

From: Alexander Vainshtein <[email-masked]>
Date: Sat, 12 Mar 2011 06:44:47 +0200

Venkat,

You have asked "Are we implicitly mandating the CW (ACH) in HW by configuring/negotiating the CC type-4?"

IMO the answer is "No".
In VCCV Type 1 the first nibble of the CW is a data path (HW if you wish) exception mechanism forwarding the packets to an OAM entity.

In VCCV Type 4 GAL acts as such an exception mechanism. ACH is actually only needed to decide on the ACH Type. And it would not even be examined if the TTL in the PW label has not expired.

My 2c,
     Sasha

________________________________
From: venkatesan mahalingam [[email-masked]]
Sent: Friday, March 11, 2011 10:12 PM
To: Alexander Vainshtein; Greg Mirsky; Luca Martini; [email-masked]; [email-masked]; pwe3; HUANG Feng F; [email-masked]
Subject: Re: [mpls] WG LC draft-lm-pwe3-mpls-tp-gal-in-pw-00.txt

Hi,

Thanks,
Venkat.

On Fri, Mar 11, 2011 at 2:21 PM, Alexander Vainshtein <[email-masked]<mailto:[email-masked]>> wrote:
Greg, Luca,
As I’ve already stated in my comment on draft-nadeau-pwe3-vccv-2, IMHO it makes draft-lm-pwe3-mpls-tp-gal-in-pw completely useless.

My 2c,
     Sasha

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Greg Mirsky
Sent: Friday, March 11, 2011 9:14 PM
To: Luca Martini
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; pwe3; HUANG Feng F; [email-masked]<mailto:[email-masked]>
Subject: Re: [mpls] WG LC draft-lm-pwe3-mpls-tp-gal-in-pw-00.txt

Dear Luca,

Greg,

Thanks.
Luca

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls

--
Best Regards,
Venkatesan Mahalingam.

---

From: Robert Rennison <[email-masked]>
Date: Tue, 22 Mar 2011 12:22:12 -0400

Luca, Thomas,

A couple of clarification questions.

I'm trying to understand what the combination of the two drafts, -lm-pwe3-mpls-tp-gal-in-pw, and draft-nadeau-pwe3-vccv-2 amounts to.

So, I think I understood the draft-nadeau-pwe3-vccv-2 in that it's saying use VCCV type 1 where possible and if not then use the new type 4, whereby  in type 4 the exception mechanism is triggered by the use of the GAL,  and I appreciated the diagram in section 3 to lock this is, so far so good.

Now I read -pwe3-mpls-tp-gal-in-pw and I'm thinking , Ok these two drafts could work together since this one is trying to lay the "legal framework" i.e fix up the RFCs which mandated that the GAL could not be used with the PW.

Then I get hit with a brick wall in the form of the statements in the last 2 paras of section 3 of tp-gal-in-pw which state.

- Section 4.2<http://tools.ietf.org/html/draft-lm-pwe3-mpls-tp-gal-in-pw-00#section-4.2>. (GAL Applicability and Usage) in [RFC5586<http://tools.ietf.org/html/rfc5586>], the
      original text:

          In MPLS-TP, the GAL MUST be used with packets on a G-ACh on
          LSPs, Concatenated Segments of LSPs, and with Sections, and
          MUST NOT be used with PWs. It MUST always be at the bottom of
          the label stack (i.e., S bit set to 1). However, in other MPLS
          environments, this document places no restrictions on where
          the GAL may appear within the label stack or its use with PWs.

      is replaced by:

          In MPLS-TP, the GAL MUST be used with packets on a G-ACh on
          LSPs, Concatenated Segments of LSPs, and with Sections, and
          MAY be used with PWs. It MUST always be at the bottom of the
          label stack (i.e., S bit set to 1). However, in other MPLS
          environments, this document places no restrictions on where
          the GAL may appear within the label stack.

It's the bit about the GAL MUST be at the bottom of the label stack,  this is clearly inconsistent with what is proposed in the draft-nadeau-pwe3 where one can clearly see the GAL above the PW label and if one has to use  a GAL with a PW this would be the place to put it,

Now I can hear you saying "oh but look at the text below this, where we state .."However, in other MPLS environments , this document places no restrictions on where the GAL may appear within the label stack. This is consistent with draft-nadeau "   In which case I'd retort with ; what are we to do for PWs in   MPLS-TP, since what's in draft-nadeau would not be allowed ?

Clarification /explanation appreciated.

Cheers

Rob Rennison

From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexander Vainshtein
Sent: Friday, March 11, 2011 2:22 PM
To: Greg Mirsky; Luca Martini
Cc: [email-masked]; [email-masked]; pwe3; HUANG Feng F; [email-masked]
Subject: Re: [mpls] WG LC draft-lm-pwe3-mpls-tp-gal-in-pw-00.txt

Greg, Luca,

My 2c,
     Sasha

Dear Luca,

Greg,

Thanks.
Luca