Subject: Re: [mpls-tp] [mpls] poll to adopt draft-nitinb-mpls-tp-on-demand-cv as a working group document

From: Eric Gray <[email-masked]>
Date: Mon, 14 Mar 2011 09:23:15 -0400

Italo,

	Sorry for the _long-time_ in responding...

	It is important to realize that this document specifies
a procedure that is intended to be generally applicable to MPLS.
As such, it is not appropriate to document each specific case in
which this set of protocol extensions might be applicable.

	You do point out a valid hole in the suite of protocol
extensions being developed to support the transport profile of
MPLS.  We will eventually need an applicability RFC that ties
all of the various documents together.

	At the most recent ITU-T SG-15 plenary meeting, it struck
me as very probable that you might be just the person to write
such an RFC...

--
Eric 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of BUSI, ITALO (ITALO)
Sent: Monday, July 05, 2010 6:26 AM
To: Loa Andersson; [email-masked]; [email-masked]; MPLS-TP ad hoc team
Subject: Re: [mpls-tp] [mpls] poll to adopt draft-nitinb-mpls-tp-on-demand-cv as a working group document

The current draft does not clearly articulate how the solution mechanism is satisfying the requirements and behaviors associated with on-demand CV (e.g., support of per-interface MIP model).  It is important that this be documented.

Italo 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Loa Andersson
> Sent: lunedì 21 giugno 2010 14.08
> To: [email-masked]; [email-masked]; MPLS-TP ad hoc team
> Subject: [mpls] poll to adopt 
> draft-nitinb-mpls-tp-on-demand-cv as a working group document
> 
> 
> Working Group,
> 
> this email is to start poll to adopt
> draft-nitinb-mpls-tp-on-demand-cv-00.txt
> as an MPLS working group draft.
> 
> After recent experience, the chairs would like to remind you 
> all what it means to conduct a poll to adopt a draft as a 
> working group draft.
> 
> - Please recall that the IETF does not "vote." Polls of a working
>    group are to gather information to help the chairs make their
>    decisions. Voting is not part of the normal working methods of
>    an IETF working group.
> 
> - The "rough consensus" process used in the working group assumes
>    that people expressing opinions are also participating in the
>    development of standards documents.
> 
> - Subscription to the list specifically to express an opinion is
>    noticed by the chairs who has access to information on the new list
>    members. Such behavior is not part of the normal working methods.
> 
> - The purpose of a poll for adoption is to help the chairs understand
>    the level of support for a document (i.e. who has read it, who
>    believes it is a good starting point for working group work, who
>    will contribute to the work) and whether there are any significant
>    technical issues. Statements of objection must be backed up by
>    proper technical reasons.
> 
> So please respond to this poll indicating whether you support 
> the adoption of this draft or stating your technical issues.
> 
> Please also not that this draft has after a discussion with 
> the working group chairs been renamed, it was earlier know as 
> draft-nitinb-mpls-tp-lsp-ping-extensions-01.
> 
> This poll ends eob July 5.
> 
> 
> Loa and George
> mpls wg co-chairs
> 
> -- 
> 
> 
> Loa Andersson                         email: 
> [email-masked]
> Sr Strategy and Standards Manager            [email-masked]
> Ericsson Inc                          phone: +46 10 717 52 13
>                                               +46 767 72 92 
> 13 _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
> 
_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: Eric Gray <[email-masked]>
Date: Mon, 14 Mar 2011 09:50:58 -0400

Huub,

	Sorry for the delay in responding.

	As noted in my reply to Italo, the document is meant to
apply generally, hence it would be inappropriate to specify how
it would be used for a specific application (such as in the case
of a transport profile of MPLS).

	As I told Italo, you (too) are correct that this needs to
be documented somewhere.  Just not here.

	We have had some iterations of the draft since your comment
was posted.  In fact, there will be a new one later today.

	Perhaps it now fits the new name better than it did...

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Huub van Helvoort
Sent: Monday, July 05, 2010 7:56 AM
To: Loa Andersson
Cc: [email-masked]; MPLS-TP ad hoc team; [email-masked]
Subject: Re: [mpls] [mpls-tp] poll to adopt draft-nitinb-mpls-tp-on-demand-cv as a working group document

No/do not support

The change of the name of this draft gives the impression
that the content of the draft changed as well.
So before it can be adopted the text has to be aligned
with the title: On-demand CV for MPLS-TP.

I see that it is still focused on extending LSP-Ping but
not for use in a transport environment.
It does not indicate where the transport OAM requirements
are met.
It does not indicate how the ACh is used.
What is the meaning of "adjacency" in the context of MPLS-TP?
It does not document how this tool can be used in transport
environment where tools are enabled/disabled static (compared
to the dynamic set-up of LSP-ping.

Regards, Huub.

==============
On 21-06-10 14:07, Loa Andersson wrote:
> After recent experience, the chairs would like to remind you all
> what it means to conduct a poll to adopt a draft as a working group
> draft.
>
> So please respond to this poll indicating whether you support the
> adoption of this draft or stating your technical issues.
>
> Please also not that this draft has after a discussion with the
> working group chairs been renamed, it was earlier know as

-- 
================================================================
                   http://www.van-helvoort.eu/
================================================================
Always remember that you are unique...just like everyone else...
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: Eric Gray <[email-masked]>
Date: Mon, 14 Mar 2011 10:02:53 -0400

Haiyan,

	This is largely a semantics issue.

	The extensions described in this draft are intended to - among
other things - support the requirements of a transport profile of 
MPLS.  Those requirements initially drove the creation of this draft.
It is still the case that these extensions are intended to support a
transport profile of MPLS.

	However, as you note, they also support usage in an environment
that may not be strictly limited to "transport" in the sense that has
been used in referring to a "transport profile."  Specifically, in 
cases where (for example) IP addressing may be used generally in the
services being provided by a service provider who also plane to use
similar/identical technology to support "transport" requirements.

	It appears to be the (rough?) consensus of the MPLS working
group that "LSP-Ping" is the tool of choice for on demand CV.  Ping,
in general, has filled a role as on-demand connectivity verification
in IP-based networks for a very long time, and network operators who
plan to use IP infrastructure to support their own "transport" needs
are generally aware of this tool and the on-going need for it in the
IP network infrastrcture.

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Zhang Haiyan
Sent: Thursday, July 01, 2010 9:54 PM
To: Loa Andersson; [email-masked]; [email-masked]; MPLS-TP ad hoc team
Subject: Re: [mpls] [mpls-tp] poll to adopt draft-nitinb-mpls-tp-on-demand-cv as a working group document

No/ do not support.

Several comments need clarification: 

1) We do not see how the content of the draft satisfies "on-demand-cv" as claimed in the title. We only see "LSP-Ping" and "LSP Traceroute" in the main part of the draft. 
In the introduction part we also see the "on-demand Connectivity Verification, Route Tracing and Adjacency functions". 
Could the authors clarify the "on-demand CV"? 

2) Could the authors clarify the purpose of describing "LSP-Ping with IP encapsulation" and "LSP Traceroute with IP encapsulation"?

The draft seems to be just a regular extension of MPLS LSP ping, not particular for MPLS-TP. Shouldn't it be a draft with the name "mpls-lsp-ping-extensions"?

B.R.
Haiyan

----- Original Message ----- 
From: "Loa Andersson" <[email-masked]>
To: <[email-masked]>; <[email-masked]>; "MPLS-TP ad hoc team" <[email-masked]>
Sent: Monday, June 21, 2010 8:07 PM
Subject: [mpls-tp] poll to adopt draft-nitinb-mpls-tp-on-demand-cv as a working group document

> Loa Andersson                         email: [email-masked]
>                                              +46 767 72 92 13