Subject: RE: CR-LDP Negotiation procedure

From: [email-masked]
Date: Mon, 6 Dec 1999 16:55:37 +0100

What do you mean with the extract from your mail reported below?
I thought that the procedure described in my previous mail was the 
"parameter negotiation" (i.e. the sequence of label request 
messages/label mapping messages exchanged by LSRs). So, please, explane 
me by what kind of message is accomplished the negotiation procedure, 
possibly with an example.
Thanks,
            Riccardo.

-----Original Message-----
From: ewgray [SMTP:[email-masked]]
Sent: Monday, December 06, 1999 4:00 PM
To: Freschi, Riccardo
Cc: ewgray; mpls
Subject: Re: CR-LDP Negotiation procedure

Yes, but this behavior is a local issue at LSR1.
Alternatively, LSR1 could have allowed for parameter
negotiation.

------------------------------------------------------------------------
--------
>                   Name: WINMAIL.DAT
>    WINMAIL.DAT    Type: application/ms-tnef
>               Encoding: base64

-- 
Eric Gray  Email: mailto:[email-masked]
Voice: (978)960-6162 Fax: (978)960-1101
In Person:MV 21-2E33 1600 Osgood St., N. Andover, MA 01845

---

From: Eric Gray <[email-masked]>
Date: Mon, 06 Dec 1999 13:08:39 -0500

> Alternatively, LSR1 could have allowed for parameter

I misread the original question.  Juha answered what
I now believe to have been the original question 
correctly.

As I understand it, the question was - given a set
of negotiable parameters, how is inability of an
LSR along the LSP to handle one of the parameters
dealt with.

I was mislead by the apparent assumption that the
parameter would be passed on unchanged.  In fact,
as Juha pointed out, if a parameter is negotiable
it may be adjusted to a value the LSR can handle.

If the parameter is not negotiable, then a notify
message is returned.

Just saying no is a minimalist negotiation too.

>   --------------------------------------------------------------------------------
>                   Name: WINMAIL.DAT