Subject: RE: CR-LDP Negotiation procedure

From: [email-masked]
Date: Tue, 7 Dec 1999 11:07:03 +0100

Hello Ravi,
I think you misunderstood the question: I'm sorry, it's my fault.
I try to explane better my problem.
In my example P are a problem only for LSR2 (not for LSR3 and LSR4). 
But  LSR1 (I think) is not able to know that LSR3 and LSR4 can support 
P', because it receives a lmm from LSR2 (which received a lmm with P' 
from LSR3 and LSR3 a lmm with P' from LSR4) with parameters P'.
So, can LSR1 know (from the lmm sent by LSR2 to it) that LSR3 and LSR4 
are able to support P? If it was possible, LSR1 could substitute only 
LSR2' (which is choosen by LSR1 because it supposes that LSR2' can 
support P) for LSR2 !

If the answer is negative, what will LSR1 do after receiving the lmm 
from LSR2, if P' aren't enough ?
It will send a label abort request message (or a label withdrow message 
?) to LSR2, so that LSR1 could setup a "better" path ?

I have another question:
how do the LSRs negotiate the parameters ? Exchanging label request 
messages and  label mapping messages ?

Thanks,
            Riccardo.

-----Original Message-----
From: rlambi [SMTP:[email-masked]]
Sent: Monday, December 06, 1999 6:39 PM
To: Freschi, Riccardo; jh
Cc: rlambi; mpls
Subject: Re: CR-LDP Negotiation procedure

Hello Riccardo,

Ravindra M. Lambi
Ficon Technology, Inc.
E-mail: [email-masked]
Web: www.ficon-tech.com

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, December 06, 1999 11:22 AM
Subject: RE: CR-LDP Negotiation procedure

> So LSR2 sends a lrm with P'. Suppose that P aren't a matter for LSR3
> and LSR4, but they receive a request for P'.
> LSR4 replies to the lrm with a lmm containing P' and LSR3 and LSR2 
too.
> It could be suitable if LSR1 could know that P are a problem only for
> LSR2 and reroute the path in this way LSR1-LSR2'-LSR3-LSR4 with LSR2' 
a
> LSR probably able to support P (in LSR1 opinion). Is there a way to do
> this?
>
One way of doing this through configured policy saying that always try
through LSR2 first, if path through LSR2 can not support P, then try 
through
LSR2'. Because path having LSR2 may be least expensive  path then LSR2',
which may be more expensive.

Regards,
Ravi.

> -----Original Message-----
> From: jh [SMTP:[email-masked]]
> Sent: Monday, December 06, 1999 3:53 PM
> To: Freschi, Riccardo
> Cc: jh; mpls
> Subject: CR-LDP Negotiation procedure
>
> [email-masked] writes:
>
>  >   - LSR2 sends a lrm to LSR3 containing the parameters P, although
> LSR2
>  >  can't support x,
>
> no, if an lsr can't support a negotiable parameter value, it replaces 
it
> with a value it can support before forwarding the request.
>
> -- juha
>
>

---

From: Vasanthi Thirumalai <[email-masked]>
Date: Tue, 07 Dec 1999 12:00:40 -0500

Riccardo,
	Please see comments below:

> ?) to LSR2, so that LSR1 could setup a "better" path ?

	LSR1 will send a Label Release Message to LSR2 (which is its downstream LSR) in
this case.
> messages and  label mapping messages ?

	That is correct. The 'Negotiable flag' is used to express the willingness to
negotiate a parameter.

-Vasanthi
>   --------------------------------------------------------------------------------
> 
>                      Name: WINMAIL.DAT
>    WINMAIL.DAT       Type: application/ms-tnef
>                  Encoding: base64

-- 
------------------------------------------------
Vasanthi Thirumalai         Phone: 732-949-3787
Lucent Technologies         Room : 2J-643
101 Crawfords Corner
Holmdel, NJ-07733
------------------------------------------------

---

From: "Ravindra M. Lambi" <[email-masked]>
Date: Tue, 7 Dec 1999 12:53:37 -0500

Hello Ricardo,

Ravindra M. Lambi
Ficon Technology, Inc.     

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, December 07, 1999 5:07 AM
Subject: RE: CR-LDP Negotiation procedure

> I try to explane better my problem.
I am sorry, I misinterpreted the question.
> LSR2' (which is choosen by LSR1 because it supposes that LSR2' can 

No the answer is negative. 
> ?) to LSR2, so that LSR1 could setup a "better" path ?
Yes

Regards,
Ravi.