Subject: Question about interfacing Routing and LDP in MPLS systems?

From: [email-masked]
Date: Thu, 9 Dec 1999 21:32:54 -0500

Hello, everyone:

If a system is supporting routing protocols RIP, OSPF, and BGP all, how to
associate the routing information with the label in MPLS (the interface between
the routing and LDP)?  For BGP, someone suggest using piggyback method. But what
about OSPF? So far, I could not find any document on that. How to converting the
routing information between those routing protocols?

Any suggestions will be appreciated. 

Zhong Hu

Comsat Labs

---

From: Jeremy Lawrence <[email-masked]>
Date: Fri, 10 Dec 1999 16:34:46 +1100

At 21:32 12/09/1999 -0500, [email-masked] wrote:
>associate the routing information with the label in MPLS (the interface between the routing and LDP)?  

In general, the interface between LDP (or another label distribution
protocol) and routing is the routing table (also known as a
"forwarding table" or "forwarding information base"). The routing
protocol builds a routing table. LDP then uses the routing table when
establishing label bindings.

>For BGP, someone suggest using piggyback method.

This is a sort of shortcut. Conceptually, the building of the
routing table is still separate from the assignment of labels.
But in this case, the labels are carried in routing messages
as a matter of convenience. There is still both a routing
protocol and a label distribution protocol, but BGP is acting
as both.

>But what about OSPF?

With OSPF (or RIP or IS-IS, etc.), a separate label distribution
protocol is used.

>How to converting the routing information between those routing protocols?

That's a separate issue to MPLS itself. Some routing protocol
implementations allow routing information to be "readvertized"
from one routing protocol to another, which involves allowing
two or more different routing protocols to access a routing
table in a controlled fashion. LDP doesn't see that, and
doesn't care about it.

Jeremy Lawrence

---

From: "DEREK TSE" <[email-masked]>
Date: Fri, 10 Dec 1999 21:03:54 +0800

Hi, all,

In the case of piggybacking label info on BGP, will the binding of signaling and routing cause any
problem? I just don't understand, because my understanding is the routing plane and signaling plane are
usually clear cut.

Regards,
Derek

---

From: Jeremy Lawrence <[email-masked]>
Date: Mon, 13 Dec 1999 12:25:06 +1100

Derek,

At 21:03 12/10/1999 +0800, DEREK TSE wrote:
>problem?

Signalling and routing are not really bound together in this case.
A routing message is sent, with a label signalling component
which is purely advisory. The sending BGP-speaking router says,
approximately: "Here is a route to these destinations. Also, here
is label, which is the label which I am defining to correspond to
that route."

The receiving BGP-speaking router. Is free, in some circumstances,
to use just the routing information and to ignore the label
information:
- The route may not be the best route to the destination, so
   it is noted, but the label information may be ignored (though
   a good implementation would store the label information in
   case it was needed later).
- The receiving BGP-speaker might not be configured to forward
   labelled packets. In this case, it would, by BGP Capability
   Negotiation, refuse to accept any of the label information
   from the sender. It would just accept and use the routing
   information in the normal way.
There may be other examples.

>I just don't understand, because my understanding is the routing plane and signaling plane are usually clear cut.

The signalling information is being carried with the routing
information purely for convenience. In this particular application,
this works because label signalling is tied to routing in a particular
way: here, a label always corresponds to a route, so it makes sense
to signal the label along with the route.

In other applications of MPLS, the binding of routing and label
signalling does not make sense, and it is not used.

Regards,

Jeremy Lawrence