Subject: CR-LDP Negotiation procedure

From: [email-masked]
Date: Mon, 6 Dec 1999 15:43:14 +0100

Hi,
      my name is Riccardo, I'm an Italian student.
 I have some doubts about the CR-LDP negotiation procedure.
 Look at the network of the example of page 29 in the
 "draft-ietf-mpls-cr-ldp-03.txt" (reported here):

                                   LSR1----LSR2----LSR3----LSR4

 Suppose that LSR1 is trying to setup the CR-LSP LSR1-LSR2-LSR3-LSR4
 with some negotiable parameters, one of which, called x, can't be
 supported by the LSR2, e.g. because x is the bandwith parameter, too
 large for the connection LSR2-LSR3.
 Also suppose that the bandwith x is not a problem for the LSR3-LSR4
 connection.

 I understood that the sequence of steps is the following:

  - LSR1 sends a label request message (lrm) containing the parameters P
 (one of those is x) to LSR2,
  - LSR2 sends a lrm to LSR3 containing the parameters P, although LSR2
 can't support x,
  - LSR3 sends a lrm to LSR4 containing the parameters P,
  - LSR4 sends back a label mapping message (lmm) to LSR3 containing the
 parameters P,
  - LSR3 does the same,
  - LSR2 sends a lmm to LSR1 containing the parameters P' (with a
 parameter x' that is different from x)

 Is it correct?

 Questions:

 1) How can LSR1 know that the bottlenek is the LSR2-LSR3 connection
 while the LSR3-LSR4 one is able to support the parameters requested? (I
 didn't find any field, in the label mapping message, carrying the
 indication about where is the bottlenek)

 2) And if the bottlenek is LSR3-LSR4? What does it happen?
  - LSR3 sends a lmm with parameters P' to LSR2,>  - LSR2 sends a lmm 
also with parameters P' to LSR1, then
  - LSR1 (suppose that P' are right for LSR1) sends another lrm with
 parameters P' to LSR2 (this message follows a message of label abort
 rquest?),
  - LSR2 sends a lmm with parameters P' to LSR3,
  - LSR3 to LSR4
  - LSR4 sends a lmm with parameters P' to LSR3
  - LSR3 to LSR2
  - LSR2 to LSR1 and now it's OK?

---

From: Juha Heinanen <[email-masked]>
Date: Mon, 6 Dec 1999 16:53:16 +0200 (EET)

>   - LSR2 sends a lrm to LSR3 containing the parameters P, although LSR2

no, if an lsr can't support a negotiable parameter value, it replaces it
with a value it can support before forwarding the request.

-- juha

---

From: Eric Gray <[email-masked]>
Date: Mon, 06 Dec 1999 09:59:55 -0500

>  parameter x' that is different from x)

No.  LSR2 is able to determine that it will not
be able to support the requested LSP and it will
send a notify message to LSR1 rather than a Label
Request Message to LSR3.

>  indication about where is the bottlenek)

LSR1 only need to know that LSR2 cannot establish 
the requested LSP.

>  2) And if the bottlenek is LSR3-LSR4? What does it happen?

As the intitiator, LSR1 may:

a) have information about resources it expected to
   be able to use that have now been 'adjusted'
b) elect to send a new request using a different
   explicit route
c) elect to send a differnt label request to an LSR
   other than LSR2

>   - LSR2 to LSR1 and now it's OK?

Yes, but this behavior is a local issue at LSR1.
Alternatively, LSR1 could have allowed for parameter
negotiation.

> 
>   --------------------------------------------------------------------------------
>                   Name: WINMAIL.DAT
>    WINMAIL.DAT    Type: application/ms-tnef
>               Encoding: base64

-- 
Eric Gray		Email: mailto:[email-masked]
Voice: (978)960-6162	Fax: (978)960-1101
In Person:MV 21-2E33	1600 Osgood St., N. Andover, MA 01845