Subject: RE: Clarifications in I-D MPLS support of DiffServ

From: [email-masked]
Date: Tue, 7 Dec 1999 15:00:06 +0100

I am astonished by your answer because I thought a diffserv capable LSRs
with ATM interfaces could not support E-LSPs.
Can you confirm that only L-LSP applies to an ATM DiffServ LSR ?

Thanks.

Marie-Helene Hervault

> Hi,
> 
> In both E-LSP and L-LSP cases the document is referring only to
Diffserv
> capable LSRs with ATM interfaces.
> 
> Regards,
> Shahram Davari
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]
> > Sent: Wednesday, December 01, 1999 4:36 AM
> > Cc: [email-masked]
> > Subject: Clarifications in I-D MPLS support of DiffServ
> > 
> > 
> > 
> > A couple of questions about E-LSP/L-LSP related to ATM LSRs :
> > 
> > 1/Could you clarify the first sentence of the section 7.6 of the I-D
> > <draft-ietf-mpls-diff-ext-02.txt> copied below ?
> > 
> > > 7.6 LSR Implementation With ATM Interfaces
> > >
> > >   For an LSR implementation with ATM interfaces running native ATM
> > >   MPLS, support of L-LSPs over the ATM interfaces is mandatory with
> > >   respect to this specification. A Diff-Serv capable LSR with ATM
> > >   interfaces MUST support L-LSPs over these ATM interfaces in
> > >   compliance with this specification. 
> > 
> > It is logical that a Diffserv capable LSR with ATM 
> > interfaces must be
> > compliant with this specification.
> > 
> > The required compliance of a LSR running native ATM MPLS is more 
> > questionnable. In my understanding, a "LSR running native ATM 
> > MPLS" may 
> > or may not have internal mechanisms more or less close of 
> > Diffserv ones
> > but it is not actually a Diffserv capable equipment.
> > Could you clarify the difference between those two types of ATM-LSR 
> > related to L-LSP support ?
> > 
> > 
> > 2/ The following assertion is made below in the text of the I-D
> > 
> > >   Support of E-LSPs over ATM interfaces running native ATM 
> > MPLS by an
> > >   LSR implementation is not allowed.
> > 
> > I assume that the same applies to a Diff-Serv capable LSR with ATM 
> > 
> > inerfaces since the EXP field is not either in the top label
(VPI/VCI)
> > but further in the payload.
> > Could you confirm ?
> > 
> > Thanks.
> > 
> > Marie-Helene Hervault
> > 
> >

---

From: Eric Gray <[email-masked]>
Date: Tue, 07 Dec 1999 11:58:54 -0500

Marie-Helene Hervault,

	In theory, I can think of no reason why
it is absolutely impossible to support E-LSPs on
ATM interfaces - IF there was a mapping from the
EXP field in the generic LABEL to specific bits
in an ATM VPI/VCI.  No such mapping exists, now,
nor are there immediate prospects for one.

	Also, the fact that something is not im-
possible does not mean that it should be allowed
if doing so makes for additional complexity that
impacts everyone else.

	Otherwise I agree that the statement 
Shahram made with respect to making it clearer 
that DiffServ capable LSRs (as opposed to all 
LSRs) must be able to support L-LSRs.  The text
currently contains two seemingly contradictory
statements and the first one should probably be
eliminated.  

-- 
Eric Gray		Email: mailto:[email-masked]
Voice: (978)960-6162	Fax: (978)960-1101
In Person:MV 21-2E33	1600 Osgood St., N. Andover, MA 01845