Subject: More questions about LDP and routing

From: [email-masked]
Date: Fri, 10 Dec 1999 10:39:52 -0500

Hello, everyone:

Thank you for your answer. I still have two more questions:

(1) Are there any protocols or drafts dealing with 
(i) translating the routing table information to the labels in specific routing
protocols such as OSPF or RIP?
(ii)advertising routing information from one routing protocol (such as OSPF) to
another routing protocol (such as RIP). 

(2) According to some books, different routing protocols use different LDPs.
Does that mean that BGP, OSPF uses different LDPs?  Isn't it better to use a
uniform LSP to deal with different routing protocols?

Thanks again.

Zhong

At 21:32 12/09/1999 -0500, [email-masked] wrote:
>Hello, everyone:
>
>If a system is supporting routing protocols RIP, OSPF, and BGP all, how to
>associate the routing information with the label in MPLS (the interface between
the routing and LDP)?  

In general, the interface between LDP (or another label distribution
protocol) and routing is the routing table (also known as a
"forwarding table" or "forwarding information base"). The routing
protocol builds a routing table. LDP then uses the routing table when
establishing label bindings.

>For BGP, someone suggest using piggyback method.

This is a sort of shortcut. Conceptually, the building of the
routing table is still separate from the assignment of labels.
But in this case, the labels are carried in routing messages
as a matter of convenience. There is still both a routing
protocol and a label distribution protocol, but BGP is acting
as both.

>But what about OSPF?

With OSPF (or RIP or IS-IS, etc.), a separate label distribution
protocol is used.

>How to converting the routing information between those routing protocols?

That's a separate issue to MPLS itself. Some routing protocol
implementations allow routing information to be "readvertized"
from one routing protocol to another, which involves allowing
two or more different routing protocols to access a routing
table in a controlled fashion. LDP doesn't see that, and
doesn't care about it.

Jeremy Lawrence

---

From: Jeremy Lawrence <[email-masked]>
Date: Mon, 13 Dec 1999 12:35:52 +1100

>another routing protocol (such as RIP). 

Not as far as I know. There is documentation on this from specific
vendors.

>uniform LSP to deal with different routing protocols?

For exterior gateway routing, there is only one standard protocol (BGP).
It is convenient to carry the corresponding label information piggybacked
on BGP messages.

For interior gateway routing, there are three standards (OSPF, IS-IS &
RIP), as well as at least two others in common use. Here, it makes
more sense to use a common label distribution protocol.

Regards,

Jeremy Lawrence