Subject: Inorder Delivery of Packets

From: "Navin kumar Agrawal" <[email-masked]>
Date: Mon, 06 Dec 1999 11:42:21 +0530

Hi All,

Got one doubt, Is it possible that labeled MPLS packets may reach out 
of sequence at the reception end?

Regards,
Navin

---

From: Jeremy Lawrence <[email-masked]>
Date: Mon, 06 Dec 1999 18:04:49 +1100

>of sequence at the reception end?

Yes. MPLS is little different to other IP forwarding technologies in
this respect. In other words, packet mis-ordering may occur, but it
would typically be an infrequent occurrence.

Hope this helps,

Jeremy Lawrence

---

From: "Thomas Wolfram" <[email-masked]>
Date: Mon, 6 Dec 1999 13:41:35 +0100

> would typically be an infrequent occurrence.

Under what circumstances packet mis-ordering could occur?
Routing/LSP changes?
If so why is this different to other IP forwarding technologies?
Thanks

---

From: Eric Gray <[email-masked]>
Date: Mon, 06 Dec 1999 09:51:17 -0500

Thomas,

	There are circumstances in which assuring
in-order delivery is possible - precisely because
(once LSP setup is complete) packets are delivered
indepedent of 'IP forwarding technologies'.

	An example is when a strict explicit route
is used to establish an LSP.  Route pinning has a
similar effect.  Under these circumstances, packets
should only follow one path.
	
	There was a proposal to allow Optimized
Multipathing (OMP) within an LSP.  If not done right,
this could result in sending packets out of order in
the same LSP - simply because some packets would take
a different physical path than others.

	Hence it is possible to get out of order 
delivery even when the lack of path changes would
normally permit some degree of assurance.

-- 
Eric Gray		Email: mailto:[email-masked]
Voice: (978)960-6162	Fax: (978)960-1101
In Person:MV 21-2E33	1600 Osgood St., N. Andover, MA 01845

---

From: Jeremy Lawrence <[email-masked]>
Date: Tue, 07 Dec 1999 11:14:14 +1100

>should only follow one path.

Agreed, that should assure in-order delivery on that LSP.

Some comments on the broader context, though:
- Should the LSP fail and forwarding then default to another
   path, e.g. a hop-by-hop routed LSP, then in-order delivery
   would not be guaranteed.
- If the LSP were in a specific sub-network of a wider network,
   then in-order delivery would not necessarily be guaranteed
   in the wider network even when it could be guaranteed in
   the subnetwork

In general, MPLS does not remove the requirement for the
higher-level protocols to be tolerant of some mis-ordering.

Regards,

Jeremy

---

From: Eric Gray <[email-masked]>
Date: Tue, 07 Dec 1999 12:16:20 -0500

Jeremy,

	Many of the applications I foresee that may
depend on in-order delivery would not be capable of
defaulting to another path, in the general sense.  

	This does not mean that we could not build
redundancy into an implementation, just that it's
not there now.  For some of the applications, this
is not an issue because redundancy is provided in
other ways (ways that continue to preserve ordered
delivery for example).

	Also, I imagine explicitly routed LSPs being
setup from - for example - some type of translation
device to another exactly like it.  In this case, 
concerns about non-MPLS portions of the service are 
not relevant.

Voice: (978)960-6162