Subject: RE: MPLS topology questions

From: Shahram Davari <[email-masked]>
Date: Tue, 7 Dec 1999 17:17:23 -0800

Hi,

Below are some answers:

-Shahram

> -----Original Message-----
> From: Pyda Srisuresh [mailto:[email-masked]]
> Sent: Tuesday, December 07, 1999 4:33 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: MPLS topology questions
> 
> 
> 
> Folks,
> 
> I have a few rudimentary questions on MPLS. Would appreciate any 
> responses from you knowledged folks out there. Thanks.
> 
> 
>     1. How wide is the MPLS network deployment? Are the MPLS networks 
>        currently in deployment being used predominantly for VPNs (or) 
>        for some other purpose?

As far as I know MPLS is currently mostly used for Traffic Engineering.

> 
>     2. I believe, MPLS nodes operate only on high speed WAN 
> inter-links.
>        (OC-3, OC-12, OC-48 etc.). Is this accurate (or) are 
> there LAN and
>        other low-speed links as well supported?

Yes. MPLS is speed and media independent, so you can use it almost anywhere.

> 
>     3. Does every node in an MPLS network have to be a router running 
>        MPLS protocol (on top of some IGP)? If so, is there no 
> room for 
>        end-hosts? For example, does an SNMP application node used to 
>        monitor the network also have to be attached on an OC-x link 
>        and be talking MPLS label switching protocol with other nodes 
>        in the network?
> 

No, if some routers in the network don't support MPLS, they won't be
participating in MPLS path establishment. Also it is a network designer's
choice to extend the MPLS all the way to the host or just use it in the core
of the network. Besides you can have non-MPLS traffic also in an MPLS
network.

> Thanks.
> 
> regards,
> suresh
> 
> __________________________________________________
> Do You Yahoo!?
> Thousands of Stores.  Millions of Products.  All in one place.
> Yahoo! Shopping: http://shopping.yahoo.com
>

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 08 Dec 1999 16:32:20 -0800

Shahram,

> As far as I know MPLS is currently mostly used for Traffic Engineering.

That might in fact be the case in US, but anywhere else for example Europe or
Asia the primary mpls deployments are for the purpose of mpls-vpns and
hierarchical routing applications.

R.

-- 

_____________________________________________________________________

     |          |         Robert Raszuk, CCIE #3690  ICQ #12710752
    :|:        :|:        IOS-Engineering, MPLS Development Team
   :|||:      :|||:       170 W. Tasman Dr. F2, San Jose, CA 95134
.:|||||||:..:|||||||:.    Phone: 408-525-7588     Pager: 800-365-4578
C I S C O S Y S T E M S   Email: [email-masked]   Fax: 408-576-5240
                          URL:   http://wwwin-mpls.cisco.com/
_____________________________________________________________________

---

From: Joseph Wilson Neil <[email-masked]>
Date: Fri, 10 Dec 1999 08:40:02 -0800

I have to agree with Robert.  Moreover I don't even think it is true about the US, I see more IP-VPN or VOIP drivers than TE drivers, at least in the SP space.  
joe

>hierarchical routing applications.

Joe Wilson NEIL
Technical Marketing Manager 
MSSBU
Cisco Systems
CA 95134  USA

DID 		408 525 2478
Home Office 	408 357 0203
mobile	408 218 7467
page 		1800 365 4578

[email-masked]