Subject: Clarifications in I-D MPLS support of DiffServ

From: [email-masked]
Date: Wed, 1 Dec 1999 13:36:18 +0100

A couple of questions about E-LSP/L-LSP related to ATM LSRs :

1/Could you clarify the first sentence of the section 7.6 of the I-D
<draft-ietf-mpls-diff-ext-02.txt> copied below ?

> 7.6 LSR Implementation With ATM Interfaces
>
>   For an LSR implementation with ATM interfaces running native ATM
>   MPLS, support of L-LSPs over the ATM interfaces is mandatory with
>   respect to this specification. A Diff-Serv capable LSR with ATM
>   interfaces MUST support L-LSPs over these ATM interfaces in
>   compliance with this specification. 

It is logical that a Diffserv capable LSR with ATM 
interfaces must be
compliant with this specification.

The required compliance of a LSR running native ATM MPLS is more 
questionnable. In my understanding, a "LSR running native ATM MPLS" may 
or may not have internal mechanisms more or less close of Diffserv ones
but it is not actually a Diffserv capable equipment.
Could you clarify the difference between those two types of ATM-LSR 
related to L-LSP support ?

2/ The following assertion is made below in the text of the I-D

>   Support of E-LSPs over ATM interfaces running native ATM MPLS by an
>   LSR implementation is not allowed.

I assume that the same applies to a Diff-Serv capable LSR with ATM 

inerfaces since the EXP field is not either in the top label (VPI/VCI)
but further in the payload.
Could you confirm ?

Thanks.

Marie-Helene Hervault

---

From: Shahram Davari <[email-masked]>
Date: Mon, 6 Dec 1999 09:41:56 -0800

Hi,

In both E-LSP and L-LSP cases the document is referring only to Diffserv
capable LSRs with ATM interfaces.

Regards,
Shahram Davari

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Wednesday, December 01, 1999 4:36 AM
> Cc: [email-masked]
> Subject: Clarifications in I-D MPLS support of DiffServ
> 
> 
>

---

From: Shahram Davari <[email-masked]>
Date: Tue, 7 Dec 1999 09:56:19 -0800

Hi Marie,

Let me re-phrase my answer. This I-D is not concerned about requirements of
non-Diffserv capable ATM LSRs. So my answer to your question is:

A Diffserv capable ATM LSR must support L-LSP and is not allowed to support
E-LSP (although theoretically is possible). I think we need to remove the
first sentence of the first paragraph asked originally to clarify this.

Regards,
Shahram

> Sent: Tuesday, December 07, 1999 6:00 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: Clarifications in I-D MPLS support of DiffServ
> 
> 
> 
> I am astonished by your answer because I thought a diffserv 
> capable LSRs
> with ATM interfaces could not support E-LSPs.
> Can you confirm that only L-LSP applies to an ATM DiffServ LSR ?
> 
> Thanks.
> 
> Marie-Helene Hervault
> 
> > Hi,
> >