Subject: MPLS implementations??

From: Panos Trimintzios <[email-masked]>
Date: Sat, 11 Dec 1999 23:37:41 +0000

Hello everybody,

forgive me if somebody ask the same thing before,
but I am new  at this list.
Does anybody know if there are any implementations
of MPLS either in simulators (ns2, ...) or in
PC-based routers (Linux, FreeBSD)??
If yes can you send me some info (maybe URLs)?
If no, what would be the expected complexity to
implement it?
Thanks in advance for any help.

best regards

Panos Trimintzios
Centre for Communication
Systems Research
University of Surrey
U.K.

---

From: Senthilkumar Rajasekharan <[email-masked]>
Date: Sun, 12 Dec 1999 00:26:27 -0500 (EST)

You can try 

ftp://nero.doit.wisc.edu/pub/mpls/

which is a Linux implementation.

There are no publicly available implementations for NS to the best of my
know-how.

HTH,
-Senthil

---

From: Nikunj Vaidya <[email-masked]>
Date: Mon, 13 Dec 1999 14:22:43 +0530

> of MPLS either in simulators (ns2, ...) or in

Hello Panos,
 I am working on a basic implementation of MPLS on NS2.
 This is part of my MTech Project at the Indian Institute of Technology,
 Bombay (India). 
 This work is not yet made public, but i intend to do so when i finish.

regards,
-- 
nik.. .
-------------
Nikunj Vaidya ([email-masked])
Computer Science & Engineering Dept.
Indian Institute of Technology,  Bombay.