Subject: Question about where to calculate the next hop

From: [email-masked]
Date: Fri, 17 Dec 1999 17:14:15 -0500

If the MPLS uses the conventional routing and the next hop address is calculated
according to the routing table, the destination address, for example, IP
destination address,  should be passed to the next hop so that next next hop
address can be calculated, when LDP "label request" message is sent. However, in
the "label request" message, no such a field involves the destination address. 

I might miss something when I read the LDP draft.  If anyone can point out how
the next hop adress is calculated, I would appreciate it. Thank you.

Zhong Hu
Comsat Labs

---

From: "Srinivasan.E.S." <[email-masked]>
Date: Fri, 17 Dec 1999 17:32:14 -0500

Zhong,

    The next hop calculation is done based on the FEC, which is carried in all the
label management messages of the LDP.

--Srinivasan.