Subject: Label Intersection

From: T M Kishore <[email-masked]>
Date: Tue, 7 Dec 1999 17:20:46 +0530

Hi,
     I have one doubt regarding calculation of Intersection of  ATM label range components   .  
    Draft ldp-06 says  as follows :
        " A receiving LSR MUST calculate the intersection between the
         received range and its own supported label range.  The
         intersection is the range in which the LSR may allocate and accept labels. " 
My doubt is how to calculate Intersection of ATM Label range.
For example,
       LSR1 has following label range :
            Min VPI Max VPI      Min VCI Max VCI 
              20   - 100          35    - 140
              150  - 250          160   - 200
              250  - 350          400   - 500 

       LSR 2 has following Label Range  : 

            Min VPI Max VPI      Min VCI Max VCI 
              30   - 120          50    - 160
              175  - 220          130   - 250
              230  - 450          475   - 525 

LSR1 is received  LSR2 label range. 
LSR1 will found Intersection of Label range as follows  :

            Min VPI Max VPI      Min VCI Max VCI 
              30   - 100          50    - 140
              175  - 220          160   - 200
              230  - 350          475   - 500 
         Is the Intersection of label range like above  ?  

Regards,
Kishore

T M Kishore,
Senior Software Engineer,
HDF, Future Software Pvt Ltd,
480 - 481, Anna Salai, Nandanam,
Chennai - 600 035
India.
Phone : +91-44-4330550 Ext.412

---

From: Eric Gray <[email-masked]>
Date: Tue, 07 Dec 1999 11:14:42 -0500

Kishore,

	Certainly.  When an ATM LSR indicates
that a range of VPI and VCI values are okay,
all other VPI/VCI values are not okay.

	So the intersection function must be
applied to both VPI and VCI seperately - just
as you have done.

-- 
Eric Gray		Email: mailto:[email-masked]
Voice: (978)960-6162	Fax: (978)960-1101
In Person:MV 21-2E33	1600 Osgood St., N. Andover, MA 01845