Subject: RE: About mpls forwarding

From: Shahram Davari <[email-masked]>
Date: Thu, 16 Dec 1999 09:27:13 -0800

Hi,

From your scenario it looks like the LSPs are already built and now you want
to send RSVP messages. Usually you use the RSVP messages to build the LSP
(label distribution and request) and reserve resources for those LSPs at the
same time. The RSVP messages should use IP hop-by hop routing, rather than
LSPs. For MPLS over ATM there is a default VPI=0, VCI=32 for non-MPLS
packets, which you may be used for RSVP messages.

Regards,
Shahram

> -----Original Message-----
> From: Digendra [mailto:[email-masked]]
> Sent: Thursday, December 16, 1999 12:05 AM
> To: [email-masked]
> Subject: Re: About mpls forwarding
> 
> 
> Hello All,
> 
> I have following issue while implementing RSVP in MPLS over 
> ATM environment on WinNT
> OS.
> Please let me know if somebody came across similar kind of 
> issue or have any
> resolution.
> 
> RSVP is a hop by hop protocol.
> If RSVP is in non-MPLS environment, it can use IPOA for hop 
> by hop forwarding
> till the destination.
> 
> In MPLS over ATM environment, MPLS mechanism should find the 
> next hop for the
> destination and then choose the label (vpi/vci) corresponding 
> to the next hop to
> forward with that label (on that vpi/vci). If we choose the 
> label based on its
> destination address then the RSVP packet will be label 
> switched till the destination
> and hop by hop processing will not be done.
> If we are using WinNT, then the forwarding engine at LER has 
> to be implemented in
> the ATM Card Driver. The routing table is not accessible from 
> the Driver on WinNT.
> So the next hop info for the destination will not be available.
> 
> What should we do to forward the RSVP messages in MPLS 
> environment for its hop by
> hop processing, in this scenario?
> 
> 
> 
> Thanks and Regards,
> Digendra
> 
> 
>

---

From: "Mary Petrosky" <[email-masked]>
Date: Thu, 16 Dec 1999 11:18:06 -0800

Hi:

Can anyone point me to the relevant drafts that deal with QoS in an RSVP-TE
environment? I've been looking at draft-swallow-mpls-rsvp-trafeng-00.txt and
draft-ietf-mpls-diff-ext-02.txt but need to know if there are others I
should be looking at.

Thanks,

Mary P.