Subject: RE: Ethernet Label Assignment Question

From: Shahram Davari <[email-masked]>
Date: Mon, 6 Dec 1999 15:04:52 -0800

Hi,

I forgot to mention that this is required for multicast only.

Regards,
Shahram

> -----Original Message-----
> From: Bora Akyol [mailto:[email-masked]]
> Sent: Monday, December 06, 1999 12:59 PM
> To: [email-masked]
> Subject: Ethernet Label Assignment Question
> 
> 
> One quick question about label assignment on Ethernets.
> 
> Let us assume that there are three routers on an Ethernet, A, B, C.
> 
> Is there any requirement that A, B, C coordinate the labels that they
> assign on this Ethernet segment. Specifically, should A, B coordinate
> all labels they assigned to packets that come from C, and B,C 
> to A, etc.
> 
> Thanks
> 
> Bora
> 
>

---

From: Shahram Davari <[email-masked]>
Date: Mon, 6 Dec 1999 15:02:03 -0800

Hi,

Since the media is shared, I think the label space must be partitioned
between Ethernet LSRs, either by configuration or coordination (signaling).
But you don't need to do this partitioning per source-destination rather
only per destination. So it shouldn't matter where the packet is coming
from.

-Shahram

> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, December 06, 1999 1:09 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Ethernet Label Assignment Question
> 
> 
> > 
> > all labels they assigned to packets that come from C, and 
> B,C to A, etc.
> 
> There's no need for any such coordination for unicast traffic.
> Labeled packets are sent to a unicast MAC address corresponding 
> to the router that assigned the label.
> 
> For multicast, there would need to be some coordination, but
> the problem is not specific to Ethernet media.
> 
> -Anoop
>