Subject: RE: what's the status of draft-ietf-mpls-rsvp-lsp-fastreroute-00. txt

From: Shahram Davari <[email-masked]>
Date: Thu, 10 Oct 2002 15:07:43 -0700

Ping,

> As for the path-specific method, we cannot take it out for a simple 
> reason, that is, it is how Juniper had implemented and 
> deployed.

Although I have tried this a couple of times, but let me do it again:

IETF is a standard organization. It is not a place to rubber stamp
individual companies implementations, but rather a place to figure out
the best solutions for the industry.

There is always a risk of implementing a technology before it is standardized.
If we go by your logic then every implementation in the field must be standardized !

Does that make sense?

-Shahram

---

From: [email-masked]
Date: Fri, 11 Oct 2002 10:44:49 +0100

Brijesh Kumar11 wrote October 2002 07:30
> ----- Original Message -----
> From: "Pan, Ping" <[email-masked]>
> To: "'Shahram Davari'" <[email-masked]>
> 
> > > -----Original Message-----
> > > From: Shahram Davari [mailto:[email-masked]]
> > >
> > If customers are buying and deploying, YES!
> 
> Ping,
> 
> I think it is an emotional response not a logical one.
> 
> It is somewhat out of the context, but if IEEE 802.11 WLAN 
> standardization
> group was to go by this logic, they would have ended blessing over 30
> different proprietary standards developed by various 
> companies over the last
> decade for wireless LANs. Shahram does have a very valid point here.
> 
> cheers,
> 
> --brijesh
NH=> Absolutely right Brijesh.  The consequences of what Ping is suggesting
(while I can understand the simplistic logic here) is quite scary.  It means
the role of all stds bodies (sic) is now a simply a retrospective
rubber-stamping job for the dominant mode based on 'what wins'....so what is
the point of submitting any IDs for new ideas?....indeed the stds bodies
might as well cease to exist.  This model may be OK for some
industries/products where interworking is not required and/or where product
life-cycles are short, but it does not fit what we need in our industry.
Further, I don't want to see innovation stifled by the dominant market
players.  There simply has to be up-front thinking/debate/agreement on
solutions well in advance of large-scale deployment....else chaos.....maybe
this (at least partially) explains the mess we see around us today?

regards, Neil

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 11 Oct 2002 09:10:29 -0400

>If we go by your logic then every implementation in the field must be 

         Sharam,

         At the risk of repeating myself and others on the topic, remember the
IETF mantra: working code and rough consensus.   This is to a large part
why the Internet works today and is still not a research project.

         --Tom

Success is relative; the more success, the more relatives. -Anonymous

---

From: Shahram Davari <[email-masked]>
Date: Fri, 11 Oct 2002 10:17:41 -0700

Alia,

I don't think it is possible (or even a good idea) to incorporate a
method that has known problems in a standard RFC. However, it can
be put in another informational or experimental RFC.

-Shahram

> From: Alia Atlas [mailto:[email-masked]]
> Sent: Friday, October 11, 2002 10:38 AM
> To: Shahram Davari
> Cc: 'Thomas D. Nadeau'; [email-masked]
> Subject: RE: what's the status of
> draft-ietf-mpls-rsvp-lsp-fastreroute-00. txt
> 
> 
> What about making the method an informational part of the 
> draft, with the 
> sender-template-specific method a SHOULD?  In that way, the 
> information 
> about what was been done in the past will be preserved and 
> inter-operable 
> implementations can be made, but only as long as the 
> interoperability with 
> the path-specific method matters to someone.
> 
> Alia
> 
> At 07:09 AM 10/11/2002 -0700, Shahram Davari wrote:
> >Unfortunately I did not see any consensus? and in fact I saw many
> >objections. Therefore since no consensus exits for 
> path-specific method,
> >it has to be taken out of the draft.
> >
> >-Shahram
> >
> > > From: Thomas D. Nadeau [mailto:[email-masked]]
> > > Sent: Friday, October 11, 2002 9:10 AM
> > > To: Shahram Davari
> > > Cc: [email-masked]
> > > Subject: RE: what's the status of
> > > draft-ietf-mpls-rsvp-lsp-fastreroute-00. txt
> > >
> > >
> > >
> > > >If we go by your logic then every implementation in the
> > > field must be
> > > >standardized !
> > > >
> > > >Does that make sense?
> > >
> > >          Sharam,
> > >