Subject: RE: DiffServ MPLS over Ethernet (L-LSP vs E-LSP)

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 21 Oct 2002 19:09:37 +0200

Curtis and all,
Can you provide any suggestions/pointers as to how DiffServ and 
802.1q markings should be mapped? 
Because, IMHO, just having 802.1q is not enough, you should decide
how to use it.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: Curtis Villamizar [mailto:[email-masked]]
> Sent: Monday, October 21, 2002 6:52 PM
> To: Shahram Davari
> Cc: 'Vishal M'; [email-masked]
> Subject: Re: DiffServ MPLS over Ethernet (L-LSP vs E-LSP) 
> 
> 
> 
> In message 
> <[email-masked]
> >, Shahram Davari writes:
> > Diffserv is not supported for non-802.1q networks.
> > 
> > -Shahram
> 
> 
> Shahram,
> 
> Diffserv works perfectly fine on non-802.1q point to point links
> (which is quite common in ISP POPs).  It also happens to work if you
> are using GbE or 10GbE in a aggregation or access application where
> the circuits feeding in are lower speed.  This only works because the
> sum of all feeds is significantly less than the GbE/10GbE bandwidth.
> 
> This is just a minor clarification and generally your statement
> "Diffserv is not supported for non-802.1q networks" is true.  Point to
> point ethernet links and constrained feed bandwidth in ISP aggregation
> or access POPs can be considered special cases.
> 
> The point is that some ISPs are using GbE/10GbE with diffserv and
> without 802.1q, though admitedly in special situations.
> 
> Curtis
> 
> 
> > > -----Original Message-----
> > > From: Vishal M [mailto:[email-masked]]
> > > Sent: Friday, October 18, 2002 10:03 PM
> > > To: [email-masked]
> > > Subject: DiffServ MPLS over Ethernet (L-LSP vs E-LSP)
> > > 
> > > 
> > > 
> > > Hi,
> > > 
> > > If someone wants to use MPLS over ethernet and support
> > > DiffServ extensions for MPLS (i.e MPLS DS TE), can one
> > > still choose between using E-LSP or L-LSPs ? 
> > > 
> > > The reason for the doubt is:
> > > The Ethernet header (like ATM) doesn't have any QoS
> > > information field (unless 802.1q is supported). So
> > > does that imply that E-LSP can't be used when ethernet
> > > is the underlying media (and 802.1q is not supported).
> > > 
> > > Is L-LSP the only choice then?
> > > 
> > > Thanks for your inputs,
> > > 
> > > Regards,
> > > Vishal.
> > > 
> > > 
> > > __________________________________________________
> > > Do you Yahoo!?
> > > Y! Web Hosting - Let the expert host your web site
> > > http://webhosting.yahoo.com/
>

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 21 Oct 2002 13:37:10 -0400

In message <AF5018AC03D1D411ABB70002A509132678E63C@TLV1>, Sasha Vainshtein writ
> Because, IMHO, just having 802.1q is not enough, you should decide

I'm not a big fan of 802.1q.

Mapping EXP into 802.1q signaling is straightforward.  This mapping is
sufficient for unsignaled E-LSP.

The mapping of 802.1q priorities to packet treatment is not
straightforward.  I'd argue that what most switches are capable of
doing with 802.1q priorities does not support diffserv, particularly
AF, L-LSPs, or signaled E-LSPs.  For AF service, the EXP bits must be
modified even for unsignaled E-LSPs so any switch relying solely on
802.1q signaling is inherently broken wrt AF service.

>                                    Sasha Vainshtein

I haven't kept up with what ethernet switches are doing in this
regard.  Shahram may be better able to answer this.

Curtis