Subject: RE: DiffServ MPLS over Ethernet (L-LSP vs E-LSP)

From: Shahram Davari <[email-masked]>
Date: Mon, 21 Oct 2002 08:27:35 -0700

Eric,

There are 2 types of MPLS over Ethernet:

1) The LSRs are routers but happen to have Ethernet interfaces,
in that case what you said is correct, we don't need the 802.1q 
since the MPLS label carries all the Diffserv Info.

2) The LSRs are Ethernet switches loaded with MPLS control-plane,
(like ATM-LSRs). In that case the Ethernet switches need to have
the capability for Diffserv queuing (aka 802.1q).

-Shahram

> -----Original Message-----
> From: Gray, Eric [mailto:[email-masked]]
> Sent: Monday, October 21, 2002 11:20 AM
> To: Shahram Davari; [email-masked]
> Subject: RE: DiffServ MPLS over Ethernet (L-LSP vs E-LSP)
> 
> 
> Shahram,
> 
> 	I am not sure why you say this.  Certainly we
> can support Differentiated IP services, over MPLS, 
> without the need to rely on Layer 2 priority or VLAN 
> capability.
> 
> Eric W. Gray
> Systems Architect
> Celox Networks, Inc.
> [email-masked]
> 508 305 7214
> 
> 
> > -----Original Message-----
> > From: Shahram Davari [mailto:[email-masked]]
> > Sent: Monday, October 21, 2002 10:46 AM
> > To: 'Vishal M'; [email-masked]
> > Subject: RE: DiffServ MPLS over Ethernet (L-LSP vs E-LSP)
> > 
> > Diffserv is not supported for non-802.1q networks.
> > 
> > -Shahram
> > 
> > > -----Original Message-----
> > > From: Vishal M [mailto:[email-masked]]
> > > Sent: Friday, October 18, 2002 10:03 PM
> > > To: [email-masked]
> > > Subject: DiffServ MPLS over Ethernet (L-LSP vs E-LSP)
> > >
> > >
> > >
> > > Hi,
> > >
> > > If someone wants to use MPLS over ethernet and support
> > > DiffServ extensions for MPLS (i.e MPLS DS TE), can one
> > > still choose between using E-LSP or L-LSPs ?
> > >
> > > The reason for the doubt is:
> > > The Ethernet header (like ATM) doesn't have any QoS
> > > information field (unless 802.1q is supported). So
> > > does that imply that E-LSP can't be used when ethernet
> > > is the underlying media (and 802.1q is not supported).
> > >
> > > Is L-LSP the only choice then?
> > >
> > > Thanks for your inputs,
> > >
> > > Regards,
> > > Vishal.
> > >
> > >
> > > __________________________________________________
> > > Do you Yahoo!?
> > > Y! Web Hosting - Let the expert host your web site
> > > http://webhosting.yahoo.com/
> > >
>

---

From: Sanjay Nayak <[email-masked]>
Date: Tue, 22 Oct 2002 15:45:45 -0700

Hi, 
Any draft/Rfc  which  talks about diff-serv over  Ethernet.
Thanks 
-sanjay 
-----Original Message-----
From: mark seery [mailto:[email-masked]]
Sent: Tuesday, October 22, 2002 5:48 AM
To: Francois Le Faucheur (flefauch)
Cc: Vishal M; [email-masked]
Subject: Re: DiffServ MPLS over Ethernet (L-LSP vs E-LSP) 

Thanks Francois,

>> [snip] PS:  A few clarifications, addressing some comments in the thread:
- the Shim header is absolutely always used on Ethernet <<

So to answer the original question, if a shim is always used, then both
E-LSP and L-LSP can be supported. In a non-shim scenario, E-LSP could only
be supported if the equivalent (shim header) bits were available in
existing/other (layer2?) headers.

-mark

-------------------------------------------
Introducing NetZero Long Distance
Unlimited Long Distance only $29.95/ month!
Sign Up Today! www.netzerolongdistance.com