Subject: RE: DiffServ MPLS over Ethernet (L-LSP vs E-LSP)

From: "Gray, Eric" <[email-masked]>
Date: Mon, 21 Oct 2002 11:20:28 -0400

Shahram,

	I am not sure why you say this.  Certainly we
can support Differentiated IP services, over MPLS, 
without the need to rely on Layer 2 priority or VLAN 
capability.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

> -----Original Message-----
> From: Shahram Davari [mailto:[email-masked]]
> Sent: Monday, October 21, 2002 10:46 AM
> To: 'Vishal M'; [email-masked]
> Subject: RE: DiffServ MPLS over Ethernet (L-LSP vs E-LSP)
> 
> Diffserv is not supported for non-802.1q networks.
> 
> -Shahram
> 
> > -----Original Message-----
> > From: Vishal M [mailto:[email-masked]]
> > Sent: Friday, October 18, 2002 10:03 PM
> > To: [email-masked]
> > Subject: DiffServ MPLS over Ethernet (L-LSP vs E-LSP)
> >
> >
> >
> > Hi,
> >
> > If someone wants to use MPLS over ethernet and support
> > DiffServ extensions for MPLS (i.e MPLS DS TE), can one
> > still choose between using E-LSP or L-LSPs ?
> >
> > The reason for the doubt is:
> > The Ethernet header (like ATM) doesn't have any QoS
> > information field (unless 802.1q is supported). So
> > does that imply that E-LSP can't be used when ethernet
> > is the underlying media (and 802.1q is not supported).
> >
> > Is L-LSP the only choice then?
> >
> > Thanks for your inputs,
> >
> > Regards,
> > Vishal.
> >
> >
> > __________________________________________________
> > Do you Yahoo!?
> > Y! Web Hosting - Let the expert host your web site
> > http://webhosting.yahoo.com/
> >

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 21 Oct 2002 12:56:13 -0400

In message <[email-masked]
> without the need to rely on Layer 2 priority or VLAN 

It works fine until you put an ethernet switch in place and try to put
more than 1 Gb over a 1 GbE.  This is true for any situation where
more than one ingress going through the switch to one egreess.

If there are no ethernet switches (that being layer2 devices, don't do
MPLS) then you don't need Layer 2 priority.  That would be true for
point to point ethernets between LSR.

Curtis

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 21 Oct 2002 23:07:34 -0400

Curtis,

>more than one ingress going through the switch to one egreess.

Even this case works fine if you have LSRs that can do per-LSP (or at the 
very least per-DSCP) policing, queuing, and shaping into the GE.  I agree 
that in general, Ethernet switches don't have the necessary QoS mechanisms.

Cheers,
Andy