Subject: RE: Does a labeled packet go through "Packet Filtering/Policy Rou ting/Filter Based Forwarding"?

From: [email-masked]
Date: Fri, 25 Oct 2002 10:26:22 +0100

Chetan,

What about LDP and the desire to do a sort-of TE function using ECMP?  This
would seem to somewhat negate the intention of ingress 1-shot route/policy
selection.  Also check out LSP-Ping which changes an IP address in an
attempt to exercise the different ECMP-selected routings.

regards, Neil

> -----Original Message-----
> From: chetan kumar s [mailto:[email-masked]]
> Sent: 25 October 2002 07:34
> To: Sachin Kalra
> Cc: mpls
> Subject: Re: Does a labeled packet go through "Packet Filtering/Policy
> Routing/Filter Based Forwarding"?
> 
> 
> On Thu, 24 Oct 2002, Sachin Kalra wrote:
> 
> > Dear MPLS Community:
> >
> > A quick question. Does a labeled packet go through "Packet 
> Filtering/Policy
> > Routing/Filter Based Forwarding"?
> 
> Yes, the labeled packets go through "Packet Filtering/Policy
> Routing/Filter Based Forwarding". But unlike regular IP 
> forwarding that
> requires these rules to be applied at every nodes, in case of 
> MPLS these
> rules can be applied at one single node. And rest is done by the MPLS
> network.
> 	In MPLS each packet is assigned to an FEC (Forward Equivalent
> Class). Once this is done, only at the ingress, the packets are labled
> and rest of the network identifies the packet based on this 
> label. One can
> assign packet to a FEC based on IP dest address combined
> with Filtering/Policy based rules.
> 
> Thanks
> Chetan S
> 
> 
> >
> > Thanks,
> > Sachin Kalra
> >
> 
> -- 
> ------------
> Thinking is progress, non thinking is destruction of 
> individual, organization
> and nation
> 
> -Abdul Kalam
>

---

From: "chetan kumar s" <[email-masked]>
Date: Mon, 28 Oct 2002 12:20:02 +0530 (IST)

> would seem to somewhat negate the intention of ingress 1-shot route/policy

Neil,
	In understand these points (which are expectional for EC TE
functionalities). My response was *in principle* how packet
filtering/policy routing gets translates to LSP's in MPLS network..

Thanks
Chetan S

-- 
------------
Thinking is progress, non thinking is destruction of individual, organization
and nation

-Abdul Kalam