Subject: RE: Last call on LSP Ping

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 13 Dec 2002 09:52:04 -0500

It does seem plausible that RSVP-TE could signal
backup tunnels that could black hole traffic on the data plane
once switched on.  It is possible to do this at least in the facility-
based FRR mode, since a TE tunnel is signaled a priori (perhaps many
of  them), so one could go and test each to verify their health
to make sure that they are really protecting once turned on.

         --Tom

>I was more thinking in terms of how to make sure the backup/detour
>paths are working fine, while the traffic is still on the working path.
>
>
>Yours,
>-Shahram
>
> > -----Original Message-----
> > From: Curtis Villamizar [mailto:[email-masked]]
> > Sent: Thursday, December 12, 2002 11:14 PM
> > To: Shahram Davari
> > Cc: [email-masked]
> > Subject: Re: Last call on LSP Ping
> >
> >
> >
> > In message
> > <[email-masked]
> > >, Shahram Davari writes:
> > > Hi,
> > >
> > > Would the authors comment on how the MPLS-ping applies when
> > > Fast Reroute scheme exists? In other words how is the backup path
> > > and/or detour paths tested from the ingress?
> > >
> > > Thanks,
> > > -Shahram
> >
> >
> > In ping mode you should not know that the backup is in use.
> >
> > Perhaps an error return in traceroute mode would be helpful or an
> > indication that the next hop is part of a detour.
> >
> > Keep in mind that once the detour is put into use it is usually a
> > matter of seconds before a new primary is created with its own set of
> > detours, none of which are in use.
> >
> > Curtis
> >

"The difficult, we do immediately.  The impossible takes a little longer." 
-- Air Force Motto

---

From: Kireeti Kompella <[email-masked]>
Date: Fri, 13 Dec 2002 11:28:26 -0800 (PST)

Hi Tom,

> to make sure that they are really protecting once turned on.

(I appear to have an email *stack*, LIFO)

As Curtis mentioned, the PLR can initiate such tests.  Furthermore,
the head end can test presignaled backup LSPs (alternate tunnel
instances).  All of these are left to the implementation to provide;
perhaps after some experience, we will find that some enhancements to
LSP ping to make this work better.

Kireeti.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 13 Dec 2002 14:52:58 -0500

At 11:28 AM 12/13/2002 -0800, Kireeti Kompella wrote:
>As Curtis mentioned, the PLR can initiate such tests.

         Yes, my thinking exactly.

>Furthermore,
>instances).

         Yes. I was thinking more of just letting the PLR test
the detours as it constructs them.  I can see how the head
end can also trace the LSP instances, but I think it is more
useful for the PLR to automatically do this if programmed,
as it seems more scalable.

>  All of these are left to the implementation to provide;

         Agreed.

         --Tom