Subject: RE: Last call on LSP Ping

From: Shahram Davari <[email-masked]>
Date: Fri, 6 Dec 2002 10:00:44 -0800

I understand the intent, but these RFCs explicitly prohibit sending 
127/8 addresses out of any box. It is for a node's internal use only.

-Shahram

> -----Original Message-----
> From: George Swallow [mailto:[email-masked]]
> Sent: Friday, December 06, 2002 12:23 PM
> To: Shahram Davari
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: Last call on LSP Ping 
> 
> 
> > RFC 3330 says:
> > 
> > 
> >    127.0.0.0/8 - This block is assigned for use as the Internet host
> >    loopback address.  A datagram sent by a higher level 
> protocol to an
> >    address anywhere within this block should loop back 
> inside the host.
> >    This is ordinarily implemented using only 127.0.0.1/32 
> for loopback,
> >    but no addresses within this block should ever appear on 
> any network
> >    anywhere [RFC1700, page 5].
> > 
> > And RFC1700 says:
> > 
> >    g)   {127, <any>}
> > 
> >          Internal host loopback address.  Should never 
> appear outside
> >          a host.
> > 
> > 
> > Doesn't this draft violate these RFCs?
> 
> This it falls within the intent.  If the label stack gets completely
> poped off you don't want it to go any further.  That's the whole point
> of using that address range.  I really don't see a need to find a new
> range.
> 
> (Note that I'm counting the implicit null as still being a label stack
> - so the packet gets as far as the stack will take it and no further.)
> 
> ...George
> 
> ==================================================================
> George Swallow       Cisco Systems                  (978) 497-8143
>                      250 Apollo Drive
>                      Chelmsford, Ma 01824
>

---

From: Curtis Villamizar <[email-masked]>
Date: Fri, 06 Dec 2002 13:27:32 -0500

In message <[email-masked]
>, Shahram Davari writes:

This does not make it routeable.  It is no more a violation than using
a an IP source route with a 127.0.0.1 destination when you know that the
destination used the standard numbering of the loopback.

If any part of 127/8 became routable then it would be a violation of
the intent.

The LSP-ping objectors seem to be grasping at straws with this one.

Curtis