Subject: RE: Last call on LSP Ping

From: "Gray, Eric" <[email-masked]>
Date: Mon, 9 Dec 2002 13:54:17 -0500

Curtis,

	I am suggesting that attempting to use any address range
as a mechanism for testing ECMP routes is a mistake.  I am also
suggesting that a single address is sufficient to satisfy the
need Eric Rosen points out.  Finally, if you were suggesting 
that 127.0.0.1 should be specified (as opposed to 127.0.0.0/8)
for the same purpose, then I agree with you.

	Any address based approach to trying to test ECMP load
sharing paths implies prior knowledge of all ECMP algorithms 
in use and is therefore broken.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

> -----Original Message-----
> From: Curtis Villamizar [mailto:[email-masked]]
> Sent: Monday, December 09, 2002 1:46 PM
> To: Gray, Eric
> Cc: [email-masked]'; [email-masked]'; [email-masked]
> Subject: Re: Last call on LSP Ping
> 
> 
> In message <1117F7D44159934FB116E36F4ABF221B0267ED59@celox-ma1-
> ems1.celoxnetwor
> ks.com>, "Gray, Eric" writes:
> > Eric,
> >
> > 	Hmmm, how about 0.0.0.0?
> 
> And the advantages are... ?
> 
> For ECMP the address range of 0.0.0.0/32 is a problem or were you
> suggesting a larger subnet such as 0/8.  I think this is a lot worse
> solution than 127/8.
> 
> Curtis
> 
> 
> > Eric W. Gray
> > Systems Architect
> > Celox Networks, Inc.
> > [email-masked]
> > 508 305 7214
> >
> >
> > > -----Original Message-----
> > > From: Eric Rosen [mailto:[email-masked]]
> > > Sent: Monday, December 09, 2002 11:37 AM
> > > To: Gray, Eric
> > > Cc: [email-masked]'; [email-masked]
> > > Subject: Re: Last call on LSP Ping
> > >
> > >
> > > EricG> If there  is another reason for  using this address  range, it
> > > either
> > > EricG> has not been stated, or I missed it.
> > >
> > > Well, what  should the tunnel ingress  put into the IP  destination
> field
> > > of
> > > the "LSP Ping" UDP packet?  We want  the packet to be consumed by the
> > > egress
> > > even if the egress  isn't who the ingress thinks it is.   (That's how
> we
> > > get
> > > the  error   response  indicating  that  the  tunneled   packets  have
> > > been
> > > misrouted.)  Thus  we need to  put in a  "well known" address which
> will
> > > be
> > > interpreted by the tunnel egress as meaning "for me".
> > >
> > > Use of one of the loopback addresses (127.x.y.z) seems to achieve this
> > > goal.
> > > I think it's kind of a nifty hack ;-)
> > >
> > > As Curtis  has pointed out, there  is ample precedent for  having a
> > > tunneled
> > > packet  carry addressing  information  which  is to  be  interpreted
> in
> > > the
> > > context of the egress.
> >
> >

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 09 Dec 2002 14:13:07 -0500

In message <[email-masked]
> in use and is therefore broken.

If you have ideas to address the prior message I sent on ECMP and in
particular the problem of multiple branch points, I'd like to hear
your solution.

One thing that came to mind was the midpoint enumerating the possible
paths with indices and the ingress providing the index in subsequent
messages.  To do this, the ingress may have to bundle the better part
of an MPLS-ping message inside another so the top POP exposes an IP
packet and ECMP index to use and the packet inside is injected into
the stream.  If we go with this, then 127.0.0.1 would be fine.  This
has the disadvantage of not actually exercising the forwarding, just
the control plane.

The 127.0.0.1 address has a small advantage in that if the egress
comes out in some unexpected place, then it is delivered to that
router which can respond more intellegently than sending an ICMP TTL
expired.

Curtis

---

From: Kireeti Kompella <[email-masked]>
Date: Wed, 11 Dec 2002 03:07:03 -0800 (PST)

Hi Eric,

> as a mechanism for testing ECMP routes is a mistake.

I don't follow.  If I send ping packets with 127.0.0.1 and 127.31.41.59,
the worst that can happen is that they end up on the same path.  But
I may get lucky and hit two paths.  If I only use 127.0.0.1 (or the
ALL-ROUTERS.MCAST.NET address or whatever), I am guaranteed not to
test more than one path.

Kireeti.