Subject: Re: TE MIB - LSR MIB integration

From: [email-masked]
Date: Wed, 27 Nov 2002 09:18:55 +0100

Yuan,Rupert and Vijayanand thanks for your replies.
Please see my comments inline.

	- Roberto

Vijayanand C - CTD, Chennai. wrote:

>In this scenario there is only one TE tunnel , ie the outer tunnel across R1
>to R3. Three vanilla LSPs use it to tunnel flows across R1 to R3. ( hope I
>understood the problem right).
>
You understood right.

>
>Hence , it would be appropriate to have 3 XC entries( pointed from their
>respective FTN entries) corresponding to each vanilla LSP with the tunnel
>label in their label stacks.
>
So, the tunnel label in the mplsOutSegmentTable and the bottom label in the mplsLabelStackTable?

>
>Also, I think there should be only one tunnel entry corresponding to the TE
>tunnel.
>
Which table points to this tunnel entry? Where does this tunnel entry 
point to?

>
>Thanks and Regards
>Vijay
>
>"Where protocols are a passion, MPLS is a religion "
>
>-----Original Message-----
>From: Zhu, Rupert [mailto:[email-masked]]
>Sent: Wednesday, November 27, 2002 6:01 AM
>To: Yuan Gu; [email-masked]; [email-masked]
>Subject: RE: TE MIB - LSR MIB integration
>
>
>Roberto, Yuan:
>
>Interesting scenario.  I agree on Yuan's approach, if you
>insist on mapping the 3 LSPs into one TE tunnel.
>However, why should we choose to map the 3 LSPs to
>the same tunnel?
>
The incoming flows are Ethernet TLS flow traversing an intervening MPLS 
network. The typical scenario is to assign each of the flows entering 
and leaving the MPLS network from the same end points, with a VC label 
(following Martini's draft) and encapsulate all the obtained LSPs into 
one TE tunnel, in order to offer the different clients the same service.

>
>The application described is to have 3 flows carried in 3 LSPs,
>respectively.  Since there is no logical relationships between
>the 3 LSPs, (e.g., load sharing, backup, etc.), it seems more
>appropriate to model them as 3 independent entities.
>
>Alternative Solution #1:  Map to 3 LSPs directly.
>
>    -- Populate 3 entries in mplsFTNTable (in MPLS-FTN-MIB).
>       Have each mplsFTNActionType=redirectLSP.
>       Have each mplsFTNActionPointer pointing to one
>       of the 3 mplsXCEntry.
>
The classification is achieved using the pwe MIBs. The VC label is kept 
in the MPLS world, not in the pwe world.

>
>Alternative Solution #2:  Map to 3 tunnels (instead of one).
>
>    -- Populate 3 entries in mplsFTNTable (in MPLS-FTN-MIB).
>    -- Populate 3 entries in mplsTunnelTable, each representing
>       a distinct (logical) tunnel.  (That is, they have different
>       values in mplsTunnelIndex.)
>    -- Have each mplsFTNActionType=redirectTunnel.
>       Have each mplsFTNActionPointer pointing to one of
>       the 3 mplsTunnelEntry.
>
>In other words, if there is no relationship between the 3 LSPs,
>then they do not belong to the same TE tunnel.
>
>My two cents.
>
>-- Rupert
>
>
>  
>
>>-----Original Message-----
>>From: Yuan Gu [mailto:[email-masked]]
>>Sent: Monday, November 25, 2002 2:12 PM
>>To: [email-masked]; [email-masked]
>>Subject: RE: TE MIB - LSR MIB integration
>>
>>
>>Hello, Roberto:
>>
>>    
>>
>>>-----Original Message-----
>>>From: [email-masked] [mailto:[email-masked]]On Behalf Of
>>>[email-masked]
>>>Sent: Monday, November 25, 2002 3:19 AM
>>>To: [email-masked]
>>>Subject: TE MIB - LSR MIB integration
>>>
>>>
>>>Hello everybody,
>>>I have a doubt about interactions between LSR MIB and TE 
>>>      
>>>
>>MIB for what
>>    
>>
>>>concerning LSPs nested in TE tunnels.
>>>Consider the following scenario:
>>>
>>>R1 -------- R2 -------- R3
>>>
>>>and suppose, for example, I have three incoming flows. I 
>>>      
>>>
>>want to insert
>>    
>>
>>>each flow in one LSP and tunnel the three LSPs in one TE tunnel.
>>>My questions are:
>>>
>>>1) How are the three LSPs mapped on the same TE tunnel?
>>>      
>>>
>>There will be 3 entries in mplsTunnelTable. Each entry has different
>>mplsTuunnelInstance.
>>
>>The mplsTunnelInstance "Uniquely identifies an instance of a 
>>tunnel. It is
>>useful to identify multiple instances of tunnels for the 
>>purposes of backup
>>and parallel tunnels."
>>You may want to put your LSPID into this field.
>>
>>    
>>
>>>2) Is there only one entry in the mplsTunnelTable pointing 
>>>      
>>>
>>to one entry
>>    
>>
>>>in the mplsXCTable?
>>>      
>>>
>>There will be 3 corresponding entries in mplsXCTable. Each entry has
>>different mplsXCLspId (RSVP-TE or CR-LDP).
>>
>>    
>>
I understand your point of view.
In my opinion, the 3 entries in mplsXCTable should have the tunnel label in the mplsOutSegmentTable and the bottom label in the mplsLabelStackTable. Do you agree? If not, where the 2 labels are indicated for each flow?

---

From: [email-masked]
Date: Wed, 27 Nov 2002 11:13:38 +0100

Vijayanand,
please let me know if i understood what you just said.

1) There are 4 XC entries:
        - 1 XC entry associated to the TE tunnel entry with only the 
tunnel label in the Out Segment
        - 3 XC entries each one associated to one flow and each one with 
the tunnel label in the Out Segment and the bottom label in the Stack Table.
Is this correct?

2) In this case, how is it possible to get to one of the 3 XC entries 
containing the stack of labels, passing by the TE tunnel table, since 
the TE tunnel entry points to the XC entry with only the tunnel label? 
In other words, I don't understand how multiple LSPs can use the TE 
tunnel entry!

    - Roberto

Vijayanand C - CTD, Chennai. wrote:

>The label stack and top label arrangements are as usual , as you said.
>
>Reg. the TE tunnel entry - I would imagine its going to have an associated
>XC entry ,which has associated outsegment, FTN etc. and would be able to
>carry traffic directly( not just as a tunnel for other LSPs).
>Multiple LSPs may be using this TE tunnel entry, since they would be holding
>the TE tunnel label as their top label in their outsegments. 
>
>Thanks and Regards
>Vijay
>
>From: [email-masked] [mailto:[email-masked]]
>Sent: Wednesday, November 27, 2002 1:49 PM
>To: Vijayanand C - CTD, Chennai.; Zhu, Rupert; Yuan Gu
>Cc: [email-masked]
>Subject: Re: TE MIB - LSR MIB integration
>
>
>>In this scenario there is only one TE tunnel , ie the outer tunnel across
>>    
>>
>R1
>  
>
>In my opinion, the 3 entries in mplsXCTable should have the tunnel label in
>the mplsOutSegmentTable and the bottom label in the mplsLabelStackTable. Do
>you agree? If not, where the 2 labels are indicated for each flow?
>
>
>  
>
>>>   
>>>
>>>      
>>>
>> 
>>
>>    
>>
>
>
>  
>

---

From: [email-masked]
Date: Thu, 28 Nov 2002 09:09:30 +0100

Vijay,
I have a doubt. If the TE tunnel is internally used by the LSP, how is it possible to use all the parameters configured in the TE MIB for the TE tunnel, given the fact the the classification process would point directly to the XC entry? You can only apply traffic parameters retrieved from the LSR MIB.
	- Roberto

Vijayanand C - CTD, Chennai. wrote:

>Yes, thats because its' the vanilla LSP which is the 'hit' in the
>classification, and the TE tunnel is internally used by it.
>
>Its my pleasure to help.
>
>Thanks and Regards
>Vijay
>
>Sent: Wednesday, November 27, 2002 4:14 PM
>To: Vijayanand C - CTD, Chennai.
>Hence, the FTNActionPointer would point directly to the XC entry and not 
>to the TE tunnel entry, is it right? This was the point getting me confused.
>I really appreciate your help.
>    - Roberto
>
>
>>Yes, this is what I meant.
>>
>>But I dont understand what you are trying to get at.
>>
>>At the ingress the FTN map entries for the vanilla LSPs will clasify the
>>packet and use the labels  pointed to by the XC which will contain the TE
>>tunnel label on top. This top label will be associated with the subsequent
>>traffic shaping activities. 
>>
>>
>>Thanks and Regards
>>Vijay
>>
>>Sent: Wednesday, November 27, 2002 3:44 PM
>>To: Vijayanand C - CTD, Chennai.
>>Cc: [email-masked]
>>the tunnel label in the Out Segment and the bottom label in the Stack
>>    
>>
>Table.
>  
>
>>Is this correct?
>>
>>>Multiple LSPs may be using this TE tunnel entry, since they would be
>>>   
>>>
>>>      
>>>
>>holding
>> 
>>
>>    
>>
>>>>to R3. Three vanilla LSPs use it to tunnel flows across R1 to R3. ( hope
>>>>        
>>>>
>I
>  
>
>>>So, the tunnel label in the mplsOutSegmentTable and the bottom label in
>>>      
>>>
>the
>  
>
>>>mplsLabelStackTable?
>>>
>>>
>>>
>>>   
>>>
>>>      
>>>
>>>>Also, I think there should be only one tunnel entry corresponding to the
>>>>     
>>>>
>>>>        
>>>>
>>TE
>> 
>>
>>    
>>
>>>>tunnel.
>>>>
>>>>  
>>>>
>>>>     
>>>>
>>>>        
>>>>
>>>In my opinion, the 3 entries in mplsXCTable should have the tunnel label
>>>      
>>>
>in
>  
>
>>>the mplsOutSegmentTable and the bottom label in the mplsLabelStackTable.
>>>      
>>>
>Do
>  
>