Subject: Re: Record Object in LSP Ping

From: Curtis Villamizar <[email-masked]>
Date: Tue, 10 Dec 2002 13:00:35 -0500

In message <[email-masked]
>, Shahram Davari writes:
> I fail to understand how adding a TLV to the ping affects 
> forwarding ASICs!
> 
> -Shahram

Shahram,

There are two modes:

  1.  ping mode

  2.  traceroute mode

Since traceroute mode already yields the full path, the record route,
analogous to IP record route option, would be applicable to ping mode
or to traceroute once TTL was greater than 1.

In traceroute mode, a control plane trace is performed and confirmed
by incrementing TTL and checking to see that the router returning the
next reply was the one expected, thereby verifying each forwarding hop
separately.

In ping mode and when traceroute TTL>1 , the forwarding is being
exercised.  The only way a record route can be supported is to modify
the forwarding such that the bottom of the stack is checked, the
payload determined to be mpls-ping, the packet extracted from the
forwarding stream, the record route hop recorded, and the packet put
back into the forwarding stream.  This arguably is no longer the
normal packet forwarding so not only would we (everyone) have to
change hardware, but we defeat a prime purpose of ping mode (a
forwarding based continuity check).

Curtis

> > -----Original Message-----
> > From: Curtis Villamizar [mailto:[email-masked]]
> > Sent: Tuesday, December 10, 2002 12:19 PM
> > To: Ajay Simha
> > Cc: [email-masked]
> > Subject: Re: Record Object in LSP Ping 
> > 
> > 
> > 
> > In message <[email-masked]>, Ajay Simha writes:
> > > Hi,
> > > 
> > > Since the LSP Ping is meant for fault detection, does 
> > anyone see any value
> > > in adding a record route/label TLV to this?
> > 
> > This is infeasible without changing forwarding hardware so "no".
> > 
> > > Each node can add (if requested) the label that the packet 
> > came in with,
> > > the label that this node imposed/swapped and it's LSR-ID.
> > 
> > All you need is new forwarding ASICs.
> > 
> > > Thanks,
> > > 
> > > -ajay
> > 
> > Curtis
> > 
>

---

From: Shahram Davari <[email-masked]>
Date: Tue, 10 Dec 2002 09:35:28 -0800

-Shahram