Subject: RE: review of mpls-mgmt-overview revision 02

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 2 Dec 2002 19:10:33 +0100

> Aaagh!
> 
> Let's try to get this straight.
> 
> There is only one MIB.
> There is a series of MIB documents, such as MPLS-TE MIB.
Add "document" at the end

> Each MIB document describes one or more MIB modules, such as 
> MPLS-TE-MIB.
> 
> Is that agreed?
> 
Yep.

See also below

> Adrian
> (Sorry if I am stating the obvious, but I'd rather only make 
> the change once!)
> 
> > > > - I see you use mib module names with an underscore, for example
> > > >   MPLS-LDP_MIB, but the real module name is MPLS-LDP-MIB
> > > >   Better get that in sync. True for most mib module names I believe
> > >
> > >Ah! I made this global change after I thought I heard Tom suggest that you
> > >said
> > >that the use of underscore was a requirement. At least one of us is out of
> > >synch here - I will change back to hyphen.
> >
> >          Shouldn't it be written as MPLS-LDP MIB when referring to the actual
> > MIB and not the SMI MODULE-NAME macro?
> >

That would be fine with me too. But the underscore seemed to show the MIB
module name (incorrectly).

Bert

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 2 Dec 2002 19:10:33 +0100

> > > - Your split of references for the SNMP boilerplate text is not
> > >   correct. The correct split is:
> >[SNIP]
> > > - We're working on the new MIB boilerplate. Much shorter. 
> > >   Not 100% stable yet. If you prefer to use it (I assume the
> > >   new boiler plate will be stable by the time you go to
> > >   RFC-Editor queue), then I can send you what
> > >   the current text looks like.
> >
> >I will wait as late as I can and then include the most up-to-date version.
> >But... Do you consider that the boilerplate is appropriate for 
> >inclusion in this overview or should I aim to hack it down? Actually,
> >if the new material is shorter, perhaps it will be fine.
> 
>          I think that we had agreed during the meeting that we would not
> wait for the updated boiler plate giving the timing issues.
> 
As I said, it is up to you.
We may end up having to do the boilerplate change in 48-hour author-call
I expect/hope to have a stable new boiler plate in a week (or two) and
if you can still include it, I think it would be good. Again, up to you

Bert
>          --Tom

---

From: [email-masked]
Date: Mon, 02 Dec 2002 16:48:14 -0500

> > Each MIB document describes one or more MIB

I agree also (and prefer this convention).

  thanks, Joan

> > > >that the use of underscore was a
> requirement. At least one of us is out of
> > >          Shouldn't it be written as
> MPLS-LDP MIB when referring to the actual

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 8 Dec 2002 17:25:08 +0100

In addition to my earlier review.

I seems to me that the split of the LDP MIB module into four
MIB modules has not yet been incorporated into the overview 
document

Thanks,
Bert

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 09 Dec 2002 09:56:05 -0500

>MIB modules has not yet been incorporated into the overview

         Yes, that is new since the last revision; will make
sure that makes it into the next version.

         --Tom