Subject: RE: Last call on LSP Ping

From: "Gray, Eric" <[email-masked]>
Date: Fri, 6 Dec 2002 15:28:11 -0500

George,

	I am a little concerned about your line of
reasoning.  This usage may be "within the spirit"
of what has been specified previously, but it is
likely to result in things happening in networks
that could never have happened before.  It is not
so much a matter of insisting on doing things as
literally required by specifications as it is a
matter of insisting on not introducing behavior
in networks that has probably not been a part of
test scenarios in the past and is certainly not in 
the realm of common experience.

	In this case, a number of packets may start
to appear in a network that are addressed to the
local host for all host-like entities on that part
of the network.  Moreover, these packets will be
coming to the IP stack of these host-like entities
from "underneath" - which is certain to be novel.
More-over, the likelihood that this will start to
happen is directly related to the likelihood that
the portion of the network where this is happening
is already in trouble.

	I wonder if we are not trying to excuse what
is most likely a particularly bad hack.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

> -----Original Message-----
> From: George Swallow [mailto:[email-masked]]
> Sent: Friday, December 06, 2002 2:32 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: Last call on LSP Ping
> 
> > George....I think the point Shahram was making it is not even allowed
> > outside the host/source box according to the text quoted from the RFcs
> > below.  Wrapping it in some other package (any, not just MPLS) is still
> > violating this requirement...and note that it *must* be placed in some
> > package to get across any tranmission medium....IP pkts don't go raw on
> > wires.
> 
> As far as I'm concerned it is within the spirit of the RFCs.  If you
> want to insist on the letter of the law, perhaps you should look into
> a career as a solicitor.
> 
> ...George
> 
> ==================================================================
> George Swallow       Cisco Systems                  (978) 497-8143
>                      250 Apollo Drive
>                      Chelmsford, Ma 01824

---

From: Kireeti Kompella <[email-masked]>
Date: Wed, 11 Dec 2002 02:45:44 -0800 (PST)

Hi Eric,

On Fri, 6 Dec 2002, Gray, Eric wrote:

> that could never have happened before.

To re-iterate: a packet may have a dest IP address from 127/8 --
nothing illegal in that -- happens all the time on Unix boxes.
A box receiving such a packet SHOULD NOT forward it.  LSP ping
actually strongly desires that the box NOT forward the packet.

It's all ferpeckly legal.

Kireeti.