Subject: Upstream Labels in GMPLS

From: Marcos Antonio De Almeida Cora <[email-masked]>
Date: Mon, 2 Dec 2002 15:00:34 -0200 (EDT)

Hi, 

I have some doubts on Upstream Labels in GMPLS.
First, GMPLS supports both "unidirectional LSPs" and "bidirectional LSPs" ???
I would like to know if when a initiator node send a request message
(Path/RSVP or Label Request/CR-LDP) with a Upstream Label, and this label is 
not suitable for use at the next LSR, it must reject the request message 
and send a "Error message" to the initiator node. In this case, the Error
message may include an acceptable Label Set to tell the Upstream LSR wich
labels would have been succeful.
But if Upstream LSR decide to fail the LSP set up, my doubt is: The
unidirectional LSP will set up and just the bidirectional LSP not is set
up ?? or both uniderectional and bidirectional will fail, and LSR
initiator will try again ??

Thanks, 

       Marcos

_________________________________________________________________

  Marcos Antônio de Almeida Corá    
  School of Electrical and Computer Engineering
  Departament of Telematics
  State University of Campinas/Brazil - UNICAMP
  Phone: +55 (19) 3788.3711 - Branch: 73723   
  Home Page: www.dt.fee.unicamp.br/~cora
_________________________________________________________________

---

From: "venkat d" <[email-masked]>
Date: 2 Dec 2002 19:25:45 -0000

Hai,

     When a bi-directional request is sent for path establishment,any kind of failure irrespective of any error occurring for path towards downstream or path towards upstream will result in failure of the request as a whole. So no path is established in either and the intiator has to try again with new set.

Thanks
Venkat

On Mon, 02 Dec 2002 Marcos Antonio De Almeida Cora wrote :
>[ post by non-subscriber.  with the massive amount of spam, it is easy to miss
>   and therefore delete posts by non-subscribers.  if you wish to regularly
>   post from an address that is not subscribed to this mailing list, send a
>   message to <listname>[email-masked] and ask to have the alternate
>   address added to the list of addresses from which submissions are
>   automatically accepted. ]
>
>Hi,
>

____________________________
__________________________
 NIIT supports World Computer Literacy Day on 2nd December. 
 Enroll for NIIT SWIFT Jyoti till 2nd December for only Rs. 749
 and get free Indian Languages Office software worth Rs. 2500.
 For details contact your nearest NIIT centre, SWIFT Point
 or click here http://swift.rediff.com/