Subject: RE: Last call on LSP Ping

From: "David Allan" <[email-masked]>
Date: Sun, 8 Dec 2002 12:03:04 -0500

Eric:

I have similar concerns. 

LSP-PING supposedly is designed to provide value regardless of the vintage
of the gear that is out there (which explains many "interesting" design
decisions embodied in it). The use of 127. would appear to run counter to
that philosophy.

cheers
Dave

-----Original Message-----
From: Gray, Eric [mailto:[email-masked]]
Sent: Friday, December 06, 2002 3:28 PM
To: 'George Swallow'
Cc: [email-masked]
Subject: RE: Last call on LSP Ping 

George,

	I am a little concerned about your line of
reasoning.  This usage may be "within the spirit"
of what has been specified previously, but it is
likely to result in things happening in networks
that could never have happened before.  It is not
so much a matter of insisting on doing things as
literally required by specifications as it is a
matter of insisting on not introducing behavior
in networks that has probably not been a part of
test scenarios in the past and is certainly not in 
the realm of common experience.

	In this case, a number of packets may start
to appear in a network that are addressed to the
local host for all host-like entities on that part
of the network.  Moreover, these packets will be
coming to the IP stack of these host-like entities
from "underneath" - which is certain to be novel.
More-over, the likelihood that this will start to
happen is directly related to the likelihood that
the portion of the network where this is happening
is already in trouble.

	I wonder if we are not trying to excuse what
is most likely a particularly bad hack.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

> -----Original Message-----
> From: George Swallow [mailto:[email-masked]]
> Sent: Friday, December 06, 2002 2:32 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: Last call on LSP Ping
> 
> > George....I think the point Shahram was making it is not even allowed
> > outside the host/source box according to the text quoted from the RFcs
> > below.  Wrapping it in some other package (any, not just MPLS) is still
> > violating this requirement...and note that it *must* be placed in some
> > package to get across any tranmission medium....IP pkts don't go raw on
> > wires.
> 
> As far as I'm concerned it is within the spirit of the RFCs.  If you
> want to insist on the letter of the law, perhaps you should look into
> a career as a solicitor.
> 
> ...George
> 
> ==================================================================
> George Swallow       Cisco Systems                  (978) 497-8143
>                      250 Apollo Drive
>                      Chelmsford, Ma 01824

---

From: Curtis Villamizar <[email-masked]>
Date: Sun, 08 Dec 2002 14:45:54 -0500

In message <[email-masked]>, "
> decisions embodied in it). The use of 127. would appear to run counter to

Dave,

I find it hard to beleive anyone would hard code filters into the
hardware.  Maybe into downloadable microcode, but that is changeable.
If anyone has actually burned the list of "martian networks"
(non-routeable, meaning loopback, and private address space) into an
ASIC or other part that can't be replaced, they may have to respin
some parts and replace boards.  I seriously doubt anyone would do
this.  If not, this is nothing but a hypothetical compatibility issue
for which no real instance exists.  There are still tier-1 ISPs and
carriers that have gear for which no change is required (none of the
major routers have hard wired a 127/8 filter into silicon) and want to
move forward.

Curtis