Subject: Re: review of mpls-mgmt-overview revision 02

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 02 Dec 2002 11:35:32 -0500

At 10:14 PM 11/29/2002 -0500, Adrian Farrel wrote:
>Bert,
>Thanks. All nits are most welcome. I, for one, welcome your efforts to get 
>RFCs
>in clear and correct English.
>
>A couple of follow-up questions/comments in the snipped text below...
>
>Cheers,
>Adrian
>----- Original Message -----
>From: "Wijnen, Bert (Bert)" <[email-masked]>
>
>
> > A lot of it is indeed nits/spelling/grammar
> > stuff... do I have to repat that for all docs, or can I assume
> > that the authors/editors will seriously check those things
> > themselves?
>
>Hmmm. I know what you SHOULD be able to asume...
>
> > - I see you use mib module names with an underscore, for example
> >   MPLS-LDP_MIB, but the real module name is MPLS-LDP-MIB
> >   Better get that in sync. True for most mib module names I believe
>
>Ah! I made this global change after I thought I heard Tom suggest that you 
>said
>that the use of underscore was a requirement. At least one of us is out of 
>synch
>here - I will change back to hyphen.

         Shouldn't it be written as MPLS-LDP MIB when referring to the actual
MIB and not the SMI MODULE-NAME macro?

> > - Make descriptors consistent. Like
> >    - mplsLdpEntityFrameRelayXxxxx
> >    - mplsLdpEntityConfFrXxxx
> >   so either make all freme-relay stuff xxxFrameRelayYyy or xxxFrYyy
> >   but do not mix all that. I also wonder why in some case
> >   Fr comes before the Xxxx and in other cases after it.
> >    - mplsLdpEntityFrameRelayXxxxx
> >    - mplsLdpEntityConfFrXxxx
> >   why not mplsLdpEntityFrameRelayConfXxxx
> >  Are mplsTunnelResourceTable and mplsTunnelCRDLPResTable both "resource"
> >   tables? If so, then why not use "Resource" in both cases, or just "Res"
> >   in both cases?  Consistency please!!!!!
> >   So Tunnel Computed Hop Table is: mplsTunnelCHopTable
> >   and Tunnel Actual Hop Table is: mplsTunnelARHopTable
> >   is the R for Route? If so then add Route in there
>
>Agreed. This draft, however, can only report what is in the MIB modules
>themselves.
>
>Tom and Joan - relying on you to pick up these things and then I'll change the
>overview to match.
>
> >   Question: Is there also a mplsTunnelRSVPResTable? If yes, then I am
> >   missing it here, if no, then why is that not needed?
>
>Good question.
>No there is no RSVP resource table. CR-LDP resource specification is a 
>superset
>of RSVP resource specification.
>I will add a note explaining.
>
> > - sect 7.2
> >   ".. mplsTunnelMaxHops defines the size of route that may be configured
> >    on the LSR."
> >   I have difficulty understanding what that means.
> >   What is the "size of route"?
>
>Syntax is "size of route that", but I agree that this could be clearer.
>
> > - Your references to PWE3 and PPVPN WG docs are listed as normative.
> >   I doubt that they really are. In any event, if they are normative,
> >   then they will have to be ready for RFC at the same time that this
> >   doc goes to RFC.
>
>You're right. Old reference from when we thought we were going to include them
>in detail.
>
> > - Your split of references for the SNMP boilerplate text is not
> >   correct. The correct split is:
>[SNIP]
> > - We're working on the new MIB boilerplate. Much shorter. Not 100% stable
> >   yet. If you prefer to use it (I assume the new boiler plate will be
> >   stable by the time you go to RFC-Editor queue), then I can send you what
> >   the curretn text looks like.
>
>I will wait as late as I can and then include the most up-to-date version.
>But...
>Do you consider that the boilerplate is appropriate for inclusion in this
>overview or should I aim to hack it down? Actually, if the new material is
>shorter, perhaps it will be fine.

         I think that we had agreed during the meeting that we would not
wait for the updated boiler plate giving the timing issues.

         --Tom

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 2 Dec 2002 12:05:20 -0500

Aaagh!

Let's try to get this straight.

There is only one MIB.
There is a series of MIB documents, such as MPLS-TE MIB.
Each MIB document describes one or more MIB modules, such as MPLS-TE-MIB.

Is that agreed?

Adrian
(Sorry if I am stating the obvious, but I'd rather only make the change once!)

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 02 Dec 2002 13:21:32 -0500

>Each MIB document describes one or more MIB modules, such as MPLS-TE-MIB.

         That jives with my understanding.

         --Tom