Subject: RE: Last Call on MPLS ping

From: Shahram Davari <[email-masked]>
Date: Tue, 10 Dec 2002 14:10:52 -0800

Eric,

The LSP-ping text says:

"  In either case, the MPLS echo request would
   have a label stack of <1001, 23456>.  (Note: in this example, 1001 is
   the "outer" label and 23456 is the "inner" label.)"

-Shahram

> -----Original Message-----
> From: Shahram Davari 
> Sent: Tuesday, December 10, 2002 1:55 PM
> To: [email-masked]'; Alia Atlas
> Cc: [email-masked]
> Subject: RE: Last Call on MPLS ping 
> 
> 
> > -----Original Message-----
> > From: Eric Rosen [mailto:[email-masked]]
> > Sent: Monday, December 09, 2002 12:38 PM
> > Alia> So,  my concern  here  is  for the  case  where the  
> > route  is not  an
> > Alia> aggregate  and the label  indicates the  egress 
> > attachment  circuit as
> > Alia> well as the encapsulation header for the packet. 
> > 
> > Alia> In  this case,  LSP ping  would send  an IP  packet 
> > with  the specific
> > Alia> route's label and then the PSN's label. 
> > 
> > That isn't  my interpretation of the  draft.  I think the  
> > intention is that
> > the LSP  ping carries only  the "PSN label".   That is, it 
> > carries  only the
> > label  or labels  needed to  get it  to the  egress PE,  not 
> > the  label that
> > identifies a particular VPN route (or a particular PWE3 
> pseudowire). 
> > 
> > If  you wanted  to  know not  only whether  a  particular LSP 
> >  leads to  the
> > intended PE,  but also whether that PE  is a proper egress  
> > for a particular
> > VPN route (or PWE3  pseudowire), then I think you would need  
> > to use the FEC
> > stack TLV in the body of the message to identify that VPN route.
> > 
> 
> But how do you test that the VPN route is bound to the proper 
> PW label?
> 
> 
> -Shahram
>

---

From: Eric Rosen <[email-masked]>
Date: Tue, 10 Dec 2002 17:26:47 -0500

Shahram> The LSP-ping text says: 

Okay, so  my interpretation was  overly charitable ;-) Perhaps  I overlooked
that passage because it is obvious that  it can't work that way, as Alia has
pointed out in more detail.  Generally one can't put the PW label or the VPN
route label on the LSP ping, because the LSP egress for those labels will be
a CE device.  But  I don't think that's a real problem,  since we don't want
the pings to go to the CE device.