Subject: RE: Last call on LSP Ping

From: "Gray, Eric" <[email-masked]>
Date: Fri, 13 Dec 2002 14:30:30 -0500

And so, naturally, you could make this same argument for
how an ECMP splitter would test out all of the equal cost
paths...

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

> -----Original Message-----
> From: George Swallow [mailto:[email-masked]]
> Sent: Friday, December 13, 2002 2:22 PM
> To: [email-masked]
> Cc: Shahram Davari; [email-masked]; [email-masked]
> Subject: Re: Last call on LSP Ping
> 
> > Currently you'd have to do that from each PLR.  We don't provide a
> > means to tell the ingress of the existance of a detour (except the
> > local-protect-available bit in the signaling itself which one major
> > implementation wasn't using last I checked).  We also don't provide a
> > means to tell a specific PLR to exercise its detour and report back.
> >
> > Let's wait and hear from Kireeti or other authors whether they think
> > anything should be added or whether the intent is to require testing
> > initiated at each PLR.
> 
> The PLR is responsible for the bypass.  It knows what sender-template
> it used, so it can form the proper FEC for the ping.  It can send a
> lsp-ping with the proper label stack.  So it is the natural place to
> do this.  If it fails, it should
> 
> a) report to network management
> b) reset the backup in place bit
> c) look for another way of establishing a backup
> d) if successful on c) set the backup in place bit.
> 
> You may want to put a hold-down on b) to avoid reporting to the
> head-end on a transient situation.
> 
> I don't see what advantage you would gain by moving all this to the
> head-end.  I do see a lot of complications...
> 
> ...George
> 
> 
> ==================================================================
> George Swallow       Cisco Systems                  (978) 497-8143
>                      250 Apollo Drive
>                      Chelmsford, Ma 01824

---

From: Kireeti Kompella <[email-masked]>
Date: Fri, 13 Dec 2002 11:46:54 -0800 (PST)

Hi Eric,

> how an ECMP splitter would test out all of the equal cost

There is a difference between ECMP and detours, which I am sure you
appreciate, but for the good of all, I'll articulate: packets can in
principle take all ECMP paths; however, packets cannot (SHOULD NOT)
take a detour without a failure occurring.

Kireeti.

---

From: Curtis Villamizar <[email-masked]>
Date: Fri, 13 Dec 2002 14:53:49 -0500

In message <[email-masked]
> how an ECMP splitter would test out all of the equal cost

The ECMP split affects the primary path.  The traffic for a branch has
to be injected upstream of the branch or you are not adequately
testing it.  There is no way to send traffic from upstream of a detour
to exercise a detour that is not in use.

Curtis