Subject: RE: Last call on LSP Ping

From: Shahram Davari <[email-masked]>
Date: Fri, 6 Dec 2002 10:33:59 -0800

> > 
> >    127.0.0.0/8 - This block is assigned for use as the Internet host
> >    loopback address.  A datagram sent by a higher level 
> protocol to an
> >    address anywhere within this block should loop back 
> inside the host.
> >    This is ordinarily implemented using only 127.0.0.1/32 
> for loopback,
> >    but no addresses within this block should ever appear on 
> any network
> >    anywhere [RFC1700, page 5].
> > 
> > And RFC1700 says:
> > 
> >    g)   {127, <any>}
> > 
> >          Internal host loopback address.  Should never 
> appear outside
> >          a host.
> > 
> > 
> > Doesn't this draft violate these RFCs?
> > 
> > -Shahram
> 
> 
> No.  It is exactly what RFC1700 specifies.  127.0.0.1/32 is not
> routable, just avaiable locally.
> 
> Curtis

Locally available to who? the ingress? I think it is clear that such an IP packet should never leave any box including the ingress. Here is what RFC 1122 says:

A host MUST silently discard an incoming datagram that is
            not destined for the host.  An incoming datagram is destined
            for the host if the datagram's destination address field is:

            (1)  (one of) the host's IP address(es); or

            (2)  an IP broadcast address valid for the connected
                 network; or

            (3)  the address for a multicast group of which the host is
                 a member on the incoming physical interface.

Therefore such a packet will get discarded at that node before even reaching
the UDP/ping layer.

-Shahram

---

From: Curtis Villamizar <[email-masked]>
Date: Fri, 06 Dec 2002 13:44:52 -0500

In message <[email-masked]
>, Shahram Davari writes:
> Locally available to who? the ingress? I think it is clear that such an IP pa
> cket should never leave any box including the ingress. Here is what RFC 1122 
> says:
> 

It is one of the hosts non-routable IP addresses configured on the
loopback device.

> Therefore such a packet will get discarded at that node before even reaching

Try "ping -g <routable-address> 127.0.0.1" fron any host or router
that supports source route ping to any host or router that doesn't
have source routing disable.  You'll get a response.

Curtis