Subject: RE: Last call on LSP Ping

From: [email-masked]
Date: Fri, 6 Dec 2002 17:49:37 -0000

George....I think the point Shahram was making it is not even allowed
outside the host/source box according to the text quoted from the RFcs
below.  Wrapping it in some other package (any, not just MPLS) is still
violating this requirement...and note that it *must* be placed in some
package to get across any tranmission medium....IP pkts don't go raw on
wires.

regards, Neil

> -----Original Message-----
> From: George Swallow [mailto:[email-masked]]
> Sent: 06 December 2002 17:23
> To: Shahram Davari
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: Last call on LSP Ping 
> 
> 
> > RFC 3330 says:
> > 
> > 
> >    127.0.0.0/8 - This block is assigned for use as the Internet host
> >    loopback address.  A datagram sent by a higher level 
> protocol to an
> >    address anywhere within this block should loop back 
> inside the host.
> >    This is ordinarily implemented using only 127.0.0.1/32 
> for loopback,
> >    but no addresses within this block should ever appear on 
> any network
> >    anywhere [RFC1700, page 5].
> > 
> > And RFC1700 says:
> > 
> >    g)   {127, <any>}
> > 
> >          Internal host loopback address.  Should never 
> appear outside
> >          a host.
> > 
> > 
> > Doesn't this draft violate these RFCs?
> 
> This it falls within the intent.  If the label stack gets completely
> poped off you don't want it to go any further.  That's the whole point
> of using that address range.  I really don't see a need to find a new
> range.
> 
> (Note that I'm counting the implicit null as still being a label stack
> - so the packet gets as far as the stack will take it and no further.)
> 
> ...George
> 
> ==================================================================
> George Swallow       Cisco Systems                  (978) 497-8143
>                      250 Apollo Drive
>                      Chelmsford, Ma 01824
>

---

From: George Swallow <[email-masked]>
Date: Fri, 06 Dec 2002 14:32:08 -0500

> package to get across any tranmission medium....IP pkts don't go raw on

As far as I'm concerned it is within the spirit of the RFCs.  If you
want to insist on the letter of the law, perhaps you should look into
a career as a solicitor.

...George