Subject: Text for Management Overview Document

From: "Sharon Chisholm" <[email-masked]>
Date: Mon, 16 Dec 2002 10:36:41 -0500

hi

In the MPLS MIB meeting in Atlanta, I promised to provide
some text for the management overview document to help
demystify the MIBs for general applications trying to
discover and manage LSPs.

There are still a few aspects I'm not 100% sure of, so 
I suspect some cleanup of the text will be required.

---------
N. LSP Discovery and Management

There are three different types of LSPs in MPLS - 
Traffic Engineering Tunnels, LDP and single hop 
service LSPs. Each of these will be discovered 
and managed somewhat differently.  
 
N.1. Traffic Engineering LSPs
 
Traffic engineering LSPs are frequently explicitly 
routed and tend to be fairly persistent so can 
therefore be managed using techniques similar to 
that of connection oriented systems.
 
These links can be discovered by reading in the
interface table and matching against entries with
an ifType of mplsTunnel(150). Under normal operation,
ifConnectorPresent will always have a value of 'true'.
As the operational status of these links is 
service affecting, ifLinkUpDownTrapEnable should
be changed from its default value of 'false'
to be 'true'.
 
Additional information about this type of LSP can be 
found in the MPLS LSR MIB and the MPLS Traffic 
Engineering MIB.
 
N.2. Label Distribution Protocol (LDP) LSPs
 
LDP LSPs are implicitly routed LSPs and therefore
most closely resembles traditional routing protocols, 
but, unlike protocols like BGP, the components of 
the LSP are found in the interfaces table.
 
Both active and redundant links can be discovered by 
reading in the interface table and matching against entries with
an ifType of mpls (166).  A value of 'true' for ifConnectorPresent
indicates that a link is active. Given the redundancy of
links as well as the potential for non-service affecting
changes in the operational status of component links, it
does not really make sense to monitor these interfaces for
linkDown notifications, so ifLinkUpDownTrapEnable has a
default value of disabled for this type of interface.
 
Additional information about this type of LSP can be 
found in the MPLS LSR MIB and the MPLS LDP MIB.

N.3. Single Hop Service LSPs

At the service level, there is a third type of LSPs in
single hop service LSPs (e.g. 2547 BGP, or extended 
LDP discovery). It is not a peer layer to TE and 
LDP, but an overlay. 

This type of LSP shows up in the interface table
as interfaces with ifType of mplsTunnel(150) layered
over interfaces with ifType of mpls(166). The ifStack
table will show the layering relationship between 
the LSPs.

Additional information about this type of LSP can be 
found in the MPLS LSR MIB, the MPLS LDP MIB and the
MPLS TE MIB.
-----

Sharon Chisholm
Portfolio Integration
Nortel Networks
Ottawa, Canada

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 16 Dec 2002 11:45:35 -0500

Thanks,
That's very helpful.

I'll massage it and work it. If I have any issues or questions, I'll come back
to you.

Adrian