Subject: RE: Last call on LSP Ping

From: "Gray, Eric" <[email-masked]>
Date: Mon, 9 Dec 2002 13:31:53 -0500

Eric,

	Hmmm, how about 0.0.0.0?

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

> -----Original Message-----
> From: Eric Rosen [mailto:[email-masked]]
> Sent: Monday, December 09, 2002 11:37 AM
> To: Gray, Eric
> Cc: [email-masked]'; [email-masked]
> Subject: Re: Last call on LSP Ping
> 
> 
> EricG> If there  is another reason for  using this address  range, it
> either
> EricG> has not been stated, or I missed it.
> 
> Well, what  should the tunnel ingress  put into the IP  destination field
> of
> the "LSP Ping" UDP packet?  We want  the packet to be consumed by the
> egress
> even if the egress  isn't who the ingress thinks it is.   (That's how we
> get
> the  error   response  indicating  that  the  tunneled   packets  have
> been
> misrouted.)  Thus  we need to  put in a  "well known" address which  will
> be
> interpreted by the tunnel egress as meaning "for me".
> 
> Use of one of the loopback addresses (127.x.y.z) seems to achieve this
> goal.
> I think it's kind of a nifty hack ;-)
> 
> As Curtis  has pointed out, there  is ample precedent for  having a
> tunneled
> packet  carry addressing  information  which  is to  be  interpreted in
> the
> context of the egress.

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 09 Dec 2002 13:46:00 -0500

In message <[email-masked]
> 	Hmmm, how about 0.0.0.0?

And the advantages are... ?

For ECMP the address range of 0.0.0.0/32 is a problem or were you
suggesting a larger subnet such as 0/8.  I think this is a lot worse
solution than 127/8.

Curtis