Subject: RE: Last Call on MPLS ping

From: "David Allan" <[email-masked]>
Date: Tue, 10 Dec 2002 13:43:07 -0500

Eric:

Someone else probably should be answering this but I would presume the
existence of the FEC stack is that for some implementations, only the PSN
label can be tested, not the actual PW label. SO the FEC stack proxies for
the inability to test the PW label, and some precision is lost as a result.
(esp. when considered in the context of the parallel ECMP discussion).

cheers
Dave

> -----Original Message-----
> From: Eric Rosen [mailto:[email-masked]]
> Sent: Monday, December 09, 2002 12:38 PM
> To: Alia Atlas
> Cc: [email-masked]
> Subject: Re: Last Call on MPLS ping 
> 
> 
> 
> Alia> So,  my concern  here  is  for the  case  where the  
> route  is not  an
> Alia> aggregate  and the label  indicates the  egress 
> attachment  circuit as
> Alia> well as the encapsulation header for the packet. 
> 
> Alia> In  this case,  LSP ping  would send  an IP  packet 
> with  the specific
> Alia> route's label and then the PSN's label. 
> 
> That isn't  my interpretation of the  draft.  I think the  
> intention is that
> the LSP  ping carries only  the "PSN label".   That is, it 
> carries  only the
> label  or labels  needed to  get it  to the  egress PE,  not 
> the  label that
> identifies a particular VPN route (or a particular PWE3 pseudowire). 
> 
> If  you wanted  to  know not  only whether  a  particular LSP 
>  leads to  the
> intended PE,  but also whether that PE  is a proper egress  
> for a particular
> VPN route (or PWE3  pseudowire), then I think you would need  
> to use the FEC
> stack TLV in the body of the message to identify that VPN route.
> 
> 
> Alia> I.e., consider if 
> Alia> a packet comes in with a PSN label, PW label, and then 
> an IPv4 Explicit 
> Alia> NULL, as specified in Section  5.3:
> Alia>     "To test an LSP that carries non-IP traffic, before 
> injecting ICMP
> Alia>     and MPLS ping messages into  the LSP, the IPv4 
> Explicit NULL label
> Alia>     should be prepended to such messages. The ingress 
> and egress LSR's
> Alia>     must follow the procedures defined in [LABEL-STACKING]"
> 
> 
> I'd  agree that  this is  a  strange passage  ;-) Remember  
> though that  the
> context is RSVP-TE only. I'd guess  that the purpose of the 
> explicit null is
> to counteract the effect of the RSVP-TE L3PID field. 
>

---

From: Shahram Davari <[email-masked]>
Date: Tue, 10 Dec 2002 10:55:26 -0800

> stack TLV in the body of the message to identify that VPN route.

But how do you test that the VPN route is bound to the proper PW label?

-Shahram