Subject: Creating labels when VRF defined?

From: John Smith <[email-masked]>
Date: Wed, 4 Jun 2003 11:19:35 +0100 (BST)

Hello,
What is the use of the aggregate label?

Why will we ever want to create and assign a label (i think they call it the aggregate
label) when a VRF is created?

I can understand the utility of assigning labels when some interfaces are bound to the
VRFs but not when only a VRF is created?

Any pointers on why we may want to do that?

Regards,
JS

__________________________________________________
Yahoo! Plus - For a better Internet experience
http://uk.promotions.yahoo.com/yplus/yoffer.html

---

From: "tricia ruggiero" <[email-masked]>
Date: Wed, 4 Jun 2003 09:46:53 -0400

if i understand your question - the aggregate label simply means the packet
arrives with the vpn label, it will be removed and the pe does not have
next-hop information, so it must do a fib lookup.
hth
tricia

-----Original Message-----
From: John Smith [mailto:[email-masked]]
Sent: Wednesday, 04 June, 2003 06:20
To: [email-masked]
Cc: [email-masked]
Subject: [MPLS-OPS]: Creating labels when VRF defined?

Hello,

Why will we ever want to create and assign a label (i think they call it the
aggregate
label) when a VRF is created?

I can understand the utility of assigning labels when some interfaces are
bound to the
VRFs but not when only a VRF is created?

Regards,
JS

-------
The MPLS-OPS Mailing List
Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

---

From: Rajiv Asati <[email-masked]>
Date: Wed, 04 Jun 2003 10:58:07 -0400

John,

>VRFs but not when only a VRF is created?

Agreed.

It might be vendor-specific.
Which platform you are seeing this on ?

Cheers,
Rajiv

---

From: David Charlap <[email-masked]>
Date: Wed, 04 Jun 2003 15:10:17 -0400

> Any pointers on why we may want to do that?

What about traffic destined for the PE router itself.

For instance, given a topology:

	CE1 ---- PE1 ---- {mpls cloud} --- PE2

Assuming that PE2 has a VRF that's configured to be a part of the same 
VPN that CE1 is in, CE2 can send traffic to PE2 (perhaps to an 
automatically-created loopback interface in that VRF).  In order to do 
this, the VRF on PE2 needs to have a label.

-- David