Subject: Re: LMP-MIB Module Compile Test

From: [email-masked]
Date: Tue, 10 Jun 2003 21:08:02 -0400

Hi Len,

This issue is discussed from time to time on the "mibs"
email list and you may want to take
a look at those email archives, or post the question to that
list.

Here's more info about the "mibs" IETF email list:

"A special mailing list has been created for generic/common MIB related
discussions, [email-masked]. To subscribe, send email to
[email-masked] with the word subscribe in the body. The mailing
lists archives will be at ftp://ftp.psg.com/pub/lists/mibs* "

I agree with you that there are extra steps (as you point out)
to get the MIB to compile once it is abstracted from the draft.

On the other hand, there are potential pitfalls with putting
a sub-Id in the MIB draft.  One of the issues is that 
the MIB, even though a draft document, gets coded it up this temporary
sub-id  even when you have a BIG disclaimer comment 
around the sub-Id, so this is one of the reasons that 
the XXX appears.

   -Joan

At 06:23 PM 6/10/03 -0400, Len Nieman wrote:
>For anyone interested, I ran a test compile of the LMP-MIB module
>extracted from draft-ietf-ccamp-lmp-mib-06.txt.
>
>For the TE-LINK-STD-MIB "IMPORT" I used the module extracted from
>draft-ietf-mpls-telink-mib-02.txt
>
>The tests were run using the MG-Soft compiler, version 4.0, build 459.
>
>There were only two minor problems due to "xxx" being used for values
>with assignments pending from IANA.
>
>In the LMP-MIB module I had to manually change the "mib-2 xxx" to "mib-2
>113" here:
>
>   DESCRIPTION
>       "Initial version published as RFC xxxx (to be assigned by RFC
>        Editor)"
>   ::= { mib-2 xxx } -- To be assigned by IANA (experimental 113 can
>                     -- be used in the interim)
>
>And in the TE-LINK-STD-MIB module I had to make a similar change of
>"transmission xxx" to "transmission 114" here:
>
> DESCRIPTION
>   "Initial version published as RFC xxxx (to be assigned by RFC
>    Editor)"
> ::= { transmission xxx } -- To be assigned by IANA (experimental 114
>                          -- can be used in the interim)
>
>With the "xxx"s out of the way, both modules compiled completed with no
>errors or warnings.
>
>After looking through a number of other drafts, I see this "xxx" place
>holder for numeric values is used quite a bit.
>
>It would be helpful, and cut down on the manual intervention needed to
>run compile tests, if a numeric value (999?) were specifically defined as
>"Pending assignment by IANA ("whatever ###" can be used in the interim)"
>for use in draft documents. Any thoughts on that?
>
>Len Nieman
>
>
>

---

From: Len Nieman <[email-masked]>
Date: Tue, 10 Jun 2003 18:23 -0400 (EDT)

DESCRIPTION

 DESCRIPTION

Len Nieman