Subject: Merging SE style reservations for make-before-break

From: jiri prekow <[email-masked]>
Date: Mon, 16 Jun 2003 14:09:28 -0700 (PDT)

Hi,

I have a confgiuration as follows-

R1========R2==========R3
\        /
 \      /
  \    /
   \R4/

lsp1 takes the path R1-R2-R3 with a reservation of 1M
At this time you do a make-before-break for lsp1 with
a lower bandwidth of say 500K, and it takes the path
R1-R4-R2-R3. When you get the resv at R2 it will have
a  
flow descriptor of 1M followed by 2 filter specs. When
R2 sends out a resv to R4 for the new
make-before-break lsp should the flow descriptor
contain a value of 500K or should it be 1M.

Thanks
Jiri

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

---

From: David Charlap <[email-masked]>
Date: Tue, 17 Jun 2003 10:02:02 -0400

jiri prekow wrote:
> R1-R4-R2-R3. When you get the resv at R2 it will have a  

1M.

The RSVP merging rules are pretty explicit.  For classical RSVP, where 
all reservations are made on the egress interface, you take the least 
upper bound of the incoming reservations (with is 1M in this case), 
reserve that and transmit that upstream towards your PHOP.

With MPLS, it's functionally the same.  You're not reserving only on the 
egress interface, so your internal reservations (ingress bandwidth, 
fabric bandwidth, egress bandwidth, connection, etc.) will be on a 
per-LSP basis with appropriate sharing where possible, but the Resv you 
send out will still be the least upper bound of its compponents.

After the original LSP is torn down (the "break" step of "make before 
break") then router R2 will re-sent its Resv message with a bandwidth of 
500K, since there is now only one LSP to merge.  R3 will see this and 
will change its reservation for the group at that time.

-- David