Subject: MPLS traffic-eng tunnel query!

From: Anurag Srivastava <[email-masked]>
Date: Thu, 24 Jul 2003 09:52:00 -0400 (EDT)

Hello,

I have a query regarding MPLS traffic-engg tunnel implementation in Cisco IOS.

Here are the tunnel details:
--------------------------------------------------------------------
!
interface Tunnel1
 ip unnumbered Loopback0
 no ip directed-broadcast
 no ip route-cache distributed
 tunnel destination x.x.x.x
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth  1000
 tunnel mpls traffic-eng path-option 1 explicit name path1
 tunnel mpls traffic-eng path-option 2 explicit name path2
--------------------------------------------------------------------

This MPLS tunnel is currently using path1 and I am interested in moving it on
to path2. Is there any method to achieve this in a hitless
(make-before-break or bridge-and-roll) or disruption free manner without
affecting the traffic for a long period of time?

One simple way to move traffic is to remove path-option 1 which would force
router to move the traffic to path-option 2 (or path2). However, for the period
path2 is signalled and setup, traffic will be disrupted.

Looking forward for a reply...

Thanks,
- Anurag

--
Anurag Srivastava
Network Software Research Center,
Bell Labs. Research.
(908)-582-0469

---

From: "Kellermann,Rurick" <[email-masked]>
Date: 24 Jul 2003 12:09:23 -0400

Arunag,

Try sending the question to [email-masked], as this distribution
list is not for deployment / vendor-specific issues.