Subject: draft-ietf-mpls-lsr-mib-11.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 14 Jul 2003 19:38:58 +0200

I get these problems pointed out:

  $ /bin/checkpage.awk < draft-ietf-mpls-lsr-mib-11.txt
  Long line at 4 with 73 chars, only spaces extra
  Long page at 59
  Long line at 2591 with 108 chars
  Long line at 2624 with 106 chars
  Long line at 3048 with 73 chars
  Long page at 3303
  -: 4 lines longer than 72 characters, max 108
  -: 2 pages longer than 58 lines, max 60 lines

The long line at lines 2591 and 2624 cause SMICng compile error:
  E: f(mplslsr.mi2), (1737,4) Syntax error

After I fix the above I get:
  W: f(mplslsr.mi2), (1569,1) Row "mplsInSegmentMapEntry" has
     indexing that may create variables with more than 128 sub-ids

For that you need to add some text to warn implementers that they
should make sure such does not happen. You can take a look at
   draft-ietf-sigtran-sctp-mib-10.txt
and search for string "128" to see an example of what type of
text needs to be added.

Thanks,
Bert

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 15 Jul 2003 04:25:32 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Wijnen, Bert (Bert)
> Sent: Monday, July 14, 2003 1:39 PM
> To: Mpls (E-mail)
> Subject: draft-ietf-mpls-lsr-mib-11.txt
> 
> 
> For that you need to add some text to warn implementers that 
> they should make sure such does not happen. You can take a look at

	Will change and re-post with the TC MIB right after
the meeting.

	--Tom