Subject: Question about BGP/MPLS VPNs with NHS disabled

From: Sachin Kalra <[email-masked]>
Date: Fri, 11 Jul 2003 15:55:09 -0400

Dear MPLS Community:

I would appreciate if someone can answer the following question about 
BGP-MPLS VPNs.

Lets say we have the following topology:

[CE1]                                                              [CE11]
         \                                                            /
          [PE1]-----------------[Rtr1]-------------------[PE2]
         /                                                            \
[CE2]                                                             [CE22]

1. Running IBGP between PE1 and PE2.
2. Running EBGP between all PEs and CEs.
3. BGP "Next Hop Self (NHS)" option is disabled on PEs.

Now, when PE1 receive a route from PE2, how will PE1 know "BGP Next Hop" 
address for that route? As NHS is disabled on PE2, the new route will have 
CE's address as "BGP Next Hop", and PE1 will not be able to find any LSP 
going to that CE.

Is this correct?

I appreciate your response.
Thanks,
Sachin Kalra

---

From: "Gopal@Yahoo" <[email-masked]>
Date: Sat, 12 Jul 2003 00:11:43 -0700 (PDT)

Sachin, You wrote "...As NHS is disabled on PE2, the
new route will have CE's address as "BGP Next Hop"....

That is not right. On remote-PE vpn-v4 route will not
have another vpnv4 addr as the next-hop. On PE-1
next-hop addr for vpnv4 routes will not be the CE
addr. The next-hop addr would some ipv4 addr of PE-2.

There is only one bgp session btw PE1 and PE2. For
ipv4 and vpn-v4 address family routes, the next-hop is
going to be a ipv4 address. If next-hop-self is
disabled, you need to config some ipv4 addr as the
next-hop. PE1 will use this ipv4 next-hop's label as
the outer label.
Does it answer your q?
cheers,
Gopal

--- Sachin Kalra <[email-masked]> wrote:
> [CE1]                                               
>               [CE11]
>          \                                          
>                  /
>          /                                          
>                  \
> [CE2]                                               
>              [CE22]

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

---

From: Gargi Nalawade <[email-masked]>
Date: Sat, 12 Jul 2003 09:46:31 -0700

Pe-2 need not have NHS in order to set itself as the nexthop. The PE-CE
session is eBGP & so the PE will always set tself as the nexthop.

-Gargi