Subject: RE: doubt in draft-ietf-mpls-ftn-mib-07.txt

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 29 Jul 2003 12:06:37 -0400

The advantage of specifying the TE tunnel head
interface is that for static routes, this is permanent
whereas the XCindex can change. Bear in mind that 
you can auto-route your IGP traffic over a TE
tunnel if that is the preferred route, so you may
also have dynamic entries pointing at a tunnel head
as well.

	--Tom

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of ramasamy ramanathan
> Sent: Monday, July 28, 2003 10:16 PM
> To: [email-masked]
> Subject: doubt in draft-ietf-mpls-ftn-mib-07.txt
> 
> 
> hi all,
> 
>    I have a doubt in mpls ftn mib draft( 
> draft-ietf-mpls-ftn-mib-07.txt), could u please explain me?
> 
> * mplsFTNActionType can take either redirectLSP or 
> redirectTunnel. If redirecTunnel is specified, then actionptr 
> will point to mplsTunnelEntry. So while forwarding the 
> packets,  mplsXCPtr which is there inside mplsTunnelEntry is 
> taken and then packet will be switched accordingly. If the 
> Action type is redirectLSP then ActionPtr points to 
> mplsXCEntry directly. so while forwarding this will be 
> directly referred.
> 
> If my above assumption is correct, what is the use of 
> specifying type as redirectTunnel? In either case mplsXCptr 
> will be used for switching right, so why can't it point to 
> mplsXCEntry always, what is the use of it pointing to redirectTunnel?
> 
> If my assumption is not correct, what is the difference 
> between redirectLSP and redirectTunnel, and in what scenario 
> each of these types will be used?
> 
> thanks
> rams.
> 
> 
> 
>

---

From: "ramasamy ramanathan" <[email-masked]>
Date: Mon, 28 Jul 2003 19:16:12 -0700

hi all,

   I have a doubt in mpls ftn mib draft( draft-ietf-mpls-ftn-mib-07.txt),
could u please explain me?

* mplsFTNActionType can take either redirectLSP or redirectTunnel. If
redirecTunnel is specified, then actionptr will point to mplsTunnelEntry. So
while forwarding the packets,  mplsXCPtr which is there inside
mplsTunnelEntry is taken and then packet will be switched accordingly. If
the Action type is redirectLSP then ActionPtr points to mplsXCEntry
directly. so while forwarding this will be directly referred.

If my above assumption is correct, what is the use of specifying type as
redirectTunnel? In either case mplsXCptr will be used for switching right,
so why can't it point to mplsXCEntry always, what is the use of it pointing
to redirectTunnel?

If my assumption is not correct, what is the difference between redirectLSP
and redirectTunnel, and in what scenario each of these types will be used?

thanks
rams.