Subject: [mpls] Fast Reroute - Path message onto a bypass tunnel

From: Harish Kumtakar <[email-masked]>
Date: Fri, 1 Oct 2004 11:25:24 +0100 (BST)

I've a question on draft
'draft-ietf-mpls-rsvp-lsp-fastreroute-07.txt'
The question is related to the Path message handling
sent over the bypass tunnel (facility backup) for the
protected LSP before/after failure. 

Consider the following example,

               [R1]---[R2]----[R3]----[R4]---[R5]
                          \\         //
                           [R6]===[R7]

                Protected LSP : [R1->R2->R3->R4->R5]
                Bypass LSP Tunnel: [R2->R6->R7->R4]

Section 7.4.4 of the draft says,

   More specifically, the PLR MUST:

     - remove all the sub-objects proceeding the first
address belonging
        to the MP.

     - replace this first MP address with an IP
address of the MP.
        (Note that this could be same address that was
just removed.)

So, the ERO of the Path message sent over the bypass
tunnel contains the IP address of MP (i.e R4) as its
sub-object. (My understanding is that, all the
sub-objects that appear before MP's address are
removed from ERO)

Now, when R6 recieves this Path message, as per the
ERO processing rules specified in Section 4.3.4 of RFC
3209:Extensions to RSVP for LSP Tunnels, should it not
return "Bad initial subobject" error to PLR R2? I know
I'm definitely missing something here OR my
understanding of the draft itself is partially
incorrect.

Please clear the grey area,

TIA, Regards,
-Harish

=====

________________________________________________________________________
Yahoo! India Matrimony: Find your life partner online
Go to: http://yahoo.shaadi.com/india-matrimony

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: Naiming Shen <[email-masked]>
Date: Fri, 01 Oct 2004 10:35:40 -0700

the trick is for R2 to send the path msg 'directly' to R4 through the
tunnel, not hop-by-hop.

 ] 
 ] I've a question on draft
 ] 'draft-ietf-mpls-rsvp-lsp-fastreroute-07.txt'
 ] The question is related to the Path message handling
 ] sent over the bypass tunnel (facility backup) for the
 ] protected LSP before/after failure. 
 ] 
 ] Consider the following example,
 ] 
 ]                [R1]---[R2]----[R3]----[R4]---[R5]
 ]                           \\         //
 ]                            [R6]===[R7]
 ] 
 ]                 Protected LSP : [R1->R2->R3->R4->R5]
 ]                 Bypass LSP Tunnel: [R2->R6->R7->R4]
 ] 
 ] Section 7.4.4 of the draft says,
 ] 
 ]    More specifically, the PLR MUST:
 ] 
 ]      - remove all the sub-objects proceeding the first
 ] address belonging
 ]         to the MP.
 ] 
 ]      - replace this first MP address with an IP
 ] address of the MP.
 ]         (Note that this could be same address that was
 ] just removed.)
 ] 
 ] So, the ERO of the Path message sent over the bypass
 ] tunnel contains the IP address of MP (i.e R4) as its
 ] sub-object. (My understanding is that, all the
 ] sub-objects that appear before MP's address are
 ] removed from ERO)
 ] 
 ] Now, when R6 recieves this Path message, as per the
 ] ERO processing rules specified in Section 4.3.4 of RFC
 ] 3209:Extensions to RSVP for LSP Tunnels, should it not
 ] return "Bad initial subobject" error to PLR R2? I know
 ] I'm definitely missing something here OR my
 ] understanding of the draft itself is partially
 ] incorrect.
 ] 
 ] Please clear the grey area,
 ] 
 ] TIA, Regards,
 ] -Harish
 ] 
 ] 
 ] =====
 ] 
 ]  
 ] 
 ] ________________________________________________________________________
 ] Yahoo! India Matrimony: Find your life partner online
 ] Go to: http://yahoo.shaadi.com/india-matrimony
 ] 
 ] _______________________________________________
 ] mpls mailing list
 ] [email-masked]
 ] https://www1.ietf.org/mailman/listinfo/mpls

- Naiming