Subject: RE: [mpls] For your review - Issues/errors/clarifications in RFC3 036

From: [email-masked]
Date: Fri, 8 Oct 2004 11:25:37 +0100

Loa,

I was meaning in general, ie labelled pkts.  Just want to check nothing
is being overlooked here.

regards, Neil

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]] 
> Sent: 08 October 2004 11:19
> To: Harrison,N,Neil,IKR2 R
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [mpls] For your review - 
> Issues/errors/clarifications in RFC3 036
> 
> 
> Neil,
> 
> are you talking about packets exchange over the TCP 
> connection between two LDP peers, or (labeled) packets in genral?
> 
> /Loa
> 
> [email-masked] wrote:
> > Eric,
> > <Snipped>
> >  
> > 
> >>Not if the downstream router sends a label withdraw as an 
> appropriate 
> >>recovery response to getting a packet with a label that is invalid.
> > 
> > 
> > Is there not a possibility that packets might end up at the wrong 
> > destination for other (defect) reasons?  And in such a case 
> sending a 
> > label withdraw seems the wrong action...comments?
> > 
> > regards, Neil
> > 
> > 
> > _______________________________________________
> > mpls mailing list
> > [email-masked] https://www1.ietf.org/mailman/listinfo/mpls
> > 
> > 
> 
> -- 
> Loa Andersson
> 
> Principal Networking Architect
> Acreo AB                           phone:  +46 8 632 77 14
> Isafjordsgatan 22                  mobile: +46 739 81 21 64
> Kista, Sweden                      email:  [email-masked]
>                                             [email-masked]
> 

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: Loa Andersson <[email-masked]>
Date: Fri, 08 Oct 2004 12:33:06 +0200

Neil,

guess that tht is a fair question, it should be looked into,
but I guess that it is out of scope for an update of the
LDP spec. (I didn't say "implemenation specific :) ). For
communication between LDP peers it is my take that we can
trust TCP, after all that was one of the reasons chosing
TCP.

Now, if the protocol exchange information in a correct
manner, but one implementation creates a label mapping
that is errornous, this is not something we can address
in the protocol specification, is it?

/Loa

-- 
Loa Andersson

---

From: Eric Gray <[email-masked]>
Date: Fri, 08 Oct 2004 18:05:28 -0400

Neil,

    What you ask should only be a concern if an implementation is either
sloppy in allocating labels or not particularly careful about re-allocating
them.

    There is a "window of opportunity" if an implementation re-issues labels
on a time scale similar to expected packet inter-arrival time for 
traffic using
that label (either before or after the re-issue). There is also a window of
opportunity if the same label is somehow issued in two separate contexts
and the LSR is not able to correctly recover context when it subsequently
receives  ambiguously labeled packets.

    The first window is avoidable by a robust implementation. The second
window only exists for a broken implementation.

    This is the reason why I feel we are making a big deal out of nothing
very much.

    :-)

--
Eric