Subject: RE: [mpls] LDP Multicast to WG Document

From: "Drake, John E" <[email-masked]>
Date: Mon, 6 Feb 2006 15:59:49 -0800

yes

> -----Original Message-----
> From: George Swallow [mailto:[email-masked]]
> Sent: Monday, February 06, 2006 4:51 AM
> To: [email-masked]
> Subject: [mpls] LDP Multicast to WG Document
> 
> It has been requested that
> 
> Label Distribution Protocol Extensions for Point-to-Multipoint and
>              Multipoint-to-Multipoint Label Switched Paths
>                  draft-minei-wijnands-mpls-ldp-p2mp-00
> 
> become a MPLS WG document.
> 
> Please indicate your support or objections by the end of this week.
> 
> Thanks,
> 
> ...George
> 
>
========================================================================
> George Swallow             Cisco Systems                  (978)
936-1398
>                            1414 Massachusetts Avenue
>                            Boxborough, MA 01719
> 
> 
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mpls

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "Leymann, Nicolai" <[email-masked]>
Date: Tue, 7 Feb 2006 21:38:32 +0100

Yes.

  Nic

> -----Ursprüngliche Nachricht-----
> Von: George Swallow [mailto:[email-masked]] 
> Gesendet: Montag, 6. Februar 2006 13:51
> An: [email-masked]
> Betreff: [mpls] LDP Multicast to WG Document
> 
> George Swallow             Cisco Systems                  
> (978) 936-1398

---

From: "Fang, Luyuan, ALABS" <[email-masked]>
Date: Mon, 13 Feb 2006 15:35:17 -0600

Support.

- Luyuan 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of George Swallow
Sent: Monday, February 06, 2006 7:51 AM
To: [email-masked]
Subject: [mpls] LDP Multicast to WG Document

Thanks,

...George

========================================================================
George Swallow             Cisco Systems                  (978) 936-1398
                           1414 Massachusetts Avenue
                           Boxborough, MA 01719

---

From: Cao Wei <[email-masked]>
Date: Tue, 14 Feb 2006 10:40:17 +0800

Salability is a important issue for multicast. The load will be very heavy to maintain

large number of multicast route entry in control plane. If used in MVPN  environment

mpls p2mp  will face to the requirement to support more and more VPNs. 

And I also think reconvergence is a tougher problem for multicast (PIM or other) 

than unicast. Currently unicast routing protocols already have many techniques

to reduce the impact of route change, but multicast depends on unicast 

and reconstructing forwarding tree needs more time. Further more, packet

loss caused by reconvergence have more impact on multicast traffic

than unicast traffic because of less of retransmitting mechanism for multicast

and the property of multicast application.

MPLS have bring a lot of benefit to unicast forwarding such as FRR and TE, 

I think it is good if mpls solution can do something for multicast in this

aspect. 

So I think more consideration at design stage on these aspects will show 

its advantage. 

Thanks. 

Have a good day!

----- Original Message ----- 
From: "Thomas Morin" <[email-masked]>
To: "IJsbrand Wijnands" <[email-masked]>
Cc: <[email-masked]>
Sent: Saturday, February 11, 2006 5:52 AM
Subject: Re: [mpls] LDP Multicast to WG Document

>I believe liushuying was perhaps more worried about control plane load,
> at reconvergence, for a high number of P2MP tunnels. 
> Though the concern is valid, I would say that things should roughly be
> comparable to what happens with PIM. But I think it is fair to say that
> this aspect requires consideration in the solution design.
> 
> Cheers,
> 
> -Thomas
> 
> IJsbrand Wijnands:
>> 
>> We have some ideas on how to minimize the traffic loss during  
>> switchover, but I'm not sure if we can prevent it without some kind of  
>> FRR mechanism.
>> 
>> Thx,
>> 
>> Ice.
>> 
>> BTW, I support make this a WG document.
>> 
>> 
>> On Feb 9, 2006, at 7:56 AM, liushuying wrote:
>> 
>> > Hi folks,
>> >     I support this draft becoming a WG document.
>> >
>> >     However,i am about to ask a  question.
>> >
>> >    1) 2.3.2.4.  Upstream LSR change
>> >
>> >    If, for a given node Z participating in a P2MP LSP <X, Y>, the
>> >    upstream LSR changes, say from U to U', then Z MUST update its
>> >    forwarding state by deleting the state for label L, allocating a new
>> >    label, L', for <X,Y>, and installing the forwarding state for L'.   
>> > In
>> >    addition Z MUST send a Label Map <X, Y, L'> to U' and send a Label
>> >    Withdraw <X, Y, L> to U.
>> >
>> >   The question:
>> >   When a large quantity of P2MP LSPs exists in MPLS networks,
>> >   if unicast routing information changes, there may be many LSRs
>> >   whose upstream LSRs have changed in every P2MP LSP, each of them  
>> > sends a Label Withdraw message
>> >   to its old upstream LSR and a Label Map message to its new upstream  
>> > LSR  at the same time,
>> >   so the load of every LSR will enhance sharply and last for a long  
>> > time.
>> >   As a result, the time of traffic disruption in every P2MP LSP will  
>> > last for a long time,
>> >   and so many packets will be lost.
>> >
>> >   Thanks
>> >   Shuying Liu
>> >
>> >
>> > ----- Original Message -----
>> >> Date: Mon, 06 Feb 2006 07:50:51 -0500
>> >> From: George Swallow <[email-masked]>
>> >> Message-ID: <[email-masked]>
>> >>
>> >> ------------------------------
>> >>

---

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Tue, 14 Feb 2006 09:42:37 +0100

Hi Cao
 
>MPLS have bring a lot of benefit to unicast forwarding such as FRR and TE, 
 
Here you are refering to MPLS-TE, and not LDP-based MPLS. Note that unicast LDP does not improve unicast routing, and the same actually applies for multicast....

>aspect. 
 
If you want FRR and TE you can rely on P2MP RSVP-TE.
 
Regards,
 
JL

________________________________

	De : [email-masked] [mailto:[email-masked]] De la part de Cao Wei
	Envoyé : mardi 14 février 2006 03:40
	À : [email-masked]
	Cc : MORIN Thomas RD-CORE-LAN
	Objet : Re: [mpls] LDP Multicast to WG Document

	

	

	

	

	aspect. 

	
	its advantage. 

	Thanks. 
	
	Have a good day!