Subject: Re: [mpls] LDP Multicast to WG Document

From: liushuying <[email-masked]>
Date: Thu, 09 Feb 2006 14:56:07 +0800

Hi folks,
    I support this draft becoming a WG document.

    However,i am about to ask a  question.

   1) 2.3.2.4.  Upstream LSR change

   If, for a given node Z participating in a P2MP LSP <X, Y>, the
   upstream LSR changes, say from U to U', then Z MUST update its
   forwarding state by deleting the state for label L, allocating a new
   label, L', for <X,Y>, and installing the forwarding state for L'.  In
   addition Z MUST send a Label Map <X, Y, L'> to U' and send a Label
   Withdraw <X, Y, L> to U.

  The question:
  When a large quantity of P2MP LSPs exists in MPLS networks, 
  if unicast routing information changes, there may be many LSRs 
  whose upstream LSRs have changed in every P2MP LSP, each of them sends a Label Withdraw message 
  to its old upstream LSR and a Label Map message to its new upstream LSR  at the same time, 
  so the load of every LSR will enhance sharply and last for a long time. 
  As a result, the time of traffic disruption in every P2MP LSP will last for a long time, 
  and so many packets will be lost.  
    
  Thanks 
  Shuying Liu         

----- Original Message ----- 
> Date: Mon, 06 Feb 2006 07:50:51 -0500
> From: George Swallow <[email-masked]>
> Subject: [mpls] LDP Multicast to WG Document
> To: [email-masked]
> Message-ID: <[email-masked]>
> 
> It has been requested that 
> 
> Label Distribution Protocol Extensions for Point-to-Multipoint and
>             Multipoint-to-Multipoint Label Switched Paths
>                 draft-minei-wijnands-mpls-ldp-p2mp-00
> 
> become a MPLS WG document.
> 
> Please indicate your support or objections by the end of this week.
> 
> Thanks,
> 
> ...George
> 
> ========================================================================
> George Swallow             Cisco Systems                  (978) 936-1398
>                           1414 Massachusetts Avenue
>                           Boxborough, MA 01719
> 
> 
> 
> 
> 
> ------------------------------
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mpls
>

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: IJsbrand Wijnands <[email-masked]>
Date: Thu, 9 Feb 2006 10:11:21 +0100

Hi Shuying,

We have some ideas on how to minimize the traffic loss during  
switchover, but I'm not sure if we can prevent it without some kind of  
FRR mechanism.

Thx,

Ice.

BTW, I support make this a WG document.

---

From: Thomas Morin <[email-masked]>
Date: Fri, 10 Feb 2006 22:52:51 +0100

I believe liushuying was perhaps more worried about control plane load,
at reconvergence, for a high number of P2MP tunnels. 
Though the concern is valid, I would say that things should roughly be
comparable to what happens with PIM. But I think it is fair to say that
this aspect requires consideration in the solution design.

Cheers,

-Thomas

---

From: IJsbrand Wijnands <[email-masked]>
Date: Mon, 13 Feb 2006 10:37:54 +0100

Hi Thomas,

> this aspect requires consideration in the solution design.

LDP uses TCP to send the label mappings to its peers. So in case of a  
large number of P2MP LSP we will take maximum benefit of the flow  
control en reliability in TCP, I don't think we can do better then  
that. I think the real problem behind the need to send many updates is  
that during that time, which increases with the number of updates, you  
have traffic loss.

Thx,

Ice.

>>>> ==================================================================== 
>>>> ==
>>>> ==