Subject: [mpls] mplsTunnelInstance in MPLS TE MIB

From: Daniel Chuang <[email-masked]>
Date: Tue, 26 Sep 2006 12:11:22 -0700

Hi,

   In the rfc3812(TE)/rfc3811(TC) mib, mplsTunnelInstance definition 
mentions:

When the MPLS signaling protocol is
rsvp(2) this value SHOULD be equal to the LSP Id
of the Sender Template object.

This is 'SHOULD',  but  based on rfc2119 definition:

3. SHOULD   This word, or the adjective "RECOMMENDED", mean that there
   may exist valid reasons in particular circumstances to ignore a
   particular item, but the full implications must be understood and
   carefully weighed before choosing a different course.

What is the valid reason for not being 'MUST' then any internal/other
value can be used as vendors see fit ?

thanks,
Daniel

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 26 Sep 2006 15:56:30 -0400

I am glad that you guys are finally getting
around to implementing the MPLS-TE-MIB. *)

	To answer your question, the use of SHOULD
in the text is there to denote that "most of the time"
this is the recommended usage. In practice, we also
made this recommendation based on how the implementations
at the time chose the contents of that value. The idea
is that the indexes are most useful when they correlate
as closely as possible to the signaled values. Also,
the SHOULD here denotes the fact that the exceptional
case of mplsTunnelInstance=0 denotes a tunnel head,
and thus in this case does not correlate to any Sender
Template object.

	--Tom