Subject: RE: [mpls] Question regarding LDP session setup

From: <[email-masked]>
Date: Fri, 29 Sep 2006 15:40:53 +0200

Hi Luca,

Just a small observation which may or may not be relevant: If both links are connected to the same two routers via ethernet and are operating in raw mode, then its likely that the LDP Identifiers will be identical as you say. The first 4 octets will probably  be the router ID ( Loopback address in this case) and the Label Space ID, in accordance to RFC 3036, will be zero for per platform labels for ethernet. Hence 1 TCP connection.

Cheers

santanu

Santanu Ganguly
Swisscom Fixnet Wholesale AG
Binz-Ring 17
Zurich
Switzerland 

-----Original Message-----
From: Fantolino Luca [mailto:[email-masked]] 
Sent: Thursday, September 28, 2006 4:18 PM
To: Kishore Tiruveedhula
Cc: [email-masked]
Subject: RE: [mpls] Question regarding LDP session setup

Thanks for your reply.

I verified again the content of the LDP messages: both report the same LDP ID (the loopback address) and same Label Space ID (0).

In this case I understand you expect a single TCP connection be created.

bye
Luca

-----Original Message-----
From: Kishore Tiruveedhula [mailto:[email-masked]]
Sent: mercoledì 27 settembre 2006 18:42
To: Tempia Bonda Alberto; [email-masked]
Cc: Fantolino Luca
Subject: RE: [mpls] Question regarding LDP session setup

If the both links uses the same local LDP ID (LSR Id:label space id), then it should create single LDP session (single TCP connection).

I guess your case might be something like below:

If Router A (assuming passive) LDP ID on link1 is Ra:La1, on link2 is Ra:La2 and Router B (assuming Active) LDP ID on both links is same Rb:Lb.

Router A link1 (LDP ID is Ra:La1) <--> Router B link1 (LDP ID is Rb:Lb) Router A link2 (LDP ID is Ra:La2) <--> Router B link2 (LDP ID is Rb:Lb)

In this case, Router B opens two TCP connections and Router B accepts both connections, but it may be accepted the TCP connections
      link1 of Router A to link2 of Router B  and
      link2 of Router A to link1 of Router B.

In this case, the session initialization fails when it verifies the Initialization message with its Hello adjacency ( by using Receiver LDP Identifier in CommonSession Parameter TLV).

Thanks,
Kishore

-----Original Message-----
From: Tempia Bonda Alberto [mailto:[email-masked]]
Sent: Wednesday, September 27, 2006 11:21 AM
To: [email-masked]
Cc: Fantolino Luca
Subject: [mpls] Question regarding LDP session setup

Hello,

I have a question about LDP session establishment between two LSRs connected by multiple links.
A problem has occurred in the network during LDP session set up between two routers linked by two Ethernet LANs. Below I describe the behavior.

 1. Router A sends a LDP HELLO message on each Ethernet link at the same time; the two messages are identical, including the router ID and the source IP address (IP address assigned to an internal interface).

 2. Router B tries to open two TCP connections with router A on port
646: it sends two TCP SYN packets (using two different local ports).

 3. Router A accepts both connections (TCP SYN ACK) and router B completes the TCP connections set up (TCP ACK): two TCP connections are now available for LDP message exchange.

 4. Router B (active role) sends two copies of the same LDP INITIALIZATION message to router A through the two TCP connections.

 5. Router A sends a LDP INITIALIZATION message on the first TCP connection and clears the second TCP connection (TCP FIN).

 6. Router A sends a LDP NOTIFICATION message with E-bit set and then resets the second TCP connection.

What happens is that two TCP connections are created and Router B tries to open two separate LDP sessions. It tries to open a second LDP session when the first one is not yet established with the result that router A closes both TCP connections and no LDP session is set up.

It is not clear to me whether this behavior is correct according to RFC 3036. In particular, is it correct that two TCP sessions are created and a router tries to open two LDP sessions (it sends two LDP INITIALIZATION
messages) with the same peer?

Thanks,
Alberto and Luca
--------------------------------------------------------------------

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited.
Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it

--------------------------------------------------------------------

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

--------------------------------------------------------------------

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it

--------------------------------------------------------------------

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: <[email-masked]>
Date: Fri, 29 Sep 2006 16:45:33 +0200

Hi,

As for different transport addresses, its true that RFC 3036 does not
seem to specify which one to pick for connectivity. However, it does say
the following:

"  Note that when an LSR sends a Hello it selects the transport address
   for its end of the session connection and uses the Hello to advertise
   the address, either explicitly by including it in an optional
   Transport Address TLV or implicitly by omitting the TLV and using it
   as the Hello source address.

   An LSR MUST advertise the same transport address in all Hellos that
   advertise the same label space.  This requirement ensures that two
   LSRs linked by multiple Hello adjacencies using the same label spaces
   play the same connection establishment role for each adjacency."

Thanks

santanu

-----Original Message-----
From: Kishore Tiruveedhula [mailto:[email-masked]] 
Sent: Friday, September 29, 2006 4:04 PM
To: Bob Thomas
Cc: Fantolino Luca; [email-masked]
Subject: RE: [mpls] Question regarding LDP session setup 

Hi Bob,
    If the transport addresses are same, then active router can attempt
single TCP connection, agree with Pranjal.

If the transport addresses differ, then RFC3036 is not clear which one
to pick for TCP connection or attempt multiple TCP connections.

And there is one more problem that both routers may become Active or
both may become passive if both links advertises the different transport
addresses in such way that first adjacency transport address is higher
and second transport address is lower.

Thanks,
Kishore

-----Original Message-----
From: Dutta, Pranjal [mailto:[email-masked]]
Sent: Thursday, September 28, 2006 11:26 PM
To: Bob Thomas; Kishore Tiruveedhula
Cc: Fantolino Luca; [email-masked]
Subject: RE: [mpls] Question regarding LDP session setup

Hi Bob,
        It is well understood that the passive router has to close the
second or subsequent TCP connection requests for the same LDP session.
But
If the passive router advertises one LDPID (single label space) from it
then I don't see any reason for the active one to trigger up multiple
TCP connections.  The active router has to initiate only one TCP
connection for remote LDPID, although multiple hello adjacencies may
exist for the same LDPID.

Thanks,
Pranjal

-----Original Message-----
From: Bob Thomas [mailto:[email-masked]]
Sent: Friday, 29 September, 2006 4:10 AM
To: Kishore Tiruveedhula
Cc: Fantolino Luca; [email-masked]
Subject: Re: [mpls] Question regarding LDP session setup

Hi Kishore,

> Date: Thu, 28 Sep 2006 11:49:22 -0400
> Cc: [email-masked]
>
> Luca,
>    Yes. I expect single TCP connection.

RFC3036 is silent on this point.

RFC3036 specifies a single session between the 2 routers in this
situation but places no limit on the number of connections the active
router may attempt to open in order to establish the single session.

This leaves the router playing the passive role with the job of
selecting one connection for the session and closing the other(s).

Bob

> Sent: Thursday, September 28, 2006 10:18 AM
> To: Kishore Tiruveedhula
> Cc: [email-masked]; Tempia Bonda Alberto
> I verified again the content of the LDP messages: both report the same
=
> LDP ID (the loopback address) and same Label Space ID (0).
>
> From: Kishore Tiruveedhula [mailto:[email-masked]]=20
> Sent: mercoled=EC 27 settembre 2006 18:42
> If the both links uses the same local LDP ID (LSR Id:label space id),
=
> then
> it should create single LDP session (single TCP connection).
>
> If Router A (assuming passive) LDP ID on link1 is Ra:La1, on link2 is
=
> Ra:La2
> and
> Router B (assuming Active) LDP ID on both links is same Rb:Lb.
>
>
> Router A link1 (LDP ID is Ra:La1) <--> Router B link1 (LDP ID is
Rb:Lb)
> Router A link2 (LDP ID is Ra:La2) <--> Router B link2 (LDP ID is
Rb:Lb)
>
>
> In this case, Router B opens two TCP connections and Router B accepts
=
> both
> connections,
> but it may be accepted the TCP connections
> In this case, the session initialization fails when it verifies the 
> Initialization message with its Hello adjacency ( by using Receiver
LDP
> Identifier in CommonSession Parameter TLV).
>
>
> Thanks,
> Kishore
>
> From: Tempia Bonda Alberto
[mailto:[email-masked]]
> A problem has occurred in the network during LDP session set up
between
> two routers linked by two Ethernet LANs. Below I describe the
behavior.
>
>  1. Router A sends a LDP HELLO message on each Ethernet link at the
same
> time; the two messages are identical, including the router ID and the 
> source IP address (IP address assigned to an internal interface).
>
>  3. Router A accepts both connections (TCP SYN ACK) and router B 
> completes the TCP connections set up (TCP ACK): two TCP connections
are
> now available for LDP message exchange.
>
>  4. Router B (active role) sends two copies of the same LDP 
> INITIALIZATION message to router A through the two TCP connections.
>
>  5. Router A sends a LDP INITIALIZATION message on the first TCP 
> connection and clears the second TCP connection (TCP FIN).
>
> What happens is that two TCP connections are created and Router B
tries
> to open two separate LDP sessions. It tries to open a second LDP
session
> when the first one is not yet established with the result that router
A
> closes both TCP connections and no LDP session is set up.
>
> It is not clear to me whether this behavior is correct according to
RFC
> 3036. In particular, is it correct that two TCP sessions are created
and
> a router tries to open two LDP sessions (it sends two LDP
INITIALIZATION
> This message and its attachments are addressed solely to the persons =

> above and may contain confidential information. If you have received 
> the = message in error, be informed that any use of the content hereof

> is
prohibited.
> Please return it immediately to the sender and delete the message. = 
> Should you have any questions, please contact us by replying to 
> [email-masked].
>
>         Thank you
>
>                                         www.telecomitalia.it
>
> This message and its attachments are addressed solely to the persons =

> above and may contain confidential information. If you have received
the =
> message in error, be informed that any use of the content hereof is = 
> prohibited. Please return it immediately to the sender and delete the
=
> message. Should you have any questions, please contact us by replying
to =
> [email-masked].
>
>         Thank you
>
>                                         www.telecomitalia.it
>
>                        =20