Subject: RE: [mpls] RE: Comments on draft-leroux-mpls-p2mp-te-bypass-00.txt

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Thu, 9 Nov 2006 18:13:40 +0100

Hi Kireeti, 

Please see in-line

> -----Message d'origine-----
> De : Kireeti Kompella [mailto:[email-masked]] 
> Envoyé : mercredi 8 novembre 2006 20:56
> À : LE ROUX Jean-Louis RD-CORE-LAN
> Cc : [email-masked]
> Objet : Re: [mpls] RE: Comments on 
> draft-leroux-mpls-p2mp-te-bypass-00.txt
> 
> Hi Jean-Louis,
> 
> To re-iterate my comment in the WG, in general, node 
> protection, whether for p2p or p2mp LSPs, is an order of 
> magnitude less scalable than link protection.

You are right. If D is the average node degree, link protection scales as 0(D) and node protection scales as 0(D^2)... 

> 
> I think we should step back at this point, and request SPs 
> and others deploying MPLS networks to share with the WG: 
> frequencies of link failures, node software failures (node 
> recovers), node failures (requires manual intervention), and 
> battery explosions, to give us a sense of the importance of 
> continuing the work on node protection.

I know several SPs, including Orange, who deployed FRR node protection for P2P LSPs,
and want the same level of protection for P2MP LSPs, particularly for TV broadcasting.

By the way I don't think that SPs are likely to share failure occurrence frequencies in the IETF, these are critical figures...

The approach sounds actually a bit surprising to me: The IETF worked on P2P FRR node protection, it has been implemented, deployed, SPs are happy with this feature. And now you want to step back as P2MP node protection may be a bit more complex...

Note that P2MP node protection may rely on a single P2MP Bypass per PLR, whose set of Leaf LSRs equals the set of PLR NNHOP, (ie a superset of the protected P2MP LSP downstream LSRs). So it can scale as P2P node protection...

> 
> I realize that some of these figures may be sensitive, 

YES :-)

>but 
> even normalized numbers may be useful.

The fact that link failure frequency is an order of magnitude higher than node failure frequency, does definitely not imply that we don't need node protection. 

Best Regards,

JL

> Kireeti.
> -------

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: Kireeti Kompella <[email-masked]>
Date: Thu, 9 Nov 2006 10:21:11 -0800 (PST)

> Please see in-line

Thanks for your comments.

> The approach sounds actually a bit surprising to me: The IETF worked 
> on P2P FRR node protection, it has been implemented, deployed, SPs 
> are happy with this feature. And now you want to step back as P2MP 
> node protection may be a bit more complex...

Well, I had the same opinion for p2p; in retrospect, I wish I had 
raised the point then.  P2MP just makes this a bit more complex.

But, to repeat, I'm not against node protection.  I just want 
validation from SPs that the additional complexity etc. of node 
protection is required.  You said yes; Mazen said no.  Others have yet 
to speak.  If SPs were to themselves step back and reconsider how they 
really want to protect nodes, that would be a bonus.

Finally, this is not a call for consensus, just a request for 
information.  Whether or not we work on this depends on the WG chairs, 
which I am not :-)

Kireeti.
-------