Subject: Re: [mpls] wg last call on draft-ietf-mpls-ldp-igp-sync-01.txt

From: "Luyuan Fang (lufang)" <[email-masked]>
Date: Thu, 1 May 2008 22:02:30 -0400

Priyanka and Gaurav,
 
Yes, discouraging IP forwarding over the link is to prevent labeled
traffic being blackholed, not to help LDP session establishment. 
 
The draft is intend to prevent all three types of failure scenarios.
Nothing is 100%, but good equipment implementation and good operational
procedures would help.
 
Thanks,
Luyuan

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of gaurav gupta
	Sent: 17 April 2008 12:07
	To: priyanka gupta; [email-masked]
	Subject: Re: [mpls] wg last call on
draft-ietf-mpls-ldp-igp-sync-01.txt

	Hi Priyanka,
	
	Discouraging IP forwarding over a link does not help in LDP
session establishment. Discouraging IP forwarding over a link only
prevents traffic loss if IGP is up over a link but LDP bindings are not
already exchanged. The draft mentions 3 reasons for a potential
black-holing of traffic: configuration error, implementation bug or the
reason which I just mentioned above. To my understanding the draft only
prevents from the 3rd reason.
	
	Hope this helps.

	Thanks, 
	Gaurav 

	----- Original Message ----
	From: priyanka gupta <[email-masked]>
	To: [email-masked]
	Sent: Thursday, April 17, 2008 4:21:22 AM
	Subject: Re: [mpls] wg last call on
draft-ietf-mpls-ldp-igp-sync-01.txt

	Comments:
	I am not able to understand that how discouraging the IP
forwarding over a link where LDP is not fully established help in LDP
session establishment.
	As you mentioned the reason for blackhole could be
-configuration error or - An implementation bug.   
	Can you help me in uderstanding this.
	Secondly,
	"It is recommended this that both side of a link implement
mechanism to be effective and to avoid asymmetric link costs which could

	   cause problems with IP multicast forwarding."
	what exactly mean by IP multicast forwarding problems?

________________________________

	Bollywood, fun, friendship, sports and more. You name it, we
have it.
<http://in.rd.yahoo.com/tagline_groups_1/*http://in.promos.yahoo.com/gro
ups/bestofyahoo/> 

________________________________

	Be a better friend, newshound, and know-it-all with Yahoo!
Mobile. Try it now.
<http://us.rd.yahoo.com/evt=51733/*http://mobile.yahoo.com/;_ylt=Ahu06i6
2sR8HDtDypao8Wcj9tAcJ> 

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: "Luyuan Fang (lufang)" <[email-masked]>
Date: Thu, 1 May 2008 22:10:47 -0400

I meant to say to prevent traffic loss from...
Thanks,
Luyuan

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Luyuan Fang (lufang)
	Sent: 01 May 2008 22:03
	To: gaurav gupta; priyanka gupta; [email-masked]
	Subject: Re: [mpls] wg last call on
draft-ietf-mpls-ldp-igp-sync-01.txt

	Priyanka and Gaurav,
	 
	Yes, discouraging IP forwarding over the link is to prevent
labeled traffic being blackholed, not to help LDP session establishment.

	The draft is intend to prevent all three types of failure
scenarios. Nothing is 100%, but good equipment implementation and good
operational procedures would help.
	 
	Thanks,
	Luyuan

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of gaurav gupta
		Sent: 17 April 2008 12:07
		To: priyanka gupta; [email-masked]
		Subject: Re: [mpls] wg last call on
draft-ietf-mpls-ldp-igp-sync-01.txt

		Hi Priyanka,
		
		Discouraging IP forwarding over a link does not help in
LDP session establishment. Discouraging IP forwarding over a link only
prevents traffic loss if IGP is up over a link but LDP bindings are not
already exchanged. The draft mentions 3 reasons for a potential
black-holing of traffic: configuration error, implementation bug or the
reason which I just mentioned above. To my understanding the draft only
prevents from the 3rd reason.
		
		Hope this helps.

		Thanks, 
		Gaurav 

		----- Original Message ----
		From: priyanka gupta <[email-masked]>
		To: [email-masked]
		Sent: Thursday, April 17, 2008 4:21:22 AM
		Subject: Re: [mpls] wg last call on

		Comments:
		I am not able to understand that how discouraging the IP
forwarding over a link where LDP is not fully established help in LDP
session establishment.
		As you mentioned the reason for blackhole could be
-configuration error or - An implementation bug.   
		Can you help me in uderstanding this.
		Secondly,
		"It is recommended this that both side of a link
implement mechanism to be effective and to avoid asymmetric link costs
which could 
		   cause problems with IP multicast forwarding."
		what exactly mean by IP multicast forwarding problems?

		Bollywood, fun, friendship, sports and more. You name
it, we have it.
<http://in.rd.yahoo.com/tagline_groups_1/*http://in.promos.yahoo.com/gro
ups/bestofyahoo/> 

		Be a better friend, newshound, and know-it-all with
Yahoo! Mobile. Try it now.
<http://us.rd.yahoo.com/evt=51733/*http://mobile.yahoo.com/;_ylt=Ahu06i6
2sR8HDtDypao8Wcj9tAcJ>