Subject: [mpls] proposed charter update for the MPLS TP work

From: Loa Andersson <[email-masked]>
Date: Fri, 09 May 2008 12:56:45 +0200

MPLS, CCAMP and PWE3 working groups,

The Joint Working Team of the IETF and ITU-T has resulted in
the agreement to create a Transport Profile for MPLS (MPLS TP).
This effort requires the MPLS, PWE3 and CCAMP Working Groups
are chartered to do the required work.

The MPLS, PWE3 and CCAMP chairs proposes that we add the
following paragraph to the three working group charters:

   "- Include extensions to the [MPLS, PWE3, CCAMP] protocols and RFCs
      necessary to fulfill an MPLS Transport Profile (MPLS TP), the work
      on the MPLS TP needs to be coordinated between the three working
      groups (MPLS, PWE3 and CCAMP) that are chartered to do MPLS TP
      work."

Please send your comments to the working group(s) mailing list(s)
eob Friday May 16.

Adrian, Deborah, Danny, Stewart, George and Loa

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                            [email-masked]
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: "Shahram Davari" <[email-masked]>
Date: Fri, 9 May 2008 14:51:50 -0400

Hi Loa,

The term "extension" is not very appropriate. It doesn't cover the possible
case of MPLS TP requiring a reduction in MPLS functionality? 

How about changing that to "extensions and reductions"

Regards,
-Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa
Andersson
Sent: May-09-08 6:57 AM
To: ccamp; [email-masked]; pwe3
Subject: [mpls] proposed charter update for the MPLS TP work

-- 
Loa Andersson

---

From: "Shahram Davari" <[email-masked]>
Date: Fri, 9 May 2008 16:26:39 -0400

Hi Loa,

Just a clarification. The term reduction means components of the MPLS
architecture left unused. 

Regards,
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Shahram Davari
Sent: May-09-08 2:52 PM
To: 'Loa Andersson'; 'ccamp'; [email-masked]; 'pwe3'
Subject: Re: [mpls] proposed charter update for the MPLS TP work

Hi Loa,

Regards,
-Shahram

-----Original Message-----

-- 
Loa Andersson

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 09 May 2008 21:52:17 +0100

I think it was fine as it was. We are not going to do and unnecessary 
extensions, and we are not going to remove any functionality that is 
already in there because we need it for other applications.

We could perhaps say:

"Include necessary extensions ...." to make it completely clear.

Stewart

---

From: George Swallow <[email-masked]>
Date: Fri, 09 May 2008 17:21:12 -0400

We are not reducing anything in the MPLS architecture and protocols.  There
will be a few extension.  The Transport Profile will define a profile of the
MPLS architecture and that is were the reduction comes.

...George

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 9 May 2008 22:31:12 +0100

Hi,

Perhaps...
OLD
Include extensions to the [MPLS, PWE3, CCAMP] protocols
NEW
Include modifications and extensions to the [MPLS, PWE3, CCAMP] protocols 
and procedures

Adrian

----- Original Message ----- 
From: "Stewart Bryant" <[email-masked]>
To: "Shahram Davari" <[email-masked]>
Cc: "'ccamp'" <[email-masked]>; <[email-masked]>; "'pwe3'" 
<[email-masked]>
Sent: Friday, May 09, 2008 9:52 PM
Subject: Re: [PWE3] [mpls] proposed charter update for the MPLS TP work

>> Loa
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>

---

From: Loa Andersson <[email-masked]>
Date: Mon, 12 May 2008 09:33:39 +0200

All,

Adrian Farrel wrote:
> Include modifications and extensions to the [MPLS, PWE3, CCAMP] 
> protocols and procedures

my take on this that we are talking about "extensions" relative the
the existing specification, it is quite possible for an extension to
leave "components of the MPLS architecture unused", that is in
fact the case with most of our documents.

Consequently I agree with Stewart, and would oppose words like,
reduce and modify, since that implies that we intend to *change*
the MPLS architecture, while one of the foundations of the
agreement to create an MPLS TP was that it should fit into the
MPLS architecture.

/Loa
> 
> Adrian
> 
> ----- Original Message ----- From: "Stewart Bryant" <[email-masked]>

-- 
Loa Andersson

---

From: <[email-masked]>
Date: Mon, 12 May 2008 12:55:50 +0100

Loa/Adrian/Stewart,

I think it would be really useful if someone could summarise what
specific proposals/options are being considered for MPLS-TP.  In
particular, given:
-	most operators would regard an OOB CP as an essential component
of a transport network (and this is a forced requirement in the co-cs
mode anyway);
-	GMPLS already uses an OOB CP and there is a long-standing CCAMPs
charter item to unify the GMPLS/MPLS CPs;
-	I believe re-using common CP techniques would also be of
interest to many operators;
then it would appear that the MPLS-TP initiative provides a very good
opportunity to address this.

Any comments?

regards, Neil 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Loa Andersson
> Sent: 12 May 2008 08:34
> To: Adrian Farrel
> Cc: [email-masked]; Shahram Davari; 'ccamp'; [email-masked]; 'pwe3'
> my take on this that we are talking about "extensions" 
> relative the the existing specification, it is quite possible 
> for an extension to leave "components of the MPLS 
> architecture unused", that is in fact the case with most of 
> our documents.
> 
> Consequently I agree with Stewart, and would oppose words 
> like, reduce and modify, since that implies that we intend to 
> *change* the MPLS architecture, while one of the foundations 
> of the agreement to create an MPLS TP was that it should fit 
> into the MPLS architecture.
> 
> /Loa
> > 
> > Adrian
> > 
> >>> Just a clarification. The term reduction means components of the 
> >>> MPLS architecture left unused.
> >>>
> >>> Regards,
> >>> Shahram
> >>>
> >>> From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> >>> Of Shahram Davari
> >>> Sent: May-09-08 2:52 PM
> >>> From: [email-masked] 
> [mailto:[email-masked]] On Behalf
> >>> Of Loa
> >>> Andersson
> >>> Sent: May-09-08 6:57 AM
> >>> The Joint Working Team of the IETF and ITU-T has resulted in the 
> >>> agreement to create a Transport Profile for MPLS (MPLS TP). This 
> >>> effort requires the MPLS, PWE3 and CCAMP Working Groups are 
> >>> chartered to do the required work.
> >>>
> following 
> >>> paragraph to the three working group charters:
> >>>

---

From: "Sprecher, Nurit (NSN - IL/Israel - MiniMD)" <[email-masked]>
Date: Fri, 9 May 2008 17:53:19 +0200

I support the extension in the charters of the three WGs. 
Best regards,
Nurit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Loa Andersson
Sent: Friday, May 09, 2008 13:57
To: ccamp; [email-masked]; pwe3
Subject: proposed charter update for the MPLS TP work

-- 
Loa Andersson