Subject: Re: [mpls] Doubt related to RFC 5036

From: priyanka gupta <[email-masked]>
Date: Fri, 16 May 2008 09:05:42 +0530 (IST)

thx Shahram.
but still i am not clear on the point that can i bunch number of FEC as well as same number of label associated with the different FECs in the same label mapping??
Hop count is required to prevent looping.

----- Original Message ----
From: Shahram Davari <[email-masked]>
To: priyanka gupta <[email-masked]>
Sent: Thursday, 15 May, 2008 9:23:39 PM
Subject: RE: [mpls] Doubt related to RFC 5036

Hi,
 
Your understanding is correct. You can bunch a number of address prefixes and assign them to the same label. But why do you think a hop count TLV is needed?
 
-Shahram
 
From:[email-masked] [mailto:[email-masked]] On Behalf Of priyanka gupta
Sent: May-15-08 10:58 AM
To: [email-masked]
Subject: [mpls] Doubt related to RFC 5036
 
hello all,
 
Can anybody help in understanding the statement in RFC 5036
"A FEC is a list of  one or more FEC elemets".
 
For example,
If there are three LDP enabled routers A--B--C.
50.50.50.1 ,50.50.50.2, 50.50.50.3 , 50.50.50.4 are the four /32 host connetced to the router C.
Router C will advertise four label associated with four /32 host.
So in the label mapping message,can router C aggregrate all the four FEC TLV and associated label with it or not?
will all four mentioned /32 host will be called FEC element of a FEC??
 
Can i really club the label mapping messages and send in one label mapping message??please help me to understand this.  
 
If we really can do this then in that case label mapping message should have a list of hop count TLV too,which is not specified in RFC.

________________________________

Meet people who discuss and share your passions. Join them now.

      Best Jokes, Best Friends, Best Food and more. Go to http://in.promos.yahoo.com/groups/bestofyahoo/

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: "Shahram Davari" <[email-masked]>
Date: Fri, 16 May 2008 09:48:57 -0400

Hi,
 
I think I misunderstood your question. What you are asking is whether you can bunch multiple label mappings in to the same label mapping message. The answer is No. Each label mapping message only maps one label to a set of FECs.
 
Regarding the hop count TLV, it could be used optionally.
 
Regards,
Shahram
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of priyanka gupta
Sent: May-15-08 11:36 PM
To: Shahram Davari; [email-masked]
Subject: Re: [mpls] Doubt related to RFC 5036
 
thx Shahram.

----- Original Message ----
From: Shahram Davari <[email-masked]>
To: priyanka gupta <[email-masked]>
Sent: Thursday, 15 May, 2008 9:23:39 PM
Subject: RE: [mpls] Doubt related to RFC 5036
Hi,

-Shahram
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of priyanka gupta
Sent: May-15-08 10:58 AM
To: [email-masked]
Subject: [mpls] Doubt related to RFC 5036
 
hello all,

For example,
50.50.50.1 ,50.50.50.2, 50.50.50.3 , 50.50.50.4 are the four /32 host connetced to the router C..

 
  _____  

Meet people who discuss and share your passions. Join them now. <http://in.rd.yahoo.com/tagline_groups_7/*http:/in.promos.yahoo.com/groups/bestofyahoo/> 

  _____  

Meet people who discuss and share your passions. Join <http://in.rd.yahoo.com/tagline_groups_7/*http:/in.promos.yahoo.com/groups/bestofyahoo/>  them now.
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls