Subject: Re: [mpls] [mpls-tp] RES: R: discussion on ring protection inMPLS-TP

From: "Niven-jenkins,B,Ben,DMF R" <[email-masked]>
Date: Tue, 2 Sep 2008 20:52:15 +0100

let's take a step back. 

Requirements exist based on a use/deployment case. What is the use case for rings - can someone articulate it clearly (if it has been presented elsewhere great we can reuse that).

From the use case we can distil the true requirements

From the requirements we can evaluate solutions.

It may be that the use/deployment case for mpls-tp may differ from sdh and so the requirements may be subtlely different. It may be that the nature of a packet based technology means that the requirements can be satisfied in an alternative way to in a circuit switched technology.

In any case let's start with a clearly define use/deployment case and work from there.

Ben

-----Original Message-----
From: "Loa Andersson" <[email-masked]>
To: "Italo Busi" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Sent: 02/09/2008 16:18
Subject: Re: [mpls] [mpls-tp] RES: R: discussion on ring protection inMPLS-TP

Italo,

inline

Italo Busi wrote:
> Salvio,
>  
> "I think we need to start from the requirements ..."

that far I agree!

but I think what needs to be said in the second part of the
sentence is

"... and not from the solutions ring protoection or FRR."

Also, since we are seeking MPLS compatibility, once we have the
requirments we need to evaluate/analyze the existing mpls
solutions to seee if they meet the requirements, and sedond
build something new.

/Loa
>  
> Italo
> 
> 
>   _____  
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Salvio Straube Stecz
> Sent: Friday, August 29, 2008 4:29 PM
> To: [email-masked]
> Subject: [mpls-tp] RES: R: discussion on ring protection in MPLS-TP
> 
> 
> 
> Hi all, 
> 
>         I think that for the MPLS-TP, the better protection scheme to be used is
> fast-reroute - FRR. Comparing to SDH-like ring protection it can works like
> MS-SPring, where is possible to achieve less than 50ms switching time, and the
> use of the protection side of the ring to carry extra-traffic. There are already
> equipment in the market that works with this idea.
> 
> 
> 
> 
> rgds, 
> ------------------------------------------------ 
>     Sálvio Straube Stecz 
>   GVT - Global Village Telecom 
>  Planning - Transport Networks 
>      +55 41 3022 - 9451 
>      +55 41 8848 - 3428  
>         [email-masked] 
> ----------------------------------------------- 
> 
> 
> 
> 
> 
> 
> -----Mensagem original----- 
> De: [email-masked] [mailto:[email-masked]]Em nome de 
> Diego Caviglia 
> Enviada em: sexta-feira, 29 de agosto de 2008 10:38 
> Para: [email-masked] 
> Cc: [email-masked]; [email-masked] 
> Assunto: [mpls-tp] R: discussion on ring protection in MPLS-TP 
> 
> 
> Ciao Alessandro, 
>                            I think you made a good point. 
> 
> If, as stated in sveral documents, mpls-tp is going to replace sdh we 
> have to consider that most of the metro and metro core topology are ring 
> based. 
> 
> Br 
> 
> Diego 
> _______________________________________________ 
> mpls-tp mailing list 
> [email-masked] 
> https://www.ietf.org/mailman/listinfo/mpls-tp 
> 
> 
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                           [email-masked]
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: "Diego Caviglia" <[email-masked]>
Date: Wed, 3 Sep 2008 10:30:32 +0200

Ben,
    AFAIK the most interesting use case for this is multicast (video) distribution on metro/regional ring topology.

Typically there is a regional high capacity ring with several metro ring attached to it.  Both the metro and regional ring nodes can be connected to DSLAM that actually distribute the multicast (video) to end user.

So the situation in the ring is exactly the one depicted by John/Italo, that is, p2p LSP between adjacent nodes on the ring.

Now, even if I'm not a carrier, I think that the requirement is to protect (50ms?) the multicast traffic using less recovery bandwidth as possible.

Of course given that we are in mpls-tp environment that should be done without control plane and I suppose with the minimum complexity possible, I think that this can be read that the complexity should be moved at provisioning/planning stage and not during the life of the network.

Just my two cents

BR

Diego

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Niven-jenkins,B,Ben,DMF R
> Sent: martedì 2 settembre 2008 21.52
> To: Loa Andersson; Italo Busi
> Cc: [email-masked]
> Requirements exist based on a use/deployment case. What is the use case
> for rings - can someone articulate it clearly (if it has been presented
> elsewhere great we can reuse that).
> 
> It may be that the use/deployment case for mpls-tp may differ from sdh and
> so the requirements may be subtlely different. It may be that the nature
> of a packet based technology means that the requirements can be satisfied
> in an alternative way to in a circuit switched technology.
>