Subject: [mpls] [Editorial Errata Reported] RFC3270 (1910)

From: RFC Errata System <[email-masked]>
Date: Tue, 13 Oct 2009 00:31:02 -0700 (PDT)

The following errata report has been submitted for RFC3270,
"Multi-Protocol Label Switching (MPLS) Support of Differentiated Services".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3270&eid=1910

--------------------------------------
Type: Editorial
Reported by: Francois Le Faucheur <[email-masked]>

Section: 5.2.1

Original Text
-------------
MAPnb : 4 bits
         Indicates the number of MAP entries included in the DIFFSERV
         Object.  This can be set to any value from 0 to 8.

Corrected Text
--------------
MAPnb : 4 bits
         Indicates the number of MAP entries included in the DIFFSERV
         Object.  This can be set to any value from 0 to 7.

Notes
-----
This errata was reported by Colors Springfield <[email-masked]> on 13 October 2009.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3270 (draft-ietf-mpls-diff-ext-09)
--------------------------------------
Title               : Multi-Protocol Label Switching (MPLS) Support of Differentiated Services
Publication Date    : May 2002
Author(s)           : F. Le Faucheur, L. Wu, B. Davie, S. Davari, P. Vaananen, R. Krishnan, P. Cheval, J. Heinanen
Category            : PROPOSED STANDARD
Source              : Multiprotocol Label Switching
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: fanshaojun <[email-masked]>
Date: Wed, 14 Oct 2009 09:34:52 +0800

Dear ALL:

This MAPnb column occupied 4 bits in the object. So it can be set to any
value from 0 to 15.

Corrected Text will be
--------------
MAPnb : 4 bits
         Indicates the number of MAP entries included in the DIFFSERV
         Object.  This can be set to any value from 0 to 15. 

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: Tuesday, October 13, 2009 3:31 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] [Editorial Errata Reported] RFC3270 (1910)

Section: 5.2.1

Original Text
-------------
MAPnb : 4 bits

Corrected Text
--------------
MAPnb : 4 bits

Notes
-----
This errata was reported by Colors Springfield <[email-masked]>
on 13 October 2009.

Instructions:
-------------

--------------------------------------
RFC3270 (draft-ietf-mpls-diff-ext-09)
--------------------------------------
Title               : Multi-Protocol Label Switching (MPLS) Support of
Differentiated Services
Publication Date    : May 2002
Author(s)           : F. Le Faucheur, L. Wu, B. Davie, S. Davari, P.
Vaananen, R. Krishnan, P. Cheval, J. Heinanen
Category            : PROPOSED STANDARD
Source              : Multiprotocol Label Switching
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 14 Oct 2009 13:36:47 +0200

Hello,

Just looked back at RFC3270:
MAPnb defines the number of MAP entries carried inside the DIFFSERV  
object.
Each MAP entry defines the mapping between one EXP (now "COS") field  
value and one PHB.
Since there is only 8 possible EXP values, I think:
	* MAPnb should actually be encoded over 3 bits, and not 4 bits
	* value range should be 0-7.
Does that sound right?

If yes, I can update the errata with appropraite required changes.

Francois

On 14 Oct 2009, at 03:34, fanshaojun wrote:

> This errata was reported by Colors Springfield <[email-masked] 
> >
> on 13 October 2009.
>
> Instructions:
> -------------
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: "Shahram Davari" <[email-masked]>
Date: Wed, 14 Oct 2009 09:09:44 -0700

Hi Francois and co-authors,

I think you are correct. So I have no objection in changing that in the Errata.

Regards,
Shahram 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Francois Le Faucheur
Sent: Wednesday, October 14, 2009 4:37 AM
To: fanshaojun
Cc: [email-masked]; Le Faucheur Francois; [email-masked]; Bruce Davie; [email-masked]; [email-masked]; [email-masked]; springfield colors; Ross Callon; [email-masked]; Adrian Farrel; [email-masked]; RFC Errata System
Subject: Re: [mpls] [Editorial Errata Reported] RFC3270 (1910)

Hello,

Francois

---

From: Adrian Farrel <[email-masked]>
Date: Thu, 15 Oct 2009 15:56:40 +0100

Hi,

Note that, per RFC5462, the EXP bits are renamed to the TC (Traffic Class) 
field. Not the "COS field".

Cheers,
Adrian
----- Original Message ----- 
From: "Shahram Davari" <[email-masked]>
To: "Francois Le Faucheur" <[email-masked]>; "fanshaojun" 
<[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "Bruce Davie" <[email-masked]>; 
<[email-masked]>; <[email-masked]>; <[email-masked]>; 
"springfield colors" <[email-masked]>; <[email-masked]>; 
<[email-masked]>; "Adrian Farrel" <[email-masked]>; "Ross 
Callon" <[email-masked]>; "RFC Errata System" 
<[email-masked]>
Sent: Wednesday, October 14, 2009 5:09 PM
Subject: Re: [mpls] [Editorial Errata Reported] RFC3270 (1910)

> Cc: [email-masked]; Le Faucheur Francois; [email-masked]; Bruce Davie; 
> [email-masked]; [email-masked]; [email-masked]; 
> springfield colors; Ross Callon; [email-masked]; Adrian Farrel; 
> [email-masked]; RFC Errata System
>> [email-masked]; [email-masked]; 
>> [email-masked]
>> ;