Subject: Re: [mpls] [mpls-tp] poll on making draft-sprecher-mpls-tp-oam-analysis-07.txt a working group draft

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 19 Oct 2009 18:03:57 +0200

Adrian,
I fully agree with you  regarding "four questions" that should be answered when we decide whether an individual draft 
should - or should not - be adopted as a WG draft.

And I do not have any problem with answering "yes" to the first two:
- the draft belongs to MPLS-TP and, as such, is within the scope of the MPLS WG
- MPLS-TP is of some interest to the MPLS WG (or at least to me). BTW, I've added [email-masked] to the CC list.

My problems start with the  remaining two questions:

- Does the WG to work on a draft that covers the  subject material?

  The answer is far from obvious, since the specific subject of the draft is analysis (sometimes inaccurate) of existing OAM tools vs.
  documented MPLS-TP OAM requirements, with some recommendations as to how to develop specific OAM tools.
  We may, of course, continue to work on the analysis (e.g., by fixing the errors in the document) and update some recommendations.
  However, this would not replace actual work on the new OAM tools or extension of the existing ones.

- Is this draft a good enough starting point for further work?
  
  This question assumes that we understand which "further work" we have in mind.
  And this is completely not clear to me, especially when looking at Loa's explanation.
  At least, the usual understanding of "further work" at IETF - to deliver an RFC - seems to be not applicable.
  We have examples of work items that have been adopted as WG documents and eventually published as 
  Informational RFCs while documenting certain status rather than defining some protocols (e.g., 5037 and 5038),
  but I am not sure if  this analogy really holds.
  
  If the objective is to preserve the design team notes, this can be done in many other ways. Just to remind you
  that the "Martini drafts" have never been adopted as WG drafts. This did not prevent Luca from periodically updating
  them in parallel with working on the PWE3 WG documents... And eventually they have been published as Historical RFCs.

I will provide my analysis of specific issues with the draft later in a separate email.

Regards,
     Sasha

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Monday, October 19, 2009 5:09 PM
> To: Satoru Matsushima; Loa Andersson
> Cc: [email-masked]
> Subject: Re: [mpls-tp] poll on 
> makingdraft-sprecher-mpls-tp-oam-analysis-07.txt a working group draft
> 
> Hi Satoru,
> 
> I didn't see anyone else answer, so I'll jump in.
> 
> > I'm trying to understand what the purpose of this poll.
> >
> > Does this poll to make decision of MPLS-TP OAM solution, or
> > to make sure a current status of mpls-tp oam considerations?
> 
> Neither of these.
> 
> This poll is to decide whether the MPLS working group wants 
> to adopt this 
> draft as a work in progress to be developed further under the 
> care of the 
> MPLS working group.
> 
> The material questions are:
> - is this within the scope of the MPLS working group?
> - is there sufficient interest in the broader topic (MPLS-TP)?
> - does the working group want to work on a draft that covers
>    this subject material?
> - is this draft a good starting point for further work?
> 
> Thanks,
> Adrian
> 
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Mon, 19 Oct 2009 18:38:16 +0200

Dear Sasha,
I'll appreciate if you can refer to what you believe are errors in the
document. We of course would like to fix them. That is the reason we
solicited many times the group to review and comment. 
The draft gives an overview on the existing mechanisms and tries to
analyze whether they can apply to the requirements, or can be enhanced
to apply to the requirements. It also summarizes the agreements we
reached in the discussions in the design team and the considerations. 
We also know that there are further requirements on the table that are
under discussions and if agreed we will need to extend the document and
analyze them as well.
I hope you can support the adoption of the draft as a WG document/. 
Best regards,
Nurit.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Alexander Vainshtein
Sent: Monday, October 19, 2009 6:04 PM
To: Adrian Farrel
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls-tp] poll on making
draft-sprecher-mpls-tp-oam-analysis-07.txt a working group draft

Adrian,
I fully agree with you  regarding "four questions" that should be
answered when we decide whether an individual draft 
should - or should not - be adopted as a WG draft.

And I do not have any problem with answering "yes" to the first two:
- the draft belongs to MPLS-TP and, as such, is within the scope of the
MPLS WG
- MPLS-TP is of some interest to the MPLS WG (or at least to me). BTW,
I've added [email-masked] to the CC list.

  The answer is far from obvious, since the specific subject of the
draft is analysis (sometimes inaccurate) of existing OAM tools vs.
  documented MPLS-TP OAM requirements, with some recommendations as to
how to develop specific OAM tools.
  We may, of course, continue to work on the analysis (e.g., by fixing
the errors in the document) and update some recommendations.
  However, this would not replace actual work on the new OAM tools or
extension of the existing ones.

  This question assumes that we understand which "further work" we have
in mind.
  And this is completely not clear to me, especially when looking at
Loa's explanation.
  At least, the usual understanding of "further work" at IETF - to
deliver an RFC - seems to be not applicable.
  We have examples of work items that have been adopted as WG documents
and eventually published as 
  Informational RFCs while documenting certain status rather than
defining some protocols (e.g., 5037 and 5038),
  but I am not sure if  this analogy really holds.
  
  If the objective is to preserve the design team notes, this can be
done in many other ways. Just to remind you
  that the "Martini drafts" have never been adopted as WG drafts. This
did not prevent Luca from periodically updating
  them in parallel with working on the PWE3 WG documents... And
eventually they have been published as Historical RFCs.

I will provide my analysis of specific issues with the draft later in a
separate email.

Regards,
     Sasha