Subject: [mpls] Comments to Detecting MPLS Path Impairment using MPLS-Ping

From: Greg Mirsky <[email-masked]>
Date: Wed, 24 Mar 2010 12:52:14 -0700

Dear Authors,
please consider my comments to the work presented at yesterday's MPLS WG
meeting.

   - If I understand the network correctly, this is IP/MPLS, not MPLS TE
   network. Even then, the impairment in the Layer 2 is not MPLS specific, in
   my view. An IGP can reflect change in available bandwidth through its cost
   and then flood new LSAs. The LDP will converge after IGP properly.
   - If operator is interested in more substantive information then just
   changed cost, then, I assume, radio nodes should send alarms to the NMS.
   - The stated problem is neither related to MPLS LSP, nor to correlation
   between the Control Plane and the Data path. Choice of LSP-Ping to carry
   query and response is a problem.
   - If there's sufficient interest to use LSP-Ping as a donkey, a vehicle
   to transport some information, perhaps we need an Opaque TLV (similar to
   OSPF Opaque LSA).

Regards,
Greg

---

From: John E Drake <[email-masked]>
Date: Wed, 24 Mar 2010 12:58:07 -0700

Greg,

I think your analysis is correct.

Thanks,

John

Sent from my iPhone

On Mar 24, 2010, at 12:52 PM, "Greg Mirsky" <[email-masked]>  
wrote:

> Dear Authors,
> please consider my comments to the work presented at yesterday's  
> MPLS WG meeting.
> If I understand the network correctly, this is IP/MPLS, not MPLS TE  
> network. Even then, the impairment in the Layer 2 is not MPLS  
> specific, in my view. An IGP can reflect change in available  
> bandwidth through its cost and then flood new LSAs. The LDP will  
> converge after IGP properly.
> If operator is interested in more substantive information then just  
> The stated problem is neither related to MPLS LSP, nor to  
> correlation between the Control Plane and the Data path. Choice of  
> LSP-Ping to carry query and response is a problem.
> If there's sufficient interest to use LSP-Ping as a donkey, a  
> vehicle to transport some information, perhaps we need an Opaque TLV  
> (similar to OSPF Opaque LSA).
> Regards,
> Greg
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 24 Mar 2010 13:15:40 -0700

I would agree with the points below.  I would also point out that the problem described as the main use case for this approach (microwave link degradation issues), should be solvable based on routing equipment understanding the state of the microwave interface, or gleaning a degraded state using other means such as end-to-end path testing, or layer-1/2. 

	--Tom

> Dear Authors,
> please consider my comments to the work presented at yesterday's MPLS WG meeting.
> If I understand the network correctly, this is IP/MPLS, not MPLS TE network. Even then, the impairment in the Layer 2 is not MPLS specific, in my view. An IGP can reflect change in available bandwidth through its cost and then flood new LSAs. The LDP will converge after IGP properly.
> If operator is interested in more substantive information then just changed cost, then, I assume, radio nodes should send alarms to the NMS.
> The stated problem is neither related to MPLS LSP, nor to correlation between the Control Plane and the Data path. Choice of LSP-Ping to carry query and response is a problem.
> If there's sufficient interest to use LSP-Ping as a donkey, a vehicle to transport some information, perhaps we need an Opaque TLV (similar to OSPF Opaque LSA).
> Regards,
> Greg

---

From: <[email-masked]>
Date: Thu, 25 Mar 2010 03:16:19 +0100

Greg,
 
Thanks for the comments.
Please see responses below.
 
Regards,
Philippe.

________________________________

De : Greg Mirsky [mailto:[email-masked]] 
Envoyé : mercredi 24 mars 2010 20:52
À : Linda Dunbar; So, Ning; NIGER Philippe RD-RESA-LAN; LE GOFF Yannick RD-RESA-LAN; [email-masked]
Objet : Comments to Detecting MPLS Path Impairment using MPLS-Ping

Dear Authors,

*	If I understand the network correctly, this is IP/MPLS, not MPLS TE network. Even then, the impairment in the Layer 2 is not MPLS specific, in my view. An IGP can reflect change in available bandwidth through its cost and then flood new LSAs. The LDP will converge after IGP properly. 

[PN] : It is not only a change of topology that is targeted. We would like the edge node (initiating the MPLS transport layer, i.e. PW/LSP) to be able to retrieve information on effective available transport capacity to allow an update of the policy control on the edge node. 

*	If operator is interested in more substantive information then just changed cost, then, I assume, radio nodes should send alarms to the NMS. 

[PN] : We have to face very different network configurations depending on countries in which all the nodes (edge nodes and L2/L3 transit nodes) could be managed by different NMSs, potentially by different administrative enities. We would like to avoid as much as possible a solution based on NMS and NMS interconnection.  

*	The stated problem is neither related to MPLS LSP, nor to correlation between the Control Plane and the Data path. Choice of LSP-Ping to carry query and response is a problem. 

[PN] : Yes the problem is not solely related to the MPLS layer. However the transport capacity seen by the edge node is provided by the MPLS layer.
           The objective is to have a very simple solution allowing the edge node to retrieve the information on the transport capacity toward a transit MPLS node using a simple mechanism.  The proposal fully relies on existing LSP Ping behavior as define by the MPLS WG. It is also in-line with the WG draft on LSP Ping enhancement which is under progress. It just defines a new bit in the request message to indicate the type of request and a TLV in the reply message to transport the information.

*	If there's sufficient interest to use LSP-Ping as a donkey, a vehicle to transport some information, perhaps we need an Opaque TLV (similar to OSPF Opaque LSA). 

[PN] : That is correct. Thanks for the proposal. Personally I would be happy with that, I let my co-authors react.
 
Regards,
Greg

---

From: <[email-masked]>
Date: Thu, 25 Mar 2010 21:43:03 +0100

Hi,
Re-send as apparently it did not work the first time.
 
Regards,
Philippe.

De : NIGER Philippe RD-RESA-LAN 
Envoyé : jeudi 25 mars 2010 03:16
À : Greg Mirsky; Linda Dunbar; So, Ning; LE GOFF Yannick RD-RESA-LAN; [email-masked]
Cc : NIGER Philippe RD-RESA-LAN
Objet : RE: Comments to Detecting MPLS Path Impairment using MPLS-Ping

Greg,
 
Thanks for the comments.
 
Regards,
Philippe.

Dear Authors,

 
Regards,
Greg