Subject: Re: [mpls] draft-boutros-mpls-lsp-ping-ttl-tlv

From: Vishwas Manral <[email-masked]>
Date: Sun, 4 Apr 2010 16:59:55 -0700

Hi,

I think I have found some very basic issues with the draft and had
mailed the same on the list.

I have not heard back from you. I was wondering if you had abandoned
the draft. If so I can pick it up and probably correct it. Do let us
know?

Thanks,
Vishwas

On Sun, Mar 28, 2010 at 9:12 PM, Vishwas Manral <[email-masked]> wrote:
> Hi,
>
> I find the draft useful and concise. I read the draft and found a
> basic issue - it cannot be used the way it is defined. I had a few
> suggestions and an issue with the draft(point 3):
>
> 1. I think the draft can be made more generic as it can be used to
> test hops in heirarchical bidirectional LSP's or even just plain
> bidirectional LSP from an LSR to another LSR.
> 2. Though the TLV we talk about is an LSP Ping TLV, I at first thought
> it is probably a TLV in the ACH header. May be that should be made
> clear.
> 3. I am not sure how you can assume that a node that does not
> understand the TLV will just ignore the TLV (Type value 11). RFC 4379
> which mentions that
>
>   Types greater than or equal to 32768 (i.e., with the high-order bit
>   equal to 1) are optional TLVs that SHOULD be ignored if the
>   implementation does not understand or support them.
>
> In that context the statement is very interesting:
>
> If a receiver does not understand the TTL TLV, it can simply ignore the TLV.
>
> I am not sure but it may be nice to remove the statement above instead
> of making an exception. We cannot make reccomedations of what to do
> with a TLV if someone does not understand the TLV as the equipment
> that does not understand it is already deployed.
>
> Thanks,
> Vishwas
>

---

From: [email-masked]
Date: Tue, 6 Apr 2010 16:11:10 +0800

hi
For this draft, I don't know what meaning to do so. 
can it verify the connection from any node to any node in the MS-PW?
If so, when it detects the failure in the segment by LSP Ping TTL TLV,
will the source node trigger segment protection switching?
or other applyment for LSP Ping TTL TLV?

I don't know. thank you!

best regards
liu

Vishwas Manral <[email-masked]> 
发件人:  [email-masked]
2010-04-05 07:59

收件人
[email-masked]
抄送
Sami Boutros <[email-masked]>, [email-masked]
主题
Re: [mpls] draft-boutros-mpls-lsp-ping-ttl-tlv

Hi,

Thanks,
Vishwas

> that does not understand it is already deployed.
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.