Subject: Re: [mpls] draft-boutros-mpls-lsp-ping-ttl-tlv

From: Sami Boutros <[email-masked]>
Date: Thu, 13 May 2010 14:40:03 -0700

Hi Vishwas,

Sorry, somehow I didn't see this message, let me go through it and 
get back to you.

Thanks,

Sami
At 04:59 PM 4/4/2010, Vishwas Manral wrote:
>Hi,
>
>I think I have found some very basic issues with the draft and had
>mailed the same on the list.
>
>I have not heard back from you. I was wondering if you had abandoned
>the draft. If so I can pick it up and probably correct it. Do let us
>know?
>
>Thanks,
>Vishwas
>
>On Sun, Mar 28, 2010 at 9:12 PM, Vishwas Manral 
><[email-masked]> wrote:
> > Hi,
> >
> > I find the draft useful and concise. I read the draft and found a
> > basic issue - it cannot be used the way it is defined. I had a few
> > suggestions and an issue with the draft(point 3):
> >
> > 1. I think the draft can be made more generic as it can be used to
> > test hops in heirarchical bidirectional LSP's or even just plain
> > bidirectional LSP from an LSR to another LSR.
> > 2. Though the TLV we talk about is an LSP Ping TLV, I at first thought
> > it is probably a TLV in the ACH header. May be that should be made
> > clear.
> > 3. I am not sure how you can assume that a node that does not
> > understand the TLV will just ignore the TLV (Type value 11). RFC 4379
> > which mentions that
> >
> >   Types greater than or equal to 32768 (i.e., with the high-order bit
> >   equal to 1) are optional TLVs that SHOULD be ignored if the
> >   implementation does not understand or support them.
> >
> > In that context the statement is very interesting:
> >
> > If a receiver does not understand the TTL TLV, it can simply 
> ignore the TLV.
> >
> > I am not sure but it may be nice to remove the statement above instead
> > of making an exception. We cannot make reccomedations of what to do
> > with a TLV if someone does not understand the TLV as the equipment
> > that does not understand it is already deployed.
> >
> > Thanks,
> > Vishwas
> >

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 13 May 2010 14:56:47 -0700

Dear Vishwas,
to your second note I'd copy from PWE3 WG IETF-77 minutes:
draft-boutros-mpls-lsp-ping-ttl-tlv-00
 Sami, 10 min
 Sami presented, see slides
 Extension to LSP Ping (not MPLS-TP draft)
 Greg Mirsky: Is this supposed to be an LSP Ping TLV or ACH.
Sami: LSP Ping TLV, not an MPLS-TP draft
 Greg: Might be useful to MPLS TP.
 Sami: Agree
 Dave Allan: agree that it is useful. Concern because heading down path
where MIPs and MEPs are becoming indistinguishable.
George: At an SPE could have MIPs and MEPs, would be a MEP to MIP
transaction.
Dave A: assumes TTL back to sender is same as outgoing path, which not sure
can guarantee in non-corouted path
 George: in PWE3 MS PWs are corouted

I hope that authors will use our recommendations.

Regards,
Greg

On Sun, Mar 28, 2010 at 9:12 PM, Vishwas Manral <[email-masked]>wrote:

> If a receiver does not understand the TTL TLV, it can simply ignore the
> TLV.
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>