Subject: [mpls] A Question on RFC 3815 when implementing the LDP remote session configuration command

From: Tina TSOU <[email-masked]>
Date: Mon, 24 May 2010 14:17:32 +0800

Hi all,

While designing the LDP MIB according to RFC 3815, I have one question.

When I look at the following specification in RFC 3815, I found it difficult to implement the LDP remote session configuration command. The reasons are following.

•         “Another way to use this index is to give this the value of ifIndex. However, this is dependant on the implementation.”----RFC 3815

•         “A Targeted Hello is sent to a specific address rather than to the “all routers” group multicast address for the outgoing interface.”----RFC 5036

The Ifindex and IP address conflict/overlap at the value range. I couldn’t find a technical way to elude it.

Hints are appreciated.

B. R.
Tina
http://tinatsou.weebly.com/contact.html

---

From: Vishwas Manral <[email-masked]>
Date: Mon, 24 May 2010 09:58:54 -0700

Hi Tina,

You could use a mapping table to get the index. Another way you could
do it is to use different ranges i.e. 0 - 2 ^24 for ifindex and rest
for IP address which would never clash.

Thanks,
Vishwas

On Sun, May 23, 2010 at 11:17 PM, Tina TSOU <[email-masked]> wrote:
> When I look at the following specification in RFC 3815, I found it difficult
> to implement the LDP remote session configuration command. The reasons are
> following.
>
> •         “Another way to use this index is to give this the value of
> ifIndex. However, this is dependant on the implementation.”----RFC 3815
>
>
>
> •         “A Targeted Hello is sent to a specific address rather than to the
> “all routers” group multicast address for the outgoing interface.”----RFC
> 5036
>
>
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>
>

---

From: Tina TSOU <[email-masked]>
Date: Tue, 25 May 2010 18:15:04 +0800

Thanks Vishwas.

B. R.
Tina
----- Original Message ----- 
From: "Vishwas Manral" <[email-masked]>
To: "Tina TSOU" <[email-masked]>
Cc: <[email-masked]>; "Romascanu, Dan (Dan)" <[email-masked]>; 
<[email-masked]>; <[email-masked]>
Sent: Tuesday, May 25, 2010 12:58 AM
Subject: Re: [mpls] A Question on RFC 3815 when implementing the LDP 
remotesession configuration command

Hi Tina,

Thanks,
Vishwas

---

From: "David Harrington" <[email-masked]>
Date: Mon, 24 May 2010 08:12:37 -0400

you could use a taglist approach, similar to that used in rfc3413
target-mib
 
dbh

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Tina TSOU
Sent: Monday, May 24, 2010 2:18 AM
To: [email-masked]; Romascanu, Dan (Dan); [email-masked];
[email-masked]
Subject: [OPSAWG] A Question on RFC 3815 when implementing the LDP
remote session configuration command

Hi all,

While designing the LDP MIB according to RFC 3815, I have one
question.

When I look at the following specification in RFC 3815, I found it
difficult to implement the LDP remote session configuration command.
The reasons are following.

.         "Another way to use this index is to give this the value of
ifIndex. However, this is dependant on the implementation."----RFC
3815

.         "A Targeted Hello is sent to a specific address rather than
to the "all routers" group multicast address for the outgoing
interface."----RFC 5036

The Ifindex and IP address conflict/overlap at the value range. I
couldn't find a technical way to elude it.

Hints are appreciated.

B. R.
Tina