Subject: [mpls] New Liaison Statement, "Response to "LS223 - Last Call review of the MPLS-TP OAM Framework draft" ref #039.03"

From: Loa Andersson(IETF MPLS WG) <[email-masked]>
Date: Thu, 7 Oct 2010 01:14:36 -0700 (PDT)

Title: Response to "LS223 - Last Call review of the MPLS-TP OAM Framework draft" ref #039.03
Submission Date: 2010-10-07
URL of the IETF Web page: https://datatracker.ietf.org/public/liaison_detail.cgi?detail_id=958 

From: Loa Andersson(IETF MPLS WG) <[email-masked]>
To: ITU-T Q10/15([email-masked])
Cc: [email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
Reponse Contact: [email-masked]
Technical Contact: [email-masked]
[email-masked]
Purpose: For information 
Body: 

We have received you liaison "LS223 - Last Call review of the 
MPLS-TP OAM Framework draft #039.02" and will resolve them in the
same manner as any other comments received during WG last call.

Loa and George

MPLS Working group co-chairs
Attachment(s):
No document has been attached

---

From: "BUSI, ITALO (ITALO)" <[email-masked]>
Date: Fri, 15 Oct 2010 19:14:36 +0200

I am very concerned by the content of this LS reply as it is not aligned with collaborative spirit recommended by the JWT.

At the last ITU-T SG15 meeting, following a very late request raised by the IETF participants, I have spent one night to reverse engineer all the changes done to G.8110.1 during a two-weeks-long meeting in order to allow ITU-T providing IETF a LS reply containing the information about ITU-T disposition of the IETF comments on G.8110.1.

Although ITU-T participants would have appreciated such a request being raised at the beginning of the meeting (in order to track the changes during the meeting rather than reverse engineering them at the end of the meeting), I have offered to undertake this huge effort in order to maintain the collaborative spirit between the two SDOs.

ITU-T has, since quite a long time, explicitly requested to be informed about the disposition of its comments on the IETF I-Ds. So the expectation is that the editors of MPLS-TP I-Ds would track the disposition of the ITU-T comments and that the IETF would liaise this information to ITU-T.

In this particular case, my concern is even stronger given the fact that the editors of the MPLS-TP OAM Framework draft have actually spent the effort to track all the comments and disposition raised during the third WG LC (both from IETF and ITU-T), so there is no cost from IETF perspective in sending this information to ITU-T (as per ITU-T request).

In order to make this information informally available to everybody, I have uploaded the documents describing editors' disposition of all the WG LC comments at the following URL:

http://www.italobusi.altervista.org/MPLS-TP/Third_LC_on_OAM-Framework_v09.doc

With the objective to recover a spirit of collaboration between the two SDOs, I would propose that:

a) ITU-T Q10/15 experts review the -09 version of the I-D (together with this document) to assess whether the editors have successfully resolved the ITU-T comments and there is consensus within ITU-T to support the publication of the I-D;

b) IETF MPLS WG chairs send a new LS reply providing, in a formal way, the response on how the ITU-T comments have been addressed and requesting ITU-T approval to move the document forward in the approval process;

c) ITU-T Q10/15 experts communicate IETF the result of their review.

Best Regards

Italo

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Loa Andersson
Inviato: giovedì 7 ottobre 2010 10.15
A: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; Bocci, Matthew (Matthew); [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Lam, Hing-Kam (Kam); [email-masked]
Oggetto: [mpls] New Liaison Statement, "Response to "LS223 - Last Call review of the MPLS-TP OAM Framework draft" ref #039.03"

Loa and George

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: Loa Andersson <[email-masked]>
Date: Tue, 19 Oct 2010 15:00:53 +0200

All,

see inline please.

On 2010-10-15 19:14, BUSI, ITALO (ITALO) wrote:

> I am very concerned by the content of this LS reply as it is not
> aligned with collaborative spirit recommended by the JWT.

I am a little surprised by this, as the LS simply acknowledges the
incoming comments, and promise to handle them in the same way as
other last call comments. Isn't this something to be pleased about?

> At the last ITU-T SG15 meeting, following a very late request raised
> by the IETF participants, I have spent one night to reverse engineer
> all the changes done to G.8110.1 during a two-weeks-long meeting in
> order to allow ITU-T providing IETF a LS reply containing the
> information about ITU-T disposition of the IETF comments on G.8110.1.
>
> Although ITU-T participants would have appreciated such a request
> being raised at the beginning of the meeting (in order to track the
> changes during the meeting rather than reverse engineering them at
> the end of the meeting), I have offered to undertake this huge effort
> in order to maintain the collaborative spirit between the two SDOs.

Italo's work on this is appreciated. By putting in this extra effort
he was able to help the ITU-T fulfil its commitment to the IETF.

I am not clear what Italo means by "IETF participants" as he is talking
about an ITU-T meeting where there were only ITU-T Sector Members
present.

> ITU-T has, since quite a long time, explicitly requested to be
> informed about the disposition of its comments on the IETF I-Ds. So
> the expectation is that the editors of MPLS-TP I-Ds would track the
> disposition of the ITU-T comments and that the IETF would liaise this
> information to ITU-T.

There seems to be some misunderstanding of IETF process.
The IETF process requires that comments made during IETF
last call are explicitly addressed, and it is the responsibility
of document editors/authors to explain what they have changed
in their drafts as a result of a last call, and to explain how the
last call comments were handled.

When this document was updated after 2nd last call, the WG chairs
reminded the Editors to update the WG (17-Sep-10) and were able to post
the information (23-Sep-10).

In practice, up to the time of this mail from Italo email, the
editors had not notified the WG of the changes they made or the
disposition of the comments received.

The editors sent a private mail to wg chairs indicating that
that were one outstanding comment and including the document
found following the link above. The way we understood this was
that mail was part of the editors task to communicate to folks
making comments how they been addressed and that we would see show up on 
the working group mailing lists shortly.

The working group chairs informed the editor in a mail that we intended
to request publication of the framework, and in the same mail also
informed the person that held the outstanding comment how he could
act during the IETF/IESG review of the document to make sure that his
comment were taken into consideration.

> In this particular case, my concern is even stronger given the fact
> that the editors of the MPLS-TP OAM Framework draft have actually
> spent the effort to track all the comments and disposition raised
> during the third WG LC (both from IETF and ITU-T), so there is no
> cost from IETF perspective in sending this information to ITU-T (as
> per ITU-T request).

It is good to know that the editors did this work as they went along.
However, it is odd to complain that the editors have put in this extra
work when they had not shared that work with the mailing list.

> In order to make this information informally available to everybody,
> I have uploaded the documents describing editors' disposition of all
> the WG LC comments at the following URL:
>

This is very helpful. It is especially helpful to have this as a document
available on the web, since it is too large to be posted to working
group list. I'd to encourage anyone that is interested and especially
if you had made comments during the working group last call.

> a) ITU-T Q10/15 experts review the -09 version of the I-D (together
>    with this document) to assess whether the editors have successfully
>    resolved the ITU-T comments and there is consensus within ITU-T to
>    support the publication of the I-D;

The MPLS WG chairs are not going to comment on this proposal except to
note that, as always and according to the JWT recommendations, the ITU-T
experts are invited to participate in the IETF process (including review
of documents) via the MPLS mailing lists.

> b) IETF MPLS WG chairs send a new LS reply providing, in a formal way,
>    the response on how the ITU-T comments have been addressed and
>    requesting ITU-T approval to move the document forward in the
>    approval process;

The WG chairs can then (as they did with the previous last call),
notify the ITU-T of the disposition of the changes.

However, this game of ping-pong will not continue ad nauseum. The
comments received have been handled and further review is not
solicited.

> c) ITU-T Q10/15 experts communicate IETF the result of their review.

It is an open choice for the ITU-T whether they accept the current
version of the document or not.

/Loa

> From: Loa Andersson(IETF MPLS WG)<[email-masked]>

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13