Subject: [mpls] Ask for comments: New draft notification: draft-zheng-mpls-ldp-hello-crypto-auth

From: Vero Zheng <[email-masked]>
Date: Mon, 11 Oct 2010 10:13:33 +0800

Hi All,

We have submitted a new "LDP Hello Cryptographic Authentication" draft,
The URL for it is:
http://tools.ietf.org/id/draft-zheng-mpls-ldp-hello-crypto-auth-00.txt

Unlike all other LDP messages, the Hello messages are sent using UDP not TCP. 
This means that they cannot benefit from the security mechanisms available with TCP. 
[RFC5036] does not provide any security mechanisms for use with Hello messages except to note that 
   some configuration may help protect against bogus discovery events. 

In this draft, we introduce a new Cryptographic Authentication TLV which is used in LDP Hello message as an optional parameter. 
It enhances the authentication mechanism for LDP by securing the Hello message against spoofing attack, and an LSR can be configured to 
   only accept Hello messages from specific peers when authentication is in use. 

Looking forward to your comments.

BR,
Mach and Vero

---

From: Mach Chen <[email-masked]>
Date: Thu, 14 Oct 2010 09:33:37 +0800

Hi folks,

We'd appreciate that you could spent a few minutes to read and comment this 
short draft, we are going to disuss it in Beijing meeting.

Many thanks,
Mach

--------------------------------------------------
From: "Vero Zheng" <[email-masked]>
Sent: Monday, October 11, 2010 10:13 AM
To: <[email-masked]>
Cc: "Mach Chen" <[email-masked]>
Subject: [mpls]  Ask for comments: New draft notification: 
draft-zheng-mpls-ldp-hello-crypto-auth

> In this draft, we introduce a new Cryptographic Authentication TLV which 
> is used in LDP Hello message as an optional parameter.
> It enhances the authentication mechanism for LDP by securing the Hello 
> message against spoofing attack, and an LSR can be configured to