Subject: [mpls] poll on accepting draft-manral-mpls-ldp-ipv6 as an mpls wg document

From: Loa Andersson <[email-masked]>
Date: Wed, 13 Oct 2010 19:03:28 +0200

Working Group,

the authors of draft-manral-mpls-ldp-ipv6-00 have asked that the
document is accepted as a working group document.

This starts a two week poll on making it a working group document.

Please send your comments (support or non-support) to the mpls
working group mailing list.

The poll ends November 29, 2010.

/Loa
-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: Vishwas Manral <[email-masked]>
Date: Wed, 13 Oct 2010 10:23:28 -0700

Hi folks,

The version of the latest draft is 03 and is located at:
http://tools.ietf.org/html/draft-manral-mpls-ldp-ipv6-03

Thanks,
Vishwas

On Wed, Oct 13, 2010 at 10:03 AM, Loa Andersson <[email-masked]> wrote:
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Loa Andersson <[email-masked]>
Date: Wed, 13 Oct 2010 19:31:16 +0200

Working Group,

there is was too many mistakes here and the IETF tools are not working
so I temporarily canceling the poll. Will re-send in a few minutes.

/Loa

--

---

From: Vishwas Manral <[email-masked]>
Date: Wed, 13 Oct 2010 10:20:50 -0700

Hi folks,

The draft is located at
http://tools.ietf.org/html/draft-manral-mpls-ldp-ipv6-03.

Thanks,
Vishwas

---

From: Kishore Tiruveedhula <[email-masked]>
Date: Fri, 22 Oct 2010 12:47:13 -0400

Hi Vishwas,

I think the LDP session may not established in the below scenario. 
As the single LDP session can be used for both ipv4 and ipv6 hello adjacencies, then there might be a case where one LSR acting as passive role in the ipv4 adjacency and active role in ipv6 hello adjacency when both ipv4 and ipv6 adjacencies are established at the same time. In this case both adjacent LSRs may end up with passive role or active role based first ipv4 or ipv6 adjacency created and then finally the session may not get established. I think this may need to be clarified as well.

Thanks,
Kishore

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Vishwas Manral
Sent: Wednesday, October 13, 2010 1:21 PM
To: Loa Andersson
Cc: [email-masked]
Subject: Re: [mpls] poll on accepting draft-manral-mpls-ldp-ipv6 as an mpls wg document

Hi folks,

The draft is located at

Thanks,
Vishwas

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Fri, 22 Oct 2010 12:19:46 -0500

Hi Kishore,

Thanks for your support.

The -04 version of the draft does not prescribe using active/passive roles to decide tearing down the session. So, the valid concern you are raising is not applicable. 

The draft, rather, suggests using the lagging TCP session to be torn down. Of course, the logic to address the corner case of having both TCP sessions getting established at the same time, is something we will clarify in the next version.

Cheers,
Rajiv

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Kishore Tiruveedhula
> Sent: Friday, October 22, 2010 12:47 PM
> To: Vishwas Manral; Loa Andersson
> Cc: [email-masked]
> Subject: Re: [mpls] poll on accepting draft-manral-mpls-ldp-ipv6 as anmpls wg document
> 
> Hi Vishwas,
> 
> As the single LDP session can be used for both ipv4 and ipv6 hello adjacencies, then there
> might be a case where one LSR acting as passive role in the ipv4 adjacency and active role in
> ipv6 hello adjacency when both ipv4 and ipv6 adjacencies are established at the same time. In
> this case both adjacent LSRs may end up with passive role or active role based first ipv4 or
> ipv6 adjacency created and then finally the session may not get established. I think this may
> need to be clarified as well.
> 
> Thanks,
> Kishore
>