Subject: Re: [mpls] [mpls-tp] Draft: Response to Updated draft Recommendation G.tpoam [Ref043.02]

From: Larry <[email-masked]>
Date: Thu, 13 Jan 2011 22:55:31 +0800 (CST)

Hi,

    I don't think it is proper to send the LS to ITU-T because the text doesn't reflect the requirement from providers.
    Apparently, draft-bhh based OAM is the most mature solution currently. It has been proved by more than 200,000 applications and is supported by a lot of operators and vendors. 
    
Best regards,

              Han Li

*************************************************************************
Han Li, Ph.D 
China Mobile Research Institute
Unit 2, 28 Xuanwumenxi Ave, Xuanwu District, Beijing 100053, China 
Fax: +86 10 63601087 
MOBILE: 13501093385 
*************************************************************************

--- 11年1月13日，周四, [email-masked] <[email-masked]> 写道：

> 发件人: [email-masked] <[email-masked]>
> 主题: Re: [mpls-tp] [mpls] Draft: Response to Updated draft Recommendation G.tpoam [Ref043.02]
> 收件人: [email-masked]
> 抄送: [email-masked]
> 日期: 2011年1月13日,周四,下午4:09
> Resend to mpls-tp list.
> 
> Quoting [email-masked]:
> 
> > Hi Stewart Bryant,
> > 
> > I don’t agree with the current LS text.
> > 
> > China Telecom support the standardization of Y.1731
> based MPLS-TP OAM tools
> > in 
> > the ITU-T to meet the urgent and increasing
> requirements for PTN deployment. 
> > 
> > It’s a multi-vendor supported, interoperability
> certificated and feasible 
> > solution.  It had been specified in both CCSA
> (China Communications Standards
> > 
> > Association) and China Telecom’s PTN standard as the
> only standard OAM 
> > mechanism.
> > 
> >  
> > 
> > Best Regards
> > 
> > Jing Ruiquan
> > 
> > China　Telecom  Beijing 
> Research　Institute
> > 
> >
> ------------------------------------------------------------------------------
> --
> > From: [email-masked]
> [mailto:[email-masked]]
> On Behalf Of
> > Stewart 
> > Bryant
> > Sent: Monday, January 10, 2011 6:57 PM
> > To: [email-masked]
> > Subject: [mpls] Draft: Response to Updated draft
> Recommendation G.tpoam 
> > [Ref043.02]
> > 
> > 
> > I propose to send the following Liaison Response to
> the ITU-T on Friday 
> > 14th January and am posting it to the MPLS WG list for
> review. 
> > 
> > ======= 
> > 
> > Response to Updated draft Recommendation G.tpoam [Ref
> 043.02] 
> > 
> > From: IETF Liaison to ITU-T on MPLS [email-masked]
> 
> > To: [email-masked],
> [email-masked],
> [email-masked],
> [email-masked] 
> > CC: Greg Jones, [email-masked],
> [email-masked], [email-masked] 
> > [email-masked],
> [email-masked],
> [email-masked] 
> > [email-masked],
> [email-masked]
> 
> > [email-masked],
> [email-masked]
> 
> > [email-masked],
> [email-masked]
> 
> > 
> > For Action 
> > 
> > The MPLS Working Group notes that this document
> contains text describing 
> > MPLS-TP OAM protocols not designed and standardized
> using the IETF 
> > Standards process. Specifically it uses material from
> 
> > draft-bhh-mpls-tp-oam-y1731-06. 
> > 
> > We wish to draw your attention to the status section
> of 
> > draft-bhh-mpls-tp-oam-y1731-06 which states: 
> > 
> > "Internet-Drafts are draft documents valid for a
> maximum of six months 
> > and may be updated, replaced, or obsoleted by other
> documents at any 
> > time. It is inappropriate to use Internet-Drafts as
> reference material 
> > or to cite them other than as "work in progress". 
> > 
> > Please also note that since the draft filename starts
> with the prefix 
> > string "draft-bhh" this clearly identifies it to the
> reader as a 
> > document expressing the personal technical views of
> the authors and 
> > hence hence as a document that that does not have any
> acknowledged level 
> > of IETF consensus. 
> > 
> > Since the text of draft Recommendation for G.tpoam is
> based on an 
> > MPLS-TP OAM protocol not designed within the IETF
> Standards Process this 
> > is a breach of the SG15 agreement with the IETF as
> published in Report 
> > of the first meeting of Working Party 3/15 Transport
> network structures 
> > (2009-2012) (Geneva, 1 – 12 December 2008) which can
> be found at 
> > http://www.itu.int/md/T09-SG15-R-0004/en
> 
> > 
> > Please confirm that the ITU-T intends to continue with
> the joint work on 
> > MPLS-TP and that the ITU-T will align this
> recommendation with the IETF 
> > MPLS-TP OAM design before advancing this document
> through the ITU-T 
> > publication process. 
> > 
> > The MPLS Working Group would also like to draw the
> attention of ITU-T 
> > SG15 to the IETF copyright rules. Please see 
> > http://trustee.ietf.org/license-info/archive/IETF-Trust-License-Policy-
> > 20091228.htm 
> > for further details. 
> > 
> > Since this draft Recommendation contains text in which
> the ITU-T SG15 
> > has proposed making changes to IETF protocols without
> the approval of 
> > the IETF, the MPLS Working Group have referred this
> liaison to the IAB 
> > for their consideration. 
> > 
> > 
> > 
> > ========= 
> > _______________________________________________ 
> > mpls mailing list 
> > [email-masked] 
> > https://www.ietf.org/mailman/listinfo/mpls 
> > 
> > 
> > 
> 
> 
> 
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 13 Jan 2011 16:30:32 +0100

Han Li,

Please note that this liaison is not intended to get into technical discussion or into SPs' requirements. 

It is more on the procedures and processes....

According to the collaborative agreement between the ITU-T and the IETF (which was accepted by ITU-T SG15 in December 2008), the development of the protocol should be done in the IETF using the IETF processes. The ITU-T documents should refer to the IETF solutions. 

We note a document (under development) in the ITU-T (g.tpoam), which includes the definition of messages and procedures for MSPL-TP which were not developed using the IETF standard processes and does not follow the IETF change/extension processes. This is contrary to the agreement between the IETF and the ITU-T from December 2008. 

We are responding on the process and want to be sure (and hope) that the ITU-T intends to continue with the joint work on MPLS-TP as agreed on in December 2008. 

I think the liaison is very well written!

Best regards,

Nurit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Larry
Sent: Thursday, January 13, 2011 4:56 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls-tp] [mpls] Draft: Response to Updated draftRecommendation G.tpoam [Ref043.02]

Hi,

Best regards,

              Han Li

Han Li, Ph.D 

Fax: +86 10 63601087 

MOBILE: 13501093385 

 

 

mpls-tp mailing list

[email-masked]

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Thu, 13 Jan 2011 15:41:46 +0000

Larry,

>    Apparently, draft-bhh based OAM is the most mature solution currently. It has been proved by more than 200,000 applications and is supported by a lot of operators and vendors. 

That may or may not be true, but either way it is irrelevant to the liaison.

ITU liaised G.tpoam to IETF. The liaison response Stewart has drafted points out that G.tpoam uses technology (draft-bhh) that is not endorsed by IETF consensus and points to some risks of doing so, including breach of a prior ITU-IETF agreement on how to progress MPLS-TP development.

Everything in the liaison is fact. Whether draft-bhh is good/bad/ugly, deployed, supported by operators, etc. is irrelevant, it is not endorsed by IETF as a MPLS-TP OAM solution and all the liaison does is point out that fact.

FWIW this isn't the first time a group of operators have brought a proposal to IETF only to find that the IETF has decided to do something else, and I'm sure it won't be the last. 

Ben

P.S. for some reason email chains related to draft-bhh remind me of this Dilbert cartoon http://www.dilbert.com/2010-12-22/

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 13 Jan 2011 16:27:29 +0000

Exactly Ben.

The Liaison is list of statements of relevant facts, and none of the 
contra points dispute those facts.

Stewart

On 13/01/2011 15:41, Ben Niven-Jenkins wrote:
>> --- 11年1月13日，周四, [email-masked]<[email-masked]>  写道：
>>
>>> 发件人: [email-masked]<[email-masked]>

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: David Sinicrope <[email-masked]>
Date: Thu, 13 Jan 2011 12:09:48 -0500

It seems that reference and use of draft-bhh is in violation of the ITU-T external cooperation agreement "Referencing A.5 Qualified Organizations" text found at 
http://www.itu.int/en/ITU-T/extcoop/Pages/sdo.aspx under the Referencing IETF Documents link.
In particular clause 10 of this document states: (See 2nd sentence.)

"10	Other: If a study group decides to make the reference to an IETF RFC, the reference should always be made by RFC number (and not by other designations such as STD, BCP, etc.). References should not be made to documents referred to as "Internet Drafts" or to IETF RFCs categorized as Historic or Experimental. Normative references must only be made to IETF RFCs that are Standards Track or to Informational RFCs that have IETF consensus."

Is this not correct?  If correct, shouldn't this also be pointed out in the liaison?
Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Thursday, January 13, 2011 11:27 AM
To: [email-masked]
Subject: Re: [mpls] [mpls-tp] Draft: Response to Updated draft Recommendation G.tpoam [Ref043.02]

Exactly Ben.

The Liaison is list of statements of relevant facts, and none of the contra points dispute those facts.

Stewart

On 13/01/2011 15:41, Ben Niven-Jenkins wrote:
> P.S. for some reason email chains related to draft-bhh remind me of 
> this Dilbert cartoon http://www.dilbert.com/2010-12-22/
>
>
>
>> Best regards,
>>
>>               Han Li
>>

---

From: "Kyung-Yeop Hong (hongk)" <[email-masked]>
Date: Thu, 13 Jan 2011 11:56:03 -0600

I support the proposal.

IETF has an internal process for evolving and maintaining the IETF protocols for which it is the design authority.  The change processes are in place [RFC4929] for MPLS protocols to work with other SDOs that require enhancements to its protocols and architectures.
I totally agree with the proposed liaison statement.

KY

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stewart Bryant (stbryant)
Sent: Thursday, January 13, 2011 11:27 AM
To: [email-masked]
Subject: Re: [mpls] [mpls-tp] Draft: Response to Updated draft Recommendation G.tpoam [Ref043.02]

Exactly Ben.

Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 13 Jan 2011 18:44:09 +0000

Does anyone disagree with the statement that David makes?

Stewart

---

From: Huub van Helvoort <[email-masked]>
Date: Thu, 13 Jan 2011 23:32:46 +0100

Hello Stewart,

> Does anyone disagree with the statement that David makes?

I disagree with this statement in relation to this liaison.

The draft recommendation G.tpoam that was sent for review does
not contain a reference to draft-bhh at all.

Also the statements about validity and copyright are irrelevant.

Regards, Huub.

==============
>> It seems that reference and use of draft-bhh is in violation of the
>> ITU-T external cooperation agreement "Referencing A.5 Qualified
>> Organizations" text found at
>> "10 Other: If a study group decides to make the reference to an IETF
>> RFC, the reference should always be made by RFC number (and not by
>> other designations such as STD, BCP, etc.). References should not be
>> made to documents referred to as "Internet Drafts" or to IETF RFCs
>> categorized as Historic or Experimental. Normative references must
>> only be made to IETF RFCs that are Standards Track or to Informational
>> RFCs that have IETF consensus."
>>
>>>> I don't think it is proper to send the LS to ITU-T because the text
>>>> doesn't reflect the requirement from providers.
>>>> Apparently, draft-bhh based OAM is the most mature solution
>>>> currently. It has been proved by more than 200,000 applications and
>>>> is supported by a lot of operators and vendors.
>>>>
>>> ITU liaised G.tpoam to IETF. The liaison response Stewart has drafted
>>> points out that G.tpoam uses technology (draft-bhh) that is not
>>> endorsed by IETF consensus and points to some risks of doing so,
>>> including breach of a prior ITU-IETF agreement on how to progress
>>> MPLS-TP development.
>>>
>>> Everything in the liaison is fact. Whether draft-bhh is
>>> good/bad/ugly, deployed, supported by operators, etc. is irrelevant,
>>> it is not endorsed by IETF as a MPLS-TP OAM solution and all the
>>> liaison does is point out that fact.
>>>
>>> FWIW this isn't the first time a group of operators have brought a
>>> proposal to IETF only to find that the IETF has decided to do
>>> something else, and I'm sure it won't be the last.
>>>
>>> Ben
>>>
>>>> --- 11年1月13日，周四,
>>>> [email-masked]<[email-masked]>
>>>> 写道：
>>>>

-- 
*****************************************************************
                          我爱外点一七三一

---

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Thu, 13 Jan 2011 16:51:32 -0600

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Huub van Helvoort
> Sent: Thursday, January 13, 2011 5:33 PM
> To: [email-masked]; [email-masked]
> The draft recommendation G.tpoam that was sent for review does not contain
> a reference to draft-bhh at all.

The liason is here: [https://datatracker.ietf.org/liaison/983/]
and it references "LS233 - Updated draft Recommendation G.tpoam [Ref 043.01] - pdf body" [https://datatracker.ietf.org/documents/LIAISON/file1151.pdf]
which says

----
At the Berlin interim meeting on MPLS-TP further work was undertaken on the development of the 
OAM Recommendation G.tpoam.  This version was developed using all of the relevant input 
documents to the meeting and is based on draft-bhh-mpls-tp-oam-y1731-06.  We invite your 
comments on this document
----

While you are technically correct that G.tpoam does not itself contain a reference to draft-bhh, how are we to interpret the liason statement which claims a clear lineage between draft-bhh and G.tpoam?

> Also the statements about validity and copyright are irrelevant.

Can we assume that you agree they are correct, regardless of relevance?

eric

> >> only be made to IETF RFCs that are Standards Track or to
> >> Informational RFCs that have IETF consensus."
> >>
> >>> ITU liaised G.tpoam to IETF. The liaison response Stewart has
> >>> drafted points out that G.tpoam uses technology (draft-bhh) that is
> >>> not endorsed by IETF consensus and points to some risks of doing so,
> >>>> *******************************************************************
> >>>> **
> >>>> ****
> >>>> Han Li, Ph.D
> >>>> *******************************************************************
> >>>> **
> >>>> ****
> >>>>
> >>>>
> >>>> --- 11年1月13日，周四,
> >>>>> ------------------------------------------------------------------
> >>>>> --
> >>>>> ----------
> >>>>> --
> >>>>>> http://trustee.ietf.org/license-info/archive/IETF-Trust-License-P
> >>>>>> ol
> >>>>>> icy-
> >>>>>> 20091228.htm
> >>>>>> for further details.
> >>>>>>

---

From: John E Drake <[email-masked]>
Date: Thu, 13 Jan 2011 14:49:09 -0800

This liason, https://datatracker.ietf.org/liaison/983/, includes the following statement:

"At the Berlin interim meeting on MPLS-TP further work was undertaken on the development of the OAM Recommendation G.tpoam. This version was developed using all of the relevant input documents to the meeting and is based on draft-bhh-mpls-tp-oam-y1731-06. We invite your comments on this document."

So your statement may be factually correct but misleading. 

Sent from my iPhone

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Huub van Helvoort
> Sent: Thursday, January 13, 2011 2:33 PM
> >> Is this not correct? If correct, shouldn't this also be pointed out
> in
> >> the liaison?
> >> Dave
> >>
> drafted
> >>>>> -----------------------------------------------------------------
> ---
> >>>>> ----------
> >>>>> --
> >>>>>> http://trustee.ietf.org/license-info/archive/IETF-Trust-License-
> Pol
> >>>>>> icy-
> >>>>>> 20091228.htm
> >>>>>> for further details.
> >>>>>>

---

From: Christopher LILJENSTOLPE <[email-masked]>
Date: Fri, 14 Jan 2011 09:53:15 +1100

I agree with Nurit.

	Christopher LILJENSTOLPE
	Director, Architecture, Telstra

>    Apparently, draft-bhh based OAM is the most mature solution currently. It has been proved by more than 200,000 applications and is supported by a lot of operators and vendors. 

---
李柯睿
Check my PGP key here:
https://www.asgaard.org/~cdl/cdl.asc

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Fri, 14 Jan 2011 00:12:53 +0100

Huub,
I would also recommend you to read the report of the rapporteurs of Q9, Q10, Q12 and Q14 from the Berlin meeting.
The report explicitly says that work was undertaken on the development of the OAM protocol G.tpoam, G.8121 and G.8151. The drafts of these documents are based on draft-bhh-mpls-tp-oam-y1731-06.
Best regards,
Nurit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Eric Osborne (eosborne)
Sent: Friday, January 14, 2011 12:52 AM
To: Huub van Helvoort; [email-masked]; [email-masked]
Subject: Re: [mpls] [mpls-tp] Draft: Response to Updateddraft Recommendation G.tpoam [Ref043.02]

----

eric

> >> in the liaison?

---

From: Yuji Tochio <[email-masked]>
Date: Fri, 14 Jan 2011 08:37:08 +0900

Nurit,

You should not discuss on the report of ITU-T interim meeting on
this thread that is for the reviewing LS to ITU-T since the report
was not sent as the part of LS233 from ITU-T.

And it is noted that drafts had been developed using all of the relevant
the input documents to the meeting as well. LSs from ITU-T state
this point as well.

Regards,
Yuji