Subject: [mpls] The concept of MPLS source labels

From: Xuxiaohu <[email-masked]>
Date: Wed, 31 Jul 2013 08:24:16 +0000

Hi all,

As I said at the mic, the concept of source labels has been successfully used in the ATM MPLS paradigm ten years before, which is contained in the VCI field so as to address the ATM cell merge issue.  Hence it seems safe to say that the concept of source labels is workable.

Identifying the source of the received MPLS packet is valuable for the current non-ATM MPLS paragigm as well. Besides the MPLS performance measurement use case as mentioned in the draft, it is useful for the multicast VPN service as well. AFAIK, one of the major reason that LDP-based MP2P LSPs can not be used in the ingress replicaiton mode of multicast VPN service is it's hard for the egress PE to identify the ingress PE of a given received packet for the multicast RPF check purpose.

Best regards,
Xiaohu

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 31 Jul 2013 11:18:31 +0000

Xiaohui,

Although not documented explicitly, MVPN Ingress Replication can use downstream-allocated labels to distinguish the sender PE - an egress PE just need to allocate different labels for different ingress PEs.

A draft that clarifies the Ingress Replication, including the above mentioned label allocation behavior, is already in the work.

Jeffrey

> -----Original Message-----
> From: Xuxiaohu [mailto:[email-masked]]
> Sent: Wednesday, July 31, 2013 10:24 AM
> To: [email-masked]
> Subject: [mpls] The concept of MPLS source labels
> 
> Hi all,
> 
> As I said at the mic, the concept of source labels has been
> successfully used in the ATM MPLS paradigm ten years before, which is
> contained in the VCI field so as to address the ATM cell merge issue.
> Hence it seems safe to say that the concept of source labels is
> workable.
> 
> Identifying the source of the received MPLS packet is valuable for the
> current non-ATM MPLS paragigm as well. Besides the MPLS performance
> measurement use case as mentioned in the draft, it is useful for the
> multicast VPN service as well. AFAIK, one of the major reason that LDP-
> based MP2P LSPs can not be used in the ingress replicaiton mode of
> multicast VPN service is it's hard for the egress PE to identify the
> ingress PE of a given received packet for the multicast RPF check
> purpose.
> 
> Best regards,
> Xiaohu

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 31 Jul 2013 11:56:55 +0000

________________________________________
发件人: Jeffrey (Zhaohui) Zhang [[email-masked]]
发送时间: 2013年7月31日 19:18
到: Xuxiaohu; [email-masked]
主题: RE: [mpls] The concept of MPLS source labels

Xiaohui,

[Xiaohu] In fact, I had proposed that idea about eight years before. See section 2.2. Establishment of full-meshed pseudo-wires of the following draft:
http://tools.ietf.org/pdf/draft-xu-l3vpn-2547bis-mcast-00.pdf

Xiaohu

Jeffrey

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 31 Jul 2013 12:28:01 +0000

Xiaohu,

Thanks for pointing that out.

I was more to speak about whether MVPN Ingress Replication needs the source label or not, and the mentioning of the draft in the work was say that "we know we need to document it and it's being worked on".

Jeffrey

> Sent: Wednesday, July 31, 2013 1:57 PM
> To: Jeffrey (Zhaohui) Zhang; [email-masked]
> Subject: 答复: [mpls] The concept of MPLS source labels
> 
> 
> Although not documented explicitly, MVPN Ingress Replication can use
> downstream-allocated labels to distinguish the sender PE - an egress PE
> just need to allocate different labels for different ingress PEs.
> 
> [Xiaohu] In fact, I had proposed that idea about eight years before.
> See section 2.2. Establishment of full-meshed pseudo-wires of the
> following draft:
> A draft that clarifies the Ingress Replication, including the above
> mentioned label allocation behavior, is already in the work.
> 
> Jeffrey
>