Subject: [mpls] draft-ietf-mpls-special-purpose-labels-01

From: Kireeti Kompella <[email-masked]>
Date: Sun, 7 Jul 2013 11:51:28 -0700

Hi All,

I have updated this document with the following:
a) the range of Standards Action extended special purpose labels is 16-239; experimental is 240-255.  The rest are reserved for now.
b) I've added a question/answer on whether to use extended special purpose labels in load balancing -- saying MUST NOT.
c) Clarified text regarding a label following an extended special purpose (Xuxiaohu's comment).

Finally, I note Lizhong's comment regarding label 7.  The goal in allowing label 7 as either a regular special purpose label or an extended special purpose label is to simplify parsing when searching for an entropy label.  I added text around this, but did not change SHOULD NOT to MUST NOT.

WG chairs, I believe this doc is ready for WG LC.

Kireeti.

---

From: William McCall <[email-masked]>
Date: Sun, 07 Jul 2013 14:25:09 -0500

[editorial stuff]

Section 3, list element #4 says:
" [...]If this decision is revisited later, an accompanying Standards 
Track RFC that details the use of the label, a discussion of possible 
sources of confusion between signaling and data plane, and mitigation 
thereof."
Should say:
Sentence is incomplete. I think you're looking for something like "[...] 
thereof shall be required".

Section 3, list element #6 says:
" [...]these packets be re-ordered."
Should say:
"[...]these packets may be re-ordered."

Section 3.2 sub-part a says:
"[...]not to include deprecated value[...]"
Should say:
"[...]not to include the deprecated value[...]"

Section 5, list element #3 says:
"[...]registry must be also say[...]"
Should say:
"[...]registry must also say[...]"

--WM

---

From: Kireeti Kompella <[email-masked]>
Date: Mon, 8 Jul 2013 08:32:13 -0700

> thereof shall be required".

Sentence, spelled out, is:

"... an accompanying Standards Track RFC that details
a) the use of the label,
b) a discussion of possible sources of confusion between signaling and data
plane, and
c) mitigation thereof."

Seems complete to me.

> "[...]these packets may be re-ordered."

Thanks, will fix.

> "[...]not to include the deprecated value[...]"

Ditto.

> "[...]registry must also say[...]"

Ditto.

Thanks,
Kireeti.

-- 
Kireeti