Subject: Re: [mpls] FW: New Version Notification for draft-manral-mpls-rfc3811bis-03.txt

From: "Rogers, Josh" <[email-masked]>
Date: Mon, 1 Jul 2013 09:16:57 -0400

RE: MplsNewExtendedTunnelId
>For IPv6 this represents an IPv4 address of the ingress or
>egress LSR for the tunnel for an IPv6 network.

We've been interested in changing a couple of private networks to v6 only,
but are waiting for feature in code and maturity of v6 MPLS, so may still
be a while before we can do it.  I noticed that the language about the
Extended TunnelID uses words like 'suggests' and 'should' when speaking
about using a v4 loopback address as the TunnelId for a 'IPv6 network'.
If there is no v4 address because the network is v6 only, what should be
used instead?  Are we setting the expectation that everything will be dual
stacked forever?

Thanks for your response and insight,
Josh

On 6/27/13 11:58 PM, "Will Liu (Shucheng)" <[email-masked]> wrote:

>Hi Folks,
>
>We uploaded a new version to address the comments about MplsLSPID
>description as below. We are looking forward to your further comments.
>Thanks.
>
>Cheers,
>Will
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Friday, June 28, 2013 12:54 PM
>To: Tina TSOU; Will Liu (Shucheng); Francesco Fondelli; Vishwas Manral;
>Will Liu (Shucheng)
>Subject: New Version Notification for draft-manral-mpls-rfc3811bis-03.txt
>
>
>A new version of I-D, draft-manral-mpls-rfc3811bis-03.txt
>has been successfully submitted by Vishwas Manral and posted to the
>IETF repository.
>
>Filename:       draft-manral-mpls-rfc3811bis
>Revision:       03
>Title:          Definitions of Textual Conventions (TCs) for Multiprotocol Label
>Switching (MPLS) Management
>Creation date:  2013-06-28
>Group:          Individual Submission
>Number of pages: 22
>URL:
>http://www.ietf.org/internet-drafts/draft-manral-mpls-rfc3811bis-03.txt
>Status:
>http://datatracker.ietf.org/doc/draft-manral-mpls-rfc3811bis
>Htmlized:
>http://tools.ietf.org/html/draft-manral-mpls-rfc3811bis-03
>Diff:
>http://www.ietf.org/rfcdiff?url2=draft-manral-mpls-rfc3811bis-03
>
>Abstract:
>   This memo defines a Management Information Base (MIB) module which
>   contains Textual Conventions to represent commonly used Multiprotocol
>   Label Switching (MPLS) management information.  The intent is that
>   these TEXTUAL CONVENTIONS (TCs) will be imported and used in MPLS
>   related MIB modules that would otherwise define their own
>   representations.
>
>   This document obsoletes RFC3811 as it addresses the need to support
>   IPv6 extended TunnelID's by defining a new TC-
>   MplsNewExtendedTunnelID which suggests using IPv4 address of the
>   ingress or egress LSR for the tunnel for an IPv6 network.  Changes
>   from RFC3811 and the effect of the new TC to other related documents
>   are summarized in Section 4 and 5, respectively.
>
>
>
>
>
>The IETF Secretariat
>
>_______________________________________________
>mpls mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mpls

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Vishwas Manral <[email-masked]>
Date: Mon, 1 Jul 2013 08:49:13 -0700

Hi Josh,

Good point. I read the words and they did sound very confusing.

As a format its an OCTET STRING, we however need to clarify the definition
of the TC MplsNewExtendedTunnelId. We will update that text across.

Thanks,
Vishwas

On Mon, Jul 1, 2013 at 6:16 AM, Rogers, Josh <[email-masked]>wrote:

> This E-mail and any of its attachments may contain Time Warner Cable
> proprietary information, which is privileged, confidential, or subject to
> copyright belonging to Time Warner Cable. This E-mail is intended solely
> for the use of the individual or entity to which it is addressed. If you
> are not the intended recipient of this E-mail, you are hereby notified that
> any dissemination, distribution, copying, or action taken in relation to
> the contents of and attachments to this E-mail is strictly prohibited and
> may be unlawful. If you have received this E-mail in error, please notify
> the sender immediately and permanently delete the original and any copy of
> this E-mail and any printout.