Subject: Re: [mpls] mpls-rt review of draft­-rhd­-mpls­-tp­-psc­-sd

From: "Hejia (Jia)" <[email-masked]>
Date: Mon, 2 Sep 2013 13:13:43 +0000

Hi All,

I didn't receive my review mail... Resend it...

======

Hi ,

I have finished reviewing draft-rhd-mpls-tp-psc-sd-00.txt as the member of MPLS Review team and have the following comments:

* Is the document coherent?

Yes. It describes the rational to complement current RFC 6378 with protection switching protocol associated with Signal Degrade (SD) and provides the text proposal accordingly.

* Is it useful (i.e., is it likely to be actually useful in operational networks), and is the document technically sound?

Yes.  The document is motivated by enhancing current RFC 6378 to meet ITU-T protection switching requirements (in ITU-T liaison statements) and align with MPLS-TP survivability framework defined in RFC6372. It completes the placeholders wrt SD in RFC 6378.

* Is the document ready to be considered for WG adoption?

Yes. But I have the following comments which appreciates consideration when further developing this document. 
 
1) I notice that the priority issue of "FS" and "SF-P" is not fixed in this document but in another separate document, but they may impact the same paragraph of the text. This may cause misunderstanding if people do not read the other PSC-related drafts together. However, by reading the presentation of the Berlin meeting, there seems another planned draft to integrate all the PSC-related drafts, which may solve this comment. Right? 

2) Typo: Page 14, the first sentence of the second paragraph under 5.10, 

      A local SD-P SHALL cause the LER to go to local Unavailabe state
      and begin transmitting an SD(0,0) message, it the current state is
      due to a (local or remote) MS command.

s/it/if

3) Typo: Page 17, the last three paragraphs, s/SF-W/SD-W

Thanks!

B.R.
Jia

-----邮件原件-----
发件人: Loa Andersson [mailto:[email-masked]] 
发送时间: 2013年8月23日 19:26
收件人: draft??-rhd??-mpls??-tp??-psc??[email-masked]; Eric Gray; Kamran Raza (skraza); Sam Aldrin; Hejia (Jia)
抄送: [email-masked]; Eric Osborne (eosborne)
主题: mpls-rt rebiew of draft-rhd-mpls-tp-psc-sd

Authors and reviewers,

I originally asked for mpls-rt reviews as seen below

draft-rhd-mpls-tp-psc-sd
------------------------
eric osborne
sam aldrin
eric gray
kamran raza

However, it turns out that Eric O is on PTO a little too long
to be optimal; I've there for asked Jia to do this review instead.
She has indicated that she will have the review done by Thu Aug 29.

I guess that Eric O will comment on any psc-draft as necessary, when
he is back.

I don't think this "delay" mean that much, we will be able to
catch up.

Eric G, Sam and Kamran - please review as planned, but if you are
short of time please focus on getting your other document in first.
And line up with Jia's dead line for this document.

/Loa
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Ryoo, Jeong-dong" <[email-masked]>
Date: Tue, 3 Sep 2013 05:41:30 +0000

Jia, thanks for the review.

Regarding your comments:

#1: Yes, your understanding is correct and this draft is just for SD without considering other features. There will be a new document for combining all the features.

#2: It will be corrected.

#3: I have read P.17 and P.18 and couldn't find anything wrong with the sentences containing SF-W.
     Would you please let me know the sentences that you think they are wrong?

Best regards,

Jeong-dong

________________________________
From : "Hejia (Jia)" <[email-masked]>
Sent : 2013-09-02 22:14:49 ( +09:00 )
To : [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Cc : [email-masked] <[email-masked]>
Subject : Re: mpls-rt review of draft-rhd-mpls-tp-psc-sd

Hi All,

======

Hi ,

s/it/if

Thanks!

B.R.
Jia

-----邮件原件-----
发件人: Loa Andersson [mailto:[email-masked]]
发送时间: 2013年8月23日 19:26
收件人: draft??-rhd??-mpls??-tp??-psc??[email-masked]; Eric Gray; Kamran Raza (skraza); Sam Aldrin; Hejia (Jia)
抄送: [email-masked]; Eric Osborne (eosborne)
主题: mpls-rt rebiew of draft-rhd-mpls-tp-psc-sd

Authors and reviewers,

draft-rhd-mpls-tp-psc-sd
------------------------
eric osborne
sam aldrin
eric gray
kamran raza

/Loa
--