Subject: Re: [mpls] mpls-rt review of draft-­cdh-­mpls-­tp-­psc-­non-­revertive

From: "Hejia (Jia)" <[email-masked]>
Date: Mon, 2 Sep 2013 13:09:03 +0000

Hi All,

I didn't receive my review mail... Resend it...

========
Hi ,

I have finished reviewing draft-cdh-mpls-tp-psc-non-revertive-00.txt as the member of MPLS Review team and have the following comments:

* Is the document coherent?

Yes. It describes the rational to complement the non-revertive operation and Manual Switch command (add MS-W) in current RFC 6378 and provides the text proposal accordingly.

* Is it useful (i.e., is it likely to be actually useful in operational networks), and is the document technically sound?

Yes.  The document is motivated by enhancing current RFC 6378 to meet ITU-T protection switching requirements (in ITU-T liaison statements) and align with RFC4427.  It fixes problems with RFC 6378 in some scenarios identified in ITU-T liaisons, which helps MPLS-TP linear protection protocol PSC defined by RFC 6378 to work soundly in operational networks.

* Is the document ready to be considered for WG adoption?

Yes. But I have the following comments which appreciates consideration when further developing this document. 
 
1) Page 6, the replacement of the text about Remote DNR, "... has determined that the switch-over condition has ceased or that the failure condition has recovered and ..."

IMHO, the former condition "the switch-over condition has ceased" already covers the latter condition "the failure condition has recovered". Therefore, it is suggested to delete "the failure condition has recovered" or modify "the switch-over condition has ceased" as "the switch-over condition by administrative commands has ceased"

2) To save effort, the replacement of "Protecting administrative state" with "Switching administrative state" throughout RFC 6378 can be set as a rule in this document without indicating each one.

3) I notice that the priority issue of "FS" and "SF-P" is not fixed in this document but in another separate document, but they may impact the same paragraph of the text. This may cause misunderstanding if people do not read the other PSC-related drafts together. However, by reading the presentation of the Berlin meeting, there seems another planned draft to integrate all the PSC-related drafts, which may solve this comment. Right? 

Thanks!

B.R.
Jia

-----邮件原件-----
发件人: Loa Andersson [mailto:[email-masked]] 
发送时间: 2013年8月23日 19:41
收件人: [email-masked]; [email-masked]; Mach Chen; Yaacov Weingarten; Eric Gray; Hejia (Jia)
主题: mpls-rt review of draft-cdh-mpls-tp-psc-non-revertive

Authors and Reviewers,

I originally asked for mpls-rt reviews as seen below

draft-cdh-mpls-tp-psc-non-revertive
-----------------------------------
mach chen
eric osborne
eric gray
yacoov weingarten

However, it turns out that Eric O is on PTO a little too long
to be optimal; I've there for asked Jia to do this review instead.
She has indicated that she will have the review done by Thu Aug 29.

I guess that Eric O will comment on any psc-draft as necessary, when
he is back.

I don't think this "delay" mean that much, we will be able to
catch up.

Eric G, - please review as planned.
Mach and Yaacov I already have your reviews - tnx!

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: 정태식 <[email-masked]>
Date: Tue, 3 Sep 2013 04:15:25 +0000

Hi Jia,

Thank you for reviewing draft-cdh-mpls-tp-psc-non-revertive-00.

Please see [Taesik] inline.

Best regards,
Taesik

-----Original Message-----
From: Hejia (Jia) [mailto:[email-masked]] 
Sent: Monday, September 02, 2013 10:09 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: mpls-rt review of draft-cdh-mpls-tp-psc-non-revertive

Hi All,

========
Hi ,

 

IMHO, the former condition "the switch-over condition has ceased" already covers the latter condition "the failure condition has recovered". Therefore, it is suggested to delete "the failure condition has recovered" or modify "the switch-over condition has ceased" as "the switch-over condition by administrative commands has ceased"
[Taesik] I agree with your second suggestion for the sake of clarity. It can be reflected in the next version of the draft. 

2) To save effort, the replacement of "Protecting administrative state" with "Switching administrative state" throughout RFC 6378 can be set as a rule in this document without indicating each one.
[Taesik] It can be considered in the next version of the draft.

3) I notice that the priority issue of "FS" and "SF-P" is not fixed in this document but in another separate document, but they may impact the same paragraph of the text. This may cause misunderstanding if people do not read the other PSC-related drafts together. However, by reading the presentation of the Berlin meeting, there seems another planned draft to integrate all the PSC-related drafts, which may solve this comment. Right? 
[Taesik] This draft only describes changes to the RFC6378 regarding non-revertive behavior and MS-W command. So, for example, the priority issue of "FS" and "SF-P" is not fixed in this draft. This comment will be solved in another draft which merges all the changes.

Thanks!

B.R.
Jia

-----邮件原件-----
发件人: Loa Andersson [mailto:[email-masked]]
发送时间: 2013年8月23日 19:41
收件人: [email-masked]; [email-masked]; Mach Chen; Yaacov Weingarten; Eric Gray; Hejia (Jia)
主题: mpls-rt review of draft-cdh-mpls-tp-psc-non-revertive

Authors and Reviewers,

However, it turns out that Eric O is on PTO a little too long to be optimal; I've there for asked Jia to do this review instead.
She has indicated that she will have the review done by Thu Aug 29.

I guess that Eric O will comment on any psc-draft as necessary, when he is back.

I don't think this "delay" mean that much, we will be able to catch up.

/Loa

--

---

From: "Hejia (Jia)" <[email-masked]>
Date: Fri, 6 Sep 2013 01:29:59 +0000

Hi Taesik,

Thanks a lot. I'm OK with your reply. 

B.R.
Jia

-----邮件原件-----
发件人: 정태식 [mailto:[email-masked]] 
发送时间: 2013年9月3日 12:15
收件人: Hejia (Jia); [email-masked]; [email-masked]
抄送: [email-masked]
主题: RE: mpls-rt review of draft-cdh-mpls-tp-psc-non-revertive

Hi Jia,

Best regards,
Taesik

-----Original Message-----
From: Hejia (Jia) [mailto:[email-masked]] 
Sent: Monday, September 02, 2013 10:09 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: mpls-rt review of draft-cdh-mpls-tp-psc-non-revertive

Hi All,

========
Hi ,

 

Thanks!

B.R.
Jia

-----邮件原件-----
发件人: Loa Andersson [mailto:[email-masked]]
发送时间: 2013年8月23日 19:41
收件人: [email-masked]; [email-masked]; Mach Chen; Yaacov Weingarten; Eric Gray; Hejia (Jia)
主题: mpls-rt review of draft-cdh-mpls-tp-psc-non-revertive

Authors and Reviewers,

/Loa

--