Subject: [mpls] MPLS-RT review of draft-rekhter-mpls-pim-sm-over-mldp

From: Gregory Mirsky <[email-masked]>
Date: Wed, 18 Sep 2013 01:48:05 +0000

Dear Authors, WG co-chairs, Martin, et. al,
I find that the draft-rekhter-mpls-pim-sm-over-mldp is:

*         coherent, well written;

*         operationally useful;

*         technically sound.
Hence, in my opinion, it is ready to be considered for the WG adoption.

As I was reading it I've made several notes that Authors may kindly consider for the next edited version:

*         may consider Terminology section and/or make expansion of acronyms on first time used consistent;

*         Abstract s/Switches/Switched/

*         use cross-references as currently Section 2 Introduction references itself as description of Option 1 (apparently it moved to Section 3 at some time);

*         perhaps more descriptive tags for description of Option 1 and Option 2 can be used

*         reference to sub-section "Originating Source Active auto-discovery routes" in Section 4 Option 2 is confusing since there are two sub-sections of the same name (Option 1 and Option 2)

*         should it be Informative References rather than Non-normative References?

Regards,
                        Greg

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 17 Sep 2013 19:21:47 -0700

Greg,

> Hence, in my opinion, it is ready to be considered for the WG adoption.

Thanks.

> on first time used consistent;

I would be glad to expand acronyms on first time use.
  
> *         Abstract s/Switches/Switched/

Sure.

> *  use cross-references as currently Section 2 Introduction references
> itself as description of Option 1 (apparently it moved to Section 3 at 
> some time);

Sorry, my mistake. Will fix it.

> *  perhaps more descriptive tags for description of Option 1 and Option

Loa already asked me for this. Unfortunately I can not come up
with any "more descriptive tags". But I would be glad to accept
any suggestions/recommendations.
  
> * reference to sub-section "Originating Source Active auto-discovery
> routes" in Section 4 Option 2 is confusing since there are two sub-sections
> of the same name (Option 1 and Option 2)

Will fix this.

> * should it be Informative References rather than Non-normative References?

Will fix this.

Thanks for your review.

Yakov.

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 18 Sep 2013 22:40:21 +0000

Hi Yakov,
would the following be accurate and short enough for tags:
*       Option 1 - Non-transitive mapping of IP multicast shared tree over  MPLS network
*       Option 2 - Transitive mapping of IP multicast shared tree over MPLS network

        Regards,
                Greg

-----Original Message-----
From: Yakov Rekhter [mailto:[email-masked]]
Sent: Tuesday, September 17, 2013 7:22 PM
To: Gregory Mirsky
Cc: [email-masked]; [email-masked]; VIGOUREUX, MARTIN (MARTIN) ([email-masked]); [email-masked]
Subject: Re: MPLS-RT review of draft-rekhter-mpls-pim-sm-over-mldp

Greg,

> Dear Authors, WG co-chairs, Martin, et. al, I find that the
> draft-rekhter-mpls-pim-sm-over-mldp is:
>

Thanks.

Sure.

> *  perhaps more descriptive tags for description of Option 1 and
> Option
> 2 can be used

Loa already asked me for this. Unfortunately I can not come up with any "more descriptive tags". But I would be glad to accept any suggestions/recommendations.

> routes" in Section 4 Option 2 is confusing since there are two
> sub-sections of the same name (Option 1 and Option 2)

Will fix this.

Will fix this.

Thanks for your review.

Yakov.

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 23 Sep 2013 07:50:11 -0700

Greg,

> *       Option 1 - Non-transitive mapping of IP multicast shared tree over =
>  MPLS network
> *       Option 2 - Transitive mapping of IP multicast shared tree over MPLS=
>  network

I shorten both to just 
 *  Option 1 - Non-transitive mapping of IP multicast shared tree 
 *  Option 2 - Transitive mapping of IP multicast shared tree 

This is to make each of them fit into a single line in ToC.

Yakov.

> Cc: [email-masked]; [email-masked]=
> etf.org; VIGOUREUX, MARTIN (MARTIN) ([email-masked]); =
> [email-masked]
> Loa already asked me for this. Unfortunately I can not come up with any "mo=
> re descriptive tags". But I would be glad to accept any suggestions/recomme=
> ndations.
> 
> > * should it be Informative References rather than Non-normative Reference=
> s?
> 
> Will fix this.
> 
> Thanks for your review.
> 
> Yakov.
> 
> 
> 
> --_000_7347100B5761DC41A166AC17F22DF1121B6EC08Feusaamb103erics_
> Content-Type: text/html; charset="us-ascii"
> Content-Transfer-Encoding: quoted-printable
> 
> <html>
> <head>
> <meta http-equiv=3D"Content-Type" content=3D"text/html; charset=3Dus-ascii"=
> >
> <meta name=3D"Generator" content=3D"Microsoft Exchange Server">
> <!-- converted from rtf -->
> <style><!-- .EmailQuote { margin-left: 1pt; padding-left: 4pt; border-left:=
>  #800000 2px solid; } --></style>
> </head>
> <body>
> <font face=3D"Calibri" size=3D"2"><span style=3D"font-size:11pt;">
> <div>Hi Yakov,</div>
> <div>would the following be accurate and short enough for tags:</div>
> <ul style=3D"margin:0;padding-left:36pt;">
> <li>Option 1 - Non-transitive mapping of IP multicast shared tree over&nbsp=
> ; MPLS network</li><li>Option 2 - Transitive mapping of IP multicast shared=
>  tree over MPLS network</li></ul>
> <div>&nbsp;</div>
> <div>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Regards,</div>
> <div>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbs=
> p;&nbsp;&nbsp;&nbsp; Greg</div>
> <div>&nbsp;</div>
> <div>-----Original Message-----<br>
> 
> From: Yakov Rekhter [<a href=3D"mailto:[email-masked]">mailto:yakov@juni=
> per.net</a>]
> <br>
> 
> Sent: Tuesday, September 17, 2013 7:22 PM<br>
> 
> To: Gregory Mirsky<br>
> 
> Cc: [email-masked]; [email-masked]=
> etf.org; VIGOUREUX, MARTIN (MARTIN) ([email-masked]); =
> [email-masked]<br>
> 
> Subject: Re: MPLS-RT review of draft-rekhter-mpls-pim-sm-over-mldp </div>
> <div>&nbsp;</div>
> <div>Greg,</div>
> <div>&nbsp;</div>
> <div>&gt; Dear Authors, WG co-chairs, Martin, et. al, I find that the </div=
> >
> <div>&gt; draft-rekhter-mpls-pim-sm-over-mldp is:</div>
> <div>&gt; </div>
> <div>&gt; *&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; coherent, well =
> written;</div>
> <div>&gt; </div>
> <div>&gt; *&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; operationally u=
> seful;</div>
> <div>&gt; </div>
> <div>&gt; *&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; technically sou=
> nd.</div>
> <div>&gt; Hence, in my opinion, it is ready to be considered for the WG ado=
> ption.</div>
> <div>&nbsp;</div>
> <div>Thanks.</div>
> <div>&nbsp;</div>
> <div>&gt; As I was reading it I've made several notes that Authors may kind=
> ly </div>
> <div>&gt; consider for the next edited version:</div>
> <div>&gt; </div>
> <div>&gt; *&nbsp; may consider Terminology section and/or make expansion of=
>  acronyms </div>
> <div>&gt; on first time used consistent;</div>
> <div>&nbsp;</div>
> <div>I would be glad to expand acronyms on first time use.</div>
> <div>&nbsp;</div>
> <div>&gt; *&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Abstract s/Swit=
> ches/Switched/</div>
> <div>&nbsp;</div>
> <div>Sure.</div>
> <div>&nbsp;</div>
> <div>&gt; *&nbsp; use cross-references as currently Section 2 Introduction =
> references </div>
> <div>&gt; itself as description of Option 1 (apparently it moved to Section=
>  3 at </div>
> <div>&gt; some time);</div>
> <div>&nbsp;</div>
> <div>Sorry, my mistake. Will fix it.</div>
> <div>&nbsp;</div>
> <div>&gt; *&nbsp; perhaps more descriptive tags for description of Option 1=
>  and </div>
> <div>&gt; Option</div>
> <div>&gt; 2 can be used</div>
> <div>&nbsp;</div>
> <div>Loa already asked me for this. Unfortunately I can not come up with an=
> y &quot;more descriptive tags&quot;. But I would be glad to accept any sugg=
> estions/recommendations.</div>
> <div>&nbsp;</div>
> <div>&gt; * reference to sub-section &quot;Originating Source Active auto-d=
> iscovery </div>
> <div>&gt; routes&quot; in Section 4 Option 2 is confusing since there are t=
> wo </div>
> <div>&gt; sub-sections of the same name (Option 1 and Option 2)</div>
> <div>&nbsp;</div>
> <div>Will fix this.</div>
> <div>&nbsp;</div>
> <div>&gt; * should it be Informative References rather than Non-normative R=
> eferences?</div>
> <div>&nbsp;</div>
> <div>Will fix this.</div>
> <div>&nbsp;</div>
> <div>Thanks for your review.</div>
> <div>&nbsp;</div>
> <div>Yakov.</div>
> <div>&nbsp;</div>
> <div>&nbsp;</div>
> </span></font>
> </body>
> </html>
> 
> --_000_7347100B5761DC41A166AC17F22DF1121B6EC08Feusaamb103erics_--
>