Subject: [mpls] MPLS WG last call on draft-ietf-mpls-in-udp-03.txt

From: Ross Callon <[email-masked]>
Date: Thu, 12 Sep 2013 16:42:58 +0000

Working Group,

This is to start Working Group last call on  draft-ietf-mpls-in-udp-03.txt

Please send your comments to the mpls working group mailing list ([email-masked]<mailto:[email-masked]>).

Please send both technical comments, and (if you are happy with the document as is)
also send indications of support.

There is one IPR claim that applies to this draft, which can be seen at:
https://datatracker.ietf.org/ipr/1941/

The coauthors and contributor have indicated that they don't know of any other
IPR applicable to this draft. If anyone else in the working group is aware of IPR
claims against this draft, the time to disclose that is now.

This working group last call will end on September 27, 2013.

Ross
for the wg co-chairs

---

From: Richard Li <[email-masked]>
Date: Tue, 17 Sep 2013 22:29:53 +0000

Support.

/Richard

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ross Callon
Sent: Thursday, September 12, 2013 9:43 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [mpls] MPLS WG last call on draft-ietf-mpls-in-udp-03.txt

Working Group,

Ross
for the wg co-chairs

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 18 Sep 2013 07:27:39 +0000

Support.

Best regards,
Jie

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ross Callon
Sent: Thursday, September 12, 2013 7:43 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [mpls] MPLS WG last call on draft-ietf-mpls-in-udp-03.txt

Working Group,

Ross
for the wg co-chairs

---

From: Sriganesh Kini <[email-masked]>
Date: Fri, 20 Sep 2013 16:05:51 -0700

There is no reference cited for the "MPLS-in-IP" encapsulation.

What is the applicability of this encapsulation compared to the generalized
mechanism in draft-quinn-vxlan-gpe ?

- Sri

On Thu, Sep 12, 2013 at 9:42 AM, Ross Callon <[email-masked]> wrote:

>   Working Group,****
>  ****
> ****
>  ****
> Please send your comments to the mpls working group mailing list (
> [email-masked]).****
>
>  ****
>
> Please send both technical comments, and (if you are happy with the
> document as is) ****
>
> also send indications of support.****
>
>  ****
>
> There is one IPR claim that applies to this draft, which can be seen at:**
> **
>
> https://datatracker.ietf.org/ipr/1941/****
>
> ** **
>
> The coauthors and contributor have indicated that they don’t know of any
> other ****
>
> IPR applicable to this draft. If anyone else in the working group is aware
> of IPR ****
>
> claims against this draft, the time to disclose that is now.****
>
>  ****
>
> This working group last call will end on September 27, 2013.****
>
>  ****
>
> Ross****
>
> for the wg co-chairs****
>
> ** **
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>
>

---

From: Xuxiaohu <[email-masked]>
Date: Mon, 23 Sep 2013 06:02:10 +0000

Hi Sri,

发件人: [email-masked] [mailto:[email-masked]] 代表 Sriganesh Kini
发送时间: 2013年9月21日 7:06
收件人: Ross Callon
抄送: [email-masked]; [email-masked]; [email-masked]
主题: Re: [mpls] MPLS WG last call on draft-ietf-mpls-in-udp-03.txt

[Xiaohu] MPLS-in-IP and MPLS-in-GRE are actually specified in the same RFC that is RFC4023.

What is the applicability of this encapsulation compared to the generalized mechanism in draft-quinn-vxlan-gpe ?

[Xiaohu] The applicability of this encapsulation is the same as the existing IP-based encapsulations for MPLS (e.g., MPLS-in-GRE).

Best regards,
Xiaohu

- Sri

On Thu, Sep 12, 2013 at 9:42 AM, Ross Callon <[email-masked]<mailto:[email-masked]>> wrote:
Working Group,

The coauthors and contributor have indicated that they don’t know of any other
IPR applicable to this draft. If anyone else in the working group is aware of IPR
claims against this draft, the time to disclose that is now.

Ross
for the wg co-chairs

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls

---

From: Sriganesh Kini <[email-masked]>
Date: Mon, 23 Sep 2013 12:39:33 -0700

Hi Xu,

The existing encapsulations you pointed out were defined a long time ago.
Whereas the other two are just being proposed now. Moreover if we follow
this approach it will require standardizing UDP port numbers for each new
protocol to encap into UDP.

- Sri

On Sun, Sep 22, 2013 at 11:02 PM, Xuxiaohu <[email-masked]> wrote:

>  Hi Sri,****
>
> ** **
>
> *发件人:* [email-masked] [mailto:[email-masked]] *代表 *Sriganesh
> Kini
> *发送时间:* 2013年9月21日 7:06
> *收件人:* Ross Callon
> *抄送:* [email-masked]; [email-masked]; [email-masked]
> *主题:* Re: [mpls] MPLS WG last call on draft-ietf-mpls-in-udp-03.txt****
>
> ** **
>
> There is no reference cited for the "MPLS-in-IP" encapsulation.****
>
> ** **
>
> [Xiaohu] MPLS-in-IP and MPLS-in-GRE are actually specified in the same RFC
> that is RFC4023.****
>
> ** **
>
> What is the applicability of this encapsulation compared to the
> generalized mechanism in draft-quinn-vxlan-gpe ?****
>
> ** **
>
> [Xiaohu] The applicability of this encapsulation is the same as the
> existing IP-based encapsulations for MPLS (e.g., MPLS-in-GRE).****
>
> ** **
>
> Best regards,****
>
> Xiaohu****
>
> ** **
>
> - Sri****
>
> ** **
>
> On Thu, Sep 12, 2013 at 9:42 AM, Ross Callon <[email-masked]> wrote:*
> ***
>
> Working Group,****
>
>  ****
>
> https://www.ietf.org/mailman/listinfo/mpls****
>
> ** **
>

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 24 Sep 2013 02:00:51 +0000

Hi Sri,

It’s no problem provided that anybody was willing to use VXLAN-GPE to replace the existing MPLS-based applications such as L2 or L3 VPN services. Furthermore, there is another choice for VXLAN extension other than VXLAN-GPE, which has been described in http://tools.ietf.org/html/draft-yong-l3vpn-nvgre-vxlan-encap-00. I’m willing to hear your further comments on the comparison of these two options for VXLAN extension (Maybe MPLS WG is not a suitable place to talk about this topic).

Xiaohu

发件人: [email-masked] [mailto:[email-masked]] 代表 Sriganesh Kini
发送时间: 2013年9月24日 3:40
收件人: Xuxiaohu
抄送: Ross Callon; [email-masked]; [email-masked]; [email-masked]
主题: Re: [mpls] 答复: MPLS WG last call on draft-ietf-mpls-in-udp-03.txt

Hi Xu,

The existing encapsulations you pointed out were defined a long time ago. Whereas the other two are just being proposed now. Moreover if we follow this approach it will require standardizing UDP port numbers for each new protocol to encap into UDP.

- Sri

On Sun, Sep 22, 2013 at 11:02 PM, Xuxiaohu <[email-masked]<mailto:[email-masked]>> wrote:
Hi Sri,

发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] 代表 Sriganesh Kini
发送时间: 2013年9月21日 7:06
收件人: Ross Callon
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [mpls] MPLS WG last call on draft-ietf-mpls-in-udp-03.txt

Best regards,
Xiaohu

- Sri

Ross
for the wg co-chairs

---

From: Sriganesh Kini <[email-masked]>
Date: Wed, 25 Sep 2013 16:13:53 -0700

Hi Xu,

I read the other draft you pointed to and I don't see how that helps. What
I had said earlier was that having a protocol-id in a header following the
UDP header but before the user payload (in this draft the MPLS packet is
the user payload) keeps the design generic and any protocol (not just MPLS
applications) can then use such an encapsulation. Standardizing UDP port
numbers to denote protocol types consumes the port number space and is
unnecessary. Another important point is that developing OAM using a header
after the UDP hdr but before the user-payload is easier.

- Sri

On Mon, Sep 23, 2013 at 7:00 PM, Xuxiaohu <[email-masked]> wrote:

>  Hi Sri,****
>
> ** **
>
> It’s no problem provided that anybody was willing to use VXLAN-GPE to
> replace the existing MPLS-based applications such as L2 or L3 VPN services.
> Furthermore, there is another choice for VXLAN extension other than
> VXLAN-GPE, which has been described in
> http://tools.ietf.org/html/draft-yong-l3vpn-nvgre-vxlan-encap-00. I’m
> willing to hear your further comments on the comparison of these two
> options for VXLAN extension (Maybe MPLS WG is not a suitable place to talk
> about this topic).****
>
> ** **
>
> Xiaohu****
>
> ** **
>
> *发件人:* [email-masked] [mailto:[email-masked]] *代表 *Sriganesh
> Kini
> *发送时间:* 2013年9月24日 3:40
> *收件人:* Xuxiaohu
> *抄送:* Ross Callon; [email-masked]; [email-masked];
> [email-masked]
> *主题:* Re: [mpls] 答复: MPLS WG last call on draft-ietf-mpls-in-udp-03.txt***
> *
>
> ** **
>
> Hi Xu,****
>
> ** **
>
> protocol to encap into UDP.****
>
> ** **
>
> - Sri****
>
> ** **
>
> On Sun, Sep 22, 2013 at 11:02 PM, Xuxiaohu <[email-masked]> wrote:***
> *
>
> Hi Sri,****
>
>  ****
>

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 26 Sep 2013 01:37:43 +0000

Hi Sri,

Since you don’t see how that draft (http://tools.ietf.org/html/draft-yong-l3vpn-nvgre-vxlan-encap-00) helps, I’m curious to know why you had intentionally mentioned draft-quinn-vxlan-gpe before. Have you found any significant difference between them?

Best regards,
Xiaohu

发送时间: 2013年9月26日 7:14

Hi Xu,

I read the other draft you pointed to and I don't see how that helps. What I had said earlier was that having a protocol-id in a header following the UDP header but before the user payload (in this draft the MPLS packet is the user payload) keeps the design generic and any protocol (not just MPLS applications) can then use such an encapsulation. Standardizing UDP port numbers to denote protocol types consumes the port number space and is unnecessary. Another important point is that developing OAM using a header after the UDP hdr but before the user-payload is easier.

- Sri

On Mon, Sep 23, 2013 at 7:00 PM, Xuxiaohu <[email-masked]<mailto:[email-masked]>> wrote:
Hi Sri,

Xiaohu

发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] 代表 Sriganesh Kini
发送时间: 2013年9月24日 3:40
收件人: Xuxiaohu
抄送: Ross Callon; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [mpls] 答复: MPLS WG last call on draft-ietf-mpls-in-udp-03.txt

Hi Xu,

- Sri

Best regards,
Xiaohu

- Sri

Ross
for the wg co-chairs

---

From: Sriganesh Kini <[email-masked]>
Date: Fri, 27 Sep 2013 16:58:54 -0700

Xu,

The other draft I referred to was just an example to point out the
difference with draft-ietf-mpls-in-udp.

Let me re-phrase my concerns without referring to other drafts.
1. The approach uses dest UDP port number to map to a protocol identifier
(in this case, MPLS) for the user-payload. If other protocols were to
follow this approach we would be assigning a UDP port number for each such
protocol identifier. This unnecessarily consumes the UDP port number space.
Would be better to have a shim header that has a "protocol type". This
should be after the UDP header but before the user payload.
2. This draft has no text on OAM issues for this encapsulation. Even though
the UDP provides the advantage of load-balancing, how can a connectivity
check at the IP layer that follows the same path as a user-payload be
performed ? Having a shim header should allow such functions to be
incorporated.

These issues must be addressed before this is adopted as an RFC. In its
current form I do not support this draft.

- Sri

On Wed, Sep 25, 2013 at 6:37 PM, Xuxiaohu <[email-masked]> wrote:

>  Hi Sri,****
>
> ** **
>
> Since you don’t see how that draft (
> http://tools.ietf.org/html/draft-yong-l3vpn-nvgre-vxlan-encap-00) helps,
> I’m curious to know why you had intentionally mentioned
> draft-quinn-vxlan-gpe before. Have you found any significant difference
> between them?****
>
> ** **
>
> Best regards,****
>
> Xiaohu****
>
> ** **
>
> *发送时间:* 2013年9月26日 7:14
> after the UDP hdr but before the user-payload is easier.****
>
>  ****
>
> - Sri****
>
> ** **
>
> On Mon, Sep 23, 2013 at 7:00 PM, Xuxiaohu <[email-masked]> wrote:****
>
> Hi Sri,****
>
>  ****
>