Subject: [mpls] Response to Liaison on Clarifying P2MP Combinations

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Fri, 22 Nov 2013 01:15:29 +0000

PWE3 and MPLS Working Groups

Please find below a draft response to the liaison from ITU-T SG15 of July 2013 on clarifying combinations of point to multipoint pseudowires and LSPs.

Please direct any discussion to the PWE3 list.

We would like to reply to the ITU by Wednesday 27th November.

Regards

Matthew and Andy

===============

Body:

Thank you for your liaison of July 2013 inquiring on the valid use of p2mp pseudowires and LSPs. A new version of the "Requirements and Framework for Point-to-Multipoint Pseudowires over MPLS PSNs" is available (see  draft-ietf-pwe3-p2mp-pw-requirements-06.txt) that should help to clarify some of the points in your liaison.

In general, point-to-point PWs are not intended to be used in conjunction with P2MP LSPs.  There is currently no way for the PEs terminating all of the P2MP LSP leaves to establish the applicable PW/FEC label mappings.  We do not believe that this case is supported by the PWE3 architecture.  The only current valid case for P2MP PWs is when used with corresponding P2MP LSPs, as described in the draft referenced above.

Best regards,

Matthew Bocci
Andrew Malis

IETF PWE3 Working Group Chairs

---

From: Loa Andersson <[email-masked]>
Date: Sat, 23 Nov 2013 12:13:58 +0800

Mathew, working groups,

Good response! I'm OK with sending this!

Thanks for the all the work! One small question and one suggetion.

Ouestion:
Is this intended to be sent "For Information"?

Suggestuion:
Since this was sent in two identical liaisons to PWE# and MPLS can we
send it from the chairs of both working groups?

/Loa
mpls wg co-chair

On 2013-11-22 09:15, Bocci, Matthew (Matthew) wrote:
> Please find below a draft response to the liaison from ITU-T SG15 of
> July 2013 on clarifying combinations of point to multipoint pseudowires
> and LSPs.
>
> Thank you for your liaison of July 2013 inquiring on the valid use of
> p2mp pseudowires and LSPs. A new version of the "Requirements and
> Framework for Point-to-Multipoint Pseudowires over MPLS PSNs" is
> available (see  draft-ietf-pwe3-p2mp-pw-requirements-06.txt) that should
> help to clarify some of the points in your liaison.
> In general, point-to-point PWs are not intended to be used in
> conjunction with P2MP LSPs.  There is currently no way for the PEs
> terminating all of the P2MP LSP leaves to establish the applicable
> PW/FEC label mappings.  We do not believe that this case is supported by
> the PWE3 architecture.  The only current valid case for P2MP PWs is when
> used with corresponding P2MP LSPs, as described in the draft referenced
> above.
>
> Best regards,
>
>
> Matthew Bocci
> Andrew Malis
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sat, 23 Nov 2013 09:14:17 -0500

Loa,

Yes, this is meant for information, not for action, and it's a good
idea for it to come from both WGs in one response.

Cheers,
Andy

---

From: Huub van Helvoort <[email-masked]>
Date: Sat, 23 Nov 2013 15:43:08 +0100

Hello Matthew,

> July 2013 on clarifying combinations of point to multipoint pseudowires

Please see in-line [hvh]
Best regards, Huub.

[hvh] you mention that some of the points are clarified, are the 
remaining points clarified by another liaison or by the text that
follows?

> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样

---

From: Loa Andersson <[email-masked]>
Date: Mon, 25 Nov 2013 09:20:55 +0800

Folks,

I think what should be done is to drop "some of" from the first
paragraph and in the second say "Additionally, point-to-point PWs are
not in general intended to ..."

/Loa

--

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Mon, 25 Nov 2013 12:44:26 +0000

Loa, 

Yes, I agree with your suggested clarification.

Best regards

Matthew

---

From: Eric Gray <[email-masked]>
Date: Mon, 25 Nov 2013 14:14:53 +0000

In addition, should the last sentence in the proposed liaison letter text be changed
from:

  "The only current valid case for P2MP PWs is when used with corresponding P2MP 
    LSPs, as described in the draft referenced above"

to:

  "The only current valid case for PW use in a point-to-multipoint scenario is when 
    a P2MP PW is used with a corresponding P2MP LSP, as described in the draft 
    referenced above"?

I believe we are trying to say two things:

1) use of multiple P2P PWs in conjunction with a single P2MP LSP is (generally?) 
     not valid;
2) use of a P2MP PW in conjunction with one or more P2P LSPs is definitely not 
     valid.

We make the point (in the second paragraph) that there is (currently?) an issue
(potentially pathological?) associated with use of P2P PWs with a P2MP.  I would
think we want to discourage this usage.

The current text makes the second point, more than it makes the first.  As it is
currently worded, this text implies that use of multiple P2P PWs _might_ be a
valid use case, even though this seems to differ slightly from what I think we're
trying to say in the second paragraph...

--
Eric

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Sunday, November 24, 2013 8:21 PM
To: [email-masked]; Bocci, Matthew (Matthew); [email-masked]
Cc: [email-masked]
Subject: Re: [mpls] [PWE3] Response to Liaison on Clarifying P2MP Combinations

Folks,

I think what should be done is to drop "some of" from the first paragraph and in the second say "Additionally, point-to-point PWs are not in general intended to ..."

/Loa

On 2013-11-23 22:43, Huub van Helvoort wrote:
>> July 2013 on clarifying combinations of point to multipoint 
>> pseudowires and LSPs.
>
> Please see in-line [hvh]
> Best regards, Huub.
>
>> ===============
>> Body:
>>
>> available (see  draft-ietf-pwe3-p2mp-pw-requirements-06.txt) that 
>> should help to clarify some of the points in your liaison.
>
>> PW/FEC label mappings.  We do not believe that this case is supported 
>> by the PWE3 architecture.  The only current valid case for P2MP PWs 
>> is when used with corresponding P2MP LSPs, as described in the draft 
>> referenced above.
>>
>> Best regards,
>>
>>
>> Matthew Bocci
>> Andrew Malis
>>

--

---

From: Loa Andersson <[email-masked]>
Date: Tue, 26 Nov 2013 12:16:45 +0800

<snip>
> 2) use of a P2MP PW in conjunction with one or more P2P LSPs is definitely not
snip>

Well a MS-PW could do P2MP over P2P LSPs, right?

/Loa

--

---

From: Eric Gray <[email-masked]>
Date: Tue, 26 Nov 2013 14:45:28 +0000

Loa,

	I think you mean on a per-segment basis, where a group of PW-branches
would traverse the segment using the same segment-ingress/egress pair, right?

	If so, this is not logically different from having the same set of PW-branches
traversing a common link.  I guess it is possible that a P2MP MS-PW would only use 
P2P LSPs in every segment; that would require every branching point to be at the
points where the P2P LSP in one domain terminates and two or more P2P LSPs are
used to forward distinct subsets of the P2MP PW through the next domain.  This
seems likely (to me, anyway) only if the LSR at the domain boundary belongs to
both domains (not the common case, I believe).  

	If there was no branching at domain boundaries, and no P2MP LSPs in any 
domain, it beggars the imagination as to why a P2MP PW would be used in the first 
place, so the overall set of LSPs would effectively be P2MP - wouldn't they?

	But, if you think transport of a P2MP PW over a set of P2P LSPs exclusively 
is a valid scenario to consider, why include the text in question at all?

	Since you snipped it, I am adding back the text in question.  It says:

  " The only current valid case for P2MP PWs is when used with corresponding P2MP 
    LSPs, as described in the draft referenced above."

	The primary message in this text is that carrying a P2MP PW over anything 
other than a P2MP LSP is invalid.  If that is not the clarification we want to provide,
then we need to change this text, or remove it.

--
Eric

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]] 
Sent: Monday, November 25, 2013 11:17 PM
To: Eric Gray; [email-masked]; Bocci, Matthew (Matthew); [email-masked]
Cc: [email-masked]
Subject: Re: [mpls] [PWE3] Response to Liaison on Clarifying P2MP Combinations
Importance: High

<snip>
snip>

/Loa

--

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Tue, 26 Nov 2013 15:56:08 +0000

Eric

Theoretically it is possible, but the key is in the word Œcurrent¹. The
P2MP requirements/framework was deliberately scoped down after AD review,
from the problem of any P2MP PW over any underlying LSP type. Trying to
define all possible combinations in a single document (when we hadn¹t even
characterised the simplest case) was going far beyond the basic
requirements from VPMS.

Maybe we should rephrase the sentence below as follows:

" The only use case for P2MP PWs described in the draft referenced above
is when used with corresponding P2MP
    LSPs. Other more complex use cases are for further study. If required,
participants are encouraged to bring extensions to this architecture to
the PWE3 working group."

Matthew

---

From: Eric Gray <[email-masked]>
Date: Tue, 26 Nov 2013 15:59:01 +0000

Matthew,

	Your wording is acceptable to me.  It certainly makes the clarification clearer.

:-)
--
Eric

-----Original Message-----
From: Bocci, Matthew (Matthew) [mailto:[email-masked]] 
Sent: Tuesday, November 26, 2013 10:56 AM
To: Eric Gray; Loa Andersson; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [mpls] [PWE3] Response to Liaison on Clarifying P2MP Combinations
Importance: High

Eric

Matthew