Subject: [mpls] Fwd: seeking consensus on making draft-ietf-mpls-tp-te-mib read-only

From: Agrahara Kiran Koushik <[email-masked]>
Date: Tue, 4 Feb 2014 10:23:19 -0600

Hi

Oppose.

At present all the TP MIB implementations within Cisco are read-only. But we need the MIBs to be read-write/create
to handle future requirements.

Thanks
Kiran

>> ---------- Forwarded message ----------
>> From: Muly Ilan <[email-masked]>
>> Date: Tuesday, February 4, 2014
>> Subject: seeking consensus on making draft-ietf-mpls-tp-te-mib read-only
>> To: Loa Andersson <[email-masked]>, "[email-masked]" <[email-masked]>
>> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
>> 
>> 
>> Oppose.
>> 
>> In our implementation we need read-write/read-create access for the TE and LSR extensions.
>> 
>> Specifically, the new functionality provided by mplsIdGlobalId, mplsIdNodeId and mplsTunnelExtNodeConfigTable can only be realized by read-write/read-create objects.
>> 
>> Regards,
>> 
>> Muly Ilan
>> 
>> -----Original Message-----
>> From: mpls [mailto:[email-masked]] On Behalf Of Loa Andersson
>> Sent: Tuesday, February 04, 2014 8:55 AM
>> To: [email-masked]
>> Cc: [email-masked]; [email-masked]
>> Subject: [mpls] seeking consensus on making draft-ietf-mpls-tp-te-mib read-only
>> 
>> Working Group,
>> 
>> We have just recalled draft-ietf-mpls-tp-te-mib from the IESG to the working group for more work. We have a series of comments that are mostly for clarification. However the main reason for recalling the document is that there is one point where we need to confirm working group consensus.
>> 
>> The IETF, the working group and the MIB Doctors are today very reluctant to produce read-write MIB modules. The current draft is read-write for a few objects, this is based on a consensus call for an earlier discussion, however the consensus call was not clear. It can be taken to mean both that we want to go with read-write objects and that we want to see read-only. Is it clear that it has been interpreted differently by different individuals.
>> 
>> The authors and chairs have discussed the issue and we have a rough consensus that we want the MIB module(s) to be read-only.
>> 
>> We therefore are asking the working group if this is OK for the MIB
>> module(s) in the current document. Please indicate Support or Oppose for this MIB (draft-ietf-mpls-tp-te-mib) to be read-only.
>> 
>> Please send your comments to the working group mailing list before February 18, 2014.
>> 
>> Loa
>> for the MPLS wg chairs
>> --
>> 
>> 
>> Loa Andersson                        email: [email-masked]
>> Senior MPLS Expert                          [email-masked]
>> Huawei Technologies (consultant)     phone: +46 739 81 21 64
>> _______________________________________________
>> mpls mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/mpls
>> 
>> 
>> 
>

---

From: Agrahara Kiran Koushik <[email-masked]>
Date: Wed, 5 Feb 2014 12:39:51 -0600

I'd like to change my decision to "Support" based on Cisco-wide consensus to 
support read-only MIBs in the future.

Thanks
Kiran