Subject: [mpls] seeking consensus on making draft-ietf-mpls-tp-te-mib read-only

From: Loa Andersson <[email-masked]>
Date: Tue, 04 Feb 2014 14:55:21 +0800

Working Group,

We have just recalled draft-ietf-mpls-tp-te-mib from the IESG to the
working group for more work. We have a series of comments that are
mostly for clarification. However the main reason for recalling the
document is that there is one point where we need to confirm working
group consensus.

The IETF, the working group and the MIB Doctors are today very reluctant
to produce read-write MIB modules. The current draft is read-write for a 
few objects, this is based on a consensus call for an earlier
discussion, however the consensus call was not clear. It can be taken
to mean both that we want to go with read-write objects and that we
want to see read-only. Is it clear that it has been interpreted
differently by different individuals.

The authors and chairs have discussed the issue and we have a rough
consensus that we want the MIB module(s) to be read-only.

We therefore are asking the working group if this is OK for the MIB
module(s) in the current document. Please indicate Support or Oppose
for this MIB (draft-ietf-mpls-tp-te-mib) to be read-only.

Please send your comments to the working group mailing list before
February 18, 2014.

Loa
for the MPLS wg chairs
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 4 Feb 2014 06:57:44 +0000

yes/support read-only MIB

	Regards,
		Greg

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Monday, February 03, 2014 10:55 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [mpls] seeking consensus on making draft-ietf-mpls-tp-te-mib read-only

Working Group,

We have just recalled draft-ietf-mpls-tp-te-mib from the IESG to the working group for more work. We have a series of comments that are mostly for clarification. However the main reason for recalling the document is that there is one point where we need to confirm working group consensus.

The IETF, the working group and the MIB Doctors are today very reluctant to produce read-write MIB modules. The current draft is read-write for a few objects, this is based on a consensus call for an earlier discussion, however the consensus call was not clear. It can be taken to mean both that we want to go with read-write objects and that we want to see read-only. Is it clear that it has been interpreted differently by different individuals.

The authors and chairs have discussed the issue and we have a rough consensus that we want the MIB module(s) to be read-only.

We therefore are asking the working group if this is OK for the MIB
module(s) in the current document. Please indicate Support or Oppose for this MIB (draft-ietf-mpls-tp-te-mib) to be read-only.

Please send your comments to the working group mailing list before February 18, 2014.

Loa
for the MPLS wg chairs
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 4 Feb 2014 05:59:40 -0800

I support removal of all writable objects in this MIB.

Tom 

> On Feb 3, 2014, at 10:55 PM, Loa Andersson <[email-masked]> wrote:
> 
> Working Group,
> 
> to produce read-write MIB modules. The current draft is read-write for a few objects, this is based on a consensus call for an earlier

---

From: Muly Ilan <[email-masked]>
Date: Tue, 4 Feb 2014 14:49:06 +0000

Oppose.

In our implementation we need read-write/read-create access for the TE and LSR extensions.

Specifically, the new functionality provided by mplsIdGlobalId, mplsIdNodeId and mplsTunnelExtNodeConfigTable can only be realized by read-write/read-create objects.

Regards,

Muly Ilan

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Tuesday, February 04, 2014 8:55 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [mpls] seeking consensus on making draft-ietf-mpls-tp-te-mib read-only

Working Group,

Loa
for the MPLS wg chairs
--

---

From: Curtis Villamizar <[email-masked]>
Date: Tue, 04 Feb 2014 15:08:53 -0500

Support these as read-only.

See inline for comments on prior post.

In message <[email-masked]>
Muly Ilan writes:
> Specifically, the new functionality provided by mplsIdGlobalId,
> mplsIdNodeId and mplsTunnelExtNodeConfigTable can only be realized by
> read-write/read-create objects.

The reason that people in operations and equipment vendors both
generally oppose read/write MIBs is that they are a bad way to
configure equipment.  Some reasons are:

  1. MIB sets using UDP are unreliable and need to be confirmed.

  2. MIB sets generally require small configuration change operations.
     Sparse bulk set operations are not supported.

  3. Large configuration changes using MIB requires lots of small
     operations followed by confirmation in most cases after each
     small operation.  Large atomic operations are not possible.

  4. Large configuration changes are common for providers that batch
     changes and apply them during "maintenance windows" during very
     off-peak hours such that should something go wrong or small
     disruptions occur, the impact to most enterprises is minimal.

  5. Configuration changes, both small and large are better
     accomplished through other means such as NETCONF.

Note that some tools based on the Yang language can translate a MIB
into an XML dialect suitable for use with NETCONF.  This may be a good
transition strategy if you had planned to use read/write MIB.

> Muly Ilan

Curtis

> The IETF, the working group and the MIB Doctors are today very
> reluctant to produce read-write MIB modules. The current draft is
> read-write for a few objects, this is based on a consensus call for an
> earlier discussion, however the consensus call was not clear. It can
> be taken to mean both that we want to go with read-write objects and
> that we want to see read-only. Is it clear that it has been
> interpreted differently by different individuals.
>

---

From: Muly Ilan <[email-masked]>
Date: Tue, 4 Feb 2014 22:29:17 +0000

Hi Curtis,

I agree with some (most) of the points you listed below.
It's not my intention to start a debate on the pros/cons of SNMP as a provisioning protocol.

Currently, our products do not support NETCONF. I believe this is the case for other vendors as well.

In addition, we already support the MPLS-TE-STD-MIB and MPLS-LSR-STD-MIB for MPLS-TE provisioning. So for us the shortest TTM is to add MIB extensions for MPLS-TP provisioning. I believe this is the case for other vendors as well.

Since we need the functionality of mapping the MPLS-TP identifiers, Global_ID::Node_ID, to the ingress/egress LSR identifier in existing mplsTunnelTable the mpls-tp-te-mib in its present contents, with read-write/read-create objects, is good for us.

Muly

-----Original Message-----
From: Curtis Villamizar [mailto:[email-masked]] 
Sent: Tuesday, February 04, 2014 10:09 PM
To: Muly Ilan
Cc: Loa Andersson; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls] seeking consensus on making draft-ietf-mpls-tp-te-mib read-only

> read-write/read-create objects.

The reason that people in operations and equipment vendors both generally oppose read/write MIBs is that they are a bad way to configure equipment.  Some reasons are:

Note that some tools based on the Yang language can translate a MIB into an XML dialect suitable for use with NETCONF.  This may be a good transition strategy if you had planned to use read/write MIB.

Curtis

---

From: Kingston Smiler <[email-masked]>
Date: Thu, 6 Feb 2014 12:43:56 +0530

Hi All,

Oppose as Read-only. We prefer to have read-write variant of this MIB for
our product because of the reasons already mentioned by different folks in
this thread.

Regards,
S. Kingston Smiler.

---

From: Loa Andersson <[email-masked]>
Date: Sat, 22 Feb 2014 14:25:35 +0100

Working Group,

This poll has ended. The working group chairs discussed the outcome and
found that it is "undecided".

In part this is because the question was not asked clearly enough. We
tried to ask a specific question on draft-ietf-mpls-tp-te-mib, and
as substantial part of the responses are on a more general question.

We have decided to bring this discussion to the mpls wg meeting in
London, and hope that we will get help with introduction and managing
the discussion from the OPS Area AD.

/Loa

--