Subject: [mpls] [Editorial Errata Reported] RFC6371 (3956)

From: RFC Errata System <[email-masked]>
Date: Fri, 11 Apr 2014 00:27:14 -0700 (PDT)

The following errata report has been submitted for RFC6371,
"Operations, Administration, and Maintenance Framework for MPLS-Based Transport Networks".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6371&eid=3956

--------------------------------------
Type: Editorial
Reported by: Liu Lin <[email-masked]>

Section: 3.2

Original Text
-------------
When an SPME is instantiated after the transport path has been
      instantiated, the TTL distance to the MIPs may change for the
      short-pipe model of TTL copying, and may change for the uniform
      model if the SPME is not co-routed with the original path.

Corrected Text
--------------
When an SPME is instantiated after the transport path has been
      instantiated, the TTL distance to the MIPs may change for the
      short-pipe model of no TTL copying, and may change for the uniform
      model if the SPME is not co-routed with the original path.

Notes
-----
there is no TTL copying in short-pipe model

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6371 (draft-ietf-mpls-tp-oam-framework-11)
--------------------------------------
Title               : Operations, Administration, and Maintenance Framework for MPLS-Based Transport Networks
Publication Date    : September 2011
Author(s)           : I. Busi, Ed., D. Allan, Ed.
Category            : INFORMATIONAL
Source              : Multiprotocol Label Switching
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 11 Apr 2014 10:56:27 +0100

Working group,

This definitely looks like a typo.

I am inclined to think that better revised text would be...

       When an SPME is instantiated after the transport path has been
       instantiated, the TTL distance to the MIPs may change for the
       short-pipe model, and may change for the uniform model if the
       SPME is not co-routed with the original path.

Thus leaving out any mention of TTL copying.

Thoughts?

Thanks,
Adrian

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]]
> Sent: 11 April 2014 08:27
> To: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Editorial Errata Reported] RFC6371 (3956)
> 
> Title               : Operations, Administration, and Maintenance Framework
for MPLS-
> Based Transport Networks

---

From: David Allan I <[email-masked]>
Date: Fri, 11 Apr 2014 15:53:23 +0000

Hi Adrian:

I agree that your proposal circumvents any confusion, but frankly we had no problem with the original text precisely because the mode of TTL copying for short pipe was "no copying". So there was an implied "this is why" in the choice of words.

But as that has been called out as a problem, your proposal is the best way to address it...

Cheers
Dave

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Friday, April 11, 2014 2:56 AM
To: [email-masked]
Cc: [email-masked]; David Allan I; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Editorial Errata Reported] RFC6371 (3956)

Working group,

Thoughts?

Thanks,
Adrian

> use "Reply All" to discuss whether it should be verified or rejected. 
> When a decision is reached, the verifying party (IESG) can log in to 
> change the status and edit the report, if necessary.
> 
for MPLS-