Subject: [mpls] I-D Action: draft-chen-mpls-source-label-06.txt

From: [email-masked]
Date: Mon, 13 Oct 2014 19:45:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Multiprotocol Label Switching Working Group of the IETF.

        Title           : MultiProtocol Label Switching (MPLS) Source Label
        Authors         : Mach(Guoyi) Chen
                          Xiaohu Xu
                          Zhenbin Li
                          Luyuan Fang
                          Greg Mirsky
	Filename        : draft-chen-mpls-source-label-06.txt
	Pages           : 13
	Date            : 2014-10-13

Abstract:
   A MultiProtocol Label Switching (MPLS) label was originally defined
   to identify a Forwarding Equivalence Class (FEC).  A packet is
   assigned to a specific FEC based on its network layer destination
   address, and optionally Class of Service.  It's difficult or even
   impossible to derive the source identity information from the label.
   For some applications, source identification is a critical
   requirement.  For example, performance monitoring, where the
   monitoring node needs to identify where a packet was sent from.

   This document introduces the concept of Source Identifier (SI) that
   identifies the ingress Label Switching Router (LSR) of a Label
   Switched Path (LSP).  A SI is unique within a domain that is referred
   to as Source Identifier Administrative Domain (SIAD).

   This document also introduces the concept of Source Label (SL) that
   is carried in the label stack and carries the SI of the ingress LSR
   of an LSP.  Source Label is preceded by a Source Label Indicator
   (SLI) when included the label stack and is not used for forwarding.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-chen-mpls-source-label/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-chen-mpls-source-label-06

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-chen-mpls-source-label-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mach Chen <[email-masked]>
Date: Tue, 14 Oct 2014 03:26:10 +0000

Hi MPLSers, 

We just uploaded an update that solved the online and offline comments received so far. 

In this version, we made the following changes:

1) introducing the concept of Source Identifier that uniquely identifies an LSR in a domain. The Source Identifier is similar to the Segment Identifier (SID);

2) the Source Label (SL) is not required to be unique anymore, no need to signal, not used for forwarding. It is defined to carry the Source Identifier. The usage of SL is the same as Entropy Label, where SL carries the Source Identifier, the EL carries the Entropy. In this way, the Source Label is completely align with the MPLS architecture and existing usage;

3) some editorial changes;

Please read the draft, any comments are welcome!

Thanks,
Mach

> -----Original Message-----
> From: mpls [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Tuesday, October 14, 2014 10:45 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [mpls] I-D Action: draft-chen-mpls-source-label-06.txt
> 
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: "S, Somasundaram (Somasundaram)" <[email-masked]>
Date: Tue, 14 Oct 2014 17:26:30 +0000

Hi Mach,
	Need Couple of clarifications here..

	1: Reference to Section 4) use case
		G-ACH can't be used for customer traffic.. Given that RFC 6374 uses G-ACH header how can we cite it as an example of "Passive performance measurement protocol" ? I understand that Passive monitoring/measurement uses customer traffic for measurement. 

	2: Given that this draft paves way for passive measurement using SL/SLI, Can you elaborate on the benefits it brings in comparison to other tools like sflow/netflow that are available today...? 

Regards
Somasundaram

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Mach Chen
Sent: Tuesday, October 14, 2014 8:56 AM
To: [email-masked]
Subject: Re: [mpls] I-D Action: draft-chen-mpls-source-label-06.txt

Hi MPLSers, 

Thanks,
Mach

> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
>

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 14 Oct 2014 18:15:05 +0000

Hi Somasundaram,
thank you for your interest in this work and thoughtful questions. Please find my comments in-line and tagged GIM>>.

	Regards,
		Greg

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of S, Somasundaram (Somasundaram)
Sent: Tuesday, October 14, 2014 10:27 AM
To: Mach Chen; [email-masked]
Subject: Re: [mpls] I-D Action: draft-chen-mpls-source-label-06.txt

Hi Mach,

GIM>> True, customer traffic not gets encapsulated in G-ACH in most cases (Residence Time Measurement may be one of exceptions I can recall). Yes, passive measurement do not use test packets to measure performance but uses data traffic. At the same time, OAM packets may be used to collect passive measurement statistics, e.g. as ETH-LM.

GIM>> I can refer to draft-chen-ippm-coloring-based-ipfpm-framework that discusses marking data packets in non-intrusive manner in order to facilitate passive measurements. Use of S/SLI is important, IMO, in IP/MPLS networks in particular.

Regards
Somasundaram

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Mach Chen
Sent: Tuesday, October 14, 2014 8:56 AM
To: [email-masked]
Subject: Re: [mpls] I-D Action: draft-chen-mpls-source-label-06.txt

Hi MPLSers, 

Thanks,
Mach

---

From: Mach Chen <[email-masked]>
Date: Wed, 15 Oct 2014 01:53:58 +0000

Hi Somasundaram,

Thanks for your thoughtful questions!

Please see my reply inline...

> From: S, Somasundaram (Somasundaram)
> [mailto:[email-masked]]
> Sent: Wednesday, October 15, 2014 1:27 AM
> Subject: RE: [mpls] I-D Action: draft-chen-mpls-source-label-06.txt
> 
> Hi Mach,
> 		G-ACH can't be used for customer traffic.. Given that RFC 6374 uses
> G-ACH header how can we cite it as an example of "Passive performance
> measurement protocol" ? I understand that Passive monitoring/measurement
> uses customer traffic for measurement.

In RFC6374, when do direct (passive) measurement, the GACh header is mainly used for delimitating a flow (user traffic) to consecutive blocks and carrying the transmitted counters at the ingress. Then the egress can based on the blocks to count. With the its own counted number and the counters carried in the GACh header, the egress can perform the passive lost calculation.
 
> 
> 	2: Given that this draft paves way for passive measurement using SL/SLI,
> Can you elaborate on the benefits it brings in comparison to other tools like
> sflow/netflow that are available today...?

I am not very familiar with sflow/netflow, if I am wrong, please correct me. In my understanding, sflow/netflow is used to collect IP traffic statistics on all interfaces where netflow is enabled, and later export those statistics as netflow records toward at least one netflow collector - typically a server that does the actual traffic analysis. So, normally, sflow/netflow is not used for performance measurement. Even this, sflow/netflow can benefit from SL/SLI when collect and analyze MPLS traffic flows, because it also needs the source information to facilitate analysis. 

Best regards,
Mach
> 1) introducing the concept of Source Identifier that uniquely identifies an LSR in a
> domain. The Source Identifier is similar to the Segment Identifier (SID);
> 
> 2) the Source Label (SL) is not required to be unique anymore, no need to signal,
> not used for forwarding. It is defined to carry the Source Identifier. The usage of
> SL is the same as Entropy Label, where SL carries the Source Identifier, the EL
> carries the Entropy. In this way, the Source Label is completely align with the
> MPLS architecture and existing usage;
>