Subject: [mpls] Fwd: New Version Notification for draft-kompella-mpls-larp-02.txt

From: Kireeti Kompella <[email-masked]>
Date: Wed, 29 Oct 2014 10:36:25 -0700

Hi All,

Not sure why this didn't get copied to the MPLS WG list.

In any case, this update breaks out the "Hardware Address" into two parts.
The HA part contains just the MAC address of L-ARP replier.  Labels are in
a separate TLV that now can contain a label stack.  Finally, the metric is
taken out of the HA part and is separate.

We also have a new co-author, George Swallow.

Please comment on the draft as a whole, and on these changes in particular.

Thanks,
Kireeti.

---------- Forwarded message ----------
From: <[email-masked]>
Date: Mon, Oct 27, 2014 at 4:12 PM
Subject: New Version Notification for draft-kompella-mpls-larp-02.txt
To: Kireeti Kompella <[email-masked]>, George Swallow <
[email-masked]>, Balaji Rajagopalan <[email-masked]>

A new version of I-D, draft-kompella-mpls-larp-02.txt
has been successfully submitted by Kireeti Kompella and posted to the
IETF repository.

Name:           draft-kompella-mpls-larp
Revision:       02
Title:          Label Distribution Using ARP
Document date:  2014-10-27
Group:          Individual Submission
Pages:          11
URL:
http://www.ietf.org/internet-drafts/draft-kompella-mpls-larp-02.txt
Status:         https://datatracker.ietf.org/doc/draft-kompella-mpls-larp/
Htmlized:       http://tools.ietf.org/html/draft-kompella-mpls-larp-02
Diff:           http://www.ietf.org/rfcdiff?url2=draft-kompella-mpls-larp-02

Abstract:
   This document describes extensions to the Address Resolution Protocol
   to distribute MPLS labels for IPv4 and IPv6 host addresses.
   Distribution of labels via ARP enables simple plug-and-play operation
   of MPLS, which is a key goal of the MPLS Fabric architecture.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

-- 
Kireeti

---

From: Bhupesh Kothari <[email-masked]>
Date: Thu, 30 Oct 2014 14:02:08 -0700

Hi Kireeti,

Can you describe how L-ARP can be used between a DSLAM and its upstream
router to form bi-directional tunnels?  I want to understand what, if any,
assumptions are made.

Bhupesh

On Wed, Oct 29, 2014 at 10:36 AM, Kireeti Kompella <
[email-masked]> wrote:

> In any case, this update breaks out the "Hardware Address" into two
> parts.  The HA part contains just the MAC address of L-ARP replier.  Labels
> are in a separate TLV that now can contain a label stack.  Finally, the
> metric is taken out of the HA part and is separate.
>
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-kompella-mpls-larp-02
>
> Abstract:
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>
>

---

From: Kireeti Kompella <[email-masked]>
Date: Fri, 31 Oct 2014 19:06:48 -0700

Hi Bhupesh,

> On Oct 30, 2014, at 14:02 , Bhupesh Kothari <[email-masked]> wrote:
> 
> Hi Kireeti,
> 
> Can you describe how L-ARP can be used between a DSLAM and its upstream router to form bi-directional tunnels?  I want to understand what, if any, assumptions are made.

L-ARP is for the DSLAM (or server, or whatever) to talk to a BNG (or remote server).  For the reverse direction, one possibility is “labeled DHCP”.  A quick overview is that when a DSLAM X asks for an IP address, it also says, allocate a label for me.  The upstream node (switch/BNG/CMTS) Y then allocates a label, which it advertises to reach X.  That would establish bidirectional connectivity.

To establish hierarchical tunnels, I would recommend L-BGP (RFC 3107).  Two possibilities: The X announces this label (with next hop Y); or Y announces this label with itself as next hop.  In the former case, the L-DHCP reply needs to have a label for X to advertise.

If this makes sense (and interests you), I’d be happy to collaborate with you on the L-DHCP draft.

Kireeti.

> Bhupesh
> 
> 
> On Wed, Oct 29, 2014 at 10:36 AM, Kireeti Kompella <[email-masked] <mailto:[email-masked]>> wrote:
> Hi All,
> 
> In any case, this update breaks out the "Hardware Address" into two parts.  The HA part contains just the MAC address of L-ARP replier.  Labels are in a separate TLV that now can contain a label stack.  Finally, the metric is taken out of the HA part and is separate.
> 
> From: <[email-masked] <mailto:[email-masked]>>
> To: Kireeti Kompella <[email-masked] <mailto:[email-masked]>>, George Swallow <[email-masked] <mailto:[email-masked]>>, Balaji Rajagopalan <[email-masked] <mailto:[email-masked]>>
> 
> 
> 
> URL:            http://www.ietf.org/internet-drafts/draft-kompella-mpls-larp-02.txt <http://www.ietf.org/internet-drafts/draft-kompella-mpls-larp-02.txt>
> Status:         https://datatracker.ietf.org/doc/draft-kompella-mpls-larp/ <https://datatracker.ietf.org/doc/draft-kompella-mpls-larp/>
> Htmlized:       http://tools.ietf.org/html/draft-kompella-mpls-larp-02 <http://tools.ietf.org/html/draft-kompella-mpls-larp-02>
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-kompella-mpls-larp-02 <http://www.ietf.org/rfcdiff?url2=draft-kompella-mpls-larp-02>
> 
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> The IETF Secretariat
> 
> 
> 
> 
> -- 
> Kireeti
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/mpls <https://www.ietf.org/mailman/listinfo/mpls>
> 
>