Subject: [mpls] MPLS-RT review of draft-kini-mpls-spring-entropy-label-01.txt

From: Markus Jork <[email-masked]>
Date: Tue, 14 Oct 2014 20:11:06 +0000

I have been asked to review draft-kini-mpls-spring-entropy-label-01 as one of the MPLS-RT members.

The document is coherent and makes a good argument for why the entropy label mechanism is useful and needed for SPRING. There are likely to be networks for which this would be beneficial.

Unfortunately, the nature of the problem and existing hardware compatibility constraints don't lend themselves to very elegant solutions. The proposed solution in section 4 pretty much screams "compromise". But the following sections do a good job of describing the design constraints and why other solutions were rejected. It will be useful to keep this content in the document somewhere even in its final version.

I believe the document is ready for WG adoption. Though I think there are a couple of small problems with the examples in section 5 that should be corrected:

1. Up to section 5.1, the example label stack includes a label S-SvcS2 for the service at S2. But in all the following sections, this label is dropped from the examples. I think it's best to leave this out in all of the examples for brevity.

2. In section 5.3, the first example is given as <SS11, ELI, EL, S-SvcS1, SS2, SD>.
  That should be <SP1, ELI, EL, SS1, S-SvcS1, SS2, SD>

3. In section 5.4, the example is given as:

  "For the same Figure 1 above, if LSR P1
   needs to have the EL within a depth of 4, then the source LSR S
   encoded label stack would be <SS1, S-SvcS1, ELI, EL2, SS2, SD> where
   all the ELs would typically have the same value."

That is leaving out the first hop SP1 from the stack (which means the EL has to move up the stack). Also, only one EL is present. So why call it EL2?

-Markus

---

From: Sriganesh Kini <[email-masked]>
Date: Wed, 15 Oct 2014 23:42:16 -0700

Thanks Markus for the review and comments. We will address your comments in
the next rev of the draft.

Sri

On Tue, Oct 14, 2014 at 1:11 PM, Markus Jork <[email-masked]> wrote:

> The document is coherent and makes a good argument for why the entropy
> label mechanism is useful and needed for SPRING. There are likely to be
> networks for which this would be beneficial.
>
> Unfortunately, the nature of the problem and existing hardware
> compatibility constraints don't lend themselves to very elegant solutions.
> The proposed solution in section 4 pretty much screams "compromise". But
> the following sections do a good job of describing the design constraints
> and why other solutions were rejected. It will be useful to keep this
> content in the document somewhere even in its final version.
>
> I believe the document is ready for WG adoption. Though I think there are
> a couple of small problems with the examples in section 5 that should be
> corrected:
>
> 1. Up to section 5.1, the example label stack includes a label S-SvcS2 for
> the service at S2. But in all the following sections, this label is dropped
> from the examples. I think it's best to leave this out in all of the
> examples for brevity.
>
> That is leaving out the first hop SP1 from the stack (which means the EL
> has to move up the stack). Also, only one EL is present. So why call it EL2?
>
> -Markus
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>