Subject: Re: [mpls] [Rtg-yang-coord] hopefully a simple question

From: Gregory Mirsky <[email-masked]>
Date: Sun, 26 Oct 2014 18:50:32 +0000

Hi Loa,
I think that your question is not simple at all and it would be a great to discuss how Generic OAM proposal is related to MPLS OAM at the meeting.
Personally, I think that there's no separate LDP, RSVP-TE or EVPN, Segment Routing (as far as transport layer for the latter two) OAMs but one MPLS OAM with extensions/special cases for IP/MPLS, MPLS-TP and Segment Routing networks.

	Regards,
		Greg
-----Original Message-----
From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Sunday, October 26, 2014 3:14 AM
To: [email-masked]; [email-masked]
Subject: [Rtg-yang-coord] hopefully a simple question

Folks,

I have what I hope is a simple question, and that it will only reveal that I'm not up to speed on yang.

I trying to figure out the relationship between the generic yang models in e.g. draft-tissa-lime-yang-oam-model and the specific models we do for different variants of e.g. mpls oam.

I guess we have a structure more or less like this

mpls
  |
  |- ldp
  |   |-ldp oam
  |
  |- rsvp-te
  |   |
  |   |- rsvp-te oam
  |
  |- lsp ping
  |   |
  |   |- lsp ping oam
  |
  |- etc

Where does the generic work fit in?

/Loa
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

_______________________________________________
Rtg-yang-coord mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtg-yang-coord

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 27 Oct 2014 00:03:20 -0000

The intention of LIME (who knows whether it is achievable?) is to produce a
single YANG module that provides a generic way in to OAM across all IETF
technologies. 

There are certainly a number of core concepts, configurable items, and
reportable things that can be stated in a technology independent way.

LIME has as a deliverable a set of applicability statements showing how the
generic module is applied to different IETF OAM technologies.

I should not be surprised if technology-specific modules are also required. I
think LIME hopes that these will build on the generic module and not reinvent. I
assume this will be through augmentation. And I assume the work will be done by
the WGs that own the technologies (where those WGs exist).

I don't think I understand your tree. Why would "RSVP-TE OAM" live under rsvp-te
under mpls? The OAM is going to be standard mpls oam, but the concepts (MIPs,
MEPs, on/off, failure found, etc.) are general.

Adrian

> From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of
> Gregory Mirsky
> Sent: 26 October 2014 18:51
> To: Loa Andersson; [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [Rtg-yang-coord] hopefully a simple question
> 
> Hi Loa,
> I think that your question is not simple at all and it would be a great to
discuss
> how Generic OAM proposal is related to MPLS OAM at the meeting.
> Personally, I think that there's no separate LDP, RSVP-TE or EVPN, Segment
> Routing (as far as transport layer for the latter two) OAMs but one MPLS OAM
> with extensions/special cases for IP/MPLS, MPLS-TP and Segment Routing
> networks.
> 
> 	Regards,
> 		Greg
> I have what I hope is a simple question, and that it will only reveal that I'm
not up
> to speed on yang.
> 
> I trying to figure out the relationship between the generic yang models in
e.g.
> draft-tissa-lime-yang-oam-model and the specific models we do for different
> variants of e.g. mpls oam.
>

---

From: Tom Taylor <[email-masked]>
Date: Sun, 26 Oct 2014 20:15:38 -0400

This might be a good time to remind/alert people about the liaison 
statement received from the MEF regarding 
draft-tissa-lime-yang-oam-model.  It can be found at

https://datatracker.ietf.org/documents/LIAISON/liaison-2014-07-31-mef-netmod-liaison-to-ietf-on-yang-service-oam-models-attachment-1.pdf

  Tom Taylor

On 26/10/2014 8:03 PM, Adrian Farrel wrote:
>> Loa Andersson