Subject: [mpls] LDPv6 Behaviour In Dual Stack Network - Testing Cisco IOS XR

From: Mark Tinka <[email-masked]>
Date: Mon, 4 May 2015 08:03:26 +0200

Hello all.

Being specific since I am an operator - IOS XR is now shipping LDPv6
capability in 5.3.0.

I've been testing this over the weekend, and would just like to clarify
whether code with dual-stack LDP support is meant to be backwards
compatible with code that only has single-stack LDP support.

IOS XR 5.3.0's implementation of dual-stack IPv6 is explained in good
detail here:

        http://tinyurl.com/mbt5z4l

When we enable "address-family ipv6" for LDP in IOS XR, the box is
unable to establish any LDP adjacencies. Given the code defaults to
setting up adjacencies via IPv6, this makes sense since all the other
routers around it do not yet run code that supports LDPv6. However, per
the implementation notes from Cisco, they say after 15x seconds of no
adjacency formation, the code should fall back to IPv4. I waited 1hr,
this never happened.

IOS XR has a knob to force adjacencies to be setup over IPv4, which I
tried as well. The box seemed to struggle building LDP adjacencies.
Adjacencies rise, and then fall in the space of 3x seconds. I think this
could be a bug, but just FYI.

I'm, obviously, going to take this up with Cisco, but wondering whether
IOS XR is in violation of the spec., or if it's just me.

Mark.

---

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Mon, 4 May 2015 14:55:16 +0000

Hi Mark,

Yes, Cisco XR 5.3.0 dual-stack capable LDP is backward compatible with single-stack LDP.
I think when you say “adjacencies”, you meant “session” and not “hello adjacencies”.  Please confirm.

Could you share your topology /cfg etc ?
What type of LSRs are XR neighbours  ? Cisco ? Release ? Non Cisco ?
Did you have reachability for IPv6 [transport] address ?

Regarding knob for “ipv4 transport preference”: Please make sure that both sides (LSRs) have the same preference otherwise the session will not get established.

Rgds,
—
Kamran

From: Mark Tinka <[email-masked]<mailto:[email-masked]>>
Date: Monday, May 4, 2015 at 2:03 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [mpls] LDPv6 Behaviour In Dual Stack Network - Testing Cisco IOS XR

Hello all.

Being specific since I am an operator - IOS XR is now shipping LDPv6 capability in 5.3.0.

I've been testing this over the weekend, and would just like to clarify whether code with dual-stack LDP support is meant to be backwards compatible with code that only has single-stack LDP support.

IOS XR 5.3.0's implementation of dual-stack IPv6 is explained in good detail here:

When we enable "address-family ipv6" for LDP in IOS XR, the box is unable to establish any LDP adjacencies. Given the code defaults to setting up adjacencies via IPv6, this makes sense since all the other routers around it do not yet run code that supports LDPv6. However, per the implementation notes from Cisco, they say after 15x seconds of no adjacency formation, the code should fall back to IPv4. I waited 1hr, this never happened.

IOS XR has a knob to force adjacencies to be setup over IPv4, which I tried as well. The box seemed to struggle building LDP adjacencies. Adjacencies rise, and then fall in the space of 3x seconds. I think this could be a bug, but just FYI.

I'm, obviously, going to take this up with Cisco, but wondering whether IOS XR is in violation of the spec., or if it's just me.

Mark.

---

From: Mark Tinka <[email-masked]>
Date: Mon, 4 May 2015 22:11:26 +0200

Hi Kamran.

Thanks for your feedback.

Yes, I meant the TCP sessions.

I opened a TAC case earlier today and provided them all the details.
They are checking with the BU as the setup is normal.

I'm guessing that because none of the neighbors are LDP dual-stack
capable, this could be my issue. In this particular case, the directly
attached neighbors are Juniper MX480 routers. As Junos do not currently
dual-stack LDP, I'm guessing this could be issue. Which does not make
sense to me if LDP in IOS XR 5.3.0 is backward compatible with code
(whether from Cisco or another vendor) that is still running "old" LDP.

IPv6 reachability between the Cisco and Juniper are fine.

Mark.

On 4/May/15 16:55, Kamran Raza (skraza) wrote:
> Regarding knob for “ipv4 transport preference”: Please make sure that
> both sides (LSRs) have the same preference otherwise the session will
> not get established.
>
> Rgds,
> —
> Kamran
>
> From: Mark Tinka <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked]
> <mailto:[email-masked]>>
> I've been testing this over the weekend, and would just like to
> clarify whether code with dual-stack LDP support is meant to be
> backwards compatible with code that only has single-stack LDP support.
>
> routers around it do not yet run code that supports LDPv6. However,
> per the implementation notes from Cisco, they say after 15x seconds of
> no adjacency formation, the code should fall back to IPv4. I waited
> 1hr, this never happened.
>
> Adjacencies rise, and then fall in the space of 3x seconds. I think
> this could be a bug, but just FYI.
>
> I'm, obviously, going to take this up with Cisco, but wondering
> whether IOS XR is in violation of the spec., or if it's just me.
>
> Mark.

---

From: Gyan Mishra <[email-masked]>
Date: Tue, 5 May 2015 00:18:28 -0400

All

With 6PE and 6vPE over  IPv4 mpls core what is the business driver for Dual
stack especially with BGP Free P core makes the core simple with minimal
protocols for high speed forwarding plane.

So what is the necessity for Dual stack core and running  LDP v4 and v6.
At this time we do not see any technical reason for Dual stack core.

Gyan
On May 4, 2015 2:03 AM, "Mark Tinka" <[email-masked]> wrote:

> When we enable "address-family ipv6" for LDP in IOS XR, the box is unable
> to establish any LDP adjacencies. Given the code defaults to setting up
> adjacencies via IPv6, this makes sense since all the other routers around
> it do not yet run code that supports LDPv6. However, per the implementation
> notes from Cisco, they say after 15x seconds of no adjacency formation, the
> code should fall back to IPv4. I waited 1hr, this never happened.
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>
>

---

From: Mark Tinka <[email-masked]>
Date: Tue, 5 May 2015 07:27:55 +0200

Not everybody likes or runs MPLS.

6PE adds more complexity than native IPv6.

Mark.

On 5/May/15 06:18, Gyan Mishra wrote:
>
> All
>
> With 6PE and 6vPE over  IPv4 mpls core what is the business driver for
> Dual stack especially with BGP Free P core makes the core simple with
> minimal protocols for high speed forwarding plane.
>
> So what is the necessity for Dual stack core and running  LDP v4 and
> v6.  At this time we do not see any technical reason for Dual stack core.
>
> Gyan
>
> On May 4, 2015 2:03 AM, "Mark Tinka" <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hello all.
>
>     unable to establish any LDP adjacencies. Given the code defaults
>     to setting up adjacencies via IPv6, this makes sense since all the
>     other routers around it do not yet run code that supports LDPv6.
>     However, per the implementation notes from Cisco, they say after
>     15x seconds of no adjacency formation, the code should fall back
>     to IPv4. I waited 1hr, this never happened.
>
>     IOS XR has a knob to force adjacencies to be setup over IPv4,
>     which I tried as well. The box seemed to struggle building LDP
>     adjacencies. Adjacencies rise, and then fall in the space of 3x
>     seconds. I think this could be a bug, but just FYI.
>
>     [email-masked] <mailto:[email-masked]>

---

From: [email-masked]
Date: Tue, 5 May 2015 06:50:18 +0000

We have been running 6PE and 6VPE for a while and works very well and all is done by the PE and RR ipv6 labeled unicast AFI.  Actually is pretty simple configuration on both  IOS or XR to run.

I would think LDPv6 would only be a consideration if you are running mpls.

Gyan
Sent from my Verizon Wireless BlackBerry

-----Original Message-----
From: Mark Tinka <[email-masked]>
Date: Tue, 5 May 2015 07:27:55 
To: Gyan Mishra<[email-masked]>
Cc: <[email-masked]>
Subject:
 Re: [mpls] LDPv6 Behaviour In Dual Stack Network - Testing Cisco IOS XR

Mark.

---

From: Mikael Abrahamsson <[email-masked]>
Date: Tue, 5 May 2015 08:56:41 +0200 (CEST)

> At this time we do not see any technical reason for Dual stack core.

Because if you're a greenfield operator which might get a /22 IPv4 space, 
using any part of this space for infrastructure is just stupid, and you 
might not want to number your core out of RFC1918 addresses.

So the necessity is not for dual stack core but to be able to build a 
single stack IPv6 core and run 4PE over it.

https://puck.nether.net/pipermail/cisco-nsp/2010-July/071550.html is 4 
years and 10 months ago, and we're still not really close to possibility 
of building a core MPLS network without IPv4, even though we're closer 
than we were 5 years ago.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Mark Tinka <[email-masked]>
Date: Tue, 5 May 2015 09:14:19 +0200

As I said on another forum, 6PE is stable, so it works. I just think it
is unnecessary complexity if your network can do basic/simple IPv6.
Moreover, I don't want my IPv6 falling over if MPLS dies.

Yes, LDPv6 is if you run MPLS. But for me, native MPLS for IPv6 is
better than tunneled MPLS for IPv6.

We do use 6VPE, because we do sell l3vpnv6 services. 6VPE does not
require 6PE, which suits me just fine.

Mark.

On 5/May/15 08:50, [email-masked] wrote:
>
> We have been running 6PE and 6VPE for a while and works very well and
> all is done by the PE and RR ipv6 labeled unicast AFI. Actually is
> pretty simple configuration on both IOS or XR to run.
>
> ------------------------------------------------------------------------
> *From: * Mark Tinka <[email-masked]>
> *Date: *Tue, 5 May 2015 07:27:55 +0200
> *To: *Gyan Mishra<[email-masked]>
> *Cc: *<[email-masked]>
> *Subject: *Re: [mpls] LDPv6 Behaviour In Dual Stack Network - Testing
> Cisco IOS XR
>
>> With 6PE and 6vPE over  IPv4 mpls core what is the business driver
>> for Dual stack especially with BGP Free P core makes the core simple
>> with minimal protocols for high speed forwarding plane.
>>
>>     When we enable "address-family ipv6" for LDP in IOS XR, the box
>>     is unable to establish any LDP adjacencies. Given the code
>>     defaults to setting up adjacencies via IPv6, this makes sense
>>     since all the other routers around it do not yet run code that
>>     supports LDPv6. However, per the implementation notes from Cisco,
>>     they say after 15x seconds of no adjacency formation, the code
>>     should fall back to IPv4. I waited 1hr, this never happened.
>>