Subject: [mpls] Poll to see if we have consensus adopting draft-bonica-mpls-self-ping as an MPLS wg document

From: Loa Andersson <[email-masked]>
Date: Wed, 20 May 2015 11:55:41 +0200

Working Group,

This is to start a two week poll on adopting draft-bonica-mpls-self-
ping-06 as an MPLS working group document.

Please send your comments (support/not support) to the mpls working
group mailing list ([email-masked]). Please give a technical
motivation for your support/not support, especially if you think that
the document should not be adopted as a working group document.

There is one IPR disclosures directly against this document. All the
authors has stated on the working group mailing that they are unaware of
any undisclosed IPRs against this document.

However if you are on the the mpls working group mailing list and
aware of IPR that relates to this draft, the time to disclose
this is now.

This poll ends June 5, 2015.

/Loa
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Conn, Michael" <[email-masked]>
Date: Fri, 22 May 2015 13:34:00 -0400

Support

Michael E Conn
Manager Network Planning
Office 972 729 6469
 
There are two ways to deal with a problem:
You can accept it and learn to live with it or
you can fix it and learn to live without it.
 
Which will you choose?

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]] 
Sent: Wednesday, May 20, 2015 4:56 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Poll to see if we have consensus adopting draft-bonica-mpls-self-ping as an MPLS wg document

Working Group,

Please send your comments (support/not support) to the mpls working group mailing list ([email-masked]). Please give a technical motivation for your support/not support, especially if you think that the document should not be adopted as a working group document.

There is one IPR disclosures directly against this document. All the authors has stated on the working group mailing that they are unaware of any undisclosed IPRs against this document.

However if you are on the the mpls working group mailing list and aware of IPR that relates to this draft, the time to disclose this is now.

/Loa
--

---

From: "Tomotaki, Luis M" <[email-masked]>
Date: Fri, 22 May 2015 13:36:19 -0400

Support

-----Original Message-----
From: Conn, Michael [mailto:[email-masked]] 
Sent: Friday, May 22, 2015 12:34 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: Poll to see if we have consensus adopting draft-bonica-mpls-self-ping as an MPLS wg document

Support

Michael E Conn
Manager Network Planning
Office 972 729 6469
 
There are two ways to deal with a problem:
You can accept it and learn to live with it or you can fix it and learn to live without it.
 
Which will you choose?

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]]
Sent: Wednesday, May 20, 2015 4:56 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Poll to see if we have consensus adopting draft-bonica-mpls-self-ping as an MPLS wg document

Working Group,

/Loa
--

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 23 May 2015 05:36:19 +0100

Hi Loa,

I think this is a useful tool and the document is stable enough to be within the
working group.

The explanation of why the function is needed (which really clarifies how it is
used) would be enhanced by reference to RFC 6383 which describes the problems
associated with RSVP-TE signaling and LSP establishment.

Cheers,
Adrian

> From: mpls [mailto:[email-masked]] On Behalf Of Loa Andersson
> Sent: 20 May 2015 10:56
> Subject: [mpls] Poll to see if we have consensus adopting
draft-bonica-mpls-self-
> ping as an MPLS wg document
> 
> Working Group,
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Ronald Bonica <[email-masked]>
Date: Sun, 24 May 2015 21:38:00 +0000

Adrian,

Thanks for calling my attention to RFC 6383!  I will reference it in the next revision of the draft.

                               Ron

> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Saturday, May 23, 2015 12:36 AM
> To: 'Loa Andersson'; [email-masked]; draft-bonica-mpls-self-
> [email-masked]; [email-masked]
> Subject: RE: [mpls] Poll to see if we have consensus adopting draft-bonica-
> mpls-self-ping as an MPLS wg document
> 
> Hi Loa,
> 
> I think this is a useful tool and the document is stable enough to be within
> the working group.
> 
> used) would be enhanced by reference to RFC 6383 which describes the
> problems associated with RSVP-TE signaling and LSP establishment.
> 
> Cheers,
> Adrian
> 
> > group mailing list ([email-masked]). Please give a technical motivation
> > for your support/not support, especially if you think that the
> > document should not be adopted as a working group document.
> >
> > authors has stated on the working group mailing that they are unaware
> > of any undisclosed IPRs against this document.
> >
> > aware of IPR that relates to this draft, the time to disclose this is
> > now.
> >

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 25 May 2015 01:05:43 +0000

Hi Loa,

I believe this draft greatly improved based on the MPLS-RT review, and in particular Ron has been extremely responsive to and inclusive of feedback.

I support adoption of this document, and it is useful in its current scope.

I do have a small additional piece of feedback for the author's consideration: currently the doc says something like:

" For example, if a downstream LSR installs a forwarding state that

   causes an LSP to terminate at the wrong node, LSP Self-ping will not

   detect an error."

Could we add a similar applicability hat if an LSP is broken mid stream such that the packet is sent unlabeled, then it won't detect an error?

Thanks!

Thumb typed by Carlos Pignataro.
Excuze typofraphicak errows

On May 20, 2015, at 05:55, Loa Andersson <[email-masked]<mailto:[email-masked]>> wrote:

Working Group,

Please send your comments (support/not support) to the mpls working
group mailing list ([email-masked]<mailto:[email-masked]>). Please give a technical
motivation for your support/not support, especially if you think that
the document should not be adopted as a working group document.

/Loa
--

Loa Andersson                        email: [email-masked]<mailto:[email-masked]>
Senior MPLS Expert                          [email-masked]<mailto:[email-masked]>
Huawei Technologies (consultant)     phone: +46 739 81 21 64

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 25 May 2015 01:56:17 -0400

I agree with previous comments that this is a useful draft and should be
adopted by the WG. If this was written in response to an observed problem
in the field, that would be useful to note in Section 1. Assuming that this
is the case, it would also be useful to note in an "implementation
experience" section if there is an implementation of this draft and it
corrects the problem.

Cheers,
Andy

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 26 May 2015 13:24:58 +0000

Support.

Jeffrey Zhang

---

From: "Wygant, Mark" <[email-masked]>
Date: Tue, 26 May 2015 10:05:31 -0400

Support.

Mark Wygant
Verizon
Network Infrastructure Planning

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Wednesday, May 20, 2015 4:56 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] Poll to see if we have consensus adopting draft-bonica-mpls-self-ping as an MPLS wg document

Working Group,

/Loa
--

---

From: Santosh Esale <[email-masked]>
Date: Wed, 27 May 2015 15:07:33 +0000

Support.

Santosh Esale
>draft-bonica-mpls-self-ping as an MPLS wg document
>
>Working Group,
>
>Please send your comments (support/not support) to the mpls working group
>mailing list ([email-masked]). Please give a technical motivation for your
>support/not support, especially if you think that the document should not
>be adopted as a working group document.
>
>However if you are on the the mpls working group mailing list and aware
>of IPR that relates to this draft, the time to disclose this is now.
>

---

From: Lucy yong <[email-masked]>
Date: Wed, 27 May 2015 16:38:33 +0000

This is a useful draft and should be adopted by the WG.

In future version, the draft should clarify that this mechanism applies to p2p LSP only or other as well such as P2MP LSP.

Cheers,
Lucy

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Wednesday, May 20, 2015 4:56 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] Poll to see if we have consensus adopting draft-bonica-mpls-self-ping as an MPLS wg document

Working Group,

/Loa
--

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 27 May 2015 18:02:32 +0000

+1. 

Support. 

Linda

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Wednesday, May 27, 2015 11:39 AM
To: Loa Andersson; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls] Poll to see if we have consensus adopting draft-bonica-mpls-self-ping as an MPLS wg document

Cheers,
Lucy

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Wednesday, May 20, 2015 4:56 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] Poll to see if we have consensus adopting draft-bonica-mpls-self-ping as an MPLS wg document

Working Group,

/Loa
--

---

From: Minjie Dai <[email-masked]>
Date: Wed, 27 May 2015 23:54:09 +0000

Support.

Minjie Dai

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 28 May 2015 00:52:54 +0000

This is a useful draft and I support the adoption.

Best regards,
Xiaohu

> support/not support, especially if you think that the document should not be
> adopted as a working group document.
> 
> There is one IPR disclosures directly against this document. All the authors has
> stated on the working group mailing that they are unaware of any undisclosed
> IPRs against this document.
> 
> However if you are on the the mpls working group mailing list and aware of IPR
> that relates to this draft, the time to disclose this is now.
>

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 28 May 2015 01:09:57 +0000

I believe that the document addresses practical use case and offers reasonable solution. The document have been improved and I think that now is ready for WG adoption.

	Regards,
		Greg	

> aware of IPR that relates to this draft, the time to disclose this is now.
>

---

From: Raveendra Torvi <[email-masked]>
Date: Thu, 28 May 2015 01:47:16 +0000

As a co-author, I support this draft  for WG adoption.
Thanks,
Ravi

> On May 27, 2015, at 9:10 PM, Gregory Mirsky <[email-masked]> wrote:
> 
>> aware of IPR that relates to this draft, the time to disclose this is now

---

From: Mach Chen <[email-masked]>
Date: Fri, 29 May 2015 01:18:19 +0000

Yes/support.

Best regards,
Mach

> Sent: Wednesday, May 20, 2015 5:56 PM