Subject: Re: [mpls] MPLS-RT review of draft-mirsky-mpls-bfd-directed-03

From: Ross Callon <[email-masked]>
Date: Tue, 4 Aug 2015 16:13:11 +0000

Greg;

Do you feel that you are ready to post the update?

I believe that the next steps here are for you to post the update (whenever the authors feel that you are ready), for me to check with the MPLS-RT reviewers to make sure that they are fine with the update, to do an IPR poll, and then to call for WG adoption.

Thanks, Ross

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Friday, July 24, 2015 3:51 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: Ross Callon; [email-masked]; Jeff Tantsura; [email-masked]; [email-masked]
Subject: RE: MPLS-RT review of draft-mirsky-mpls-bfd-directed-03

Hi Thomas,
would greatly appreciate if you kindly review proposed changes to address your comments. I've attached diff and MS copy of what may be next version.

                Regards,
                                Greg

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, July 14, 2015 4:03 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Gregory Mirsky; Jeff Tantsura; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: MPLS-RT review of draft-mirsky-mpls-bfd-directed-03

Hello,

I have been selected as reviewer of http://tools.ietf.org/html/draft-mirsky-mpls-bfd-directed-03.

I think the draft is coherent, technically sound and operational useful. It extents the explicit path capability for the backward direction of _bidirectional_ forwarding detection (BFD). The document is ready for WG adoption.

Some comments:

Section 1.1.1, Terminology:
I am not sure, whether the term _MPLS_ is really required in this section.

Section 3.1, "Case of MPLS Data Plane": Structure of sub-TLV specification.
The whole section describes, that three sub-TLV are specified for usage: "Static", "RSVP-TE" and "Segment Routing". For "Static" and "RSVP-TE", the draft refers to the according RFC (that's fine). But the structure of this section contains only a subsection for "Segment routing" and the reference to the other sub-TLV is part of this subsection. I propose to add two additional subsections "Static" (3.1.x) and "RSVP-TE" (3.1.x) with the references and remove it from the subsection "Segment Routing" to be more coherent.

Section 3.1.2: "Segment Routing Tunnel Sub-TLV >
The section specifies the encoding of the SR tunnel Sub-TLV with the encoding of the label stack elements. I think it makes sense to describe the usage of this information in the draft ("copy this information to the label stack"). Is the remote PE (initiator) allowed to add additional segments bases on his local information or is the encoded label stack strict?

Section 3.3:
This section confused me. Maybe it should be considered to be rewritten (or explained specifically to me).
Who is the _initiator_ in this case for the BFD reverse path scenario?

Section 3.4: "Return Codes"
The paragraph repeats the description text of the return code 2 times.  The section specifies, that the egress LSR _MAY_ send back the return code. In section 3.1.1, last paragraph, the behavior is specified, that the egress LSR may set up the BFD session or not, but in both cases, it sends back the return code (are the MAYs are concatenated in the case, when the BFD session is set up - see also comment from Nobo?). This implies, that the egress LSR _MUST_ send the return code, when the reverse path is not known.

Section 4 "Use case scenario":
The "value N" and "value M" are confusing, because it uses the same vocabulary as the nodes in the network example (capital letter). It could be called "foobar" if it is not for interest.

Regards.

Thomas

---

From: David Allan I <[email-masked]>
Date: Tue, 4 Aug 2015 17:27:29 +0000

Hi

I've read the document and believe it to be close to complete.

My only concerns are

1)      Given a configuration message can support configuring multiple tests at a time, what are the actual consequences of one or more errors. Are those requests only invalidated or is are all the sub-TLVs in a request invalidated. IMO this should be clarified. Given that there are classes of error that should invalidate the entire request, and those that do not necessarily do so, it might be easiest to make a blanket statement that any error invalidates the entire message.

2)      The IANA considerations section is missing sub-TLV types 300 and 400.

If these items were addressed, I would be supportive of the document progressing.

Cheers
D

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 4 Aug 2015 19:19:23 +0000

Hi Ross,
many thanks for you kind consideration. I agree and support the plan you've set forward.
I believe Thomas Beckhaus agreed to proposed changes that address his MPLS-RT review.  Work on addressing comments by Nobo still continues. We'll try to upload the new version by the end of this week.

                Regards,
                                Greg

From: Ross Callon [mailto:[email-masked]]
Sent: Tuesday, August 04, 2015 9:13 AM
To: Gregory Mirsky
Cc: [email-masked]; Jeff Tantsura; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: MPLS-RT review of draft-mirsky-mpls-bfd-directed-03

Greg;

Thanks, Ross

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Friday, July 24, 2015 3:51 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Ross Callon; [email-masked]<mailto:[email-masked]>; Jeff Tantsura; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: MPLS-RT review of draft-mirsky-mpls-bfd-directed-03

Hi Thomas,

                Regards,
                                Greg

Hello,

Some comments:

Section 3.3:

Regards.

Thomas

---

From: Gregory Mirsky <[email-masked]>
Date: Sat, 8 Aug 2015 01:01:59 +0000

Dear Ross, et. al,
we have posted the update. We hope we've addressed comments received from Thomas and Nobo during MPLS-RT review.

                Regards,
                                Greg

Greg;

Thanks, Ross

Hi Thomas,

                Regards,
                                Greg

Hello,

Some comments:

Section 3.3:

Regards.

Thomas

Subject: New Version Notification for draft-mirsky-mpls-bfd-directed-04.txt
From: "[email-masked]" <[email-masked]>
To: Mach Chen <[email-masked]>, Gregory Mirsky <[email-masked]>, Jeff Tantsura <[email-masked]>, Gregory Mirsky <[email-masked]>, "Mach Chen (Guoyi)" <[email-masked]>, Ilya Varlashkin <[email-masked]>, Jeff Tantsura <[email-masked]>, Ilya Varlashkin <[email-masked]>
Date: Sat, 8 Aug 2015 00:56:18 +0000

A new version of I-D, draft-mirsky-mpls-bfd-directed-04.txt
has been successfully submitted by Greg Mirsky and posted to the
IETF repository.

Name:		draft-mirsky-mpls-bfd-directed
Revision:	04
Title:		Bidirectional Forwarding Detection (BFD) Directed Return Path
Document date:	2015-08-08
Group:		mpls
Pages:		10
URL:            https://www.ietf.org/internet-drafts/draft-mirsky-mpls-bfd-directed-04.txt
Status:         https://datatracker.ietf.org/doc/draft-mirsky-mpls-bfd-directed/
Htmlized:       https://tools.ietf.org/html/draft-mirsky-mpls-bfd-directed-04
Diff:           https://www.ietf.org/rfcdiff?url2=draft-mirsky-mpls-bfd-directed-04

Abstract:
   Bidirectional Forwarding Detection (BFD) is expected to monitor bi-
   directional paths.  When a BFD session monitors in its forward
   direction an explicitly routed path there is a need to be able to
   direct egress BFD peer to use specific path as reverse direction of
   the BFD session.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat