Subject: [mpls] IPR poll on draft-bryant-mpls-flow-ident

From: Ross Callon <[email-masked]>
Date: Thu, 12 Nov 2015 16:28:49 +0000

Working Group,

The authors of draft-bryant-mpls-flow-ident have told us that the
draft is ready to be polled to see if we have consensus to make it a working
group document.

Before we start the adoption poll we will do an IPR poll. This mail starts the IPR poll.

Are you aware of any IPR that applies to draft-bryant-mpls-flow-ident?

If so, has this IPR been disclosed in compliance with IETF IPR rules
(see RFCs 3979, 4879, 3669 and 5378 for more details).

Currently there are no IPR disclosures that relate to this document.

If you are listed as a document author or contributor please respond to
this email regardless of whether or not you are aware of any relevant
IPR. *The response needs to be sent to the MPLS wg mailing list.* The
document will not advance to the next stage until a response has been
received from each author and contributor.

If you are on the MPLS WG email list but are not listed as an author or
contributor, then please explicitly respond only if you are aware of any
IPR that has not yet been disclosed in conformance with IETF rules.

Thanks, Ross
(as MPLS WG co-chair)

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 12 Nov 2015 19:01:11 +0000

As a requirements draft, I know of no IPR per se,
but the reader may be drawn to the solutions
posited in the SFL drafts which do have disclosed IPR.

The reference in the text to the need to implement a
solution to

draft-tempia-ippm-p3m-02 
<https://tools.ietf.org/html/draft-tempia-ippm-p3m-02>  

by definition brings in it to play the IPR disclosed
against that draft.

- Stewart

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Thu, 12 Nov 2015 22:34:51 +0000

Ditto.

Thanks,

— Carlos.

> On Nov 12, 2015, at 2:01 PM, Stewart Bryant <[email-masked]> wrote:
> 
> draft-tempia-ippm-p3m-02 <https://tools.ietf.org/html/draft-tempia-ippm-p3m-02>
>

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 13 Nov 2015 01:33:06 +0000

I don't know of any other IPR related to the draft other than mentioned by Stewart.

                Regards,
                                Greg

From: Stewart Bryant [mailto:[email-masked]]
Sent: Thursday, November 12, 2015 11:01 AM
To: Ross Callon; [email-masked]; Stewart Bryant (stbryant); Carlos Pignataro (cpignata); Mach Chen ([email-masked]); [email-masked]; Gregory Mirsky
Cc: [email-masked]
Subject: Re: IPR poll on draft-bryant-mpls-flow-ident

draft-tempia-ippm-p3m-02<https://tools.ietf.org/html/draft-tempia-ippm-p3m-02>

against that draft.

- Stewart

Thanks, Ross
(as MPLS WG co-chair)

---

From: Mach Chen <[email-masked]>
Date: Fri, 13 Nov 2015 01:37:57 +0000

The same here.

Best regards,
Mach

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Friday, November 13, 2015 6:35 AM
To: Stewart Bryant
Cc: Ross Callon; [email-masked]; Stewart Bryant (stbryant); Mach Chen; Lizhenbin; Gregory Mirsky; [email-masked]
Subject: Re: IPR poll on draft-bryant-mpls-flow-ident

Ditto.

Thanks,

- Carlos.

On Nov 12, 2015, at 2:01 PM, Stewart Bryant <[email-masked]<mailto:[email-masked]>> wrote:

against that draft.

- Stewart

Thanks, Ross
(as MPLS WG co-chair)

---

From: Fioccola Giuseppe <[email-masked]>
Date: Fri, 13 Nov 2015 16:50:39 +0000

I'm agree with Stewart.
This draft introduces the requirements for MPLS flow identification, so there are not IPRs per se.
But the SFL drafts have a declared IPR, because these drafts describe how to use draft-tempia-ippm-p3m for RFC6374 performance measurements.

Giuseppe

Da: mpls [mailto:[email-masked]] Per conto di Stewart Bryant
Inviato: giovedì 12 novembre 2015 20:01
A: Ross Callon; [email-masked]; Stewart Bryant (stbryant); Carlos Pignataro (cpignata); Mach Chen ([email-masked]); [email-masked]; Gregory Mirsky
Cc: [email-masked]
Oggetto: Re: [mpls] IPR poll on draft-bryant-mpls-flow-ident

against that draft.

- Stewart

Thanks, Ross
(as MPLS WG co-chair)

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

[rispetta l'ambiente]Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: "George Swallow (swallow)" <[email-masked]>
Date: Fri, 13 Nov 2015 21:13:35 +0000

Same here.

George

From: Carlos Pignataro <[email-masked]<mailto:[email-masked]>>
Date: Thursday, November 12, 2015 at 6:34 PM
To: Stewart Bryant <[email-masked]<mailto:[email-masked]>>
Cc: Ross Callon <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Stewart Bryant (stbryant)" <[email-masked]<mailto:[email-masked]>>, Mach Chen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Gregory Mirsky <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: IPR poll on draft-bryant-mpls-flow-ident

Ditto.

Thanks,

- Carlos.

- Stewart

Thanks, Ross
(as MPLS WG co-chair)

---

From: Lizhenbin <[email-masked]>
Date: Sat, 21 Nov 2015 11:20:59 +0000

Same here.

Best Regards,
Zhenbin(Robin)

发件人: Mach Chen
发送时间: 2015年11月13日 9:38
收件人: Carlos Pignataro (cpignata); Stewart Bryant
抄送: Ross Callon; [email-masked]; Stewart Bryant (stbryant); Lizhenbin; Gregory Mirsky; [email-masked]
主题: RE: IPR poll on draft-bryant-mpls-flow-ident

The same here.

Best regards,
Mach

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Friday, November 13, 2015 6:35 AM
To: Stewart Bryant
Cc: Ross Callon; [email-masked]<mailto:[email-masked]>; Stewart Bryant (stbryant); Mach Chen; Lizhenbin; Gregory Mirsky; [email-masked]<mailto:[email-masked]>
Subject: Re: IPR poll on draft-bryant-mpls-flow-ident

Ditto.

Thanks,

― Carlos.

against that draft.

- Stewart

Thanks, Ross
(as MPLS WG co-chair)

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 26 Nov 2015 01:28:12 +0000

I'm afraid I don't understand section 11 at all. (It's title
is "privacy considerations" but it's current content bemuses me;-)

If this is adopted and if that section gets fixed (e.g. to become
some kind of applicability statement), then that would be a fine
outcome.

There's a bit of work to be done to figure out when this is a safe
or unsafe thing to do from the privacy perspective and to document
that, but such work should be something the WG is well able for.

Put another way: I support adoption of this (not that I know squat
about MPLS;-) on the assumption that section 11 gets fixed. And I'm
confident fixing that should not be hard.

But in any case - I am very happy to see section 11 in an MPLS
document - recognition that privacy is an issue, even at this layer,
does represent progress. (Thanks to the authors for that.)

S.

On 12/11/15 16:28, Ross Callon wrote:
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 30 Nov 2015 15:55:31 +0000

Hi Stephen

Always willing to talk and receive feedback.

Perhaps we need a guide to considering privacy issues
in protocols, in the same way that we have a useful
guide to writing privacy sections.

The fundamental point I was making was that in regular
MPLS in an LDP context you can tell where a packet is headed
but not where it came from (a comment that us network
layer folks made at the privacy workshop). If the payload is
other than IP this makes it difficult to figure out which PE
injected the packet and hence have any idea where the
origin was. By indicating the source PE (needed for
network management) you remove some of this anonymity
from the MPLS layer.

- Stewart