Subject: [mpls] Ben Campbell's No Objection on draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf-15: (with COMMENT)

From: "Ben Campbell" <[email-masked]>
Date: Mon, 16 Nov 2015 19:07:21 -0800

Ben Campbell has entered the following ballot position for
draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf-15: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I have one minor (almost trivial) comment/question, and several nits:

Comment:
=========
- 4.1, paragraph 3:
Is it reasonable for a TLV in this standards-action registry to be have
sub-tlvs with reduced registration requirements?  (And if so, is there a
reason to exclude specifications that are not RFCs?)

Nits:
====
-1, paragraph 1:
Missing "the" before "MPLS Transport Profile "

- 1.0, last paragraph, last two sentences:
Who are “we” in these sentences? Does it make sense to talk about what
“we” are or are not “configuring”?

2.1.1, first bullet in first list:
consider s/"both sides should be"/"both sides are"

-4.1, 2nd paragraph, first sentence:
Missing words? (What is IANA requested to do with the TLV? I assume
register it. Also, what is the name of the new TLV?
Consider a cross-reference to table to for "this sub-registry"

-4.2: "Assignments of bit positions 0 through 31"
If I read correctly, that's all the bits. Is this the same as saying the
registry itself requires standards-action?

-5:
It's mildly odd to find the acknowledgements section between two
substantive sections.

-6, first paragraph:
Should "liveliness" be "liveness"?

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 17 Nov 2015 15:00:19 +0000

Hi Ben,
thank you for your thorough review and thoughtful comments. Please find my responses and proposed changes in-line and tagged GIM.

	Regards,
		Greg

-----Original Message-----
From: Ben Campbell [mailto:[email-masked]] 
Sent: Monday, November 16, 2015 7:07 PM
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Ben Campbell's No Objection on draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf-15: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Comment:
=========
- 4.1, paragraph 3:
Is it reasonable for a TLV in this standards-action registry to be have sub-tlvs with reduced registration requirements?  (And if so, is there a reason to exclude specifications that are not RFCs?)
GIM>> Yes. This is how it is done for all standard track registry TLVs for the entire LSP ping.
And yes we want RFCs to define the sub-TLVs (if the come out of the Specification need range) just because they go into a standard track specified TLV.

Nits:
====
-1, paragraph 1:
GIM>> Thank you, added.

- 1.0, last paragraph, last two sentences:
Who are “we” in these sentences? Does it make sense to talk about what “we” are or are not “configuring”?
GIM>> Indeed, re-worded as:
   It should be noted that this document does not specify how to configure on-
   demand throughput estimates based on saturating the connection as
   defined in [RFC6371].  Rather, only how to enable the estimation of
   the current throughput based on loss measurements.

GIM>> Agree, accepted.

-4.1, 2nd paragraph, first sentence:
Missing words? (What is IANA requested to do with the TLV? I assume register it. Also, what is the name of the new TLV?
Consider a cross-reference to table to for "this sub-registry"
GIM>> I think that missing are "to allocate" and the name of the TLV " MPLS OAM Functions":
   IANA is requested to allocate a new MPLS OAM Functions TLV from the
   standards action range (0-16383) and sub-TLVs as follows from sub-
   registry presented in Table 1, called "Sub-TLVs for TLV [TBA1]".

-4.2: "Assignments of bit positions 0 through 31"
If I read correctly, that's all the bits. Is this the same as saying the registry itself requires standards-action?
GIM>> Yes, the whole range is under standard-action allocation policy.

-5:
It's mildly odd to find the acknowledgements section between two substantive sections.
GIM>> Thank you, moved it.

-6, first paragraph:
Should "liveliness" be "liveness"?
GIM>> Yes, we're not checking its vitality.

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 19 Nov 2015 17:19:37 +0000

Hi Ben,
would greatly appreciate your consideration of the proposed changes to address your comments and your feedback whether these changes are acceptable.

	Regards,
		Greg

-----Original Message-----
From: Gregory Mirsky [mailto:[email-masked]] 
Sent: Tuesday, November 17, 2015 7:00 AM
To: Ben Campbell; The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Ben Campbell's No Objection on draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf-15: (with COMMENT)

Hi Ben,

	Regards,
		Greg

-----Original Message-----
From: Ben Campbell [mailto:[email-masked]] 
Sent: Monday, November 16, 2015 7:07 PM
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Ben Campbell's No Objection on draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf-15: (with COMMENT)

Comment:
=========
- 4.1, paragraph 3:

Nits:
====
-1, paragraph 1:

-5:

-6, first paragraph:

---

From: "Ben Campbell" <[email-masked]>
Date: Thu, 19 Nov 2015 17:42:41 -0600

Thanks for the response. Please see below (I removed sections that don't 
seem to need further discussion.)

Thanks!

Ben.

On 19 Nov 2015, at 11:19, Gregory Mirsky wrote:

[...]

> Is it reasonable for a TLV in this standards-action registry to be 
> have sub-tlvs with reduced registration requirements?  (And if so, is 
> there a reason to exclude specifications that are not RFCs?)

Okay,

> And yes we want RFCs to define the sub-TLVs (if the come out of the 
> Specification need range) just because they go into a standard track 
> specified TLV.

That would make sense to me for a standards-action requirement. But 
requiring experimental RFCs seems to narrow down the options a lot, 
while keeping the bar fairly low. That seems more like a procedural hoop 
than a check on spec maturity.

In any case, I leave it to the proponents to do the Right Thing, even if 
the right thing means ignoring my comment :-)

[...]

---

From: Gregory Mirsky <[email-masked]>
Date: Sat, 21 Nov 2015 17:06:51 +0000

Hi Ben,
thank you for your consideration. We, authors of this document, had discussed the allocation policy question and agreed that it would be appropriate to have broader discussion as part of 4379bis work. Loa had sent the mail on the subject (attached).

	Regards,
		Greg                                                                                               

-----Original Message-----
From: Ben Campbell [mailto:[email-masked]] 
Sent: Thursday, November 19, 2015 3:43 PM
To: Gregory Mirsky
Cc: The IESG; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Ben Campbell's No Objection on draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf-15: (with COMMENT)

Thanks for the response. Please see below (I removed sections that don't seem to need further discussion.)

Thanks!

Ben.

[...]

Okay,

[...]

Subject: QUestion deferred to 4379bis - Fwd: Re: [mpls] Ben Campbell's No Objection on draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf-15: (with COMMENT)
From: Loa Andersson <[email-masked]>
To: "[email-masked]" <[email-masked]>
Cc: Gregory Mirsky <[email-masked]>, Ben Campbell <[email-masked]>, "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Sat, 21 Nov 2015 05:30:40 +0000

Authors, (chair hat tipped a bit)

During the IESG review of draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf we
got the foloowing comment on allocation policies. Since the comment is
on a LSP Ping wide policy, we have not thought we should make a local
change in allocation policies for 
draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf, but if a change is needed or 
wanted we think the right place
to consider it whould be  4379bis.

Can you take a look at this ans see if a change is needed/wanted.

/Loa

-------- Forwarded Message --------
Subject: Re: [mpls] Ben Campbell's No Objection on 
draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf-15: (with COMMENT)
Date: Thu, 19 Nov 2015 17:42:41 -0600
From: Ben Campbell <[email-masked]>
To: Gregory Mirsky <[email-masked]>
CC: [email-masked] 
<[email-masked]>, [email-masked] 
<[email-masked]>, [email-masked] 
<[email-masked]>, 
[email-masked] <[email-masked]>, The IESG <[email-masked]>, 
[email-masked] <[email-masked]>

Thanks!

Ben.

[...]

Okay,

[...]

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64