Subject: Re: [mpls] [Idr] Fwd: Working Group adoption poll on draft-rosen-mpls-rfc3107bis

From: Robert Raszuk <[email-masked]>
Date: Thu, 1 Sep 2016 09:04:53 +0200

​Acee,​

> The current capability is specific to support of multiple labels - not
> your parochial view on the interaction between SAFIs.
>

​Since "bis" specification obsoletes the base document I was under the
assumption that new capability will also obsolete the current used.

It is no longer "3107bis" but just a new draft or at best errata -  to the
best of my understanding of IETF rules "bis" obsoletes the original spec.
Requiring implmentors to read and follow both specifications to correctly
implement the labeled BGP AF seems a bit odd ... don't you think ?

 Are you suggesting a second capability? All the more reason for a separate
> draft.

​No.​ See above.

In any event, the non-backward compatible behavior you are proposing would
> be better served in a separate draft than to burden RFC 3107 BIS.
>

​Section 5 already discusses that point - so my comment should be
considered as feedback towards that section . If there is WG consensus to
proceed with that it would be pure waist of time to write a separate draft
to argue against it.

It seems interesting that IETF WG feedback expressed on the list for
specific section of the draft in adoption call or during WG progress is
turned around and request is made to write a new draft instead.

Especially that document wise the feedback consideration may require
addition of two sentences within section 5 :).

Cheers,
R.

---

From: <[email-masked]>
Date: Fri, 2 Sep 2016 14:25:09 +0000

Hi all,

I support WG adoption: multiple aspects of RFC 3107 would benefit from clarification.

However, I note that the edition of this bis is probably driven by the advertisement of multiple MPLS labels for a prefix. But this technical point was clearly specified in RFC 3107. The problem we have is not a specification issue, but an implementation issue where some vendors shipped implementations not following RFC 3107. I'm not sure whether the problem is/was on the IETF side or on the implementations side. Have we learnt from this issue and improved for the future? If so, I'd be interested in a summary

Thanks,
--Bruno

> -----Original Message-----
> From: mpls [mailto:[email-masked]] On Behalf Of Loa Andersson
> Sent: Tuesday, August 30, 2016 2:10 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: [mpls] Working Group adoption poll on draft-rosen-mpls-rfc3107bis
> 
> Working Group,
> 
> This is to start a two week poll on adopting draft-rosen-mpls-rfc3107bis
> as an MPLS working group document.
> 
> Please send your comments (support/not support) to the mpls working
> group mailing list ([email-masked]). Please give a technical
> motivation for your support/not support, especially if you think that
> the document should not be adopted as a working group document.
> 
> There are no IPR disclosures against this document.
> 
> All the authors has stated on the on the mpls wg mailing list that they
> are not aware of any IPRs that relate to this document.
> 
> The working group adoption poll ends September 14, 2016.
> 
> /Loa
> 
> MPLS wg co-chair.
> --
> 
> 
> Loa Andersson                        email: [email-masked]
> Senior MPLS Expert                          [email-masked]
> Huawei Technologies (consultant)     phone: +46 739 81 21 64
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Lucy yong <[email-masked]>
Date: Mon, 12 Sep 2016 20:14:50 +0000

I support the WG adoption.

Comments:

Section 5 only mentions that BGP session may convert a SAFI-4 to a SAFI-1 then propagate. 
IMO: the local policy could allow a BGP session to convert a SAFI-1 to a SAFI-4 then propagate it if other BGP sessions enable SAFI-4. In this case, the node of the BGP session changes the next hop to itself and adds label(s) to NLRI before propagating the route.

I made comments on 6/20 about the last use case on page 16. It does not make a sense to me. Node S1 changes <L11, L12, ..., L1k> with <L21, L22, ... L2k> and programs its data plane so that when s1 processes a received MPLS packet whose top label is L21, it replaces L21 with <L11, L12, ... L1k> and then tunnels the packet to N1.  Since this is very unusual case, pls give a concrete use case of this.  

Thanks,
Lucy

On 8/29/16, 8:10 PM, "mpls on behalf of Loa Andersson"
<[email-masked] on behalf of [email-masked]> wrote:

>Working Group,
>
>This is to start a two week poll on adopting 
>draft-rosen-mpls-rfc3107bis as an MPLS working group document.
>
>group mailing list ([email-masked]). Please give a technical motivation 
>for your support/not support, especially if you think that the document 
>should not be adopted as a working group document.
>

---

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 12 Sep 2016 17:51:37 -0400

Agree with others. This draft should be adopted as WG document.

Thanks,
Himanshu

From: mpls [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Wednesday, August 31, 2016 1:45 AM
To: Jeff Tantsura; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls] Working Group adoption poll on draft-rosen-mpls-rfc3107bis

I agree, the draft should be adopted by the WG.

Cheers,
Andy

On Wednesday, August 31, 2016, Jeff Tantsura <[email-masked]<mailto:[email-masked]>> wrote:
Loa,

This document is long due!
Support

Cheers,
Jeff

On 8/29/16, 17:10, "mpls on behalf of Loa Andersson" <[email-masked]<javascript:;> on behalf of [email-masked]<javascript:;>> wrote:

Working Group,

Please send your comments (support/not support) to the mpls working
group mailing list ([email-masked]<javascript:;>). Please give a technical
motivation for your support/not support, especially if you think that
the document should not be adopted as a working group document.

/Loa

MPLS wg co-chair.
--

Loa Andersson                        email: [email-masked]<javascript:;>
Senior MPLS Expert                          [email-masked]<javascript:;>
Huawei Technologies (consultant)     phone: +46 739 81 21 64

_______________________________________________
mpls mailing list
[email-masked]<javascript:;>
https://www.ietf.org/mailman/listinfo/mpls

_______________________________________________
mpls mailing list
[email-masked]<javascript:;>
https://www.ietf.org/mailman/listinfo/mpls

--
Autocorrected by my iPhone

---

From: Loa Andersson <[email-masked]>
Date: Thu, 15 Sep 2016 17:04:57 +0200

Working Group, Authors,

This working group adoption poll is closed, and we have a new wg
document.

Can the authors please post the working group document
"draft-ietf-mpls-rfc3107bis-00"
without any other changes than administrative info as compared with the
document we polled.

There were also some comments that should be addressed and if changes
to the document are made these should be made in version -01 (or later)
of the working group document.

/Loa
for the mpls wg chairs

--