Subject: [mpls] [Technical Errata Reported] RFC4928 (5396)

From: RFC Errata System <[email-masked]>
Date: Mon, 18 Jun 2018 02:37:15 -0700 (PDT)

The following errata report has been submitted for RFC4928,
"Avoiding Equal Cost Multipath Treatment in MPLS Networks".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5396

--------------------------------------
Type: Technical
Reported by: Jitendra Kumar Sharma <[email-masked]>

Section: Section 2

Original Text
-------------
   A less obvious case is when the packets of a given flow happen to
   have constant values in the fields upon which IP ECMP would be
   performed.  For example, if an Ethernet frame immediately follows the
   label and the LSR does ECMP on IPv4, but does not do ECMP on IPv6,
   then either the first nibble will be 0x4, or it will be something
   else.  If the nibble is not 0x4 then no IP ECMP is performed, but
   Label ECMP may be performed.  If it is 0x4, then the constant values
   of the MAC addresses overlay the fields that would have been occupied
   by the source and destination addresses of an IP header.  In this
   case, the input to the ECMP algorithm would be a constant value and
   thus the algorithm would always return the same result.

Corrected Text
--------------
<This paragraph should be removed>

Notes
-----
The example stated here seems incorrect. It talks about an L2VPN case where Ethernet frame starts immediately after the last label in the stack. But had it been an IP packet instead, the same initial 12 bytes, which is the place for MAC addresses in an Ethernet Frame, would not be the place of IP addresses, as IP addresses are placed at the end of 20-byte IP header (not start). Hence it would still be subjected to ECMP if precautions (as recommended in this RFC) are not been followed.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4928 (draft-ietf-mpls-ecmp-bcp-03)
--------------------------------------
Title               : Avoiding Equal Cost Multipath Treatment in MPLS Networks
Publication Date    : June 2007
Author(s)           : G. Swallow, S. Bryant, L. Andersson
Category            : BEST CURRENT PRACTICE
Source              : Multiprotocol Label Switching
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Fri, 29 Jun 2018 14:32:16 +0000

MPLS WG,

We have this errata on RFC4928 - any thoughts?

Deborah

-----Original Message-----
From: RFC Errata System <[email-masked]> 
Sent: Monday, June 18, 2018 5:37 AM
To: [email-masked]; [email-masked]; [email-masked]; BRUNGARD, DEBORAH A <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Technical Errata Reported] RFC4928 (5396)

--------------------------------------
You may review the report below and at:
https://urldefense.proofpoint.com/v2/url?u=http-3A__www.rfc-2Deditor.org_errata_eid5396&d=DwIBaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=zz6ovHLVAtV_M2JDhQbYVwIhYVehe5aI6IVO8gDY6fU&s=ZeHGqLSL8ZArKF83wT85HuuT78PHErIz0Lfn0bk8280&e=

Section: Section 2

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------