Subject: [mpls] Warren Kumari's No Objection on draft-ietf-mpls-spring-entropy-label-11: (with COMMENT)

From: Warren Kumari <[email-masked]>
Date: Wed, 04 Jul 2018 11:03:44 -0700

Warren Kumari has entered the following ballot position for
draft-ietf-mpls-spring-entropy-label-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-mpls-spring-entropy-label/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for writing this - it provides useful functionality.

Please see Joe Clarke's OpsDir review here:
https://datatracker.ietf.org/doc/review-ietf-mpls-spring-entropy-label-11-opsdir-lc-clarke-2018-06-25/
 - it mirrors comments made by a number of ADs, and also contains a significnat
number of nits (which would make the document better / more readable).

I had a question:
Section 4.  Entropy Readable Label Depth
" The Entropy Readable Label Depth (ERLD) is defined as the number of
   labels a router can both:
   a.  Read in an MPLS packet received on its incoming interface(s)
       (starting from the top of the stack).
   b.  Use in its load-balancing function."
...
"In a distributed switching architecture, each linecard may have a different
capability in terms of ERLD."

In many cases, a device may have a different readable label depth in hardware /
fastpath than it does by punting the packet to the CPU / control plane. Perhaps
the ERLD should be defined as 'Use in its load-balancing function in the
dataplace / fast-path" (or something, this will need some wording).

I'd also like to say that I like Section 10 (Options considered) - sections
like this make a document much more satisfying (otherwise one has niggling
questions like "What didn't they do single ELs at the bottom of the stack?!") -
thank you for including it.

I also have some nits:
Section 1.  Introduction
"The hashing technique is required to perfom a per-flow load-balancing and thus
prevent packet disordering. " 1: Perform is a type 2: While 'disordering'
explains it well, 'reordering' is a much more common term, and will (I think)
cause less confusion.

"The MPLS architecture brings some challenges on the load-balancing as an LSR
(Label Switch Router) should be able to look at header fields that are beyond
the MPLS label stack." "on the load-balancing" doesn't really parse. Perhaps:
"... brings some load-balancing challenges, as..."?

Section 2.  Abbreviations and Terminology
SRGB is not defined on first use, nor it is in the Terminology section. Also,
sorting this alphabetically would be appreciated.

---

From: <[email-masked]>
Date: Thu, 5 Jul 2018 11:43:41 +0000

Thanks Warren,

I agree with your comments and I will address them in the next revision.
You are right (at least from a theoretical point of view) about fast path vs slow path for ERLD. I think for this kind of switching implementation, we have several options: advertising the fast path ERLD (slow path will never be triggered), advertising the slow path ERLD (there is a possibility that slow path will be triggered for each packet), let this configurable by the user. I do not think that this fast path/slow path implementation is still popular at least for the SP router market.

-----Original Message-----
From: Warren Kumari [mailto:[email-masked]] 
Sent: Wednesday, July 04, 2018 20:04
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Warren Kumari's No Objection on draft-ietf-mpls-spring-entropy-label-11: (with COMMENT)

I had a question:

I also have some nits:
Section 1.  Introduction

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Warren Kumari <[email-masked]>
Date: Thu, 5 Jul 2018 11:07:49 -0400

> I agree with your comments and I will address them in the next revision.

​Thanks!​

> You are right (at least from a theoretical point of view) about fast path
> vs slow path for ERLD. I think for this kind of switching implementation,
> we have several options: advertising the fast path ERLD (slow path will
> never be triggered), advertising the slow path ERLD (there is a possibility
> that slow path will be triggered for each packet), let this configurable by
> the user. I do not think that this fast path/slow path implementation is
> still popular at least for the SP router market.
>
>
​I'm fine with whatever you select, I just wanted it to be considered.​
W

> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Subject: Warren Kumari's No Objection on
> draft-ietf-mpls-spring-entropy-label-11: (with COMMENT)
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: <[email-masked]>
Date: Thu, 5 Jul 2018 23:08:59 +0000

I have added the following text:
“There may also be a case where a router has a fast switching path (handled by an ASIC or network processor) and a slow switching path (handled by a CPU) with a different ERLD for each switching path. Again, for simplicity reasons, an implementation MAY use the minimum ERLD as the ERLD value for the system.”

I have also highlighted the drawback as per Joe’s comment:
“The drawback of using a single ERLD for a system lower than the capability of one or more specific component is that it may increase the number of ELI/ELs inserted. This leads to an increase of the label stack size and may have an impact on the capability of the ingress node to push this label stack.”

From: Warren Kumari [mailto:[email-masked]]
Sent: Thursday, July 05, 2018 17:08
To: LITKOWSKI Stephane OBS/OINIS
Cc: The IESG; [email-masked]; [email-masked]; BRUNGARD, DEBORAH A; [email-masked]; Loa Andersson; Joe Clarke
Subject: Re: Warren Kumari's No Objection on draft-ietf-mpls-spring-entropy-label-11: (with COMMENT)

On Thu, Jul 5, 2018 at 7:43 AM <[email-masked]<mailto:[email-masked]>> wrote:
Thanks Warren,

​Thanks!​

-----Original Message-----
From: Warren Kumari [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, July 04, 2018 20:04
To: The IESG
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Warren Kumari's No Objection on draft-ietf-mpls-spring-entropy-label-11: (with COMMENT)

I had a question:

I also have some nits:
Section 1.  Introduction

--
I don't think the execution is relevant when it was obviously a bad idea in the first place.
This is like putting rabid weasels in your pants, and later expressing regret at having chosen those particular rabid weasels and that pair of pants.
   ---maf

---

From: Warren Kumari <[email-masked]>
Date: Fri, 6 Jul 2018 12:32:27 -0400

> “The drawback of using a single ERLD for a system lower than the capability of one or more specific component is that it may increase the number of ELI/ELs inserted. This leads to an increase of th…

Awesome, thank you - nicely worded, and works for me.
W

> Thanks!
> I'm fine with whatever you select, I just wanted it to be considered.
>
> W
>
>
>
>
>

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf