Subject: [mpls] draft-allan-pim-sr-mpls-multicast-framework and MPLS

From: David Allan I <[email-masked]>
Date: Thu, 19 Jul 2018 18:25:47 +0000

Hi MPLS folks

Re: https://datatracker.ietf.org/doc/draft-allan-pim-sr-mpls-multicast-framework/

In presentations of this draft, the question has been repeatedly raised “is this approach confined to SR-MPLS?”. At the mike Loa suggested I post this to the MPLS list for discussion.

Our first blush take is this looks doable but would require some SR-MPLS scaffolding to handle the multicast SID:

  1.  The LDP mesh would have no trouble stunt doubling for the SR-MPLS node SIDs.
  2.  An SRGB would be required to permit the equivalent of a binding SID for the multicast SID to be advertised, and mapping to local implementation of the SRGB.  Overall procedures would be a hybrid of SR-MPLS CP components, and LDP signaled labels for the unicast tunnels.

But I would invite the group to comment and potentially disabuse us of this notion 😊

Cheers
Dave & Co

---

From: Xiejingrong <[email-masked]>
Date: Thu, 19 Jul 2018 18:52:59 +0000

Hi Allan
I really think the algorithm is very strong to calculate a very optimized tree, but the usage of the strong algorithm in the draft is complex and many people may do not like, especially when considering the implementation cost and the benefits.
So i suggest deviding things into two parts, one is algorithm like rfc7811, and one is the possible usage of the algorithm like rfc7812 and etc. The later one can be open to some others to make better benefits according to their usecase or solution.
But I don't know if a pure algorithm draft without a good enough applicability temporaryly can make this more acceptable or not.Just my comment.

Thank you to introduce a strong tree computing algorithm.

Jingrong

--------------------------------------------------
Sent From WeLink
From:David Allan I
To:[email-masked],
Date:2018-07-19 14:26:24
Subject:[mpls] draft-allan-pim-sr-mpls-multicast-framework and MPLS

Hi MPLS folks

Cheers
Dave & Co