Subject: [mpls] [Editorial Errata Reported] RFC8287 (6101)

From: RFC Errata System <[email-masked]>
Date: Mon, 13 Apr 2020 04:17:18 -0700 (PDT)

The following errata report has been submitted for RFC8287,
"Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) IGP-Prefix and IGP-Adjacency Segment Identifiers (SIDs) with MPLS Data Planes".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6101

--------------------------------------
Type: Editorial
Reported by: Alexander ("Sasha") Vainshtein <[email-masked]>

Section: 7.2

Original Text
-------------
   The network node that advertised the Node Segment ID is responsible
   for generating a FEC Stack Change sub-TLV with the Post Office
   Protocol (POP) operation type for the Node Segment ID, regardless of
   whether or not Penultimate Hop Popping (PHP) is enabled.

Corrected Text
--------------
   The network node that advertised the Node Segment ID is responsible
   for generating a FEC Stack Change sub-TLV with the   POP) operation type for 
   the Node Segment ID, regardless of whether or not Penultimate Hop Popping 
   (PHP) is enabled.

Notes
-----
Expansion of POP to "Post Office Protocol" in the context of this document is wrong.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8287 (draft-ietf-mpls-spring-lsp-ping-13)
--------------------------------------
Title               : Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) IGP-Prefix and IGP-Adjacency Segment Identifiers (SIDs) with MPLS Data Planes
Publication Date    : December 2017
Author(s)           : N. Kumar, Ed., C. Pignataro, Ed., G. Swallow, N. Akiya, S. Kini, M. Chen
Category            : PROPOSED STANDARD
Source              : Multiprotocol Label Switching
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 13 Apr 2020 14:06:08 +0000

IMHO, this should be accepted. Not sure how we missed it!

Frankly, “POP” should be “pop” as it’s not an acronym.

Thanks,

Carlos.

> 2020/04/13 午前7:17、RFC Errata System <[email-masked]>のメール:
>

---

From: Loa Andersson <[email-masked]>
Date: Mon, 13 Apr 2020 22:15:45 +0800

Sasha, et.al.,

The errata is mostly right, but the suggested corrected text is not
entirely correct.

Also this seems to have crept in while the document was in the RFC Ed
Queue, and should  have been discovered during AUTH48. As the Shepherd
I should have captured this.

The text that the IESG approved is correct, 
draft-ietf-mpls-spring-lsp-ping-13, it stands out very clearly in the diff.

> "Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) IGP-Prefix and IGP-Adjacency Segment Identifiers (SIDs) with MPLS Data Planes".

FURTHER CORRECTED TEXT

    The network node which advertised the Node Segment ID is responsible
    for generating a FEC Stack Change sub-TLV with pop operation type for
    Node Segment ID, regardless of whether penultimate hop popping (PHP)
    is enabled or not.

It should also be noted that the the next paragraph also have the same 
issue.

CURRENT TEXT

    The network node that is immediately downstream of the node that
    advertised the Adjacency Segment ID is responsible for generating the
    FEC Stack Change sub-TLV for POP operation for the Adjacency Segment
    ID.

CORRECTED TEXT

    The network node that is immediate downstream of the node which
    advertised the Adjacency Segment ID is responsible for generating FEC
    Stack Change sub-TLV for pop operation for Adjacency Segment ID.

Notes
-----
The "pop" in pop operation is not an abbreviation or acronym, it is is
the name of the operation type, the other operation type is "push".

I recommend that this Errata is held waiting for a future revision of
the RFC.

/Loa

-- 

My mail server it under a DOS attack, we are working to fix it but it
may take some time.

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 13 Apr 2020 14:22:51 +0000

Loa,
Lots of thanks for a prompt response.

There is a typo in the proposed new text (an extra closing parenthesis ")" after "POP").

And the fact that the unnecessary expansion has been added by the RFC Editor adds new meaning to the term "Editorial Errara"😉...

Get Outlook for Android<https://aka.ms/ghei36>

________________________________
From: Loa Andersson <[email-masked]>
Sent: Monday, April 13, 2020, 17:15
To: RFC Errata System; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: Alexander Vainshtein; [email-masked]
Subject: Re: [Editorial Errata Reported] RFC8287 (6101)

Sasha, et.al.,

On 13/04/2020 19:17, RFC Errata System wrote:
> https://clicktime.symantec.com/3QENn98e7GXU6Ef6sHmBXV6H2?u=https%3A%2F%2Fwww.rfc-editor.org%2Ferrata%2Feid6101
>

FURTHER CORRECTED TEXT

CURRENT TEXT

CORRECTED TEXT

Notes
-----

/Loa

--

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: Loa Andersson <[email-masked]>
Date: Tue, 14 Apr 2020 13:47:59 +0800

Sasha,

> There is a typo in the proposed new text (an extra closing parenthesis 

I hope you saw that that I want to change "POP" operation to pop 
operation at two places.
> 
> And the fact that the unnecessary expansion has been added by the RFC 
> Editor adds new meaning to the term "Editorial Errara"😉...

I can appreciate the joke, but I'm much more amazed with how much the
RFC Editor in general improve document. And error like thi should really
have been captured by the authors and shepherd.

/Loa
> 
> 
> Get Outlook for Android <https://aka.ms/ghei36>
> 
> ------------------------------------------------------------------------
> *From:* Loa Andersson <[email-masked]>
> *Sent:* Monday, April 13, 2020, 17:15
> *To:* RFC Errata System; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> *Cc:* Alexander Vainshtein; [email-masked]
> *Subject:* Re: [Editorial Errata Reported] RFC8287 (6101)
> 
> Sasha, et.al.,
> 
> 

--

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 14 Apr 2020 06:26:18 +0000

Loa,

I fully agree that there is no need in capitalized "POP" in this text.

As for everybody missing the unfortunate and unnecessary expansion of a non-abbreviation: well, such things happen. We shall all be more careful next time I think.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

-----Original Message-----
From: Loa Andersson <[email-masked]> 
Sent: Tuesday, April 14, 2020 8:48 AM
To: Alexander Vainshtein <[email-masked]>; RFC Errata System <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Editorial Errata Reported] RFC8287 (6101)

Sasha,

> There is a typo in the proposed new text (an extra closing parenthesis 

I hope you saw that that I want to change "POP" operation to pop operation at two places.
> Editor adds new meaning to the term "Editorial Errara"😉...

I can appreciate the joke, but I'm much more amazed with how much the RFC Editor in general improve document. And error like thi should really have been captured by the authors and shepherd.

/Loa
> 
> 
> Get Outlook for Android 
> <https://clicktime.symantec.com/3MyVPNLD9TEbBzPEZZjgrTf6H2?u=https%3A%
> 2F%2Faka.ms%2Fghei36>
> 
>> The following errata report has been submitted for RFC8287, "Label 
>> Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) IGP-Prefix and IGP-Adjacency Segment Identifiers (SIDs) with MPLS Data Planes".
>> 
>> https://clicktime.symantec.com/3QENn98e7GXU6Ef6sHmBXV6H2?u=https%3A%2
>> F%2Fwww.rfc-editor.org%2Ferrata%2Feid6101
>> 
>> use "Reply All" to discuss whether it should be verified or rejected. 
>> When a decision is reached, the verifying party can log in to change 
>> the status and edit the report, if necessary.
>> 
>> Title               : Label Switched Path (LSP) Ping/Traceroute for 
>> Segment Routing (SR) IGP-Prefix and IGP-Adjacency Segment Identifiers 
>> (SIDs) with MPLS Data Planes Publication Date    : December 2017
>> Author(s)           : N. Kumar, Ed., C. Pignataro, Ed., G. Swallow, 
>> N. Akiya, S. Kini, M. Chen Category            : PROPOSED STANDARD 
>> Source              : Multiprotocol Label Switching Area                
>> : Routing Stream              : IETF Verifying Party     : IESG
>> 
> 
> --
> 
> Loa Andersson                        email: [email-masked] Senior MPLS 
> Expert Bronze Dragon Consulting             phone: +46 739 81 21 64
> 
> 
> This e-mail message is intended for the recipient only and contains 
> information which is CONFIDENTIAL and which may be proprietary to ECI 
> Telecom. If you have received this transmission in error, please 
> inform us by e-mail, phone or fax, and then delete the original and 
> all copies thereof.

-- 

My mail server it under a DOS attack, we are working to fix it but it may take some time.

---

From: Loa Andersson <[email-masked]>
Date: Sun, 26 Apr 2020 12:37:28 +0800

Deborah,

Can we close this??

/Loa

On 13/04/2020 22:15, Loa Andersson wrote:
>> "Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) 
>> IGP-Prefix and IGP-Adjacency Segment Identifiers (SIDs) with MPLS Data 
>> Planes".
>>

--