Subject: [mpls] [Technical Errata Reported] RFC4090 (6203)

From: RFC Errata System <[email-masked]>
Date: Wed, 3 Jun 2020 03:20:00 -0700 (PDT)

The following errata report has been submitted for RFC4090,
"Fast Reroute Extensions to RSVP-TE for LSP Tunnels".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6203

--------------------------------------
Type: Technical
Reported by: Mihir Amrelia <[email-masked]>

Section: 6

Original Text
-------------
If the "bandwidth protection guaranteed" flag is set, the PLR SHOULD try to
provide a bandwidth guarantee; if this is not feasible, the PLR SHOULD then try
to provide a backup without a guarantee of the full bandwidth.

Corrected Text
--------------
If the "Bandwidth Protection Desired" flag is set in SESSION_ATTRIBUTE, the PLR
SHOULD try to provide a bandwidth guarantee; if this is not feasible, the PLR
SHOULD then try to provide a backup without a guarantee of the full bandwidth.

Notes
-----
Correcting flag info to consider bandwidth protection.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4090 (draft-ietf-mpls-rsvp-lsp-fastreroute-07)
--------------------------------------
Title               : Fast Reroute Extensions to RSVP-TE for LSP Tunnels
Publication Date    : May 2005
Author(s)           : P. Pan, Ed., G. Swallow, Ed., A. Atlas, Ed.
Category            : PROPOSED STANDARD
Source              : Multiprotocol Label Switching
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Loa Andersson <[email-masked]>
Date: Tue, 9 Jun 2020 18:48:22 +0800

All,

I think this errata in essence is correct, though I would want to
propose a slight modification to the Corrected Text.

> "Fast Reroute Extensions to RSVP-TE for LSP Tunnels".

Slightly Corrected Text
--------------
If the "bandwidth protection desired" flag is set in SESSION_ATTRIBUTE, 
the PLR
SHOULD try to provide a bandwidth guarantee; if this is not feasible, 
the PLR
SHOULD then try to provide a backup without a guarantee of the full 
bandwidth.

Note 1: lowercase is how the document treat all othr names of flags in
flowing text.

Note 2: with this slight change I think this Errata could be verified
and held for a document update.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          loa.pi.nu@gmail
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Alia Atlas <[email-masked]>
Date: Tue, 9 Jun 2020 09:06:23 -0400

Sure

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 9 Jun 2020 14:14:41 +0000

Is there an IETF policy for adding/correcting normative language via an Errata? I guess this is allowed.
Thanks,
Acee

From: mpls <[email-masked]> on behalf of Alia Atlas <[email-masked]>
Date: Tuesday, June 9, 2020 at 9:07 AM
To: Loa Andersson <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, RFC Errata System <[email-masked]>
Subject: Re: [mpls] [Technical Errata Reported] RFC4090 (6203)

Sure

On Tue, Jun 9, 2020 at 6:48 AM Loa Andersson <[email-masked]<mailto:[email-masked]>> wrote:
All,

On 03/06/2020 18:20, RFC Errata System wrote:
> Reported by: Mihir Amrelia <[email-masked]<mailto:mihiramrelia_89@yahoo..com>>
>
> Section: 6
>
> Original Text
> -------------

Slightly Corrected Text
--------------

/Loa

--

Loa Andersson                        email: [email-masked]<mailto:[email-masked]>
Senior MPLS Expert                          loa.pi.nu@gmail
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Loa Andersson <[email-masked]>
Date: Wed, 10 Jun 2020 11:22:36 +0800

Acee,

I don't think we are adding /correcting the normative language. The only
thing that is done is correcting the naming of one of the flags.

/Loa

On 09/06/2020 22:14, Acee Lindem (acee) wrote:
> *From: *mpls <[email-masked]> on behalf of Alia Atlas 
> <[email-masked]>
> *Date: *Tuesday, June 9, 2020 at 9:07 AM
> *To: *Loa Andersson <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>, "[email-masked]" 
> <[email-masked]>, RFC Errata System <[email-masked]>
> *Subject: *Re: [mpls] [Technical Errata Reported] RFC4090 (6203)
> 
> Sure
> 
>     Loa Andersson                        email: [email-masked] <mailto:[email-masked]>

--