Subject: [mpls] Thought on draft-ninan-mpls-spring-inter-domain-oam

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 8 Mar 2021 12:30:25 -0000

Hi,

Interesting presentation today.

Rather than waste mic time with small points, here's an email...

1. Do you *really* want the flags field to be just 7 bits? The figures show
that, but the text says "1 octet".

2. Would you consider putting the "SR algorithm" field down at the low order
bits of the double they are in? This allows (if necessary in the future)
more easy extension of the Flags field.

Cheers,
Adrian

---

From: Shraddha Hegde <[email-masked]>
Date: Wed, 10 Mar 2021 08:41:19 +0000

Adrian,

Thank you for the review and comments.

Agree with both comments and will fix it in next revision.

Rgds
Shraddha

Juniper Business Use Only

-----Original Message-----
From: Adrian Farrel <[email-masked]> 
Sent: Monday, March 8, 2021 6:00 PM
To: [email-masked]
Cc: [email-masked]
Subject: Thought on draft-ninan-mpls-spring-inter-domain-oam

[External Email. Be cautious of content]

Hi,

1. Do you *really* want the flags field to be just 7 bits? The figures show that, but the text says "1 octet".

2. Would you consider putting the "SR algorithm" field down at the low order bits of the double they are in? This allows (if necessary in the future) more easy extension of the Flags field.

Cheers,
Adrian