Subject: Re: [mpls] I-D Action: draft-andersson-mpls-open-dt-questions-00.txt

From: Stewart Bryant <[email-masked]>
Date: Thu, 29 Apr 2021 11:25:54 +0100

2.1.3.  Does flooding om maximum scanning depth of an LSR scale?

   A remedy for the issues in Section 2.1.1 has been suggested, the
   maaximum scanning depth for each LSR in the network should be flooded
   to all othr LSRs and used as a constraint when setting up LSPs.

   Would that scale satisfactorily.

Hi Loa 

That is a duplicate of 2.1.2  and I think we can answer that as yes.

It is one additional capability field (no more than a byte) to flood and I find it hard to imagine that it would not scale.

Best regards

- Stewart

> On 29 Apr 2021, at 08:59, [email-masked] wrote:
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>        Title           : MPLS Open Design Team Questions
>        Author          : Loa Andersson
> 	Filename        : draft-andersson-mpls-open-dt-questions-00.txt
> 	Pages           : 4
> 	Date            : 2021-04-29
> 
> Abstract:
>   This document is a living document, meaning that during the life
>   timme of the MPLS Open Design Team we will put additonal questions/
>   issues into the document.  When we find an answer amd a way to
>   document the issu it will be removed from this document.
> 
>   Ideally when the Design Team is closed this document will be empty,
>   or maybe we just add a pointer to where the answer to quesstion is
>   documented.  Thus this document will never go on to become an RFCc.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-andersson-mpls-open-dt-questions/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-andersson-mpls-open-dt-questions-00
> https://datatracker.ietf.org/doc/html/draft-andersson-mpls-open-dt-questions-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Loa Andersson <[email-masked]>
Date: Thu, 29 Apr 2021 15:41:12 +0200

Stewart,

I was that concerned about the amount of data that needs to be flooded, 
but rather that the mechanisms we have is insufficient.

In the LDP case an LSR informs its peers about capabilities, they are 
not flooded across the network

RFC 5561

    - Each LDP speaker is assumed to implement a set of enhancements,
      each of which has an associated capability.  At any time, a speaker
      may have none, one, or more of those enhancements "enabled".  When
      an enhancement is enabled, the speaker advertises the associated
      capability to its peers.  By advertising the capability to a peer,
      the speaker asserts that it shall perform the protocol actions
      specified for the associated enhancement.  For example, the actions
      may require the LDP speaker to receive and process enhancement-
      specific messages from its peer.  Unless the capability has been
      advertised, the speaker will not perform protocol actions specified
      for the corresponding enhancement.

An LSR that initiates an LSP with a maximum scanning depth depth need to 
know this for every LSR along the LSP.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 29 Apr 2021 14:55:11 +0100

Hi Loa

LDP really layers on an IGP in most practical networks and the IGP can flood this without missing a heartbeat.

- Stewart

> On 29 Apr 2021, at 14:41, Loa Andersson <[email-masked]> wrote:
> 
> Stewart,
> 
> I was that concerned about the amount of data that needs to be flooded, but rather that the mechanisms we have is insufficient.
> 
> In the LDP case an LSR informs its peers about capabilities, they are not flooded across the network
> 
> RFC 5561
> 
> An LSR that initiates an LSP with a maximum scanning depth depth need to know this for every LSR along the LSP.
> 
> /Loa
>

---

From: Loa Andersson <[email-masked]>
Date: Fri, 30 Apr 2021 09:21:30 +0200

Stewart,

So we need a small updates of the IGPs, right?

/Loa

--