Subject: [mpls] FAI and NFI

From: Loa Andersson <[email-masked]>
Date: Tue, 12 Oct 2021 08:58:11 +0200

John,

In your proposal you say:

   The proposal detailed below, is derived from the forwarding actions
   (FA) work but is an attempt to simplify it. Given that we will be
   defining functions not directly related to forwarding, we are using
   the term 'network functions' rather than 'forwarding actions'.

To questions just for checking

- is forwarding actions a true subset of network functions?
- does not network functions has a scope that goes way beyond what
   we discuss carrying in or after the label stack?

/Loa
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: John E Drake <[email-masked]>
Date: Tue, 12 Oct 2021 13:49:12 +0000

Loa,

Comments inline below.

Yours Irrespectively,

John

Juniper Business Use Only

> -----Original Message-----
> From: Loa Andersson <[email-masked]>
> Sent: Tuesday, October 12, 2021 2:58 AM
> To: [email-masked]; John E Drake <[email-masked]>
> Subject: FAI and NFI
> 
> [External Email. Be cautious of content]
> 
> 
> John,
> 

[JD]  Yes, see my list below

>    we discuss carrying in or after the label stack?

[JD]  No, I did a quick check of current proposals and found the following:

Resource partition [HBH, Forwarding]

E2E Loss Measurement [E2E, Network]

E2E OAM (E2E, Network]

HBH OAM [HBH, Network]

Entropy [HBH, Forwarding]  (However, I'm not sure we should do this given existing deployments)

No Reroute [HBH, Forwarding]

Flow ID [HBH, Network]

5G Slice ID [E2E, Network]

Traffic Accounting [HBH, Network]

PTP/Bounded Delay [E2E, Forwarding]

L2 Frame Reassembly [E2E, Network]