Subject: [mpls] FI -> FPI ?

From: Stewart Bryant <[email-masked]>
Date: Fri, 1 Oct 2021 16:28:49 +0100

I do not like the name FI (Forwarding Indicator) because phonetically it sounds like phy which is the abbreviation for the physical layer. MPLS and the physical layer are relatively close friends and I can see confusion.

I was wondering about the term FPI (Forwarding and Programming Indicator) which has a nice phonetic ring about it and if it confused the LI people some might consider that a plus. The term captures the notion that we indicate not just where to send the packet but also what to do with it, hence Forwarding and Programming.

- Stewart

---

From: Kireeti Kompella <[email-masked]>
Date: Mon, 4 Oct 2021 16:09:55 -0700

Hi Stewart,

FI is a term you made up :)  In my draft, the term I use, and that others, including Loa, have been using, is Forwarding Actions Indicator (FAI).  I tend to spell it out (F-A-I); Loa pronounces it the European way (“fie”); an Englishman or a Frenchman might pronounce it “fay”.  I don’t think one should pick a name based on how one might pronounce it, but rather on what is appropriate to its use.  The FAI label indicates actions to be taken by the forwarding plane.  At present, there is no programmability aspect to the FAI.

Any similarity in sound with “phy” (which one could argue should be pronounced “fee”, as in physical) is quickly dispelled by adding “label” or “SPL”, or from context.

Cheers,
Kireeti.

> On Oct 1, 2021, at 08:29, Stewart Bryant <[email-masked]> wrote:
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Loa Andersson <[email-masked]>
Date: Tue, 5 Oct 2021 09:54:46 +0200

Folks,

I share Stewart’s concern about a potential mix up of FAI and PHY, and think we should avoid if possible.

I’ve been thinking about proposing FOI (Forwarding Operations Indicator) or FFI (Forwarding Functions Indicator). 

/Loa

Sent from my iPad

> On 5 Oct 2021, at 01:10, Kireeti Kompella <[email-masked]> wrote:
> 
> Hi Stewart,
>

---

From: Haoyu Song <[email-masked]>
Date: Tue, 5 Oct 2021 15:29:43 +0000

It's function for sure but not necessarily for "forwarding" only, so IMO maybe "Network Function Indicator" (NFI) is more generic.

Haoyu

-----Original Message-----
From: mpls <[email-masked]> On Behalf Of Loa Andersson
Sent: Tuesday, October 5, 2021 12:55 AM
To: Kireeti Kompella <[email-masked]>
Cc: mpls <[email-masked]>
Subject: Re: [mpls] FI -> FPI ?

Folks,

/Loa

Sent from my iPad

>> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmpls&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C3289876af1da4fb92ed508d987d574bb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637690173123884303%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=wdBvgWJZnNov8%2BOsBp5uHLJZqCeoZh4zPVGiSffoyjw%3D&amp;reserved=0
> 
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmpls&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C3289876af1da4fb92ed508d987d574bb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637690173123884303%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=wdBvgWJZnNov8%2BOsBp5uHLJZqCeoZh4zPVGiSffoyjw%3D&amp;reserved=0

_______________________________________________
mpls mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmpls&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C3289876af1da4fb92ed508d987d574bb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637690173123884303%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=wdBvgWJZnNov8%2BOsBp5uHLJZqCeoZh4zPVGiSffoyjw%3D&amp;reserved=0