Subject: [mpls] [Technical Errata Reported] RFC6512 (6754)

From: RFC Errata System <[email-masked]>
Date: Thu, 25 Nov 2021 03:37:53 -0800 (PST)

The following errata report has been submitted for RFC6512,
"Using Multipoint LDP When the Backbone Has No Route to the Root".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6754

--------------------------------------
Type: Technical
Reported by: Bert Van Ael <[email-masked]>

Section: 3.2.1

Original Text
-------------
PE1 also has this Inter-AS I-PMSI A-D route.

Corrected Text
--------------
PE1 also has this Intra-AS I-PMSI A-D route.

Notes
-----
"PE1 also has this route" refers to "Although ASBR1 does not have a route to PE2, it does have a BGP Intra-AS Inclusive PMSI (I-PMSI) auto-discovery (A-D) route". Intra-AS mechanisms are used for auto-discovery/binding for Non-Segmented Inter-AS Tunnels.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6512 (draft-ietf-mpls-mldp-recurs-fec-04)
--------------------------------------
Title               : Using Multipoint LDP When the Backbone Has No Route to the Root
Publication Date    : February 2012
Author(s)           : IJ. Wijnands, E. Rosen, M. Napierala, N. Leymann
Category            : PROPOSED STANDARD
Source              : Multiprotocol Label Switching
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 25 Nov 2021 17:03:17 +0000

Hi all,
IMHO and FWIW this Erratum is obviously valid.
However, I am not sure it is really a Technical one and not just an Editorial  (report of a typo).

AFAIK  recursive opaque FEC in mLDP is used for setup of non-segmented inter-domain/inter-AS P2MP LSPs for intra-AS mVPN I-PMSI routes for years.

My 2c.

Get Outlook for Android<https://aka.ms/AAb9ysg>

________________________________
From: mpls <[email-masked]> on behalf of RFC Errata System <[email-masked]>
Sent: Thursday, November 25, 2021, 13:38
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [EXTERNAL] [mpls] [Technical Errata Reported] RFC6512 (6754)

--------------------------------------
You may review the report below and at:
https://clicktime.symantec.com/36qYGHSu9z4s4gec2QGgaMp6H4?u=https%3A%2F%2Fwww.rfc-editor.org%2Ferrata%2Feid6754

Section: 3.2.1

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------

_______________________________________________
mpls mailing list
[email-masked]
https://clicktime.symantec.com/396W94qhRykm4tW86Q1zyWG6H4?u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmpls

Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.

Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.

---

From: Loa Andersson <[email-masked]>
Date: Sat, 27 Nov 2021 10:48:30 +0100

Working Group, authors,

I tend to agree with Sasha, but would like to hear from the authors 
before I call this.

/Loa

On 2021-11-25 18:03, Alexander Vainshtein wrote:
> AFAIK  recursive opaque FEC in mLDP is used for setup of non-segmented 
> inter-domain/inter-AS P2MP LSPs for intra-AS mVPN I-PMSI routes for years.
> 
> My 2c.
> 
> 
> 
> Get Outlook for Android <https://aka.ms/AAb9ysg>
> 
> ------------------------------------------------------------------------
> *From:* mpls <[email-masked]> on behalf of RFC Errata System 
> <[email-masked]>
> *Sent:* Thursday, November 25, 2021, 13:38
> *To:* [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]
> *Cc:* [email-masked]; [email-masked]; [email-masked]
> *Subject:* [EXTERNAL] [mpls] [Technical Errata Reported] RFC6512 (6754)
> 
> <https://clicktime.symantec.com/36qYGHSu9z4s4gec2QGgaMp6H4?u=https%3A%2F%2Fwww.rfc-editor.org%2Ferrata%2Feid6754>
> 
> "PE1 also has this route" refers to "Although ASBR1 does not have a 
> route to PE2, it does have a BGP Intra-AS Inclusive PMSI (I-PMSI) 
> auto-discovery (A-D) route". Intra-AS mechanisms are used for 
> auto-discovery/binding for Non-Segmented Inter-AS Tunnels.
> 
> Instructions:
> -------------
> <https://clicktime.symantec.com/396W94qhRykm4tW86Q1zyWG6H4?u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmpls>
> 
> Notice: This e-mail together with any attachments may contain 
> information of Ribbon Communications Inc. and its Affiliates that is 
> confidential and/or proprietary for the sole use of the intended 
> recipient. Any review, disclosure, reliance or distribution by others or 
> forwarding without express permission is strictly prohibited. If you are 
> not the intended recipient, please notify the sender immediately and 
> then delete all copies, including any attachments.
> 
> 
> Notice: This e-mail together with any attachments may contain 
> information of Ribbon Communications Inc. and its Affiliates that is 
> confidential and/or proprietary for the sole use of the intended 
> recipient. Any review, disclosure, reliance or distribution by others or 
> forwarding without express permission is strictly prohibited. If you are 
> not the intended recipient, please notify the sender immediately and 
> then delete all copies, including any attachments.

-- 
Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64