Subject: [multimob] draft-asaeda-multimob-igmp-mld-optimization-00

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 28 Sep 2009 11:54:21 -0700 (PDT)

Hi Hitoshi,
  I read this draft and would like to say a few words about it.
I found a few typos and I can send them to you offline.

I found Section 2 quite confusing and difficult to understand. 

Section 3 on explicit membership notification makes good points. RFC 4861 which obsoleted 2461 has similar recommendations for mobile hosts. So we should go for it, I think.

I thought of suggesting two separate sections for IGMP and MLD but maybe the current structure is OK considering the fact that IGMP and MLD are very similar.

Do you expect any problems from running both IGMP and MLD simultaneously in a given dual stack mobile host? 

Section 5 is work in progress as well as 7 TODOs, no comments on it so far.

Overall, Sections 3 and 5 should constitute most of what is recommended and furthermore this may be reflected on the title.

Regards,

Behcet

---

From: Hitoshi Asaeda <[email-masked]>
Date: Tue, 29 Sep 2009 14:58:56 +0900 (JST)

Hi Behcet,

> I found a few typos and I can send them to you offline.

Thanks!

> I found Section 2 quite confusing and difficult to understand. 

I'll improve the text in the next revision.
If you have any specific opinion or find some ambiguity, please tell
me. I'm glad to hear it. Thanks.

> Section 3 on explicit membership notification makes good points. RFC
> 4861 which obsoleted 2461 has similar recommendations for mobile
> hosts. So we should go for it, I think.

Thanks.

> I thought of suggesting two separate sections for IGMP and MLD but
> maybe the current structure is OK considering the fact that IGMP and
> MLD are very similar.
> 
> Do you expect any problems from running both IGMP and MLD
> simultaneously in a given dual stack mobile host? 

I believe there is no problem at all. It is common.
Do you have any concern for some function?

> Overall, Sections 3 and 5 should constitute most of what is
> recommended and furthermore this may be reflected on the title.

I'll try to fix TODOs and ambiguities in the revised draft.

Thanks for your comments.
Regards,
--
Hitoshi Asaeda