Subject: [multipathtcp] Multipath UDP?

From: Iljitsch van Beijnum <[email-masked]>
Date: Fri, 31 Jul 2009 10:00:46 +0200

Hi,

Someone at the mic in RRG just asked about multipath UDP...

Iljitsch

---

From: Joe Touch <[email-masked]>
Date: Fri, 31 Jul 2009 01:10:36 -0700

> Someone at the mic in RRG just asked about multipath UDP...

Why?

UDP is a single packet protocol with no state. There's no relationship
between two UDP packets - regardless of same/different port or addresses.

So unless you're doing some sort of quantum double-slit experiment, a
single path can't go over multiple paths, so multipath doesn't make any
sense for UDP IMO.

Joe

---

From: Scott Brim <[email-masked]>
Date: Fri, 31 Jul 2009 10:20:48 +0200

> between two UDP packets - regardless of same/different port or addresses.

There are long-lasting flows based on UDP, but the state synchronization 
is done at a higher layer than transport.  Multipath transport is only 
meaningful if the transport layer is handling state synchronization -- 
if the multipathing is done in a higher layer, it's out of scope for 
this WG ... which isn't to say that it's not useful.

---

From: Arnaud Ongenae <[email-masked]>
Date: Fri, 31 Jul 2009 10:23:05 +0200

On Fri, 2009-07-31 at 01:10 -0700, Joe Touch wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> 

While only looking at the transport level, you're right, there is no
relation between packets. But at the application level, two UDP packets
that take different path could produce injury to the application.

This reference try to improve UDP in a multi-path context:
M. Yabandeh, S. Zarifzadeh, and N. Yazdani. 
Improving performance of transport protocols in multipath transferring
schemes. 
Elsevier B. V., doi:10.1016/j.comcom.2007.02.017, 2007.

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (MingW32)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> 
> iEYEARECAAYFAkpypvwACgkQE5f5cImnZrv8IQCgoPeLKTJRrkiqRuzkQkV/+N4J
> 6r0AoPoh6Mwf/3AMTxlTbc0IdLXGOlGD
> =H5Eq
> -----END PGP SIGNATURE-----
> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp

---

From: Joe Touch <[email-masked]>
Date: Fri, 31 Jul 2009 01:23:51 -0700

> this WG ... which isn't to say that it's not useful.

I agree - multipath protocols *above* UDP may be useful, but there is
(AFAICT) no such thing as multipath UDP.

Joe