Subject: [multipathtcp] MPTCP implementation on ns-2

From: Yoshifumi Nishida <[email-masked]>
Date: Wed, 12 May 2010 18:59:22 +0900 (JST)

Hello,

This is still preliminary, but I developed a simple implementation for mptcp on ns-2.
You can get a patch for ns-2.34 from 
   http://www.jp.nishida.org/mptcp/mptcp.patch.20100512

You also can get a sample TCL script from 
   http://www.jp.nishida.org/mptcp/mptcp-sample.tcl

There should be some bugs since I was in rush mode. Please feel free to send
bug reports, comments and suggestions. 
I guess the following functions in the implementation are tricky parts. 
If you find any mistakes, please let me know.

  1: void MptcpAgent::send_control() ... distribute application data to subflows
  2: void MpFullTcpAgent::opencwnd() ... perform congestion control for each subflow
  3: void MptcpAgent::calculate_alpha() .. calculate alpha

Thanks,
--
Yoshifumi Nishida
[email-masked]

---

From: Yoshifumi Nishida <[email-masked]>
Date: Thu, 13 May 2010 16:43:17 +0900 (JST)

Hi,
I put everything on google code.

https://code.google.com/p/multipath-tcp/

If you're insterested in being a commiter, please let me know.

Thanks,
--
Yoshifumi Nishida
[email-masked]

From: Yoshifumi Nishida <[email-masked]>
Subject: [multipathtcp] MPTCP implementation on ns-2
Date: Wed, 12 May 2010 18:59:22 +0900 (JST)
Message-ID: <[email-masked]>

 > _______________________________________________
 > multipathtcp mailing list
 > [email-masked]
 > https://www.ietf.org/mailman/listinfo/multipathtcp