Subject: [multipathtcp] Re-chartering MPTCP Issue #3: Informational documents

From: <[email-masked]>
Date: Tue, 3 Apr 2012 15:29:58 +0100

#3 of a series of emails to try and reach consensus about the re-charter.
This email is about the Informational documents we should write. We didn't do a consensus call at the meeting, but my impression from the comments is that there's support for the following work items. The text below is based on what was sent earlier to the mailing list and also the discussion in Paris.

The working group will explore several other topics, leading to Informational documents:

1.Use cases
The WG explores some of the proposed use cases in detail, to ensure that MPTCP works well in practice. Practical work is highly encouraged. Likely use cases are to offload traffic from 3G to Wifi, and to manage traffic within a data centre. Another scenario is to enable operation of a single-homed, MPTCP end host without changing the MPTCP protocol.

2.Implementation guidelines
The current (almost) RFCs have several points where an implementer would benefit from guidance, for example about buffer sizing, or from advice about alternative implementations such as bump-in-the-stack.

3.Experiments
The WG encourages experiments with MPTCP and will organise interoperability events. We document interesting results and the lessons learned.

Thanks

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 4 Apr 2012 08:46:04 +0000

> 1.Use cases

Support, if we can get the people who have themselves deployed MPTCP in such a use case to do the work (as opposed to documenting thought experiments by non-deployers)

> 2.Implementation guidelines

Support (if the implementors write this, but I think they will)

> 3.Experiments

Don't see a need for the WG to do this, could be Independent Stream. Interop events would need to be side meetings anyway, so can't really be in the charter.

Lars

---

From: "Hampel, K Georg (K Georg)" <[email-masked]>
Date: Wed, 4 Apr 2012 08:37:35 -0500

I am in strong support for #3.

Georg

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, April 03, 2012 10:30 AM
To: [email-masked]
Subject: [multipathtcp] Re-chartering MPTCP Issue #3: Informational documents

1.Use cases

3.Experiments

Thanks

---

From: John Leslie <[email-masked]>
Date: Wed, 4 Apr 2012 14:07:07 -0400

> 1.Use cases

   Do we have volunteers to draft this?

> 2.Implementation guidelines

   Could be useful... do we have a starting point? Perhaps a wiki...

> 3.Experiments

   Doesn't sound like formal WG work...

--
John Leslie <[email-masked]>