Subject: [multipathtcp] potential new work item on MPTCP API

From: <[email-masked]>
Date: Thu, 21 Jul 2016 15:43:12 +0000

Yesterday Olivier presented about his & Benjamin's recent work on MPTCP socket api. We didn't have much discussion whether to add this to the charter. One comment was that any work should build on /reference RFC6897.
https://www.ietf.org/proceedings/96/slides/slides-96-mptcp-4.pdf
Please can you comment whether you see this as a useful work item, or you think it shouldn't be worked on, or how it should be adapted to something you think the WG should work on.

To help prompt the discussion, here's a very first version of some possible charter text
RFC6897 defined an optional, basic application interface for MPTCP-aware applications, including a set of socket operations. Now there is more experience of how MPTCP is being used, the WG will re-visit this work, and consider adding more advanced socket operations.

RFC6897 was Informational - would this new Milestone be Informational or Experimental?

Thanks
phil

Philip Eardley
Research and Innovation
This email contains BT information, which may be privileged or confidential. It's meant only for the individual(s) or entity named above. If you're not the intended recipient, note that disclosing, copying, distributing or using this information is prohibited. If you've received this email in error, please let me know immediately on the email address above. Thank you.
We monitor our email system, and may record your emails.
British Telecommunications plc
Registered office: 81 Newgate Street London EC1A 7AJ
Registered in England no: 1800000

---

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Thu, 21 Jul 2016 15:52:51 +0000

As author of RFC 6897 I'd be fine with revisiting that document as some aspects may be a bit outdated. I have not closely followed MPTCP recently but I'd assume that parts of RFC 6897 are still valid.

Michael

From: multipathtcp [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, July 21, 2016 5:43 PM
To: [email-masked]
Subject: [multipathtcp] potential new work item on MPTCP API

Thanks
phil

Philip Eardley
Research and Innovation

---

From: Christoph Paasch <[email-masked]>
Date: Fri, 22 Jul 2016 10:48:25 +0200

Hello,

> On Jul 21, 2016, at 5:43 PM, [email-masked] wrote:
> Yesterday Olivier presented about his & Benjamin’s recent work on MPTCP socket api. We didn’t have much discussion whether to add this to the charter. One comment was that any work should build on /reference RFC6897.
> https://www.ietf.org/proceedings/96/slides/slides-96-mptcp-4.pdf <https://www.ietf.org/proceedings/96/slides/slides-96-mptcp-4.pdf>
> Please can you comment whether you see this as a useful work item, or you think it shouldn’t be worked on, or how it should be adapted to something you think the WG should work on.

yes, I think it is a very useful work item and am willing to contribute to this work.

I'm not sure whether this can be seen as an update to 6897. I'm under the impression that 6897 takes a different approach, giving users a high-level overview of how using MPTCP might look like to an application that is talking to a TCP-socket (which happens to end up using MPTCP).

Olivier's work seems to rather make MPTCP entirely explicit to the application. So, I think both works take a different approach.

> To help prompt the discussion, here’s a very first version of some possible charter text
> RFC6897 was Informational – would this new Milestone be Informational or Experimental?

I think it should be Informational.

Christoph

> _______________________________________________
> multipathtcp mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/multipathtcp <https://www.ietf.org/mailman/listinfo/multipathtcp>

---

From: Olivier Bonaventure <[email-masked]>
Date: Tue, 26 Jul 2016 12:43:52 +0200

Phil,

> Yesterday Olivier presented about his & Benjamin’s recent work on MPTCP
> socket api. We didn’t have much discussion whether to add this to the
> charter. One comment was that any work should build on /reference RFC6897.
>
> Please can you comment whether you see this as a useful work item, or
> you think it shouldn’t be worked on, or how it should be adapted to
> something you think the WG should work on.
>

Many MPTCP users have expressed their interest in this work and after 
the meeting, several MPTCP implementors sit together and proposed ideas 
on how to further improve the work. With several implementors involved, 
I think that we can get very good results

> RFC6897 defined an optional, basic application interface for MPTCP-aware
> applications, including a set of socket operations. Now there is more
> experience of how MPTCP is being used, the WG will re-visit this work,
> and consider adding more advanced socket operations.
>
>

Fine for me
> RFC6897 was Informational – would this new Milestone be Informational or

We should go for Informational, like the socket API for SCTP
https://tools.ietf.org/html/rfc6458

Olivier

---

From: <[email-masked]>
Date: Tue, 26 Jul 2016 14:35:08 +0000

Christoph,
https://tools.ietf.org/html/rfc6897#section-5.3 is “Sockets Interface Extensions by the Basic MPTCP API”
(also https://tools.ietf.org/html/rfc6897#appendix-A “Appendix A. Requirements on a Future Advanced MPTCP API”)
phil

From: [email-masked] [mailto:[email-masked]]
Sent: 22 July 2016 09:48
To: Eardley,PL,Philip,TUB8 R <[email-masked]>
Cc: MultiPath TCP - IETF WG <[email-masked]>
Subject: Re: [multipathtcp] potential new work item on MPTCP API

Hello,

On Jul 21, 2016, at 5:43 PM, [email-masked]<mailto:[email-masked]> wrote:
Yesterday Olivier presented about his & Benjamin’s recent work on MPTCP socket api. We didn’t have much discussion whether to add this to the charter. One comment was that any work should build on /reference RFC6897.
https://www.ietf.org/proceedings/96/slides/slides-96-mptcp-4.pdf
Please can you comment whether you see this as a useful work item, or you think it shouldn’t be worked on, or how it should be adapted to something you think the WG should work on.

Christoph

Thanks
phil

Philip Eardley
Research and Innovation

_______________________________________________
multipathtcp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/multipathtcp

---

From: Christoph Paasch <[email-masked]>
Date: Sun, 31 Jul 2016 12:36:33 -0700

> On Jul 26, 2016, at 7:35 AM, [email-masked] wrote:
> 
> Christoph,
> https://tools.ietf.org/html/rfc6897#section-5.3 <https://tools.ietf.org/html/rfc6897#section-5.3> is “Sockets Interface Extensions by the Basic MPTCP API”
> (also https://tools.ietf.org/html/rfc6897#appendix-A <https://tools.ietf.org/html/rfc6897#appendix-A> “Appendix A. Requirements on a Future Advanced MPTCP API”)

Ok, I see. Fair enough. Extension to RFC6897 seems fine to me then.

Cheers,
Christoph

> On Jul 21, 2016, at 5:43 PM, [email-masked] <mailto:[email-masked]> wrote: