Subject: [multipathtcp] comments for draft-hewu-mptcp-trust-00

From: Yoshifumi Nishida <[email-masked]>
Date: Wed, 13 Nov 2019 23:48:40 -0800

Hello,
I've read draft-hewu-mptcp-trust-00.Thanks for preparing this.
I have listed my comments below.

1: The idea for exchanging trusted addresses info for peers sounds
interesting, but i might want to see how the info will be used a bit more.
Say, if an endpoint has 1 trusted address and 2 non-trusted address, how
the endpoint utilizes these addresses?

2: I am wondering if the Trust-Flag in echo-backed ADD_ADDR can indicate
this source address is trusted. If so,  Host A in Figure 1 can update TPBT
after receiving ADD_ADDR from B.
If this is possible,  I am guessing we can reduce the cases where you need
to send ADDR_TRUST option.

Thanks,
--
Yoshi

---

From: <[email-masked]>
Date: Thu, 14 Nov 2019 10:14:08 +0000

Thanks for the draft
One thing that wasn’t clear to me – can you be sure that the Trust Flag has been correctly set ie not been set by a host for a connection that isn’t source-address-validated?

Thanks
phil

From: multipathtcp <[email-masked]> On Behalf Of Yoshifumi Nishida
Sent: 14 November 2019 07:49
To: multipathtcp <[email-masked]>
Subject: [multipathtcp] comments for draft-hewu-mptcp-trust-00

Hello,

1: The idea for exchanging trusted addresses info for peers sounds interesting, but i might want to see how the info will be used a bit more. Say, if an endpoint has 1 trusted address and 2 non-trusted address, how the endpoint utilizes these addresses?

2: I am wondering if the Trust-Flag in echo-backed ADD_ADDR can indicate this source address is trusted. If so,  Host A in Figure 1 can update TPBT after receiving ADD_ADDR from B.
If this is possible,  I am guessing we can reduce the cases where you need to send ADDR_TRUST option.

Thanks,
--
Yoshi