Subject: Re: I-D ACTION:draft-ietf-dnsext-insensitive-00.txt

From: Donald Eastlake 3rd <[email-masked]>
Date: Thu, 30 Jan 2003 18:01:43 -0500 (EST)

Thanks for pointing this out.

I'll do a revision before San Francisco.

Thanks,
Donald
======================================================================
 Donald E. Eastlake 3rd                       [email-masked]
 155 Beaver Street              +1-508-634-2066(h) +1-508-851-8280(w)
 Milford, MA 01757 USA                   [email-masked]

On Thu, 30 Jan 2003 [email-masked] wrote:

> Date: Thu, 30 Jan 2003 11:27:03 -0600
> From: [email-masked]
> To: [email-masked], [email-masked]
> Subject: Re: I-D ACTION:draft-ietf-dnsext-insensitive-00.txt
> 
> "There is one additional instance of note, which relfects the general..."
> (pg 6 para 2 line 1 (last para of section 4))  We should probably relfect
> on this awhile more lest the world think we have no spell checkers.
> 
> Dan
> 
>                                                                                                               
>                       Internet-Drafts@ietf                                                                    
>                       .org                        To:       IETF-Announce: ;                                  
>                       Sent by:                    cc:       [email-masked]                         
>                       owner-namedroppers@o        Subject:  I-D ACTION:draft-ietf-dnsext-insensitive-00.txt   
>                       ps.ietf.org                                                                             
>                                                                                                               
>                                                                                                               
>                       01/30/2003 06:53 AM                                                                     
>                       Please respond to                                                                       
>                       Internet-Drafts                                                                         
>                                                                                                               
> 
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the DNS Extensions Working Group of the IETF.
> 
>              Title                         : Domain Name System (DNS) Case
> Insensitivity
>                           Clarification
>              Author(s)         : D. Eastlake
>              Filename          : draft-ietf-dnsext-insensitive-00.txt
>              Pages                         : 8
>              Date                    : 2003-1-29
> 
> Domain Name System (DNS) names are 'case insensitive'. This document
> explains exactly what that means and provides a clear specification
> of the rules. This clarification should not have any interoperability
> consequences.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-dnsext-insensitive-00.txt
> 
> To remove yourself from the IETF Announcement list, send a message to
> ietf-announce-request with the word unsubscribe in the body of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the
> username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
>              "get draft-ietf-dnsext-insensitive-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
>              [email-masked].
> In the body type:
>              "FILE /internet-drafts/draft-ietf-dnsext-insensitive-00.txt".
> 
> NOTE:        The mail server at ietf.org can return the document in
>              MIME-encoded form by using the "mpack" utility.  To use this
>              feature, insert the command "ENCODING mime" before the "FILE"
>              command.  To decode the response(s), you will need "munpack"
> or
>              a MIME-compliant mail reader.  Different MIME-compliant mail
> readers
>              exhibit different behavior, especially when dealing with
>              "multipart" MIME messages (i.e. documents which have been
> split
>              up into multiple messages), so check your local documentation
> on
>              how to manipulate these messages.
> 
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> ftp://[email-masked]/internet-drafts/draft-ietf-dnsext-insensitive-00.txt
> 
> 
> 
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Rob Austein <[email-masked]>
Date: Fri, 31 Jan 2003 00:26:30 -0500

The "typographic convention" is decimal, not hexadecimal, and the
rules for backslash are spelled out explicitly in RFC 1035:

\X              where X is any character other than a digit (0-9), is
                used to quote that character so that its special meaning
                does not apply.  For example, "\." can be used to place
                a dot character in a label.

\DDD            where each D is a digit is the octet corresponding to
                the decimal number described by DDD.  The resulting
                octet is assumed to be text and is not checked for
                special meaning.

NB: this means that a backslash followed by one or two decimal digits
is undefined, and that a backslash followed by four decimal digits
parses as two encoded octets.

s{bytes}
 {octets}g

s{It is just that they are traditionally interpreted as ASCII characters}
 {Most applications, however, interpret them as ASCII characters}

s{Historic Note}
 {Historical Note}

s{elsewhere in the wire encoding}
 {elsewhere in the wire encoding of a DNS message}