Subject: DNSEXT WGLC: DS SHA-256

From: Ólafur Guðmundsson<[email-masked]>
Date: Wed, 14 Dec 2005 10:01:36 -0500

This message starts a Working Group Last Call on following document
http://www.ietf.org/internet-drafts/draft-ietf-dnsext-ds-sha256-02.txt

The last call is scheduled to end on December 31'st 2005.

This document defines a new digest algorithm for the DS record.
The reason why this is needed is the degrading trust in SHA-1
algorithm currently used.

The document is on standards track and is scheduled to be published as
Proposed Standard.

Please read this document and send statements of support/issues to
the namedroppers mailing list or chairs.
The chairs require that at least 5 people review and support this document.

	Olafur & Olaf 	

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: "Stuart E. Schechter" <[email-masked]>
Date: Wed, 21 Dec 2005 09:42:52 -0500

I have reviewed and support this document.

   As for whether a validator SHOULD or MUST ignore SHA1 digests when
SHA-256 are present, perhaps the "security considerations" section could
discuss the downgrade attack on validators that accept SHA1 digests when
SHA-256 digests are present?

   Should the pair of colons following "The DNSKEY Record" in 2.3 be one
colon, or is this an IETF convention with which I as a newbie am unfamiliar?

   One very minor editing nit-pick -- the words "of course" in the security
considerations are superfluous and distracting.  This isn't a show stopper
and I'm fine if Wes doesn't want to change it.  I just feel that if we truly
believed the statement was obvious to all possible readers it wouldn't be
worth including.  Putting the "of course" only makes things harder to read.

   Best

   Stuart

> From: Ólafur Gu›mundsson <[email-masked]>
> Date: Wed, 14 Dec 2005 10:01:36 -0500
> To: <[email-masked]>
> Subject: DNSEXT WGLC: DS SHA-256
> 
>

---

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Sun, 25 Dec 2005 18:08:32 -0500

I support this document; however, I believe it should also reference draft-eastlake-sha2-*.txt which has source code for SHA-256 (currently -00 but about to be updated to -01).

Thanks,
Donald

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ólafur Guðmundsson
Sent: Wednesday, December 14, 2005 10:02 AM
To: [email-masked]
Subject: DNSEXT WGLC: DS SHA-256 

This message starts a Working Group Last Call on following document http://www.ietf.org/internet-drafts/draft-ietf-dnsext-ds-sha256-02.txt

This document defines a new digest algorithm for the DS record.
The reason why this is needed is the degrading trust in SHA-1 algorithm currently used.

The document is on standards track and is scheduled to be published as Proposed Standard.

Please read this document and send statements of support/issues to the namedroppers mailing list or chairs.
The chairs require that at least 5 people review and support this document.

	Olafur & Olaf 	

--
to unsubscribe send a message to [email-masked] with the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Wes Hardaker <[email-masked]>
Date: Mon, 26 Dec 2005 12:38:39 -0800

>>>>> On Sun, 25 Dec 2005 18:08:32 -0500, Eastlake III Donald-LDE008 <[email-masked]> said:

Eastlake> I support this document; however, I believe it should also
Eastlake> reference draft-eastlake-sha2-*.txt which has source code
Eastlake> for SHA-256 (currently -00 but about to be updated to -01).

(I'm interested in other people's opinions)

Questions:
  Whats the timeline status for this document?  Is it near completion
  (on the order of weeks) or do you expect to have it advance by when?

  What track is it on?  Personal submission as informative?

  If the working group wants this, should to be informative or
  normative?

I think informative is right here (as the code reference isn't
required, unlike the spec reference which must be understood).

-- 
Wes Hardaker
Sparta, Inc.

---

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Mon, 26 Dec 2005 23:50:11 -0500

draft-eastlake-sha2 is indeed a personal submission targeted for Informational, like RFC 3174.

I'm fine with the reference being Informative. The FIPS document is the normative specification of the algorithm.

I believe that it is, indeed, near completion and I will be uploaded an updated draft in a day or two.
Due to the problems with SHA-1, I believe it will be given some priority even though it is an individual submission.

Thanks,
Donald

-----Original Message-----
From: Wes Hardaker [mailto:[email-masked]] 
Sent: Monday, December 26, 2005 3:39 PM
To: Eastlake III Donald-LDE008
Cc: [email-masked]
Subject: Re: DNSEXT WGLC: DS SHA-256

Eastlake> I support this document; however, I believe it should also 
Eastlake> reference draft-eastlake-sha2-*.txt which has source code for 
Eastlake> SHA-256 (currently -00 but about to be updated to -01).

Questions:

I think informative is right here (as the code reference isn't required, unlike the spec reference which must be understood).

--
Wes Hardaker
Sparta, Inc.