Subject: Re: unbound resolver - feedback requested

From: Simon Josefsson <[email-masked]>
Date: Tue, 13 Dec 2005 17:48:17 +0100

[email-masked] writes:

> greetings,
>
> after several months of work, we would like to announce the availablity
> of the first work product of the unbound project... a validating resolver.
>
> our prototype full-service, iterative-mode, validating DNS resolver is written 
> entirely in Java and is licensed under the BSD open-source license.
>
> it may be found here:   http://www.rfc.se/unbound
>
> comments & suggestions welcome.

Rewrite it in C and offer it to various free libc implementations?

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: [email-masked]
Date: Tue, 13 Dec 2005 16:54:58 +0000

> Rewrite it in C and offer it to various free libc implementations?

	did you check the web site?  that work is in progress.
	we thought it would be nice to get early feedback before
	locking down the C version.

--bill

---

From: Paul Vixie <[email-masked]>
Date: Tue, 13 Dec 2005 21:43:54 +0000

# > entirely in Java and is licensed under the BSD open-source license.
# >
# > it may be found here:   http://www.rfc.se/unbound
# >
# > comments & suggestions welcome.
# 
# Rewrite it in C and offer it to various free libc implementations?

if bind's resolver isn't fitting the needs of the various free libc
implementations, i hope they'll speak up.  jinmei is doing a re-work
and this is the right time for us to know the ways in which bind is
considered non-ideal.