Subject: RE: I-D ACTION:draft-ietf-dnsext-2929bis-03.txt

From: "Scott Rose" <[email-masked]>
Date: Mon, 3 Jul 2006 14:49:06 -0400

Alright then.  I think I mis-understood the text at first read.  I have no
problem with the chosen expert acting with the authority of IANA (or
whichever entity will be serving that role in the future).

Scott

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Eastlake III
> Donald-LDE008
> Sent: Sunday, July 02, 2006 9:56 PM
> To: [email-masked]
> Subject: RE: I-D ACTION:draft-ietf-dnsext-2929bis-03.txt
>
>
> The whole thing about IANA allocations is to define the process so an
> objection related to that is quite important.
>
> As I understand it, the Expert's job is to, in effect, hold the
> delegated authority of IANA to grant or withhold allocation of a code
> point. It is not a "recommend/not recommend" thing, they have the
> authority, subject to the usual appeal channels to the IESG, etc. Of
> course they should try to help proponents. And if they are sufficiently
> obstructive or obnoxious or abuse their authority, you would expect a
> clamor to the IESG to replace them.
>
> Keep in mind that this is intended to be an open but reasonably rapid
> and efficient process. The template specified in 3.1.2 must have been
> completed and posted to namedroppers for three weeks so there will be
> plenty of time for community input. But someone has to have the
> authority and make the call and "Expert Review" means that the
> Designated Expert appointed by the IESG is it.
>
> Who did you think had the authority? It can't be the DNSEXT working
> group as the IETF process assumption is that all working groups are
> temporary. (Although, of course, as long as the DNEXT working group, or
> a successor, exists, I would expect its chair or co-chair to have major
> input to the Designated Expert selection.)
>
> Thanks,
> Donald
>
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Scott Rose
> Sent: Friday, June 30, 2006 2:40 PM
> To: [email-masked]
> Subject: RE: I-D ACTION:draft-ietf-dnsext-2929bis-03.txt
>
> I have one comment on the new text (or maybe this was old, but I the
> first time I saw it).  Unfortunately, it is a high level politics thing.
>
> The first paragraph in Section 3.1.3 has the sentence "The Expert should
> reject any RRTYPE allocation request...".  That makes it sound like a
> much more formal process than the rest of the document lays out.  From
> what I gathered, it is more of a "recommend/not recommend" thing.  The
> Expert's job should be more of an endorsement, or failing the criteria,
> helping the proponents meet whatever goal they have for the draft.
>
> Yes, this is a process issue and not a technical one, but something that
> may catch some poor WG member acting as a expert in the future.
>
> Scott
> ****************************************
> Scott Rose
> Adv. Network Tech. Div., NIST
> +1 301-975-8439
>
> https://www-x.antd.nist.gov/dnssec/
> http://www.dnssec-deployment.org/
> ****************************************
>
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Eastlake III
> > Donald-LDE008
> > Sent: Friday, June 30, 2006 10:36 AM
> > To: [email-masked]
> > Subject: RE: I-D ACTION:draft-ietf-dnsext-2929bis-03.txt
> >
> >
> > Hi,
> >
> > The last feedback I got from the working group on this draft was that
> > it was in good shape except for the need for some specific guidelines
> > for the designated RR type allocation expert. So this updated version
> > has such guidelines in section 3.1.3. Hopefully this version, or
> > perhaps -04 is some minor changes are needed, will be ready for WG
> last call.
> >
> > Thanks,
> > Donald
> >
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]] On Behalf Of
> > [email-masked]
> > Sent: Thursday, June 29, 2006 3:50 PM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: I-D ACTION:draft-ietf-dnsext-2929bis-03.txt
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
> > directories.
> > This draft is a work item of the DNS Extensions Working Group of the
> > IETF.
> >
> > 	Title		: Domain Name System (DNS) IANA Considerations
> > 	Author(s)	: D. Eastlake 3rd
> > 	Filename	: draft-ietf-dnsext-2929bis-03.txt
> > 	Pages		: 19
> > 	Date		: 2006-6-29
> >
> > Internet Assigned Number Authority (IANA) parameter assignment
> > considerations are specified for the allocation of Domain Name System
> > (DNS) Classes, RR Types, operation codes, error codes, RR header bits,
>
> > and AFSDB subtypes.
> >
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-ietf-dnsext-2929bis-03.txt
> >
> > To remove yourself from the I-D Announcement list, send a message to
> > [email-masked] with the word unsubscribe in the body of
>
> > the message.
> > You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> > to change your subscription settings.
> >
> >
> > Internet-Drafts are also available by anonymous FTP. Login with the
> > username "anonymous" and a password of your e-mail address. After
> > logging in, type "cd internet-drafts" and then
> > 	"get draft-ietf-dnsext-2929bis-03.txt".
> >
> > A list of Internet-Drafts directories can be found in
> > http://www.ietf.org/shadow.html or
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> >
> >
> > Internet-Drafts can also be obtained by e-mail.
> >
> > Send a message to:
> > 	[email-masked].
> > In the body type:
> > 	"FILE /internet-drafts/draft-ietf-dnsext-2929bis-03.txt".
> >
> > NOTE:	The mail server at ietf.org can return the document in
> > 	MIME-encoded form by using the "mpack" utility.  To use this
> > 	feature, insert the command "ENCODING mime" before the "FILE"
> > 	command.  To decode the response(s), you will need "munpack" or
> > 	a MIME-compliant mail reader.  Different MIME-compliant mail
> readers
> > 	exhibit different behavior, especially when dealing with
> > 	"multipart" MIME messages (i.e. documents which have been split
> > 	up into multiple messages), so check your local documentation on
> > 	how to manipulate these messages.
> >
> >
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.
> >
> > --
> > to unsubscribe send a message to [email-masked]
> with
> > the word 'unsubscribe' in a single line as the message text body.
> > archive: <http://ops.ietf.org/lists/namedroppers/>
>
>
>
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
>
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: "Olaf M. Kolkman" <[email-masked]>
Date: Tue, 4 Jul 2006 15:25:48 +0200

> clamor to the IESG to replace them.

Actually it might be good to make that explicit:

Maybe it would be good to make that a little more explicit by  
defining the term in the introduction. Something like:

Designated Expert: a subject matter expert hired and fired by the  
relevant AD and subject to the IETF appeal. See RFC2434 section 2.

and then consequently use "Designated Expert" throughout the text.

no hats,

--Olaf

-----------------------------------------------------------
Olaf M. Kolkman
NLnet Labs
http://www.nlnetlabs.nl/