Subject: Re: TCP mandatory? Re: DNS is mandatory text

From: Dean Anderson <[email-masked]>
Date: Sat, 10 May 2008 16:38:26 -0400 (EDT)

[ Moderators note: Post was moderated, either because it was posted by
   a non-subscriber, or because it was over 20K.  
   With the massive amount of spam, it is easy to miss and therefore 
   delete relevant posts by non-subscribers. 
   Please fix your subscription addresses. ]

IESG: I cannot post to the DNSEXT list on the basis of false, fictional, 
and fraudulent claims of misconduct. 

I am in agreement that either TCP or EDNSO is mandatory.

This decision has an impact on DNS Anycast.  Both TCP and EDNSO are
unreliable when Anycasted.

FYI, I note that the NSID extension indicates that the dispute of
stateful anycast stability was entirely frivolous. The NSID draft arose
from the acceptance that two (individually stateless UDP)  packets could
not be reliably sent to the same server for identification purposes.
This implies that 2 or more packets (as necessary with TCP) also cannot
be sent reliably to the same server, and so TCP Anycast is unreliable.

		--Dean

On Mon, 14 Jan 2008, Stephane Bortzmeyer wrote:

> On Fri, Jan 11, 2008 at 01:59:05PM -0500,
>  Joe Abley <[email-masked]> wrote 
>  a message of 478 lines which said:
> 
> > >4.2.2.  TCP
> > >
> > >   {new normative language, maybe.. } The server MAY accept TCP
> > >   connections. {? what is the correct wording and reference?}
> > 
> > I think that MAY should be a MUST.
> 
> I am in sympathy with this view point but do note that EDNS0 is
> mandatory, if I read correctly the previous section. It seems to
> adress your concern.
> 
> My personal inclination would be "the name server MUST offer EDNS0 -
> with large sizes - *or* TCP". 
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
> 
> 

-- 
Av8 Internet   Prepared to pay a premium for better service?
www.av8.net         faster, more reliable, better service
617 344 9000   

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Paul Vixie <[email-masked]>
Date: Mon, 12 May 2008 16:03:03 +0000

> ... Both TCP and EDNSO are unreliable when Anycasted.

nope.