Subject: [Nea] RE: Definition of Endpoint - "MAY have an IP address", instead of "with an IP address."?

From: "Philip Richardson" <[email-masked]>
Date: Thu, 7 Jun 2007 17:18:02 +0100

Hi all,

Under "Terminology", the definition of Endpoint is as follows:
"Any host computing device that can be connected to a network. This
includes: laptops, desktops, servers, cell phone or any device with an IP
address."

Does this device always have an IP address? 
Should the definition not state "...MAY have an IP address."

For instance in the case of a CNAC deployment, the process may use 802.1x
and EAP messages, and access might be denied if the device fails posture
assessment. It may have an IP address, but it is not a requirement in all
cases.

Cheers
Phil

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 07 June 2007 17:01
To: [email-masked]
Subject: Nea Digest, Vol 20, Issue 1

Send Nea mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	https://www1.ietf.org/mailman/listinfo/nea
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Nea digest..."

Today's Topics:

   1. Reminder to review the -02 I-D (Paul Sangster)

----------------------------------------------------------------------

Message: 1
Date: Wed, 6 Jun 2007 16:39:54 -0700
From: "Paul Sangster" <[email-masked]>
Subject: [Nea] Reminder to review the -02 I-D
To: <[email-masked]>
Message-ID:
	
<[email-masked]
om>
	
Content-Type: text/plain; charset="us-ascii"

Just wanted to remind the WG that we're coming up on the milestone to
issue the next revision of the I-D which will be the WGLC candidate, so
now is a great time for comments.  We would like to encourage reviews of
the I-D prior to June 22nd so we will have time to improve the spec
prior to the July revision milestone and Chicago meeting.
 
As you know, the current draft can be found at:
http://www.ietf.org/internet-drafts/draft-ietf-nea-requirements-02.txt
 
This version largely reflects discussions from the mailing list and the
Prague meeting.  The changes in -02 include:
  o  Mention of quarantining during remediation
  o  Change title to be more broad then just requirements
  o  Removal of Policy and Compliance Claim attribute types
         - Removal of the use case example where Policy attributes are
sent instead of Request attributes
  o  Changed PB cryptographic protection requirement (during NEA
selection) to MAY
  o  Mention the scope of the posture sent by NEA Client based on its
operational domain only
         - Covers NAT device and virtualized endpoint cases
  o  Less emphasis on attribute types (more on type of message)
  o  No mention of 3rd party providing posture information for
clientless endpoints
  o  No longer capitalize terminology defined which are commonly used
words
  o  Addressed some clarification issues from alias
  o  Describe PA and PB as lightweight messaging protocols riding on top
of PT
 
Paul Sangster
NEA Design Team Chair

-------------- next part --------------
An HTML attachment was scrubbed...
URL:
http://www1.ietf.org/pipermail/nea/attachments/20070606/913e2abb/attachment-
0001.html

------------------------------

_______________________________________________
Nea mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nea

End of Nea Digest, Vol 20, Issue 1
**********************************

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________
_______________________________________________
Nea mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nea

---

From: "todd glassey" <[email-masked]>
Date: Thu, 7 Jun 2007 09:37:02 -0700

Philip you are right - the end-point nodes may include systems with a MAC or 
NW HW address as well, so that DHCP type clients can be supported.

Todd Glassey

----- Original Message ----- 
From: "Philip Richardson" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, June 07, 2007 9:18 AM
Subject: [Nea] RE: Definition of Endpoint - "MAY have an IP address",instead 
of "with an IP address."?

---

From: "Paul Sangster" <[email-masked]>
Date: Fri, 8 Jun 2007 12:32:16 -0700

> From: Philip Richardson [mailto:[email-masked]] 
> Subject: [Nea] RE: Definition of Endpoint - "MAY have an IP 
> address",instead of "with an IP address."?
> 
> Hi all,
> 
> includes: laptops, desktops, servers, cell phone or any 
> device with an IP address."
> 

No it might just have a MAC address if it hasn't yet joined the network
(pre-DHCP).  However the device should have an L2 address and
potentially an L3 address.  If the WG believes this helps the definition
we could add it.

> Should the definition not state "...MAY have an IP address."

We'll add some text to mention that this means it would have a link
layer and possibly an IP layer address.  BTW, we reserve the use of 2119
requirements language for the requirements themselves.

> 
> For instance in the case of a CNAC deployment, the process 
> may use 802.1x and EAP messages, and access might be denied 
> if the device fails posture assessment. It may have an IP 
> address, but it is not a requirement in all cases.

Agreed the endpoint might have an IP address but we don't assume it does
for cases where it hasn't yet joined the network.

> When replying, please edit your Subject line so it is more 
> specific than "Re: Contents of Nea digest..."
> 
> 
> Today's Topics:
> 
> Just wanted to remind the WG that we're coming up on the 
> milestone to issue the next revision of the I-D which will be 
> the WGLC candidate, so now is a great time for comments.  We 
> would like to encourage reviews of the I-D prior to June 22nd 
> so we will have time to improve the spec prior to the July 
> revision milestone and Chicago meeting.
>  
> This version largely reflects discussions from the mailing 
> list and the Prague meeting.  The changes in -02 include:
>          - Removal of the use case example where Policy 
> attributes are sent instead of Request attributes
>   o  Mention the scope of the posture sent by NEA Client 
> based on its operational domain only
>   o  No mention of 3rd party providing posture information 
> for clientless endpoints
>   o  No longer capitalize terminology defined which are 
> commonly used words
>   o  Describe PA and PB as lightweight messaging protocols 
> riding on top of PT
>  
> Paul Sangster
> NEA Design Team Chair
>  
>